<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Could it be? Really? The Year of Linux on the Desktop is almost here, and it's... Windows-shaped? • The Register</title>
    <meta name="robots" content="max-snippet:-1, max-image-preview:standard, max-video-preview:0">
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2020/05/19/windows_linux_kernel_logos.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/" />
    <meta property="og:title" content="Could it be? Really? The Year of Linux on the Desktop is almost here, and it's... Windows-shaped?" />
    <meta property="og:description" content="Windows Subsystem for Linux to gain out-of-the-box support for GUI apps, GPU chippery" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Windows 10">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/"},
"headline":"Could it be? Really? The Year of Linux on the Desktop is almost here, and it's... Windows-shaped?",
"datePublished":"2020-05-19T15:00:09Z",
"dateModified":"2020-05-20T15:12:49Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2020/05/19/windows_linux_kernel_logos.jpg","width":"872","height":"436"},
"author":{"@type":"Person","name":"Richard Speed"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/design_picker/1fea2ae01c5036112a295123c3cc9c56eb28836a/graphics/std/red_logo_sans_strapline.png","width":330,"height":55}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2020/05/19/wsl2_gui_linux_apps_windows/"><script>
        var RegArticle={id:208715,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['windows 10','Windows 10'],['build2020','build2020']],short_url:'https://reg.cx/31J5',cp:0,noads:[],author:'Richard Speed',vid:0}
    </script>
    <link rel=stylesheet type="text/css" href="/css_picker/default/f898a42759c67e80256382b3710e633a54bb9fee/scaffolding.css">
<link rel=stylesheet type="text/css" href="/css_picker/default/f898a42759c67e80256382b3710e633a54bb9fee/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>

    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script>
var RegCR = false;
</script>

    <script src="/design_picker/a957dc4466db4d49826f03607f11e119d8973fb3/javascript/_.js"></script>
    <script async onerror="gpt_js_errored()" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script>
        if (RegCBWT()) {
            var nir = document.createElement('script');
            nir.type = 'text/javascript';
            nir.async = false;
            nir.src = "https://nir.theregister.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/windows%2010&amp;s=vk/build2020&amp;s=vvfc/9e15ff6c77c2f748193efb257956d827&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b";
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(nir, s);
        }
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


    <style>#adtoniq-msgr-bar #adtoniq-msg {display: inline-block;}
#adtoniq-msg {width: 75%;float: left;text-align: left;}
#adtoniq-msgr-bar #adtoniq-btns {display: inline-block;}
#adtoniq-btns { width: 25%!important; float: right!important; margin-right: 0px!important; max-width: 150px;}
button#adtoniq-msg-track-btn { width: 100%; display: block;}
button#adtoniq-msg-no-track-btn { background-color: transparent!important; width: 100%; margin: 0!important; margin-top: 11px!important; color: #000000!important; font-weight: 600; font-size: 12px; border: 0; border: none;}

#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar {color: #ffffff!important;}

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {background-color: #000000; opacity: 1; width: 100%; max-width: 960px; margin: 0 auto; left: 0; right: 0; padding: 20px; border-top:2px solid #00727a;} #adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button {color: #ffffff!important;background-color: #00727a!important;margin-top: 0px;font-size: 13px;line-height: 24px;border-radius: 2px!important;font-weight: 500;padding: 10px 18px!important;letter-spacing: 1px;text-transform: uppercase; border: 0; border: none;} #adtoniq-msg {width: 70%;float: left;text-align: left;}#adtoniq-btns {width: 30%;float: none;text-align: right; margin-right:40px;} #adtoniq-msgr-bar.adtoniq-waisa p { font-size: 14px !important; line-height: 1.2; display: block; width: 100%; margin: 0 auto !important; text-align: center; max-width: 80%;} #adtoniq-msg-buttons.adtoniq-waisa { width: 100%; margin-top: 20px; } button#adtoniq-msg-track-btn {float: right;} p.a_deets {color: #000000;} #adtoniq-msgr-bar.adtoniq-waisa p { color: #ffffff; min-height: 120px; }


#a_hider .a_deets { display: inline-block; margin-bottom: 0!important;}
#a_hider.a_showme .a_deets, #a_hider.a_showme .arrow { display: none; }
#a_hider .targetadt { display: none; }
#a_hider.a_showme .targetadt { display: block; }

#a_hider { cursor: pointer; }

#a_hider:hover { cursor: pointer; }
#a_hider:hover .a_deets { text-decoration: underline; }

.arrow { height: 7px; width: 7px; border: 1px solid #000000; border-width: 2px 2px 0 0; -webkit-transform: rotate(45deg); -ms-transform: rotate(45deg); transform: rotate(45deg); display: inline-block; -webkit-transform: rotate(135deg); -ms-transform: rotate(135deg); transform: rotate(135deg); margin-left: 10px; padding-bottom: 2px; padding-left: 2px; }

@media screen and (max-width:1015px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { width: auto; float: right; }
div#adtoniq-msg h2 { font-size: 20px!important; }

p.a_deets { font-size: 14px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {width: auto!important; padding: 15px;}
#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { padding: 10px 0;}
} 

@media screen and (max-width:640px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

div#adtoniq-msg h2 { font-size: 18px!important; }
p.a_deets { font-size: 11px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
} 

@media screen and (max-width:565px){ 
#adtoniq-msg { width: 170px; padding-right: 30px; width: 65%; padding-right: 25px; }

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert { padding: 10px; width: auto!important; max-width: none; }
#adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { font-size: 11px; line-height: 17px; padding: 8px 14px!important;}
}


@media screen and (max-width:339px){ 
    #adtoniq-msg { width: 99%; padding-bottom: 7px; }
	#adtoniq-btns {width: 100%!important; float: none!important; margin-top: 20px;text-align: center;display: block!important;}
	#adtoniq-msgr-bar #adtoniq-btns { display: inline!important; }
	#adtoniq-msg-track-btn, #adtoniq-msg-no-track-btn { display: inline-block!important; }
	button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { float: left; }
	button#adtoniq-msg-no-track-btn { margin-top: 0!important; }
}


#adtoniq-msgr-bar.adtoniq-waisa.reveal-alert { z-index: 999; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons { text-align: center; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons button { margin: 10px; }
.adtoniq-mobile { }</style>
<script src='https://static-42andpark-com.s3-us-west-2.amazonaws.com/js/adtoniq-www-theregister-co-uk.js'></script>
<script>
(function () {var x = 'e9118d6e-f930-4f0b-b56c-0bede59096cc'})
</script>
<link rel='stylesheet' href='https://static-42andpark-com.s3-us-west-2.amazonaws.com/css/adtoniq-messenger-alert.css'>

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id="page">
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

        <div id="masthead">
        <a href="https://www.theregister.co.uk/" id=logo>
            <picture>
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo_no_strapline.svg" media="(max-width: 799px)">
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" media="(min-width: 800px)">
                <img src="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
            </picture>
        </a>
            <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>
    <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
        <a id="mob_user_link" href="https://account.theregister.co.uk/register/" aria-label="Your Account">
            <span id="mob_user_icon" class="user_login_icon"></span>
            <span id="mob_user_text">Sign in</span>
        </a>
<a href="/Tag/coronavirus/" id=m-sec-tag-coronavirus data-nav=".tag_coronavirus_nav" data-name="Coronavirus">Coronavirus</a>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
    </nav>

    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/Tag/coronavirus" id=sec-tag-coronavirus data-nav=".tag_coronavirus_nav" data-name="Coronavirus">Coronavirus</a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
            <a id="user_icon" class="user_login_icon" href="https://account.theregister.co.uk/register/" title="Your Account" aria-label="Your Account"></a>
        </nav>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/21/jaxa_htv_9_wifi_test/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/21/kounotori_jaxa.jpg"><h5>International space station testing WiFi links to incoming craft, with an eye on autonomous docking</h5></a>
                    <a class="story_link" href="/2020/05/21/att_slapped_down_for_its/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/26/shutterstock_5g_geek.jpg"><h5>AT&amp;T slapped down for its '5G E' ads: You don’t have a 5G network, so stop saying so, says watchdog</h5></a>
                    <a class="story_link" href="/2020/05/20/google_9_week_next_on_air/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/31/shutterstock_bored2.jpg"><h5>Hands up who wants to listen to Google blather on about cloud stuff? OK, a few of you. How about for nine weeks?</h5></a>
                    <a class="story_link" href="/2020/05/20/itam_forum_launches/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/23/shutterstock_contract.jpg"><h5>ITAM Forum opens: 'People just want to talk to other managers about how to defend against software audits'</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/20/windows_terminal_powertoys/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/10/shutterstock_old_pc.jpg"><h5>Windows Terminal hits the big 1.0: Fit for production?</h5></a>
                    <a class="story_link" href="/2020/05/20/microsoft_announces_official_windows_package/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/20/winget.jpg"><h5>Microsoft announces official Windows package manager. 'Not a package manager' users snap back</h5></a>
                    <a class="story_link" href="/2020/05/20/microsoft_directx_wsl_linux/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/04/15/hardware_chip.jpg"><h5>DirectX comes to Linux (via WSL2): Microsoft unveils tricks needed to flash a GPU at a penguin</h5></a>
                    <a class="story_link" href="/2020/05/20/google_chrome_83/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/10/shutterstock_chrome_security.jpg"><h5>Google rolls out pro-privacy DNS-over-HTTPS support in Chrome 83... with a handy kill switch for corporate IT</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/21/securus_prison_wiretapping_lawsuit/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/11/16/shuttertsock_prison_break.jpg"><h5>Remember when Securus was sued for recording 14,000 calls between prison inmates and lawyers? It just settled</h5></a>
                    <a class="story_link" href="/2020/05/20/mod_covid_19_app_data_anonymising/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/20/ipadconfused.jpg"><h5>UK's Ministry of Defence: We'll harvest and anonymise private COVID-19 apps' tracing data by handing it to 'behavioural science' arm</h5></a>
                    <a class="story_link" href="/2020/05/20/ransomware_has_gone_nuclear/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/07/shutterstock_nuke_blast.jpg"><h5>Ransomware has gone nuclear: To avoid any fallout yourself, tune in online this month to hear from KnowBe4</h5></a>
                    <a class="story_link" href="/2020/05/20/houseparty_subdomain_hijack/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/19/houseparty_screenshot.jpg"><h5>Houseparty denied it had been hacked... while miscreants were abusing its dot-com domain name infrastructure</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/18/secure_development_during/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/13/crypto_325345456456.jpg"><h5>Watch on-demand, online here: Secure development during digital transformation</h5></a>
                    <a class="story_link" href="/2020/05/14/red_hat_openshift_aws/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/28/woman_in_ret_hat_photo_via_shutterstock.jpg"><h5>AWS pulls its Red Hat on with managed OpenShift collab</h5></a>
                    <a class="story_link" href="/2020/05/13/harbors_container_registry/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/09/boats_storm_girl_photo_via_nikolina_mrakovic_shutterstock_dot_com.jpg"><h5>We'd love to come up with a Harbor container ship pun but we're too corona-frazzled. Version 2.0 is out</h5></a>
                    <a class="story_link" href="/2020/05/06/github_offers_hosted_visual_studio/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/23/shutterstock_github.jpg"><h5>GitHub rolls out hosted Visual Studio Code in Codespaces</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/20/us_senators_call_for_transparency_tsmc_fab/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/28/shutterstock_magnifying.jpg"><h5>US senators call for more transparency over $12bn TSMC fab plant investment</h5></a>
                    <a class="story_link" href="/2020/05/20/mps_ignore_calls_to_delay/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/01/16/shutterstock_running_business.jpg"><h5>UK MPs to off-payroll workers: Delay IR35 reforms until 2023? You wish</h5></a>
                    <a class="story_link" href="/2020/05/20/philippines_digital_services_tax/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/20/salceda_tax_argument.jpg"><h5>Philippines floats digital services tax – and Uber’s local arm surprisingly applauds</h5></a>
                    <a class="story_link" href="/2020/05/20/indeed_lawsuit/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/14/harrassment.jpg"><h5>Indeed sued by account exec who said she was raped by male coworker amid misogynistic, sexually charged culture</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/20/apple_siri_transcriptions/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/07/james_stewart_harvey.jpg"><h5>Hey Siri, are you still recording people's conversations despite promising not to do so nine months ago?</h5></a>
                    <a class="story_link" href="/2020/05/20/huawei_p40_lite_5g_uk_availability/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/19/p40lite5g.jpg"><h5>Huawei to sling Google-free mid-range P40 Lite 5G at British shores this summer</h5></a>
                    <a class="story_link" href="/2020/05/20/honor_launches_new_uk_store/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/19/shutterstock_toothbrush_foul.jpg"><h5>Honor launches new UK store, laptop, kettle, er... toothbrush?</h5></a>
                    <a class="story_link" href="/2020/05/19/xiaomi_miui_12/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/25/minote10.jpg"><h5>MIUI importante! Xiaomi's updated Android fork bears better permissions plus new ultra-battery-saver mode</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/20/skylark_l/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/20/skylark-l_static_fire.jpg"><h5>UK takes a step closer to domestic launches as Skyrora fires up Skylark-L</h5></a>
                    <a class="story_link" href="/2020/05/20/nasas_human_spaceflight_boss_hits/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/08/03/ejector_seat_action.jpg"><h5>NASA's Human Spaceflight boss hits eject a week before SpaceX crew launch</h5></a>
                    <a class="story_link" href="/2020/05/19/space_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/05/x37.jpg"><h5>Dickens' forgotten spaceship classic: A Tale of Three Missions</h5></a>
                    <a class="story_link" href="/2020/05/18/artemis_accords/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/21/moon_water.jpg"><h5>NASA launches guide to Lunar etiquette now that private operators will share the Moon with governments</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/20/microsoft_buys_softomotive/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/22/robots_image_via_shutterstock.jpg"><h5>The software bots are coming, the software bots are coming: Microsoft swallows UK automation minnow while dreaming of low-code apps</h5></a>
                    <a class="story_link" href="/2020/05/20/apple_glass_rumors/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/20/scoble_shower_patent_glass.jpg"><h5>We really doing this again? Rumour has it that Apple is nearly finished developing augmented-reality glasses</h5></a>
                    <a class="story_link" href="/2020/05/20/facebook_marketplace_ai/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/12/newdress.jpg"><h5>It's, it's, a red-and-blue striped golfing umbrella... Facebook teaches its online tat bazaar to auto-identify stuff for sale</h5></a>
                    <a class="story_link" href="/2020/05/19/xilinx_space_chips/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/05/18/xilinx_kintex.jpg"><h5>Hey, what kind of silicon may power next-gen space probes? We hope your answer includes 'AI acceleration'</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/05/20/berlin_nightclubs_no_dancing/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/31/tumbleweed.jpg"><h5>Berlin's renowned nightclub scene is showing signs of life. Just one problem: No dancing</h5></a>
                    <a class="story_link" href="/2020/05/18/museums_tech_uk/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/10/04/tnmoc_block_h_colossus.jpg"><h5>Doors closed by COVID-19, Brit retro tech museums need your help</h5></a>
                    <a class="story_link" href="/2020/05/18/trump_open_source_huawei/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/26/trump.jpg"><h5>Huge if true... Trump explodes as he learns open source could erode China tech ban</h5></a>
                    <a class="story_link" href="/2020/05/16/70m_pints_of_british_beer/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/08/shutterstock_pulling_pints.jpg"><h5>Beer gut-ted: As many as '70 million pints' spoiled during coronavirus pandemic must be destroyed in Britain</h5></a>
                </div>
            </div>
        </div>
    </div>


    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>








    
    <div id=top-col-story>
        
        <div id="crumb_trail">
            <h4 class="dcl">
                <a class="has_lateral_ornaments pascal_comment" href="/software/" aria-label="Software">Software</a>
            </h4>
        </div>
        
    <h1>Could it be? Really? The Year of Linux on the Desktop is almost here, and it's... Windows-shaped?</h1>
    
    <h2>Windows Subsystem for Linux to gain out-of-the-box support for GUI apps, GPU chippery</h2>
    

    </div>
    
    <div id=main-col>
        
        
        <div class="timestamp_and_comments">
        
            <span class="dateline">Tue&nbsp;19&nbsp;May&nbsp;2020<span class="slashes"> // </span>15:00</span>
        
        <a id="got_tips" class="alt_colour" href="mailto:news@theregister.co.uk?subject=%5BReader%20Tip%5D&amp;body=re:%20https%3A%2F%2Fwww.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/" title="Got a juicy news tip? Let us know">
            Got Tips?
        </a>
        
            <a href="https://forums.theregister.co.uk/forum/all/2020/05/19/wsl2_gui_linux_apps_windows/" class="reg_comments">                    <span>104</span>
                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">            </a>        </div>
        <div class="byline_and_share">
            <span class="byline_name_contact">
                <a href="/Author/Richard-Speed" title="Read more by this author" class="byline_name">Richard Speed</a>
                <span class="byline_contact alt_colour">
                    <a href="/Author/Richard-Speed">Bio</a>
                    <a href="mailto:richard.speed@theregister.co.uk">Email</a>
                    <a href="http://twitter.com/intent/user?screen_name=richard_speed" target="_blank" title="Follow on twitter">Twitter</a>
                                    </span>
            </span>
            <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
        </div>
        
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/&title=Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F&amp;url=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/&amp;via=theregister" class=twit target="_blank">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/" target="_blank">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/&amp;title=Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F&amp;summary=Windows%20Subsystem%20for%20Linux%20to%20gain%20out-of-the-box%20support%20for%20GUI%20apps%2C%20GPU%20chippery" class=linkedin_social target="_blank">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

        

        <div id="article-wrapper">
            
            <div id="article" >

                <div class="article_head">
    <img class="article_img" alt="Microsoft Windows and 'Tux' Linux logos next to each" srcset="https://regmedia.co.uk/2020/05/19/windows_linux_kernel_logos.jpg?x=396&amp;y=198&amp;crop=1 396w, https://regmedia.co.uk/2020/05/19/windows_linux_kernel_logos.jpg?x=478&amp;y=239&amp;crop=1 478w, https://regmedia.co.uk/2020/05/19/windows_linux_kernel_logos.jpg?x=648&amp;y=324&amp;crop=1 648w" sizes="(max-width: 409px) 396px, (max-width: 649px) 478px, 478px" src="https://regmedia.co.uk/2020/05/19/windows_linux_kernel_logos.jpg?x=648&amp;y=324&amp;crop=1">
                </div>
                <div id="body">
                    
                <p><strong class="trailer">Build</strong> Microsoft's Build 2020 appears to mark the long-awaited Year Of Linux on the Desktop thanks to incoming Windows Subsystem for Linux (WSL) improvements, including GUI support.</p>
                <p><a target="_blank" href="https://www.theregister.co.uk/2019/05/06/windows_subsystem_for_linux_terminal/">WSL2 was quite the star</a> of 2019's Build event and brought with it a tweaked Linux kernel, full system compatibility, and considerably snappier file performance. While its <a target="_blank" href="https://www.theregister.co.uk/2016/03/30/bash_shell_comes_to_windows_10/">predecessor</a>, effectively a translation layer, was the technological tour de force, WSL2 did the previously unthinkable and dropped a Linux kernel into Windows.</p>
                <p>Sadly, developers restricted to production machinery are still waiting to see the fruits of Microsoft's efforts. After last year's fanfare, the update was added to Windows 10 20H1 for Insiders to test. Alas, the ongoing delays in actually getting 20H1 out of preview and into general availability has left the new toys out of reach for many.</p>
                <p>Not in 20H1 but <a target="_blank" rel="nofollow" href="https://blogs.windows.com/windowsdeveloper/2020/05/19/developing-for-all-1-billion-windows-10-devices-and-beyond/">announced</a> at this year's Build is the arrival of GUI support for Linux apps running in WSL2 thanks to Wayland and RDP painting the app on the Windows desktop. Access to GPUs from Linux is also on the way.</p>
                <p>The two features regularly top the list of "wants" from developers and will be welcomed by the community, even if the thought of a graphical Linux app nestling among the Windows might cause some long-time Microsoft watchers to pass coffee through their noses.</p>
                <p>Users prepared to jump through a few hoops have been able to coax WSL into displaying graphical Linux apps for some time. Back in 2018, open-source startup Whitewater Foundry released a distro preconfigured for graphical shenanigans in the form of Debian-based <a target="_blank" href="https://www.theregister.co.uk/2018/09/26/wlinux/">WLinux</a>, which required the addition of a Windows X server to make the magic happen.</p>
                <p>Now, according to Microsoft, "support for Linux graphical user interface (GUI) apps will enable you to open a WSL instance and run a Linux GUI app directly without the need for a third-party X server."</p>
                <p>Hayden Barnes, Canonical senior developer advocate, told us the company had been looking at including an X Server in its own Microsoft Store distro but instead elected to collaborate with the Windows giant on its preferred path: "Both opened up a handful of edge cases, and it's just better to work together on these than try to do it on our own."</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2019/05/06/screenshot_linux_windows_deskop.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Linux on Windows"/>
<h2 title="Windows Update for the Linux kernel? No wonder Gates stepped down">Microsoft frees Windows Subsystem for Linux 2 from the shackles of, er, Windows?</h2>
<a href="https://www.theregister.co.uk/2020/03/16/windows_slow_ring_wsl_2/"><span>READ MORE</span></a></div>
                <p>Canonical is no stranger to collaborating with the former Linux-loathing (and now Penguin-petting) behemoth, having seen Ubuntu 18.04 LTS elevated to a <a target="_blank" href="https://www.theregister.co.uk/2018/09/19/ubuntu_microsoft_hyper_v/">first-class citizen of Microsoft's Hyper-V</a> hypervisor in 2018.</p>
                <p>In terms of what Windows users might actually use this graphical Linux support for, Microsoft suggested that developers might have a Linux IDE they'd prefer to use. Barnes agreed, putting forward KDevelop or GNOME Builder as use cases. "You don't want to torture some people with Emacs," he laughed.</p>
                <p>While the GUI support may be the most eye-catching (when it arrives in Windows 10 – it took a few weeks after 2019's Build for WSL2 to arrive in the hands of Insiders), it is GPU support that has many excited. It will accelerate GUI applications and "it also unlocks GPU accelerated workflows," explained Barnes, "things like TensorFlow on MicroK8s on WSL."</p>
                <p>The arrival of GPU acceleration for WSL2 will indeed remove a few roadblocks for users, particularly those wishing to experiment on-premises ahead of a transition to dedicated Linux machinery or a full-on Hyper-V session.</p>
                <p>Getting those GUI Linux apps running will still require diving into the command line (although we have no doubt that some enterprising users will soon have seamless links up and running on their Windows desktops). However, Microsoft also announced that WSL would be receiving a simplified install experience, "which will make it easier than ever to start using Linux apps on Windows."</p>
                <p>The Year of the Linux Desktop appears to be upon us. We're just a bit surprised that it seems to have turned out to be Windows. ®</p>
                    
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1942/-8722/ransomware-has-gone-nuclear?td=wptl1942">Webcast: Ransomware has gone nuclear</a>
                </p>
                <script>
                    RegWpTl = [
                        '<a href="https://go.theregister.co.uk/tl/1916/-8373/practical-tips-for-office-365-tenant-to-tenant-migration?td=wptl1916">Practical tips for Office 365 tenant-to-tenant migration<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1942/-8722/ransomware-has-gone-nuclear?td=wptl1942">Webcast: Ransomware has gone nuclear<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1945/-8720/how-to-simplify-data-protection-on-amazon-web-services?td=wptl1945">Webcast: Simplify data protection on AWS<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1940/-8722/ransomware-has-gone-nuclear?td=wptl1940">Ransomware has gone nuclear<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1946/-8720/how-to-simplify-data-protection-on-amazon-web-services?td=wptl1946">How to simplify data protection on Amazon Web Services<\/a>'
                    ];
                </script>
                </div>

                
                <div id=article_body_btm>
                    <div id="tips_or_corrections">
                        <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/"
                            title="Spotted an error or have a tip? Let us know.">
                            Tips and corrections
                        </a>
                    </div>
                    
                <div class="comments large">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2020/05/19/wsl2_gui_linux_apps_windows/">
                        <span>104</span>
                        Comments
                    </a>
                </div>
            
                </div>
                            </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/windows%2010">Windows 10</a>
                </li>
            </ul>
        </div>


            
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/&title=Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F&amp;url=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/&amp;via=theregister" class=twit target="_blank">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/" target="_blank">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/&amp;title=Could%20it%20be%3F%20Really%3F%20The%20Year%20of%20Linux%20on%20the%20Desktop%20is%20almost%20here%2C%20and%20it%27s...%20Windows-shaped%3F&amp;summary=Windows%20Subsystem%20for%20Linux%20to%20gain%20out-of-the-box%20support%20for%20GUI%20apps%2C%20GPU%20chippery" class=linkedin_social target="_blank">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


            
                <script type="text/javascript">show_article_signup_ml();</script>
            

        </div>
    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3 class="has_lateral_ornaments c_comment">Most Read</h3>
    <ol>
        <li>
            <a href="/2020/05/20/us_spy_bill/">
                            <img src="https://regmedia.co.uk/2016/11/30/shutterstock_fbi_guy.jpg?x=200&amp;y=200&amp;crop=1" alt="" width=90 height=90>
                <h4>You know this Land of the Free thing, yeah? Well then, why allow the FBI to trawl through America's browsing history without a warrant?
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/05/19/sap_analytics_cloud_office_integration/">
                            <img src="https://regmedia.co.uk/2016/05/17/excel_on_smart_phone_photo_via_rosonic_on_shutterstock.jpg?x=200&amp;y=200&amp;crop=1" alt="Excel on smart phone, photo via RoSonic on Shutterstock" width=90 height=90>
                <h4>SAP proves, yet again, that Excel is utterly unkillable
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/05/20/google_chrome_83/">
                            <img src="https://regmedia.co.uk/2019/09/10/shutterstock_chrome_security.jpg?x=200&amp;y=200&amp;crop=1" alt="Chrome logo behind a padlock silhouette " width=90 height=90>
                <h4>Google rolls out pro-privacy DNS-over-HTTPS support in Chrome 83... with a handy kill switch for corporate IT
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/05/19/easyjet_hack_9million_2000_credit_cards/">
                            <img src="https://regmedia.co.uk/2016/11/15/easyjet_photo_via_shutterstock.jpg?x=200&amp;y=200&amp;crop=1" alt="Easyjet photo, via Shutterstock" width=90 height=90>
                <h4>Easyjet hacked: 9 million people's data accessed plus 2,200 folks' credit card details grabbed
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/05/19/bellingcat_beer_app_osint/">
                            <img src="https://regmedia.co.uk/2020/05/19/untappd_beer_app.jpg?x=200&amp;y=200&amp;crop=1" alt="Untappd beer app homepage" width=90 height=90>
                <h4>Beer rating app reveals homes and identities of spies and military bods, warns Bellingcat
                </h4>
            </a>
        </li>
    </ol>
</div>
<a id="story_rhs_ml_signup" href="https://account.theregister.co.uk/register/?product=thereg_weekly_newsletter&utm_medium=site&utm_source=article&utm_campaign=story_rhs_ml_signup">
    <h4>SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER</h4>
    <span aria-hidden="true" class="reg_btn_secondary subscribe_newsletter_button">SUBSCRIBE</span>
    <img class="half_vulture16bits" alt="" width="83" height="65" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_16bits_half.svg">
</a>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
        <div id="read_more_on">
            <h3 class="has_lateral_ornaments c_comment">Keep Reading</h3>
            <div class=stories><div class="story">
                    <a href="/2020/05/14/the_end_really_is_nigh/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/09/01/shutterstock_vintage_pc_printer_phone.jpg?x=198&amp;y=131&amp;crop=1" alt="Vintage PC with floppy drive, dot matrix printer and old school desk phone, steaming coffee: a still life. photo by Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>The end really is nigh – for 32-bit Windows 10 on new PCs</h4>
                            <div class=standfirst>
                                It&#8217;s 64-bit or nothing for PC-makers from now on. And face it, this isn't the year of Linux on the desktop
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/05/13/windows_10_2004_release_preview_tweak/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/01/30/toolkit_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Shutterstock tools" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Third time lucky for Windows 10 2004? Microsoft yet again fiddles with code and adds a go-live SDK licence</h4>
                            <div class=standfirst>
                                Ooh... Aah... Just a little fix
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/04/15/windows_10_1809_support_extended/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/09/24/shutterstock_zombie_hand_grave.jpg?x=198&amp;y=131&amp;crop=1" alt="A freshly dead hand rises from grave" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft throws extended support lifeline for folk stuck on car-crash Windows 10 1809</h4>
                            <div class=standfirst>
                                Also: 2010 server products to survive into 2021 as overstretched admins given more breathing space
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/03/20/windows_10_1709_support_extended/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/04/10/update_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="update" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Finally – news that <i>something</i> is guaranteed to be healthy and well looked-after for the next six months. That something is Windows 10 1709</h4>
                            <div class=standfirst>
                                Microsoft extends support because right now we have better things to do with our lives than upgrade Windows
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/02/18/ikea_bork/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/02/17/ikea_windows_10.jpg?x=198&amp;y=131&amp;crop=1" alt="IKEA Windows 10" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>OK, which Dombås stuffed Windows 10 to bursting at Swedish flatpack flinger?</h4>
                            <div class=standfirst>
                                <span class=trailer>Bork!Bork!Bork!</span>
                                If only there was some way of organising the space
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/01/28/dtrace_windows_10_update/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/11/09/magnifyingglasswoman.jpg?x=198&amp;y=131&amp;crop=1" alt="Curious woman looking through a magnifying glass" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Kernel debugger begone: Microsoft emits update for DTrace on Windows 10</h4>
                            <div class=standfirst>
                                Only Insiders need apply for now
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/03/23/ikea_bork/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/03/20/bork_10.jpg?x=198&amp;y=131&amp;crop=1" alt="IKEA Bork" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Forget about those pesky closures, Windows 10 has an important message for you</h4>
                            <div class=standfirst>
                                <span class=trailer>Bork!Bork!Bork!</span>
                                Remember the three rules: social distancing, hand washing, giving Windows enough storage
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/04/17/windows_10_may_2020_update/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/12/23/airplane_still.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Mayday! Mayday! The next Windows 10 update is finally on approach to a PC near you</h4>
                            <div class=standfirst>
                                New version of Microsoft's OS shuffles into the Release Preview spotlight
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class="dcl has_lateral_ornaments c_comment">Tech Resources</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8722/ransomware-has-gone-nuclear?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Ransomware has gone nuclear</h4>
                <div class=standfirst>
                    A new generation of attackers are crafting plans to cause the most panic, pain, and operational disruption. They will take the time to maximize your organization’s potential damage and also their payoff -- not just encrypting your data, but stealing it and posting it publicly if you don’t play ball. Join Roger Grimes from KnowBe4 and Tim Phillips from The Reg for a RegCast in which they will be sounding the ransomware emergency klaxon.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8511/a-definitive-guide-to-understanding-and-meeting-the-cis-critical-security-controls?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>A Definitive Guide to Understanding and Meeting the CIS Critical Security Controls</h4>
                <div class=standfirst>
                    The CIS Critical Security Controls are the industry standard for good security. Are you up to par?
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8784/leadership-compass-privileged-access-management?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Leadership Compass: Privileged Access Management</h4>
                <div class=standfirst>
                    An overview of the market for PAM solutions and a compass to help buyers find the solution that best meets their needs
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8753/2020-sans-network-visibility-and-threat-detection-survey?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>2020 SANS Network Visibility and Threat Detection Survey</h4>
                <div class=standfirst>
                    Read the report to learn how to do more with the network data you already have and what to look for in a network visibility tool.
                </div>
            </a>
        </div>

    
    <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2020/05/19/wsl2_gui_linux_apps_windows/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
    <script>
        if (RegCBWT()) {
            $('<hr>').insertBefore('#story-bot-col .OUTBRAIN');
            var outB = document.createElement('script');
            outB.type = 'text/javascript';
            outB.async = true;
            outB.src = 'https://widgets.outbrain.com/outbrain.js';
            $(outB).insertAfter('#story-bot-col .OUTBRAIN');
            $('<hr>').insertAfter('#story-bot-col .OUTBRAIN');
        }
    </script>
    

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XsXwWBrFA3Q3j5XxcqDG0wAAAJM&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Latest News</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Popular Stories</a></li>
                    <li><a href="https://forums.theregister.co.uk/">Forums</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://devclass.com/">DevClass</a></li>
                    <li><a href="https://blocksandfiles.com/">Blocks and Files</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a class="alt_colour dcl" href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="reg_btn_secondary subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>SUBSCRIBE</strong><img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2020</p>
        <div class=foot_btm_links>
            
            <a href="https://www.theregister.co.uk/Profile/privacy_policy_california_residents/">Do not sell my personal information</a>

            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            if ( typeof(RegSendGA) === 'function' )
                RegSendGA();
        </script>

<script>if(RegCBWT()){!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);}</script>


        <script>
            $(function() { RegUtils.set_bucket_group(624) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

