<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Grsecurity maker finally coughs up $300k to foot open-source pioneer Bruce Perens' legal bill in row over GPL • The Register</title>
    <meta name="robots" content="max-snippet:-1, max-image-preview:standard, max-video-preview:0">
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2020/03/27/shutterstock_pay_now.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/" />
    <meta property="og:title" content="Grsecurity maker finally coughs up $300k to foot open-source pioneer Bruce Perens' legal bill in row over GPL" />
    <meta property="og:description" content="Failed defamation claim proves pricey" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Open Source, Security , Software">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/"},
"headline":"Grsecurity maker finally coughs up $300k to foot open-source pioneer Bruce Perens' legal bill in row over GPL",
"datePublished":"2020-03-27T23:07:53Z",
"dateModified":"2020-03-30T08:20:40Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2020/03/27/shutterstock_pay_now.jpg","width":"1000","height":"729"},
"author":{"@type":"Person","name":"Thomas Claburn"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/design_picker/1fea2ae01c5036112a295123c3cc9c56eb28836a/graphics/std/red_logo_sans_strapline.png","width":330,"height":55}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2020/03/27/grsecurity_perens_gpl_settlement/"><script>
        var RegArticle={id:207746,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['open source','Open Source'],['security','Security '],['software','Software']],short_url:'https://reg.cx/2Z3e',cp:0,noads:[],author:'Thomas Claburn',vid:0}
    </script>
    <link rel=stylesheet type="text/css" href="/css_picker/default/59d8520414350f976af1393738a6ede150b34b00/scaffolding.css">
<link rel=stylesheet type="text/css" href="/css_picker/default/59d8520414350f976af1393738a6ede150b34b00/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>

    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/9031d9d0c0ab83a2efbb659b23896eb021891f70/javascript/_.js"></script>
    <script async onerror="gpt_js_errored()" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script>
        if (RegCBWT()) {
            var nir = document.createElement('script');
            nir.type = 'text/javascript';
            nir.async = false;
            nir.src = "https://nir.theregister.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/open%20source&amp;s=vk/security&amp;s=vk/software&amp;s=vvfc/9e15ff6c77c2f748193efb257956d827&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b";
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(nir, s);
        }
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


    <style>#adtoniq-msgr-bar #adtoniq-msg {display: inline-block;}
#adtoniq-msg {width: 75%;float: left;text-align: left;}
#adtoniq-msgr-bar #adtoniq-btns {display: inline-block;}
#adtoniq-btns { width: 25%!important; float: right!important; margin-right: 0px!important; max-width: 150px;}
button#adtoniq-msg-track-btn { width: 100%; display: block;}
button#adtoniq-msg-no-track-btn { background-color: transparent!important; width: 100%; margin: 0!important; margin-top: 11px!important; color: #000000!important; font-weight: 600; font-size: 12px; border: 0; border: none;}

#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar {color: #ffffff!important;}

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {background-color: #000000; opacity: 1; width: 100%; max-width: 960px; margin: 0 auto; left: 0; right: 0; padding: 20px; border-top:2px solid #00727a;} #adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button {color: #ffffff!important;background-color: #00727a!important;margin-top: 0px;font-size: 13px;line-height: 24px;border-radius: 2px!important;font-weight: 500;padding: 10px 18px!important;letter-spacing: 1px;text-transform: uppercase; border: 0; border: none;} #adtoniq-msg {width: 70%;float: left;text-align: left;}#adtoniq-btns {width: 30%;float: none;text-align: right; margin-right:40px;} #adtoniq-msgr-bar.adtoniq-waisa p { font-size: 14px !important; line-height: 1.2; display: block; width: 100%; margin: 0 auto !important; text-align: center; max-width: 80%;} #adtoniq-msg-buttons.adtoniq-waisa { width: 100%; margin-top: 20px; } button#adtoniq-msg-track-btn {float: right;} p.a_deets {color: #000000;} #adtoniq-msgr-bar.adtoniq-waisa p { color: #ffffff; min-height: 120px; }


#a_hider .a_deets { display: inline-block; margin-bottom: 0!important;}
#a_hider.a_showme .a_deets, #a_hider.a_showme .arrow { display: none; }
#a_hider .targetadt { display: none; }
#a_hider.a_showme .targetadt { display: block; }

#a_hider { cursor: pointer; }

#a_hider:hover { cursor: pointer; }
#a_hider:hover .a_deets { text-decoration: underline; }

.arrow { height: 7px; width: 7px; border: 1px solid #000000; border-width: 2px 2px 0 0; -webkit-transform: rotate(45deg); -ms-transform: rotate(45deg); transform: rotate(45deg); display: inline-block; -webkit-transform: rotate(135deg); -ms-transform: rotate(135deg); transform: rotate(135deg); margin-left: 10px; padding-bottom: 2px; padding-left: 2px; }

@media screen and (max-width:1015px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { width: auto; float: right; }
div#adtoniq-msg h2 { font-size: 20px!important; }

p.a_deets { font-size: 14px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {width: auto!important; padding: 15px;}
#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { padding: 10px 0;}
} 

@media screen and (max-width:640px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

div#adtoniq-msg h2 { font-size: 18px!important; }
p.a_deets { font-size: 11px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
} 

@media screen and (max-width:565px){ 
#adtoniq-msg { width: 170px; padding-right: 30px; width: 65%; padding-right: 25px; }

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert { padding: 10px; width: auto!important; max-width: none; }
#adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { font-size: 11px; line-height: 17px; padding: 8px 14px!important;}
}


@media screen and (max-width:339px){ 
    #adtoniq-msg { width: 99%; padding-bottom: 7px; }
	#adtoniq-btns {width: 100%!important; float: none!important; margin-top: 20px;text-align: center;display: block!important;}
	#adtoniq-msgr-bar #adtoniq-btns { display: inline!important; }
	#adtoniq-msg-track-btn, #adtoniq-msg-no-track-btn { display: inline-block!important; }
	button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { float: left; }
	button#adtoniq-msg-no-track-btn { margin-top: 0!important; }
}


#adtoniq-msgr-bar.adtoniq-waisa.reveal-alert { z-index: 999; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons { text-align: center; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons button { margin: 10px; }
.adtoniq-mobile { }</style>
<script src='https://static-42andpark-com.s3-us-west-2.amazonaws.com/js/adtoniq-www-theregister-co-uk.js'></script>
<script>
(function () {var x = '0e6d2757-60fe-4057-91fe-b6c5de1900df'})
</script>
<link rel='stylesheet' href='https://static-42andpark-com.s3-us-west-2.amazonaws.com/css/adtoniq-messenger-alert.css'>

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id="page">
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

        <div id="masthead">
        <a href="https://www.theregister.co.uk/" id=logo>
            <picture>
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo_no_strapline.svg" media="(max-width: 799px)">
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" media="(min-width: 800px)">
                <img src="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
            </picture>
        </a>
            <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>
    <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
        <a id="mob_user_link" href="https://account.theregister.co.uk/register/" aria-label="Your Account">
            <span id="mob_user_icon" class="user_login_icon"></span>
            <span id="mob_user_text">Sign in</span>
        </a>
<a href="/Tag/coronavirus/" id=m-sec-tag-coronavirus data-nav=".tag_coronavirus_nav" data-name="Coronavirus">Coronavirus</a>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
    </nav>

    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/Tag/coronavirus" id=sec-tag-coronavirus data-nav=".tag_coronavirus_nav" data-name="Coronavirus">Coronavirus</a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
            <a id="user_icon" class="user_login_icon" href="https://account.theregister.co.uk/register/" title="Your Account" aria-label="Your Account"></a>
        </nav>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/31/cloudflare_dns/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/09/dns_shutterstock.jpg"><h5>Cloudflare is over the moon because its pro-privacy 1.1.1.1 DNS service got a clean bill of health from everyone's favorite auditor – KPMG</h5></a>
                    <a class="story_link" href="/2020/03/31/manrs_cdns/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/07/18/road_at_night_image_via_shutterstock.jpg"><h5>Watch your MANRS: Akamai, Amazon, Netflix, Microsoft, Google, and pals join internet routing security effort</h5></a>
                    <a class="story_link" href="/2020/03/31/it_spending_pandemic/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/16/shutterstock_covid_19_sf.jpg"><h5>Pandemic impact: Two-thirds of polled <i>Reg</i> readers say it's business as usual in the IT dept, one in ten panicking</h5></a>
                    <a class="story_link" href="/2020/03/31/technology_job_ads/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/shutterstock_jobs.jpg"><h5>Hunting for IT staff? Lost your job during the pandemic? Sysadmin vacancies – and a free job ads offer – inside</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/31/bork/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/bork_14_1.jpg"><h5>What's the difference between Windows 7 and a bin lorry? One is full of garbage, and the other… oh dear</h5></a>
                    <a class="story_link" href="/2020/03/31/oracle_free_education_offer/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/27/oracle_airplane_shutterstock_editorial_use_only.jpg"><h5>Oracle makes some certifications and cloudy content free, in case you have time on your hands</h5></a>
                    <a class="story_link" href="/2020/03/30/microsoft_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/01/shutterstock_rescue_ring.jpg"><h5>Microsoft qualifications will pad the CV for another year, Teams for ventilator boffins, and Windows 10 threatened with very retro news app</h5></a>
                    <a class="story_link" href="/2020/03/30/adobe_phonegap_stumbles_over_new/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/04/blurry_code2_by_zakharchuk_via_shutterstock.jpg"><h5>Adobe PhoneGap falls between the cracks thanks to new Apple requirements, developers fume</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/30/118_118_money_call_recordings/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/shutterstock_30679144.jpg"><h5>Poured your info out on a call to 118 118 Money? Bad luck. Credit provider 'fesses up that hacker nabbed customer service phone recordings</h5></a>
                    <a class="story_link" href="/2020/03/30/security_roundup_280320/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/03/28/shutterstock_top_secret.jpg"><h5>You know all those stories of leaky cloud buckets taken offline? Well, some may still be there, just badly hidden</h5></a>
                    <a class="story_link" href="/2020/03/30/sans_women_in_cybersecurity/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/25/woman_cybersecurity_image_via_shutterstock.jpg"><h5>First-ever SANS Women in Cybersecurity survey reveals significant mentorship gaps</h5></a>
                    <a class="story_link" href="/2020/03/27/doc_searls_zoom_privacy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/09/googlejamboard.jpg"><h5>Yeah, that Zoom app you're trusting with work chatter? It lives with 'vampires feeding on the blood of human data'</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/17/graph_db_compliance_network/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/12/shutetrstock_floating_city.jpg"><h5>Who the heck even owns this company? Where is it? Biz risk outfit uses graphDBs to build mammoth compliance network</h5></a>
                    <a class="story_link" href="/2020/03/10/docker_development_pipeline_service/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/04/30/dockercon19_singh.jpg"><h5>Docker disguises itself as a development pipeline service as it stalks the IT world for its elusive target – profit</h5></a>
                    <a class="story_link" href="/2020/03/10/vmware_kubernetes_tanzu_vsphere_7/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/12/23/shutterstock_vmware.jpg"><h5>Kubernetes is 'still hard' so VMware has gone all-in on container-related tech with expanded Tanzu, vSphere 7</h5></a>
                    <a class="story_link" href="/2020/03/09/monzo_microservices/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/05/microservices.jpg"><h5>How does Monzo keep 1,600 microservices spinning? Go, clean code, and a strong team</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/31/sap_project_managers_client_action_plans/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/31/start_recovery.jpg"><h5>SAP's locked-down offshore project managers develop remote work plans for clients</h5></a>
                    <a class="story_link" href="/2020/03/30/ukgov_names_chisholm/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/shutterstock_cabinet_office.jpg"><h5>UK civil service has a new boss: Alex Chisholm dubbed permanent secretary for the Cabinet Office</h5></a>
                    <a class="story_link" href="/2020/03/30/bt_free_meals_call_centre_staff/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/11/shutterstock_food_poor.jpg"><h5>BT providing free meals to coax its healthy customer support staff back into office as calls rocket amid pandemic</h5></a>
                    <a class="story_link" href="/2020/03/30/it_events_after_coronavirus/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/01/10/shutterstock_vegas.jpg"><h5>Leaving Las Vegas... for good? IT industry conference circuit won't look the same on other side of COVID-19 pandemic</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/31/us_voip_action/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/shutterstock_uncle_sam.jpg"><h5>Uncle Sam turns the screws on VoIP providers allegedly used by coronavirus, tax, bogus tech support scammers</h5></a>
                    <a class="story_link" href="/2020/03/30/planet_computers_astro_slide/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/27/astro.jpg"><h5>Planet Computers has really let things slide: Firm's third real-keyboard gizmo boasts 5G, Android 10, Linux support</h5></a>
                    <a class="story_link" href="/2020/03/26/huawei_appgallery_celia/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/05/13/google_chocolate_factory.jpg"><h5>What's a Google Play? Huawei talks up fledgling AppGallery store, shows off another voice assistant with a female name</h5></a>
                    <a class="story_link" href="/2020/03/26/huawei_p40_series/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/26/p40_pro_plus.jpg"><h5>Things that make you go zoom: Huawei rolls out pictastic P40 phones, no Google Play Store in sight</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/31/mars_express/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/04/11/mars_express.jpg"><h5>16 years and counting: How ESA squeezed oodles of bonus science out of plucky Mars Express probe</h5></a>
                    <a class="story_link" href="/2020/03/31/lunar_base_esa/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/moon_base.jpg"><h5>Are you extracting the urine, ESA? Why, yes it is, from Moon dwellers to build homes out of lunar regolith. Possibly</h5></a>
                    <a class="story_link" href="/2020/03/28/coronavirus_hydroxychloroquine_azithromycin/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/17/shutterstock_coronavirus2.jpg"><h5>Remember that clinical trial, promoted by President Trump, of a possible COVID-19 cure? So, so, so many questions...</h5></a>
                    <a class="story_link" href="/2020/03/27/trump_space_force/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/12/09/imperials_uniform.jpg"><h5>Hailing frequencies open, sir... America's Space Force hurls its first military comms satellite into Earth's orbit</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/31/opera_android_dot_crypto/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/16/crypto_fingers.jpg"><h5>Sucks to be you, ICANN. We can go our own way: Opera to support sites using renegade top-level domain .crypto</h5></a>
                    <a class="story_link" href="/2020/03/30/ai_roundup_2902320/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/01/14/jadzia_worf_laugh.jpg"><h5>Call for netizens to demand scraped pics from Clearview, ML weather forecasts, and Star Trek goes high def with AI</h5></a>
                    <a class="story_link" href="/2020/03/30/why_no_delivery_drones_during_coronavirus_lockdown/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/30/shutterstock_delivery_drone.jpg"><h5>Delivery drones: Where are they when we really need them?</h5></a>
                    <a class="story_link" href="/2020/03/28/drones_uk_coronavirus_lockdown/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/27/shutterstock_drone.jpg"><h5>Drones intone 'you must stay home,' eliciting moans from those in the zone: Flying gizmos corral Brits amid coronavirus lockdown</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/03/30/astrophysicist_magnets_stuck_up_nose_australia/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/30/shutterstock_facepalm2.jpg"><h5>Astroboffin gets magnets stuck up his schnozz trying and failing to invent anti-face-touching coronavirus gizmo</h5></a>
                    <a class="story_link" href="/2020/03/27/reg_standards_soviet_social_distancing_measure/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/26/osman.jpg"><h5>Announcing the official Reg-approved measure of social distancing: The Osman</h5></a>
                    <a class="story_link" href="/2020/03/27/davis_station_lockdown_while_seals_snore/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/03/27/elephant_seals_davis_station.jpg"><h5>Lockdown ain't easy. And that's without snoring, burping, hair-shedding seals outside your house</h5></a>
                    <a class="story_link" href="/2020/03/27/coronavirus_cure_fraud_charge/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/02/25/medical_9543464523.jpg"><h5>Instagram, YouTube 'iron man' marketer first to be nabbed by Feds cracking down on fake coronavirus web cures</h5></a>
                </div>
            </div>
        </div>
    </div>


    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col><div id="article-wrapper">
        
        
        <div id="crumb_trail">
            <h4 class="dcl">
                <a class="has_lateral_ornaments pascal_comment" href="/software/" aria-label="Software">Software</a>
            </h4>
        </div>
        <div id="article" >

            <div class="article_head">
                <h1>Grsecurity maker finally coughs up $300k to foot open-source pioneer Bruce Perens' legal bill in row over GPL</h1>
                
                <h2>Failed defamation claim proves pricey</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Thomas-Claburn" title="Read more by this author" class="alt_colour dcl">Thomas Claburn in San Francisco</a>
                        
                        <span class="dateline">
                            27&nbsp;Mar&nbsp;2020&nbsp;at&nbsp;23:07
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2020/03/27/grsecurity_perens_gpl_settlement/" class="reg_comments">                                    <span class="count">20</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&title=Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL&amp;url=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&amp;redirect_uri=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&amp;title=Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL&amp;summary=Failed%20defamation%20claim%20proves%20pricey" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2020/03/27/shutterstock_pay_now.jpg?x=442&amp;y=293&amp;crop=1" alt="A red button reading 'pay now'" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>After three years of legal wrangling, the defamation lawsuit brought by Brad Spengler and his company Open Source Security (OSS) against open-source pioneer Bruce Perens has finally concluded.</p>
                <p>It was clear that the end was nigh last month when California's Ninth Circuit Court of Appeals <a target="_blank" href="https://www.theregister.co.uk/2020/02/07/open_source_security_defamation/">affirmed a lower court ruling</a> against the plaintiffs.</p>
                <p>Spengler and OSS <a target="_blank" href="https://www.theregister.co.uk/2017/08/03/linux_kernel_grsecurity_sues_bruce_perens_for_defamation/">sued Perens</a> for a June 2017 <a target="_blank" rel="nofollow" href="https://perens.com/2017/06/28/warning-grsecurity-potential-contributory-infringement-risk-for-customers/">blog post</a> in which Perens ventured the opinion that <a target="_blank" rel="nofollow" href="https://grsecurity.net/">grsecurity</a>, Open Source Security's Linux kernel security enhancements, could expose customers to potential liability under the terms of the General Public License (GPL).</p>
                <p>OSS says that customers who exercise their rights to redistribute its software under the GPL will no longer receive software updates – the biz wants to be paid for its work, a problem not really addressed by the GPL. Perens, the creator of the <a target="_blank" rel="nofollow" href="https://opensource.org/osd-annotated">open-source definition</a>, pointed out that section six of the <a target="_blank" rel="nofollow" href="https://www.gnu.org/licenses/old-licenses/gpl-2.0.en.html">GPLv2</a> prohibits modifications of the license terms.</p>
                <p>In December 2017, San Francisco magistrate judge Laurel Beeler determined that Perens had expressed an opinion as allowed under American law and dismissed the defamation claim.</p>
                <p>Perens then sought to recoup legal expenses under California's Anti-Strategic Lawsuits Against Public Participation (SLAPP) statute, a law designed to penalize litigation brought mainly to discourage free speech and public participation. And a month later he was awarded more than $526,000 in damages.</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2020/02/07/shutterstock_open_source_banner.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Open source banner"/>
<h2 title="Ninth Circuit affirms decision that Bruce Perens was entitled to voice opinion about GPL compliance">Maker of Linux patch batch grsecurity can't duck $260,000 legal bills, says Cali appeals court in anti-SLAPP case</h2>
<a href="https://www.theregister.co.uk/2020/02/07/open_source_security_defamation/"><span>READ MORE</span></a></div>
                <p>Spengler and OSS then appealed, and managed to get the award reduced to about $260,000, but not overturned.</p>
                <p>Following the Ninth Circuit decision in February, Rohit Chhabra, attorney for OSS, declined to say whether he intended to pursue a further appeal. He insisted that Perens' statement was opinion, rather than settled legal fact, and that OSS has the right to withhold updates from customers exercising their rights under the GPL.</p>
                <p>Finally, both parties have agreed to end the litigation.</p>
                <p>On Friday, Judge Beeler signed a mutually agreed <a target="_blank" href="https://regmedia.co.uk/2020/03/27/ossvperens.pdf">order</a> [PDF] directing the payment of a $300,000 bond, filed by OSS and underwritten by its insurer, Great American Insurance Group, that was set aside to guarantee the 2018 judgement during the appeals process. The final award from OSS exceeds the $260,000 judgement because court costs have continued since then and interest payments are also due.</p>
                <p>Perens gets nothing personally for his trouble, but his legal team will be paid. O’Melveny &amp; Myers LLP will receive $262,303.62 for the district court litigation (fees and costs) and $2,210.36 for the appeal (costs) while the Electronic Frontier Foundation will be paid $34,474.35 (fees) and $1,011.67 (costs) for its role in the appeal.</p>
                <p>As to whether OSS's redistribution terms violate the GPL, that has yet to be tested in court. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1915/-8375/kemet-customer-story?td=wptl1915">Webcast: Why you need managed detection and response</a>
                </p>
                <script>
                    RegWpTl = [
                        '<a href="https://go.theregister.co.uk/tl/1916/-8373/practical-tips-for-office-365-tenant-to-tenant-migration?td=wptl1916">Practical tips for Office 365 tenant-to-tenant migration<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8381/client-story-gategroup?td=wptl1915">Webcast: Why you need managed detection and response<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8378/modern-sd-wan-management?td=wptl1915">Webcast: Why you need managed detection and response<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8377/the-definitive-guide-to-sd-wan?td=wptl1915">Webcast: Why you need managed detection and response<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8375/kemet-customer-story?td=wptl1915">Webcast: Why you need managed detection and response<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8450/webcast-slide-deck-why-you-need-managed-detection-and-response?td=wptl1915">Webcast: Why you need managed detection and response<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8374/unlock-the-value-of-sd-wan?td=wptl1915">Webcast: Why you need managed detection and response<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1915/-8406/why-you-need-managed-detection-and-response?td=wptl1915">Webcast: Why you need managed detection and response<\/a>'
                    ];
                </script>
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2020/03/27/grsecurity_perens_gpl_settlement/">
                        <span>20</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/open%20source">Open Source</a>
                </li>
                <li>
                    <a href="/Tag/security">Security </a>
                </li>
                <li>
                    <a href="/Tag/software">Software</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&title=Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL&amp;url=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&amp;redirect_uri=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/&amp;title=Grsecurity%20maker%20finally%20coughs%20up%20%24300k%20to%20foot%20open-source%20pioneer%20Bruce%20Perens%27%20legal%20bill%20in%20row%20over%20GPL&amp;summary=Failed%20defamation%20claim%20proves%20pricey" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div></div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3 class="has_lateral_ornaments c_comment">Most Read</h3>
    <ol>
        <li>
            <a href="/2020/03/30/planet_computers_astro_slide/">
                            <img src="https://regmedia.co.uk/2020/03/27/astro.jpg?x=200&amp;y=200&amp;crop=1" alt="The forthcoming Astro Slide from Planet Computers" width=90 height=90>
                <h4>Planet Computers has really let things slide: Firm's third real-keyboard gizmo boasts 5G, Android 10, Linux support
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/03/29/ico_anonymised_location_data_coronavirus/">
                            <img src="https://regmedia.co.uk/2020/03/29/coronavirus_pin_dropped_on_uk_map.jpg?x=200&amp;y=200&amp;crop=1" alt="Map of UK with Coronavirus pin stuck in London" width=90 height=90>
                <h4>UK Information Commissioner OKs use of phone data to track coronavirus spread
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/03/30/linux_5_6_released/">
                            <img src="https://regmedia.co.uk/2016/09/19/penguins_in_antarctica_shutterstock.jpg?x=200&amp;y=200&amp;crop=1" alt="Penguins in Antarctica" width=90 height=90>
                <h4>'Social distancing champ' Linus Torvalds releases Linux 5.6, tells devs to put health before next release
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/03/30/microsoft_office_changes/">
                            <img src="https://regmedia.co.uk/2016/09/07/office_365_photo_by_dennizn_via_shutterstock.jpg?x=200&amp;y=200&amp;crop=1" alt="Office 365, photo by dennizn via Shutterstock" width=90 height=90>
                <h4>Official: Office 365 Personal, Home axed next month... and replaced by Microsoft 365 cloud subscriptions
                </h4>
            </a>
        </li>
        <li>
            <a href="/2020/03/30/it_events_after_coronavirus/">
                            <img src="https://regmedia.co.uk/2020/01/10/shutterstock_vegas.jpg?x=200&amp;y=200&amp;crop=1" alt="las vegas" width=90 height=90>
                <h4>Leaving Las Vegas... for good? IT industry conference circuit won't look the same on other side of COVID-19 pandemic
                </h4>
            </a>
        </li>
    </ol>
</div>
<a id="story_rhs_ml_signup" href="https://account.theregister.co.uk/register/?product=thereg_weekly_newsletter&utm_medium=site&utm_source=article&utm_campaign=story_rhs_ml_signup">
    <h4>SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER</h4>
    <span aria-hidden="true" class="subscribe_newsletter_button">SUBSCRIBE</span>
    <img class="half_vulture16bits" alt="" width="83" height="65" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_16bits_half.svg">
</a>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
        <div id="read_more_on">
            <h3 class="has_lateral_ornaments c_comment">Keep Reading</h3>
            <div class=stories><div class="story">
                    <a href="/2020/03/18/github_mobile_app_closed_source/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/03/18/announc.jpg?x=198&amp;y=131&amp;crop=1" alt="GitHub for mobile was announced at the Universe event in 2019" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Closed source? Pull the other one... We love open source, but not enough to share code for our own app, says GitHub</h4>
                            <div class=standfirst>
                                Reviews mixed as mobile software hits GA
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/12/17/swift_ibm_pulls_back_open_source_priorities/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/12/17/shutterstock_swift.jpg?x=198&amp;y=131&amp;crop=1" alt="taylor swift" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>IBM tailors Swift relationship after 'review of open source priorities'</h4>
                            <div class=standfirst>
                                Big Blue leaves Swift server workgroup, future of Kitura server app framework uncertain
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/12/18/aws_blames_the_media/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/09/23/aws.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Amazon slams media for not saying nice things about AWS, denies it strip-mines open-source code for huge profits</h4>
                            <div class=standfirst>
                                Turns out even with the luxury and protection of billions of dollars, you still can't take any criticism
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/01/17/mit_apache_versus_gpl/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/01/17/shutterstock_716967601.jpg?x=198&amp;y=131&amp;crop=1" alt="Figure left behind on a dock as a boat sails away" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Copy-left behind: Permissive MIT, Apache open-source licenses on the up as developers snub GNU's GPL</h4>
                            <div class=standfirst>
                                Share all our code modifications with others? Think again, hippie
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/03/13/open_source_bugs/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/03/12/shutterstock_bug_software.jpg?x=198&amp;y=131&amp;crop=1" alt=" Bugs in software as an illustration" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Open-source bug bonanza: Vulnerabilities up almost 50 per cent thanks to people actually looking for them</h4>
                            <div class=standfirst>
                                Can't fix flaws if you don't look for them
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/04/17/red_hat_survey/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/04/26/girlredcap.jpg?x=198&amp;y=131&amp;crop=1" alt="Studio portrait of funny baby girl in red baseball cap over gray wall background" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Open-source enterprise software slinger Red Hat bravely reveals that IT bosses love open-source enterprise software</h4>
                            <div class=standfirst>
                                Hold the front page
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/12/16/fuse_macos_closed_source/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/10/15/shutterstock_759183667.jpg?x=198&amp;y=131&amp;crop=1" alt="Software license image" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>FUSE for macOS: Why a popular open source library became closed source and commercially licensed</h4>
                            <div class=standfirst>
                                <span class=trailer>Interview</span>
                                Maintainer: 'Most companies were reluctant to support the project their product depends on because it is available for free'
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/02/20/linux_foundation_report/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/03/27/shutterstock_javascript_crop.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>The great big open-source census: Most-used libraries revealed – plus 10 things developers should be doing to keep their code secure</h4>
                            <div class=standfirst>
                                Linux Foundation hears your gripes about naming schemes, legacy code, and more
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class="dcl has_lateral_ornaments c_comment">Tech Resources</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8381/client-story-gategroup?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Client Story: gategroup</h4>
                <div class=standfirst>
                    An Open Systems case study.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8383/modern-sd-wan-management?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Modern SD-WAN Management</h4>
                <div class=standfirst>
                    Digital transformation is changing the WAN.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8288/endpoint-detection-and-response?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Endpoint Detection and Response</h4>
                <div class=standfirst>
                    EDR solutions come in a variety of implementations and can vary significantly in scope and efficacy. Choosing the best solution can be challenging.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8530/10-critical-issues-to-cover-in-your-vendor-security-questionnaires?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>10 Critical Issues to Cover in Your Vendor Security Questionnaires</h4>
                <div class=standfirst>
                    In today’s perilous cyber world, it’s crucial for companies to assess and monitor the security of their vendors, suppliers and business partners. Failing to do so can be risky, because hackers frequently steal sensitive enterprise data by targeting the third parties to which enterprises are connected.
                </div>
            </a>
        </div>

    
    <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2020/03/27/grsecurity_perens_gpl_settlement/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
    <script>
        if (RegCBWT()) {
            $('<hr>').insertBefore('#story-bot-col .OUTBRAIN');
            var outB = document.createElement('script');
            outB.type = 'text/javascript';
            outB.async = true;
            outB.src = 'https://widgets.outbrain.com/outbrain.js';
            $(outB).insertAfter('#story-bot-col .OUTBRAIN');
            $('<hr>').insertAfter('#story-bot-col .OUTBRAIN');
        }
    </script>
    

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?co=1&amp;iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XoNALVuJD@SV2XQO8IA3fQAAAEQ&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Latest News</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Popular Stories</a></li>
                    <li><a href="https://forums.theregister.co.uk/">Forums</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://devclass.com/">DevClass</a></li>
                    <li><a href="https://blocksandfiles.com/">Blocks and Files</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup alt_colour dcl">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">SUBSCRIBE<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2020</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/privacy_policy_california_residents/">Do not sell my personal information</a>

            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            if ( typeof(RegSendGA) === 'function' )
                RegSendGA();
        </script>

<script>if(RegCBWT()){!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);}</script>


        <script>
            $(function() { RegUtils.set_bucket_group(931) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

