<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Git takes baby steps towards swapping out vulnerable SHA-1 hashing algo for SHA-256 • The Register</title>
    <meta name="robots" content="max-snippet:-1, max-image-preview:standard, max-video-preview:0">
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2020/02/05/babysteps.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2020/02/05/git_sha_256_work/" />
    <meta property="og:title" content="Git takes baby steps towards swapping out vulnerable SHA-1 hashing algo for SHA-256" />
    <meta property="og:description" content="It's proving a bit of a headache" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2020/02/05/git_sha_256_work/"},
"headline":"Git takes baby steps towards swapping out vulnerable SHA-1 hashing algo for SHA-256",
"datePublished":"2020-02-05T11:17:23Z",
"dateModified":"2020-02-05T11:16:55Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2020/02/05/babysteps.jpg","width":"648","height":"432"},
"author":{"@type":"Person","name":"Tim Anderson"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"9e15ff6c77c2f748193efb257956d827",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2020/02/05/git_sha_256_work/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2020/02/05/git_sha_256_work/"><script>
        var RegArticle={id:206837,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['git','Git']],short_url:'http://reg.cx/2Y0G',cp:0,noads:[],author:'Tim Anderson',vid:0}
    </script>
    <link rel=stylesheet type="text/css" href="/css_picker/default/a502ed1ed4dfc5555815154780a8a0e1b4ba5f51/scaffolding.css">
<link rel=stylesheet type="text/css" href="/css_picker/default/a502ed1ed4dfc5555815154780a8a0e1b4ba5f51/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>

    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/8125be5b011a6297a0c2c7ac01c6b66381c35418/javascript/_.js"></script>
    <script async onerror="gpt_js_errored()" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.theregister.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/git&amp;s=vvfc/9e15ff6c77c2f748193efb257956d827&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


    <script src='https://static-42andpark-com.s3-us-west-2.amazonaws.com/js/adtoniq-www-theregister-co-uk.js'></script>
<script>
(function () {var x = 'beac4d2f-18d2-46cb-b1e9-34ea7307e13e'})
</script>
<link rel='stylesheet' href='https://static-42andpark-com.s3-us-west-2.amazonaws.com/css/adtoniq-messenger-alert.css'>
<style>#adtoniq-msgr-bar #adtoniq-msg {display: inline-block;}
#adtoniq-msg {width: 75%;float: left;text-align: left;}
#adtoniq-msgr-bar #adtoniq-btns {display: inline-block;}
#adtoniq-btns { width: 25%!important; float: right!important; margin-right: 0px!important; max-width: 150px;}
button#adtoniq-msg-track-btn { width: 100%; display: block;}
button#adtoniq-msg-no-track-btn { background-color: transparent!important; width: 100%; margin: 0!important; margin-top: 11px!important; color: #000000!important; font-weight: 600; font-size: 12px; border: 0; border: none;}

#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar {color: #ffffff!important;}

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {background-color: #000000; opacity: 1; width: 100%; max-width: 960px; margin: 0 auto; left: 0; right: 0; padding: 20px; border-top:2px solid #00727a;} #adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button {color: #ffffff!important;background-color: #00727a!important;margin-top: 0px;font-size: 13px;line-height: 24px;border-radius: 2px!important;font-weight: 500;padding: 10px 18px!important;letter-spacing: 1px;text-transform: uppercase; border: 0; border: none;} #adtoniq-msg {width: 70%;float: left;text-align: left;}#adtoniq-btns {width: 30%;float: none;text-align: right; margin-right:40px;} #adtoniq-msgr-bar.adtoniq-waisa p { font-size: 14px !important; line-height: 1.2; display: block; width: 100%; margin: 0 auto !important; text-align: center; max-width: 80%;} #adtoniq-msg-buttons.adtoniq-waisa { width: 100%; margin-top: 20px; } button#adtoniq-msg-track-btn {float: right;} p.a_deets {color: #000000;} #adtoniq-msgr-bar.adtoniq-waisa p { color: #ffffff; min-height: 120px; }


#a_hider .a_deets { display: inline-block; margin-bottom: 0!important;}
#a_hider.a_showme .a_deets, #a_hider.a_showme .arrow { display: none; }
#a_hider .targetadt { display: none; }
#a_hider.a_showme .targetadt { display: block; }

#a_hider { cursor: pointer; }

#a_hider:hover { cursor: pointer; }
#a_hider:hover .a_deets { text-decoration: underline; }

.arrow { height: 7px; width: 7px; border: 1px solid #000000; border-width: 2px 2px 0 0; -webkit-transform: rotate(45deg); -ms-transform: rotate(45deg); transform: rotate(45deg); display: inline-block; -webkit-transform: rotate(135deg); -ms-transform: rotate(135deg); transform: rotate(135deg); margin-left: 10px; padding-bottom: 2px; padding-left: 2px; }

@media screen and (max-width:1015px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { width: auto; float: right; }
div#adtoniq-msg h2 { font-size: 20px!important; }

p.a_deets { font-size: 14px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {width: auto!important; padding: 15px;}
#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { padding: 10px 0;}
} 

@media screen and (max-width:640px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

div#adtoniq-msg h2 { font-size: 18px!important; }
p.a_deets { font-size: 11px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
} 

@media screen and (max-width:565px){ 
#adtoniq-msg { width: 170px; padding-right: 30px; width: 65%; padding-right: 25px; }

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert { padding: 10px; width: auto!important; max-width: none; }
#adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { font-size: 11px; line-height: 17px; padding: 8px 14px!important;}
}


@media screen and (max-width:339px){ 
    #adtoniq-msg { width: 99%; padding-bottom: 7px; }
	#adtoniq-btns {width: 100%!important; float: none!important; margin-top: 20px;text-align: center;display: block!important;}
	#adtoniq-msgr-bar #adtoniq-btns { display: inline!important; }
	#adtoniq-msg-track-btn, #adtoniq-msg-no-track-btn { display: inline-block!important; }
	button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { float: left; }
	button#adtoniq-msg-no-track-btn { margin-top: 0!important; }
}


#adtoniq-msgr-bar.adtoniq-waisa.reveal-alert { z-index: 999; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons { text-align: center; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons button { margin: 10px; }
.adtoniq-mobile { }</style>

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id="page">
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id="masthead">
        <a href="https://www.theregister.co.uk/" id=logo>
            <picture>
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo_no_strapline.svg" media="(max-width: 799px)">
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" media="(min-width: 800px)">
                <img src="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
            </picture>
        </a>
            <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>
    <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
    </nav>

    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/semiconductor_overall_global_spending_slumps/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/01/31/fire_money.jpg"><h5>China-US tariff tiff, Brexit and a crap economy: Why OEMs spent $56bn less on semiconductors last year</h5></a>
                    <a class="story_link" href="/2020/02/05/internet_society_org_sale/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/04/shutterstock_fed_up.jpg"><h5>Internet Society gets tetchy over .org sale delay, half-threatens ICANN over deadlines and jurisdiction</h5></a>
                    <a class="story_link" href="/2020/02/05/cisco_cdpwn_flaws/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/cdpwn_image.jpg"><h5>'Tens of millions' of Cisco devices vulnerable to CDPwn flaws: Network segmentation blown apart by security bugs</h5></a>
                    <a class="story_link" href="/2020/02/05/outlook_broken/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/09/spam_cans.jpg"><h5>Outlook more like 'look out!' as Microsoft email decides everything is spam today</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/windows_10_binged/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/28/shutterstock_magnifying.jpg"><h5>Bada Bing, bada bork: Windows 10 is not happy, and Microsoft's search engine has something to do with it</h5></a>
                    <a class="story_link" href="/2020/02/05/git_sha_256_work/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/babysteps.jpg"><h5>Git takes baby steps towards swapping out vulnerable SHA-1 hashing algo for SHA-256</h5></a>
                    <a class="story_link" href="/2020/02/05/graph_database_neo4j_chief_scientist/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/04/graph.jpg"><h5>Whaddya mean, 'niche'?! Neo4j's chief scientist schools El Reg on graph databases</h5></a>
                    <a class="story_link" href="/2020/02/04/iowa_caucus_software/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/shutterstock_dems_iowa2.jpg"><h5>Iowa has already won the worst IT rollout award of 2020: Rap for crap caucus app chaps in vote zap flap</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/whatsapp_xss_bug/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/03/shutterstock_whatsapp.jpg"><h5>Terrifying bug in WhatsApp allows hackers to steal files. So get patching all nine of you using it on the desktop</h5></a>
                    <a class="story_link" href="/2020/02/05/wacom_user_tracking/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/shutterstock_sketch_tablet.jpg"><h5>Sketchy behavior? Wacom tablet drivers phone home with names, times of every app opened on your computer</h5></a>
                    <a class="story_link" href="/2020/02/05/time_to_patch_your_lightbulb_researchers_demonstrate_philips_hue_exploit/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/lamp-vuln.jpg"><h5>Time to patch your lightbulb? Researchers demonstrate Philips Hue exploit</h5></a>
                    <a class="story_link" href="/2020/02/05/ftp_deprecated_chrome/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/18/funeral.jpg"><h5>RIP FTP? File Transfer Protocol switched off by default in Chrome 80</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/devops_workshop_cll/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/20/cll20_email_image.jpg"><h5>Get up to speed fast: Sign up now for the DevOps Essentials workshop at our brilliant Continuous Lifecycle London</h5></a>
                    <a class="story_link" href="/2020/02/03/google_cloud_adds_windows_containers_to_kubernetes_engine/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/03/k8s-diagram.jpg"><h5>Everything's coming up Kubernetes: Google Cloud adds support for Windows Server Containers</h5></a>
                    <a class="story_link" href="/2020/01/24/atlassian_2q_2020/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/12/atlassian_logo.jpg"><h5>Atlassian anticipates $1.6bn total revenue for fiscal 2020 as subscriptions make it rain</h5></a>
                    <a class="story_link" href="/2020/01/23/jenkins_creator_kohsuke_kawaguchi_steps_back_from_cloudbees/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/07/flying_cat_teaser.jpg"><h5>Jenkins creator steps back from CloudBees and flings himself at startup Launchable</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/mike_lynch_submits_himself_for_arrest/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/02/mike_lynch.jpg"><h5>Former Autonomy boss Mike Lynch 'submits himself' for arrest in central London</h5></a>
                    <a class="story_link" href="/2020/01/30/tech_companies_sue_uscis/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/05/shutterstock_us_visa.jpg"><h5>Tech outfits sue Uncle Sam over 'unlawful' H-1B admission charges totaling $350m over six years</h5></a>
                    <a class="story_link" href="/2020/01/29/apple_q1_2020/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/31/tim_cook_photo_by_jstone_via_shutterstock.jpg"><h5>How do you like them Apples? Cook drops 'record' 30 times* on conf call as iPhone sales up, services up, wearables up</h5></a>
                    <a class="story_link" href="/2020/01/27/accounting_experts_joint_statement_autonomy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/01/27/shutterstock_jelly_beans.jpg"><h5>Accounting expert told judge Autonomy was wrong not to disclose hardware sales</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/atari_vcs_console/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/shutterstock_coronavirus2.jpg"><h5>Atari would love to ship its VCS console but – would ya believe it – there's yet another delay. This time, it's the coronavirus's fault</h5></a>
                    <a class="story_link" href="/2020/02/05/the_blackberry_may_be_dead_but_others_are_lining_up_to_take_its_place_will_it_work/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/10/30/blackberry_key2_le_champagne_teaser.jpg"><h5>The BlackBerry may be dead, but others are lining up to take its place</h5></a>
                    <a class="story_link" href="/2020/02/05/mwc_coronavirus_fears/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/coronavirus2.jpg"><h5>Amid coronavirus epidemic, LG, ZTE hang up on Mobile World Congress, organizers call for 'no-handshake' policy</h5></a>
                    <a class="story_link" href="/2020/02/04/motorola_razr_owners_complain_about_hinge_noise/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/04/rustedhinge.jpg"><h5>Who's got the WD-40? Owners of Motorola's rebooted Razr whinge about creaky hinge</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/space_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/31/needyboyfriend.jpg"><h5>Billionaire pulls out of reality telly show that was supposed to find him a lunar date to take aboard Musk's space loveboat</h5></a>
                    <a class="story_link" href="/2020/02/05/galileo_uk_clause/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/29/galileo_satellite_teaser.jpg"><h5>EU tells UK: Cut the BS, sign here, and you can have access to Galileo sat's secure service</h5></a>
                    <a class="story_link" href="/2020/02/05/spacex_nasa_starship/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/spaceship.jpg"><h5>The show Musk go on: Elon asks Uncle Sam to let him fly his Starship over Texas, scores fat NASA contract</h5></a>
                    <a class="story_link" href="/2020/02/04/maven_spacecraft_plasma/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/03/mars_maven.jpg"><h5>Finally, that cruel dust world Mars proves useful: Helping scientists understand Earth's radio-scrambling plasma</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/clearviewai_cease_desist/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/17/model_selfie.jpg"><h5>Google, YouTube, Twitter tell face-rec upstart Clearview to stop harvesting people's content – that's their job</h5></a>
                    <a class="story_link" href="/2020/02/05/google_glass_now_on_sale_to_all_aimed_at_developers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/google-glass.jpg"><h5>Boss planning to tear you a new one? Google Glass is back: Weird workwear aimed at devs, but on sale to all</h5></a>
                    <a class="story_link" href="/2020/02/05/weather_ai_prediction/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/04/extreme_cold.jpg"><h5>And now, here's Cli-Mate 9000 with the weather... Pattern-recognizing neural network tries its hand at forecasting</h5></a>
                    <a class="story_link" href="/2020/02/05/blackpool_council_ai/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/pothole.jpg"><h5>This AI is full of holes: Brit council fixes thousands of road cracks spotted by algorithm using sat snaps</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="/2020/02/05/one_direction_is_a_rubbish_band_and_password/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/05/onedirection.jpg"><h5>That's what makes you hackable: Please, baby. Stop using 'onedirection' as a password</h5></a>
                    <a class="story_link" href="/2020/02/04/super_bowl_adverts/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/03/superbowl_shutterstock.jpg"><h5>What a terrible result from this year's Super Bowl. Can you believe it? Awful. Yes, we're talking about the tech ads</h5></a>
                    <a class="story_link" href="/2020/02/03/google_maps_hack_cartful_phones/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/03/cart_google_maps_phones.jpg"><h5>Artful prankster creates Google Maps traffic jams by walking a cartful of old phones around Berlin</h5></a>
                    <a class="story_link" href="/2020/02/03/tesco_scanner_fault/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2020/02/02/tesco_scan_and_shop.jpg"><h5>Very little helps: Tesco flashes ancient Windows desktop on Scan-As-You-Shop device</h5></a>
                </div>
            </div>
        </div>
    </div>


    <div id=page_overlay_side></div>
    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col><div id="article-wrapper">
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Git takes baby steps towards swapping out vulnerable SHA-1 hashing algo for SHA-256</h1>
                
                <h2>It's proving a bit of a headache</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Tim-Anderson" title="Read more by this author" class="alt_colour dcl">Tim Anderson</a>
                        
                        <span class="dateline">
                            5&nbsp;Feb&nbsp;2020&nbsp;at&nbsp;11:17
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2020/02/05/git_sha_256_work/" class="reg_comments">                                    <span class="count">18</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&title=Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256&amp;url=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&amp;redirect_uri=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&amp;title=Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256&amp;summary=It%27s%20proving%20a%20bit%20of%20a%20headache" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2020/02/05/babysteps.jpg?x=442&amp;y=293&amp;crop=1" alt="First steps" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>The Git version control system has moved closer towards using SHA-256 rather than the compromised <a target="_blank" href="https://www.theregister.co.uk/2020/01/08/hash_slamming_security_shamans/">SHA-1</a> for its hash algorithm, to help to protect code from tampering.</p>
                <p>Whenever code is committed into a Git repository, the software calculates and stores a hash value. When you retrieve the code, the hash is recalculated to ensure that the code is the same. Git also uses these hash values as a database key and to avoid storing the same code twice. If the hash value is the same, the code is presumed to be the same.</p>
                <p>What this means is that the hashing algorithm is at the heart of how Git functions. Git uses SHA-1, but in early 2017 it was shown by a team of Google engineers and others that SHA-1 can be broken, meaning that there is a technique for finding collisions, defined as different data that has the same hash value. We reported on this <a target="_blank" href="https://www.theregister.co.uk/2017/02/23/google_first_sha1_collision/">here</a>.</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2020/01/08/shutterstock_hash_tag.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Someone upset about a hashtag"/>
<h2 title="Unsafe hashing algorithm really is unsafe">Hash snag: Security shamans shame SHA-1 standard, confirm crucial collisions citing circa $45k chip cost</h2>
<a href="https://www.theregister.co.uk/2020/01/08/hash_slamming_security_shamans/"><span>READ MORE</span></a></div>
                <p>The potential consequences are serious because it means that code in a Git repository could be tampered without detection. Since Git is the world's most popular version control system, that is a frightening possibility.</p>
                <p>Last year, at the US Real World Crypto Symposium, there were <a target="_blank" href="https://www.theregister.co.uk/2020/01/08/hash_slamming_security_shamans/">demonstrations</a> of a SHA-1 collision attack that is "much more threatening for real protocols".</p>
                <h3 class="crosshead">
  <span>Not so easy to break, nonetheless. Just ask Linus £$%^ Torvalds</span>
</h3>
                <p>In practice the weakness is not easy to exploit. Linus Torvalds, the creator of Git, <a target="_blank" href="https://www.theregister.co.uk/2017/02/26/git_fscked_by_sha1_collision_not_so_fast_says_linus_torvalds/">said at the time</a>: "The sky isn't falling. There's a big difference between using a cryptographic hash for things like security signing, and using one for generating a 'content identifier' for a content-addressable system like git."</p>
                <p>Git is not secured by the hash algorithm, and finding collisions is not trivial. Further, there's the challenge of finding a collision that works with tampered code that achieves some malicious goal. Torvalds also <a target="_blank" href="https://marc.info/?l=git&amp;m=148787047422954">observed</a>: "Git doesn't actually just hash the data, it does prepend a type/length field to it. That usually tends to make collision attacks much harder, because you either have to make the resulting size the same too, or you have to be able to also edit the size field in the header."</p>
                <p>The weakness is real, though, and the Git team began investigating what it would take to replace it. A glance down <a target="_blank" href="https://public-inbox.org/git/CA+dhYEViN4-boZLN+5QJyE7RtX+q6a92p0C2O6TA53==BZfTrQ@mail.gmail.com/T/">this thread</a> shows how challenging it is to replace the algorithm while maintaining compatibility with existing repositories. But a plan was formed and the Git hash function transition to SHA-256 is documented <a target="_blank" href="https://github.com/bk2204/git/blob/transition-stage-4/Documentation/technical/hash-function-transition.txt">here</a>.</p>
                <p>Nearly three years on, Git developer Brian M Carlson has now <a target="_blank" href="https://marc.info/?l=git&amp;m=157891970412498&amp;w=2">posted</a> to the git developer mailing list a request for comments on "part 1 of 3 of a SHA-256 implementation". It is not a complete implementation since "you can create a SHA-256 repository, but will be unable to read it". Further: "It lacks support for cloning, fetching, and pushing, which while considered non-goals in the transition plan, are required for the test suite to even come close to passing."</p>
                <p>Carlson has promised to follow up with part 2, covering interoperability between SHA-1 and SHA-256 repositories, and part 3, providing the missing pieces to enable tests to run against the new version. You can also see the full work in progress implementation <a target="_blank" href="https://github.com/bk2204/git/tree/transition-stage-4">here</a>.</p>
                <p>"Because this series sets up (and documents!) a useless option (which is a large footgun) and because I'd like feedback about this approach, this series is RFC [Request for Comments]," Carlson said.</p>
                <p>As Jonathan Corbet, editor of LWN, <a target="_blank" href="https://lwn.net/SubscriberLink/811068/cfeb6a67b8dfbe47/">observed</a>: "This work is unlikely to land on the systems of most Git users for some time yet." It has not been treated as urgent because of the difficulty in exploiting the SHA-1 weakness, but a fix will be most welcome. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1889/-8120/detecting-cyber-attacks-as-a-small-to-medium-business?td=wptl1889">Detecting cyber attacks as a small to medium business</a>
                </p>
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2020/02/05/git_sha_256_work/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2020/02/05/git_sha_256_work/">
                        <span>18</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>



        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&title=Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256&amp;url=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&amp;redirect_uri=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2020/02/05/git_sha_256_work/&amp;title=Git%20takes%20baby%20steps%20towards%20swapping%20out%20vulnerable%20SHA-1%20hashing%20algo%20for%20SHA-256&amp;summary=It%27s%20proving%20a%20bit%20of%20a%20headache" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div></div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3 class="rhs_line">MOST READ</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2020/02/05/google_chrome_id_numbers/">
                            <img src="https://regmedia.co.uk/2020/02/05/shutterstock_google_chrome.jpg?x=200&amp;y=200&amp;crop=1" alt="Google Chrome logo" width=90 height=90>
                <h4>Is Chrome really secretly stalking you across Google sites using per-install ID numbers? We reveal the truth
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2020/02/04/windows_vista_ee/">
                            <img src="https://regmedia.co.uk/2020/02/04/ee_bork.jpg?x=200&amp;y=200&amp;crop=1" alt="Windows Vista makes a comeback" width=90 height=90>
                <h4>'Windows Vista' spotted doing a whoopsie over EE's signage
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2020/02/04/twitter_phone_numbers/">
                            <img src="https://regmedia.co.uk/2018/04/23/shutterstock_vintage_phone.jpg?x=200&amp;y=200&amp;crop=1" alt="woman on vintage rotary telephone 1950s" width=90 height=90>
                <h4>Twitter says a certain someone tried to discover the phone numbers used by potentially millions of twits
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2020/02/04/hisilicon_camera_backdoor/">
                            <img src="https://regmedia.co.uk/2020/02/04/shutterstock_china_backdoor.jpg?x=200&amp;y=200&amp;crop=1" alt="Illustration of a China backdoor" width=90 height=90>
                <h4>This is not Huawei to reassure people about Beijing's spying eyes: Trivial backdoor found in HiSilicon's firmware for net-connected cams, recorders
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2020/02/04/vmware/">
                            <img src="https://regmedia.co.uk/2018/02/01/cash_shuttertock.jpg?x=200&amp;y=200&amp;crop=1" alt="cash" width=90 height=90>
                <h4>Virtualization juggernaut VMware hits the CPU turbo button for licensing costs
                </h4>
            </a>
        </li>
    </ol>
</div>
<a id="story_rhs_ml_signup" href="https://account.theregister.co.uk/register/?product=thereg_weekly_newsletter&utm_medium=site&utm_source=article&utm_campaign=story_rhs_ml_signup">
    <h4>SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER</h4>
    <span aria-hidden="true" class="subscribe_newsletter_button">SUBSCRIBE</span>
    <img class="half_vulture16bits" alt="" width="83" height="65" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_16bits_half.svg">
</a>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/10/08/euroisp_slams_government_calls_to_weaken_encryption/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/11/06/encryption_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Encryption" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Euro ISP club: Sure, weaken encryption. It'll only undermine security for everyone, morons</h4>
                            <div class=standfirst>
                                UK, Oz and US pleas to Facebook given short shrift
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/11/20/google_cloud_next/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/11/20/cloudnext.jpg?x=198&amp;y=131&amp;crop=1" alt="Google Cloud Next at London&amp;#39;s Excel conference centre" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Cloud nine to cloud nein: Google beefs up punters' data encryption to fend off cyber-thieves</h4>
                            <div class=standfirst>
                                Just don't forget where you put your keys and you'll be fine
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/02/04/security_key_google_opensk/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/02/03/opensk-dongle.jpg?x=198&amp;y=131&amp;crop=1" alt="Google demonstrates the OpenSK dongle (from promotional video)" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Google's OpenSK lets you BYOSK – burn your own security key</h4>
                            <div class=standfirst>
                                Now there's no excuse
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/12/16/internet_of_crap_encryption/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/03/20/shutterstock_keys.jpg?x=198&amp;y=131&amp;crop=1" alt="Woman holding keys" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Internet of crap (encryption): IoT gear is generating easy-to-crack keys</h4>
                            <div class=standfirst>
                                Poor entropy in embedded devices leading to weaker certificates: study
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/11/18/interpol_says_encryption_helps_sickos_prey_on_kids/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/06/24/suicidal_clown_shutterstock_648.jpg?x=198&amp;y=131&amp;crop=1" alt="suicidal_clown_shutterstock_648" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Interpol: Strong encryption helps online predators. Build backdoors</h4>
                            <div class=standfirst>
                                Multinational cop agency reportedly set to issue statement
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/06/26/amd_epyc_key_security_flaw/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/07/06/amd_sinking.jpg?x=198&amp;y=131&amp;crop=1" alt="AMD underwater" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Epyc crypto flaw? AMD emits firmware fix for server processors after Googler smashes RAM encryption algorithms</h4>
                            <div class=standfirst>
                                <span class=trailer>Updated</span>
                                SEV code cracked to leak secret keys
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/01/17/scottish_cops_cellebrite_kiosks/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/01/17/youtube_scottish_police_vid_cellebrite.jpg?x=198&amp;y=131&amp;crop=1" alt="Still from Scottish police YouTube video showing use of a Cellebrite device" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Unlocking news: We decrypt those cryptic headlines about Scottish cops bypassing smartphone encryption</h4>
                            <div class=standfirst>
                                <span class=trailer>Vid</span>
                                New perspective on FBI, Interpol demands for backdoors
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2020/01/21/efs_ransomware_poc/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2020/01/21/shutterstock_encrypted_text.jpg?x=198&amp;y=131&amp;crop=1" alt="Encrypted data" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>WTF, EFS? Experts warn Windows encryption could spawn nasty new ransomware</h4>
                            <div class=standfirst>
                                Redmond's own security tools could be abused by hard-to-block file-scrambling software nasties
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8252/reduce-redis-enterprise-deployment-cost-complexity-with-intel-optane-dc-persistent-memory?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Reduce Redis Enterprise Deployment Cost, Complexity with Intel® Optane™ DC Persistent Memory</h4>
                <div class=standfirst>
                    Intel and Redis Labs have prepared this kit to help you reduce Redis Enterprise deployments cost and complexity with 2nd Generation Intel® Xeon® Scalable processors and Intel® Optane™ DC persistent memory.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8272/ceo-fraud?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>CEO Fraud</h4>
                <div class=standfirst>
                    CEO fraud has ruined the careers of many executives and loyal employees. Don’t be one of them.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8120/detecting-cyber-attacks-as-a-small-to-medium-business?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Detecting cyber attacks as a small to medium business</h4>
                <div class=standfirst>
                    If security by obscurity is no longer an option, and inaction is a risk in itself, what can smaller enterprises do to protect themselves? Endpoint Detection and Response (EDR) solutions can go a long way towards minimising the level of threat, but they need to be chosen and used in the right way.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8201/ema-report-network-detection-and-response-in-the-cloud-comes-of-age?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>EMA Report: Network Detection and Response in the Cloud Comes of Age</h4>
                <div class=standfirst>
                    &quot;ExtraHop's new Reveal(x) Cloud SaaS offering for AWS takes the deployment burden away from AWS customers, enabling fast service provisioning and instant asset discovery, and providing threat detection, investigation, and response.&quot;
                </div>
            </a>
        </div>
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
    <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55Xjts1ro8Kz261BT7JBSm2wAAAEU&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Latest News</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Popular Stories</a></li>
                    <li><a href="https://forums.theregister.co.uk/">Forums</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://devclass.com/">DevClass</a></li>
                    <li><a href="https://blocksandfiles.com/">Blocks and Files</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup alt_colour dcl">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">SUBSCRIBE<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2020</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            if ( typeof(RegSendGA) === 'function' )
                RegSendGA();
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(149) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

