<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Crossing the platforms: The Register checks in with Canonical's WSL alternative – Multipass • The Register</title>
    <meta name="robots" content="max-snippet:-1, max-image-preview:standard, max-video-preview:0">
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2016/06/20/hotticket.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/12/18/multipass/" />
    <meta property="og:title" content="Crossing the platforms: The Register checks in with Canonical's WSL alternative – Multipass" />
    <meta property="og:description" content="Lightweight Linux VMs for all. So long as Ubuntu is your thing" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Linux">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/12/18/multipass/"},
"headline":"Crossing the platforms: The Register checks in with Canonical's WSL alternative \u2013 Multipass",
"datePublished":"2019-12-18T10:00:13Z",
"dateModified":"2019-12-17T12:26:16Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2016/06/20/hotticket.jpg","width":"650","height":"511"},
"author":{"@type":"Person","name":"Richard Speed"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/12/18/multipass/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/12/18/multipass/"><script>
        var RegArticle={id:206247,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['linux','Linux'],['canonical','Canonical'],['wsl','Wsl']],short_url:'http://reg.cx/2XwT',cp:0,noads:[],author:'Richard Speed',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400,700&amp;display=swap">
<link rel=stylesheet type="text/css" href="/css_picker/default/a7bcd36e17ca48db482c3b5d73a11a4cabe2eebd/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/c0512c71db8f9a838e4f9e8c753c334720cf8092/javascript/_.js"></script>
    <script async onerror="gpt_js_errored()" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/linux&amp;s=vk/canonical&amp;s=vk/wsl&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


    <script src='https://static-42andpark-com.s3-us-west-2.amazonaws.com/js/adtoniq-www-theregister-co-uk.js'></script>
<script>
(function () {var x = '03afdb0a-4840-4b3d-a53f-737a38537261'})
</script>
<link rel='stylesheet' href='https://static-42andpark-com.s3-us-west-2.amazonaws.com/css/adtoniq-messenger-alert.css'>
<style>#adtoniq-msgr-bar #adtoniq-msg {display: inline-block;}
#adtoniq-msg {width: 75%;float: left;text-align: left;}
#adtoniq-msgr-bar #adtoniq-btns {display: inline-block;}
#adtoniq-btns { width: 25%!important; float: right!important; margin-right: 0px!important; max-width: 150px;}
button#adtoniq-msg-track-btn { width: 100%; display: block;}
button#adtoniq-msg-no-track-btn { background-color: transparent!important; width: 100%; margin: 0!important; margin-top: 11px!important; color: #000000!important; font-weight: 600; font-size: 12px; border: 0; border: none;}

#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar {color: #ffffff!important;}

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {background-color: #000000; opacity: 1; width: 100%; max-width: 960px; margin: 0 auto; left: 0; right: 0; padding: 20px; border-top:2px solid #00727a;} #adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button {color: #ffffff!important;background-color: #00727a!important;margin-top: 0px;font-size: 13px;line-height: 24px;border-radius: 2px!important;font-weight: 500;padding: 10px 18px!important;letter-spacing: 1px;text-transform: uppercase; border: 0; border: none;} #adtoniq-msg {width: 70%;float: left;text-align: left;}#adtoniq-btns {width: 30%;float: none;text-align: right; margin-right:40px;} #adtoniq-msgr-bar.adtoniq-waisa p { font-size: 14px !important; line-height: 1.2; display: block; width: 100%; margin: 0 auto !important; text-align: center; max-width: 80%;} #adtoniq-msg-buttons.adtoniq-waisa { width: 100%; margin-top: 20px; } button#adtoniq-msg-track-btn {float: right;} p.a_deets {color: #000000;} #adtoniq-msgr-bar.adtoniq-waisa p { color: #ffffff; min-height: 120px; }


#a_hider .a_deets { display: inline-block; margin-bottom: 0!important;}
#a_hider.a_showme .a_deets, #a_hider.a_showme .arrow { display: none; }
#a_hider .targetadt { display: none; }
#a_hider.a_showme .targetadt { display: block; }

#a_hider { cursor: pointer; }

#a_hider:hover { cursor: pointer; }
#a_hider:hover .a_deets { text-decoration: underline; }

.arrow { height: 7px; width: 7px; border: 1px solid #000000; border-width: 2px 2px 0 0; -webkit-transform: rotate(45deg); -ms-transform: rotate(45deg); transform: rotate(45deg); display: inline-block; -webkit-transform: rotate(135deg); -ms-transform: rotate(135deg); transform: rotate(135deg); margin-left: 10px; padding-bottom: 2px; padding-left: 2px; }

@media screen and (max-width:1015px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { width: auto; float: right; }
div#adtoniq-msg h2 { font-size: 20px!important; }

p.a_deets { font-size: 14px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {width: auto!important; padding: 15px;}
#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { padding: 10px 0;}
} 

@media screen and (max-width:640px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

div#adtoniq-msg h2 { font-size: 18px!important; }
p.a_deets { font-size: 11px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
} 

@media screen and (max-width:565px){ 
#adtoniq-msg { width: 170px; padding-right: 30px; width: 65%; padding-right: 25px; }

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert { padding: 10px; width: auto!important; max-width: none; }
#adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { font-size: 11px; line-height: 17px; padding: 8px 14px!important;}
}


@media screen and (max-width:339px){ 
    #adtoniq-msg { width: 99%; padding-bottom: 7px; }
	#adtoniq-btns {width: 100%!important; float: none!important; margin-top: 20px;text-align: center;display: block!important;}
	#adtoniq-msgr-bar #adtoniq-btns { display: inline!important; }
	#adtoniq-msg-track-btn, #adtoniq-msg-no-track-btn { display: inline-block!important; }
	button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { float: left; }
	button#adtoniq-msg-no-track-btn { margin-top: 0!important; }
}


#adtoniq-msgr-bar.adtoniq-waisa.reveal-alert { z-index: 999; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons { text-align: center; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons button { margin: 10px; }
.adtoniq-mobile { }</style>

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id="page">
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Webcasts</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id="masthead">
        <a href="https://www.theregister.co.uk/" id=logo>
            <picture>
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo_no_strapline.svg" media="(max-width: 799px)">
                <source srcset="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" media="(min-width: 800px)">
                <img src="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
            </picture>
        </a>
            <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>
    <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
    </nav>

    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/huawei_all_flash_storage/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/shutterstock_huawei_logo.jpg"><h5>All-flash storage: Faster, more stable, more cost-effective</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/inlink_limited_administration/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/12/inlinkuk_crash_3.jpg"><h5>InLink Limited limited: Firm that puts up UK's ad-supported phone booths enters administration</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/aws_blames_the_media/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/23/aws.jpg"><h5>Amazon slams media for not saying nice things about AWS, denies it strip-mines open-source code for huge profits</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/palo_alto_it_admin/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/18/jail_shuttterstock.jpg"><h5>IT isn't supposed to stand for Insider Trading... Palo Alto Networks sysadmin and pals accused of $7m shares caper</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/multipass/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/20/hotticket.jpg"><h5>Crossing the platforms: <i>The Register</i> checks in with Canonical's WSL alternative – Multipass</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/swift_ibm_pulls_back_open_source_priorities/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/shutterstock_swift.jpg"><h5>IBM tailors Swift relationship after 'review of open source priorities'</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/windows_10_insider/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/shutterstock_jelly_beans.jpg"><h5>In an homage to Harry Potter's every-flavour jelly beans, Microsoft unveils 'Lucky Dip' Windows 10 testing ring</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/737_max_halt/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/shutterstock_1544062016.jpg"><h5>Deadly 737 Max jets no longer a Boeing concern – for now: Production suspended after biz runs out of parking space</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/lifelabs_data_leak/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/04/shutterstock_doc_annoyed.jpg"><h5>Medical biz LifeLabs fesses up: Hackers slurped 15 million customer records – and we paid them to hand it all back</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/edward_snowden_memoir/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/23/snowden_9845983.jpg"><h5>You leak our secrets? We'll leak your book sales, speech fees – into our coffers: Uncle Sam wins royalties fight against Edward Snowden</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/jet2_hacker_scott_burns_prison_sentence/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/06/shutterstock_jet2_plane.jpg"><h5>Jet2 hacker who deleted every account on UK company's domain cops 5 months in jail</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/blackberry_sentinelone_non_compete_salesman_lawsuit/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/23/royal_courts_justice.jpg"><h5>BlackBerry tells UK High Court that security outfit SentinelOne is its direct rival</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/evolving_datacenters_without_complexity/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/11/kubernetes_logo.jpg"><h5>Watch online today: Take your IT ops to the next level – without drowning in complexity</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/avoiding_legacy_in_devops/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/10/shutterstock_old_pc.jpg"><h5>Just an FYI: That cool funky CI/CD tool you're installing now could be next year's legacy tech</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/16/devops_lessons_from_the_suite_past/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/09/shutterstock_choices.jpg"><h5>Devs face a choice: Go all in with a single cloud giant's toolset – or bring together best tools from a bunch of vendors</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/06/continuous_lifecycle_london_blind_bird_offer/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/24/view_qe_ii.jpg"><h5>Continuous Lifecycle London blind bird offer takes off soon: Book your place today at our DevOps conference</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/googles_paying_tax_down_under/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/09/01/tax-running.jpg"><h5>What’s that Skippy? Google’s coughed up $330m in tax Down Under?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/post_office_trial_fujitsu_horizon_judgment/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/03/27/shutterstock_755822530.jpg"><h5>Post Office faces potential criminal probe over Fujitsu IT system's accounting failures</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/samsung_chairman_and_vp_jailed/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/18/prison_shutterstock.jpg"><h5>Samsung says sorry as union-busting chairman and VP head off for 18 months in the chokey</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/google_security_engineer_fired/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/04/20/shutterstock_strike_bullhorn.jpg"><h5>Google security engineer says she was fired for daring to remind Googlers they do indeed have labor rights</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/huaweis_p40_and_p40_handsets_wont_ship_with_google_mobile_services_richard_yu_confirms/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/25/richard_yu_huawei_consumer.jpg"><h5>Huawei's P40 and P40 Pro handsets will not ship with Google Mobile Services, Richard Yu confirms</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/unrollme_ftc_slap/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/shutterstock_crafty.jpg"><h5>Remember Unrollme, the biz that helped you automatically ditch unwanted emails? Yeah, it was selling your data</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/windows_10_mobile_still_here/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/03/18/monty_python_dead.jpg"><h5>I don't want to go on the cart! Windows 10 Mobile hauls itself from the grave one last time</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/ifixit_slaps_apples_pricey_mac_air_with_a_repairability_score_of_9/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/macpro.jpg"><h5>iFixit surgeons dissect Apple's pricey Mac Pro: Industry standard sockets? Repair diagrams? Who are you and what have you done to Apple?</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/iau_exoplanet_naming/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/08/09/exoplanet_system.jpg"><h5>No, Illyrian, Naqaỹa, Mastika, Automex aren't Hollywood's hottest baby names – they're new monikers for exoplanets</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/happy_artemis_day_everybody_nasa_preps_its_monster_rocket_for_testing/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/10/shutterstock_party_hard.jpg"><h5>Happy Artemis Day everybody! NASA preps its monster rocket for testing</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/cocoon_of_carbon_ions/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/17/galaxy_cloud.jpg"><h5>Someone get Greenpeace on the line. Boffins clock carbon 'pollution' cloud 30,000 light-years wide choking galaxies</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/13/van_allen_belts/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/13/van_allen_radiation_belts.jpg"><h5>And now for this evening's space weather report. We've got a hotspot of satellite-wrecking 'killer electrons' in the outer Van Allen belt...</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/iot_standards_war/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/18/shutterstock_battle_field.jpg"><h5>The IoT wars are over, maybe? Amazon, Apple, Google give up on smart-home domination dreams, agree to develop common standards</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/voice_tech_roundtable_writeup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/11/shutterstock_office_voice_assistant.jpg"><h5>We gathered together some <i>Register</i>-reading IT pros to talk about voice AI assistants in the legal, finance worlds. Here's what they said...</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/intel_habana_buy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/16/habana_gaudi.jpg"><h5>Intel is doing so well at AI acceleration, it's dropped $2bn on another neural-net chip upstart (third time's a charm)</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/16/dead_coin_exec_exhumation/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/16/shutterstock_headstone.jpg"><h5>Put the crypt into cryptocoin: Amid grave concerns, lawyers to literally dig into exchange exec who died owing $190m</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/nerds_hate_speech/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/29/nerd_fail_photo_via_shutterstock.jpg"><h5>Hate speech row: Fine or jail anyone who calls people boffins, geeks or eggheads, psychology nerd demands</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/18/epilepsy_foundation_troll_charges/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/18/shutterstock_internet_troll.jpg"><h5>Cool 'joke', bro, you could have killed someone: Epilepsy Foundation sics cops on sick flashing-light Twitter trolls</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/17/museum_of_computing_gets_a_christmas_tidy_up/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/12/shark_photo_via_shutterstock.jpg"><h5>The National Museum of Computing goes Marie Kondo at Christmas: Luckily all the Lego sparks joy</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/12/16/starship_chocolate_fraud/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/12/13/chocolate_shutterstock.jpg"><h5>Buzz kill: Crook, 73, conned investors into shoveling millions into geek-friendly caffeine-loaded chocs that didn't exist. Now he's in jail</h5></a>
                </div>
            </div>
        </div>
    </div>


    <div id=page_overlay_side></div>
    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col><div id="article-wrapper">
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Crossing the platforms: <i>The Register</i> checks in with Canonical's WSL alternative – Multipass</h1>
                
                <h2>Lightweight Linux VMs for all. So long as Ubuntu is your thing</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Richard-Speed" title="Read more by this author" class="alt_colour dcl">Richard Speed</a>
                        
                        <span class="dateline">
                            18&nbsp;Dec&nbsp;2019&nbsp;at&nbsp;10:00
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/12/18/multipass/" class="reg_comments">                                    <span class="count">3</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/12/18/multipass/&title=Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass&amp;url=https://www.theregister.co.uk/2019/12/18/multipass/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/12/18/multipass/&amp;redirect_uri=https://www.theregister.co.uk/2019/12/18/multipass/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/12/18/multipass/&amp;title=Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass&amp;summary=Lightweight%20Linux%20VMs%20for%20all.%20So%20long%20as%20Ubuntu%20is%20your%20thing" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2016/06/20/hotticket.jpg?x=442&amp;y=293&amp;crop=1" alt="Hot ticket" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>Canonical is preparing some festive fun for developers with a major release of its lightweight VM manager, <a target="_blank" rel="nofollow" href="https://github.com/CanonicalLtd/multipass">Multipass</a>.</p>
                <p>We <a target="_blank" href="https://www.theregister.co.uk/2019/01/22/multipass/">took a look at the application</a> at the start of the year, and came away impressed with Multipass as an alternative to the Windows Subsystem for Linux (WSL) under Windows 10 for those seeking some Linux command line goodness without having to go down the full Windows 10 Hyper-V route.</p>
                <p>Of course, back then WSL was little more than a compatibility layer. The <a target="_blank" href="https://www.theregister.co.uk/2019/06/13/wsl_2/">upcoming WSL2</a> (part of 20H1, Windows 10 2004 or whatever codename Microsoft has picked today) has changed the landscape dramatically since it now includes that all important Linux kernel. Which, of course, raises the question of what exactly the point is of Multipass in this brave new world?</p>
                <p>With the impending 1.0 release, <i>The Register</i> had a chat with Michal Sawicz, engineering manager at Canonical, about the platform and what the future might hold.</p>
                <p>For those unfamiliar, Multipass is an app that is callable from the command line (we used PowerShell in our testing) or GUI which will download, launch and manage instances of Ubuntu. The 16.04 LTS and <a target="_blank" href="https://www.theregister.co.uk/2018/04/27/ubuntu_1804/">18.04 LTS</a> images are both there for download, with the latter, Bionic Beaver, being the default. Other images are apparently available, although a <code>multipass find</code> only showed the LTS editions, which is no bad thing.</p>
                <p>The addition of the <code>-cloud-init</code> option is the app's party piece since it permits the Multipass VMs to be provisioned using <a target="_blank" href="https://www.theregister.co.uk/2018/11/19/popular_programming_language_yaml/">YAML</a>, just like VMs in the cloud. Creating Ubuntu instances in this way gives developers a quick and easy way to provision and test code locally.</p>
                <p>Multipass is also cross platform. While Windows users need Hyper-V or VirtualBox, Linux fans get support through KVM, and Mac-using developers require HyperKit (or VirtualBox again). Multipass will also keep its images up to date.</p>
                <p>However, for Windows 10 users, the shadow of WSL2 looms large, and with Canonical doubling down in its support for Microsoft's Linux love-in with the hiring of <a target="_blank" rel="nofollow" href="https://twitter.com/unixterminal">Pengwin co-creator Hayden Barnes</a> and <a target="_blank" rel="nofollow" href="https://ubuntu.com/blog/canonical-sponsors-wslconf-at-microsoft-hq">sponsoring of the upcoming WSLConf</a> at Microsoft's Seattle headquarters, is there a future for Multipass?</p>
                <p>Unsurprisingly, Sawicz reckons there is, and told us "WSL2 and Multipass serve somewhat different purposes."</p>
                <p>While WSL2 famously tries to share as much as it can between host and container, "Multipass however strives for higher isolation, mimicking the cloud approach" although Sawicz did admit that there was some cross platform pollination, telling us the Multipass gang worked "closely" with the WSL team.</p>
                <p>Once that version 1.0 milestone is under its belt, the gang plans to add some extra use cases to the tool, including IDE integration ("click a button to get a build of your code going in a Multipass instance" explained Sawicz) as well as enabling native experiences on Windows and macOS (such as microk8s.)</p>
                <p>Of course, developer darling <a target="_blank" rel="nofollow" href="https://code.visualstudio.com/docs/remote/remote-overview">Visual Studio Code features the Remote Code Development extension</a>, which permits devs to use a container, remote machine or, yes, WSL, as a full development environment. There would certainly be scope to add a Multipass extension replete with YAML to create local instances that look a lot like production.</p>
                <p>With three engineers on the project as well as Sawicz, the Multipass team has been able to achieve a surprising amount, not least the addition of VirtualBox support. Sawicz told <i>The Register</i> that he expected some growth after that version one, which already included community contributions.</p>
                <p>Canonical boss Mark Shuttleworth was quick to extol the virtues of the tech during a chat with <i>The Register</i> at the recent Kubecon event. However, he was equally enthused about the possibilities afforded by WSL2.</p>
                <p>It's fair to say that Canonical is hedging its bets as far as Linux on Microsoft platforms is concerned. Developers, on the other hand, continue to be spoiled for choice. And Multipass, unlike WSL2, is cross-platform. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1858/-7798/how-to-process-wrangle-analyze-and-visualize-your-data-with-three-complementary-tools?td=wptl1858">How to Process, Wrangle, Analyze and Visualize your Data with Three Complementary Tools</a>
                </p>
                <script>
                    RegWpTl = [
                        '<a href="https://go.theregister.co.uk/tl/1858/-7799/beyond-the-data-frontier?td=wptl1858">Beyond the Data Frontier<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7802/technical-overview-exasol-peek-under-the-hood?td=wptl1858">Technical Overview: Exasol Peek Under the Hood<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7801/your-guide-to-becoming-truly-data-driven-with-unrivalled-data-analytics-performance?td=wptl1858">Your Guide to Becoming Truly Data-Driven with Unrivalled Data Analytics Performance<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7798/how-to-process-wrangle-analyze-and-visualize-your-data-with-three-complementary-tools?td=wptl1858">How to Process, Wrangle, Analyze and Visualize your Data with Three Complementary Tools<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7800/what-next-after-netezza?td=wptl1858">What next after Netezza?<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7813/how-to-get-more-from-microstrategy-by-optimising-your-data-stack?td=wptl1858">How to get more from MicroStrategy by optimising your data stack<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-8085/from-cdo-to-ceo?td=wptl1858">From CDO to CEO<\/a>'
                    ];
                </script>
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/12/18/multipass/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/12/18/multipass/">
                        <span>3</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/linux">Linux</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/12/18/multipass/&title=Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass&amp;url=https://www.theregister.co.uk/2019/12/18/multipass/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/12/18/multipass/&amp;redirect_uri=https://www.theregister.co.uk/2019/12/18/multipass/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/12/18/multipass/&amp;title=Crossing%20the%20platforms%3A%20The%20Register%20checks%20in%20with%20Canonical%27s%20WSL%20alternative%20%E2%80%93%20Multipass&amp;summary=Lightweight%20Linux%20VMs%20for%20all.%20So%20long%20as%20Ubuntu%20is%20your%20thing" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div></div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3 class="title_rhs_line">MOST READ</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/12/17/ifixit_slaps_apples_pricey_mac_air_with_a_repairability_score_of_9/">
                            <img src="https://regmedia.co.uk/2019/12/17/macpro.jpg?x=200&amp;y=200&amp;crop=1" alt="Mac Pro teardown" width=90 height=90>
                <h4>iFixit surgeons dissect Apple's pricey Mac Pro: Industry standard sockets? Repair diagrams? Who are you and what have you done to Apple?
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/12/17/swift_ibm_pulls_back_open_source_priorities/">
                            <img src="https://regmedia.co.uk/2019/12/17/shutterstock_swift.jpg?x=200&amp;y=200&amp;crop=1" alt="taylor swift" width=90 height=90>
                <h4>IBM tailors Swift relationship after 'review of open source priorities'
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/12/18/aws_blames_the_media/">
                            <img src="https://regmedia.co.uk/2015/09/23/aws.jpg?x=200&amp;y=200&amp;crop=1" alt="" width=90 height=90>
                <h4>Amazon slams media for not saying nice things about AWS, denies it strip-mines open-source code for huge profits
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/12/17/737_max_halt/">
                            <img src="https://regmedia.co.uk/2019/12/17/shutterstock_1544062016.jpg?x=200&amp;y=200&amp;crop=1" alt="Boeing 737 Max, grounded at Renton, Wash." width=90 height=90>
                <h4>Deadly 737 Max jets no longer a Boeing concern – for now: Production suspended after biz runs out of parking space
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/12/17/whatsapp_group_chat_wipe_vulnerability/">
                            <img src="https://regmedia.co.uk/2017/09/06/whatsapp_on_iphone_shutterstock_editorial_only.jpg?x=200&amp;y=200&amp;crop=1" alt="Whatsapp running on an iPhone" width=90 height=90>
                <h4>WhatsApp chaps rapped for crap app group chat zap: Infosec bods find a way to nuke messages, fix issued
                </h4>
            </a>
        </li>
    </ol>
</div>

                <script>var RegABTest = 'A_aVnslITyK8U4soe88Piw.0';</script><a id="story_rhs_ml_signup" href="https://account.theregister.co.uk/register/?product=thereg_weekly_newsletter&utm_medium=site&utm_source=article&utm_campaign=story_rhs_ml_signup">
    <h4>SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER</h4>
    <span aria-hidden="true" class="subscribe_newsletter_button">SUBSCRIBE</span>
    <img class="half_vulture16bits" alt="" width="83" height="65" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_16bits_half.svg">
</a>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/05/06/windows_subsystem_for_linux_terminal/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/05/06/screenshot_windows_termnal_nice.jpg?x=198&amp;y=131&amp;crop=1" alt="Windows Terminal" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>The Year Of Linux On The Desktop – at last! Windows Subsystem for Linux 2 brings the Linux kernel into Windows</h4>
                            <div class=standfirst>
                                <span class=trailer>Build</span>
                                Also: A new Windows Terminal is here and on GitHub
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/12/11/microsoft_teams_on_linux/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/11/13/shutterstck_business_productivitys.jpg?x=198&amp;y=131&amp;crop=1" alt="staff in business suits thrash each other with ring binders" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft's Teams goes to bat for the other team with preview on Linux</h4>
                            <div class=standfirst>
                                There is no escape from collaboration
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/06/27/microsoft_linux_distro_list/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/04/26/gentoo_penguins_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Gentoo penguins photo via Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>2001: Linux is cancer, says Microsoft. 2019: Hey friends, ah, can we join the official linux-distros mailing list, plz?</h4>
                            <div class=standfirst>
                                Windows giant cheered on by Linux Foundation as it seeks membership of private security-focused message board
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/09/25/centos_stream_linux_distro_release/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/09/25/centos.jpg?x=198&amp;y=131&amp;crop=1" alt="Centos Stream: a new distro which tracks the next minor release of Red Hat Enterprise Linux" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>New CentOS Linux distro sips updates from RHEL codebase like an ever-flowing Stream</h4>
                            <div class=standfirst>
                                Want a peek at what's coming in Red Hat? Step this way
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/11/04/open_invention_network_will_pivot_to_take_on_patent_trolls/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/11/01/keithbergelt.jpg?x=198&amp;y=131&amp;crop=1" alt="Keith Bergelt, CEO Open Invention Network" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Pro-Linux IP consortium Open Invention Network will 'pivot' to take on patent trolls</h4>
                            <div class=standfirst>
                                Not many actual software companies threaten Linux now
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/08/27/google_touts_managed_linux_get_cosy_with_dell_in_chromebook_enterprise_push/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/08/27/dell-chromebook.jpg?x=198&amp;y=131&amp;crop=1" alt="Two Dell Latitude notebooks are now available with Chrome OS Enterprise Upgrade" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Google touts managed Linux, gets cosy with Dell in Chromebook Enterprise push</h4>
                            <div class=standfirst>
                                Security plus Linux application support &#8211; enough to tempt enterprises?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/12/06/azure_sphere_19_11/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/06/24/microsoft_loves_linux.jpg?x=198&amp;y=131&amp;crop=1" alt="Microsoft Loves Linux" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Still in preview, but look! You can now develop Azure Sphere apps in Linux – if you dare</h4>
                            <div class=standfirst>
                                19.11 brings penguin support and a Visual Studio Code extension
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/10/28/kernelci_becomes_linux_foundation_project/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/10/28/kernelci.jpg?x=198&amp;y=131&amp;crop=1" alt="Greg Kroah-Hartman (left) and Kevin Hilman annouce KernelCI becoming part of the Linux Foundation" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Annoyed by too many kernel testing projects? Good news. Linux Foundation anoints chosen one – KernelCI</h4>
                            <div class=standfirst>
                                Stop, collaborate and listen
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8056/the-five-essential-elements-of-next-generation-endpoint-protection?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>The Five Essential Elements of Next-Generation Endpoint Protection</h4>
                <div class=standfirst>
                    The endpoint security market continues to expand with vendors old and new marketing their solutions as “next-generation” game-changers.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8120/detecting-cyber-attacks-as-a-small-to-medium-business?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Detecting cyber attacks as a small to medium business</h4>
                <div class=standfirst>
                    If security by obscurity is no longer an option, and inaction is a risk in itself, what can smaller enterprises do to protect themselves? Endpoint Detection and Response (EDR) solutions can go a long way towards minimising the level of threat, but they need to be chosen and used in the right way.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8070/evolving-datacenters-without-complexity?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Evolving Datacenters without Complexity</h4>
                <div class=standfirst>
                    In this session, we’ll talk about how IT leaders are advancing the capabilities of their datacenters to rise to today’s challenges. Our guest speaker, Chris Bradford, Product Manager at DataStax will bring first-hand expertise to a discussion with The Register host Elena Perez.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6199/requirements-driven-software-development-and-quality-management?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Requirements-driven software development and quality management</h4>
                <div class=standfirst>
                    A shift is underway in many development teams from traditional delivery models to Agile methods.
                </div>
            </a>
        </div>

    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/12/18/multipass/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XfqprcCoyKoAAEpgqtoAAABA&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup alt_colour dcl">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">SUBSCRIBE<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            if ( typeof(RegSendGA) === 'function' )
                RegSendGA();
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(268) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

