<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Apple's latest keyboard travels back in time to when they weren't crap • The Register</title>
    <meta name="robots" content="max-snippet:-1, max-image-preview:standard, max-video-preview:0">
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2019/11/18/ifixitmacbookprokeyboard.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/" />
    <meta property="og:title" content="Apple's latest keyboard travels back in time to when they weren't crap" />
    <meta property="og:description" content="It's Magic!" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Apple, Ifixit">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/"},
"headline":"Apple's latest keyboard travels back in time to when they weren't crap",
"datePublished":"2019-11-18T17:00:10Z",
"dateModified":"2019-11-18T16:33:29Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2019/11/18/ifixitmacbookprokeyboard.jpg","width":"648","height":"431"},
"author":{"@type":"Person","name":"John Oates"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/11/18/apples_latest_keyboard_more_like_2016_one/"><script>
        var RegArticle={id:205824,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['apple','Apple'],['macbook pro','Macbook Pro'],['ifixit','Ifixit']],short_url:'http://reg.cx/2XaD',cp:0,noads:[],author:'John Oates',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400,700&amp;display=swap">
<link rel=stylesheet type="text/css" href="/css_picker/default/c58fa7bfda11daef21f1c97f642a1e6aa14ca763/design.css">

    <style>
        #sec-personal_tech, #m-sec-personal_tech,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/personal_tech/headlines.atom" title="The Register: Personal Tech section">

    
    <script src="/design_picker/ed3c33be76031ea6eb0bbb4403af2a1120f25709/javascript/_.js"></script>
    <script async onerror="gpt_js_errored()" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/pers.front&amp;s=vk/apple&amp;s=vk/macbook%20pro&amp;s=vk/ifixit&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_personal_tech/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


    <script src='https://static-42andpark-com.s3-us-west-2.amazonaws.com/js/adtoniq-www-theregister-co-uk.js'></script>
<script>
(function () {var x = '5c9e60b2-8d69-4f99-81d5-d0fcce88b168'})
</script>
<link rel='stylesheet' href='https://static-42andpark-com.s3-us-west-2.amazonaws.com/css/adtoniq-messenger-alert.css'>
<style>#adtoniq-msgr-bar #adtoniq-msg {display: inline-block;}
#adtoniq-msg {width: 75%;float: left;text-align: left;}
#adtoniq-msgr-bar #adtoniq-btns {display: inline-block;}
#adtoniq-btns { width: 25%!important; float: right!important; margin-right: 0px!important; max-width: 150px;}
button#adtoniq-msg-track-btn { width: 100%; display: block;}
button#adtoniq-msg-no-track-btn { background-color: transparent!important; width: 100%; margin: 0!important; margin-top: 11px!important; color: #000000!important; font-weight: 600; font-size: 12px; border: 0; border: none;}

#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar {color: #ffffff!important;}

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {background-color: #000000; opacity: 1; width: 100%; max-width: 960px; margin: 0 auto; left: 0; right: 0; padding: 20px; border-top:2px solid #00727a;} #adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button {color: #ffffff!important;background-color: #00727a!important;margin-top: 0px;font-size: 13px;line-height: 24px;border-radius: 2px!important;font-weight: 500;padding: 10px 18px!important;letter-spacing: 1px;text-transform: uppercase; border: 0; border: none;} #adtoniq-msg {width: 70%;float: left;text-align: left;}#adtoniq-btns {width: 30%;float: none;text-align: right; margin-right:40px;} #adtoniq-msgr-bar.adtoniq-waisa p { font-size: 14px !important; line-height: 1.2; display: block; width: 100%; margin: 0 auto !important; text-align: center; max-width: 80%;} #adtoniq-msg-buttons.adtoniq-waisa { width: 100%; margin-top: 20px; } button#adtoniq-msg-track-btn {float: right;} p.a_deets {color: #000000;} #adtoniq-msgr-bar.adtoniq-waisa p { color: #ffffff; min-height: 120px; }


#a_hider .a_deets { display: inline-block; margin-bottom: 0!important;}
#a_hider.a_showme .a_deets, #a_hider.a_showme .arrow { display: none; }
#a_hider .targetadt { display: none; }
#a_hider.a_showme .targetadt { display: block; }

#a_hider { cursor: pointer; }

#a_hider:hover { cursor: pointer; }
#a_hider:hover .a_deets { text-decoration: underline; }

.arrow { height: 7px; width: 7px; border: 1px solid #000000; border-width: 2px 2px 0 0; -webkit-transform: rotate(45deg); -ms-transform: rotate(45deg); transform: rotate(45deg); display: inline-block; -webkit-transform: rotate(135deg); -ms-transform: rotate(135deg); transform: rotate(135deg); margin-left: 10px; padding-bottom: 2px; padding-left: 2px; }

@media screen and (max-width:1015px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { width: auto; float: right; }
div#adtoniq-msg h2 { font-size: 20px!important; }

p.a_deets { font-size: 14px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert {width: auto!important; padding: 15px;}
#adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { padding: 10px 0;}
} 

@media screen and (max-width:640px){ 
#adtoniq-msgr-bar .p.targetadt{max-width: 100%!important;margin: 0 auto!important;}

div#adtoniq-msg h2 { font-size: 18px!important; }
p.a_deets { font-size: 11px!important; }
#adtoniq-msg { width: 60%; }
#a_hider.a_showme p.targetadt { font-size: 12px!important;}
} 

@media screen and (max-width:565px){ 
#adtoniq-msg { width: 170px; padding-right: 30px; width: 65%; padding-right: 25px; }

#adtoniq-msgr-bar, #adtoniq-msgr-bar.reveal-alert { padding: 10px; width: auto!important; max-width: none; }
#adtoniq-msg-track-btn, #adtoniq-msg-close-btn, .adtoniq-waisa button, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { font-size: 11px; line-height: 17px; padding: 8px 14px!important;}
}


@media screen and (max-width:339px){ 
    #adtoniq-msg { width: 99%; padding-bottom: 7px; }
	#adtoniq-btns {width: 100%!important; float: none!important; margin-top: 20px;text-align: center;display: block!important;}
	#adtoniq-msgr-bar #adtoniq-btns { display: inline!important; }
	#adtoniq-msg-track-btn, #adtoniq-msg-no-track-btn { display: inline-block!important; }
	button#adtoniq-msg-track-btn, #adtoniq-msgr-bar #adtoniq-msg-no-track-btn.btn-msg-bar { float: left; }
	button#adtoniq-msg-no-track-btn { margin-top: 0!important; }
}


#adtoniq-msgr-bar.adtoniq-waisa.reveal-alert { z-index: 999; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons { text-align: center; }
.adtoniq-waisa.reveal-alert #adtoniq-msg-buttons button { margin: 10px; }
.adtoniq-mobile { }</style>

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Webcasts</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/intel_ponte_vecchio_gpu/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/17/shutterstock_ponte_vecchio.jpg"><h5>A bridge over troubled water: Intel teases Ponte Vecchio, the GPU brains in US govt's 1-exaFLOPS Aurora supercomputer</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/16/5g_iot_report/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/01/11/afraid_of_the_dark_image_via_shutterstock.jpg"><h5>5G SIM-swap attacks could be even worse for industrial IoT than now</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/talktalk_yet_to_close_deal_on_fibrenation/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/15/shutterstock_fibre.jpg"><h5>TalkTalk says it's yet to close deal on FibreNation as UK telecoms industry reels over Labour's nationalisation plans</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/amazon_jedi_court_contest/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/02/captain_janeway_star_trek.jpg"><h5>Use the courts, Jeff: Amazon to contest Microsoft scooping $10bn JEDI contract</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/who_me/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/31/shutterstock_1071449234.jpg"><h5>Email! HUH! Yeah. What is it good for? Absolutely nothing...</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/google_oracle_supreme_court/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/04/30/shutterstock_eyeroll.jpg"><h5>Oracle and Google will fight in court over Java AGAIN and this time it's going to the Supremes</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/chromium_silent_experiment_breaks_citrix_and_more/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/18/shutterstock_break.jpg"><h5>White Screen of Death: Admins up in arms after experimental Google emission borks Chrome</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/brave_web_browser_hits_version_1/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/14/brave-reg.jpg"><h5>Like a BAT outta hell, Brave browser hits 1.0 with crypto-coin rewards for your fave websites</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/interpol_says_encryption_helps_paedos_barmy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/24/suicidal_clown_shutterstock_648.jpg"><h5>Interpol: Strong encryption helps online predators. Build backdoors</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/nathan_wyatt_accused_hacker_us_extradition/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/28/royal_courts_justice_court_room.jpg"><h5>Pack your bags, you're going to America, Lord Chief Justice tells accused Brit hacker</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/security_roundup_15_november/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/shutterstock_mailbox_stuffed.jpg"><h5>Pemex hit by ransomware, US Postal Service gets a copycat and new WhatsApp bugs</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/ddos_owner_13_months_prison/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/15/shutterstock_cell_door.jpg"><h5>Denial of service kingpin hit with 13 months denial of freedom and a massive bill to pay</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/google_cloud_run_serverless_containers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/15/cloudrun.jpg"><h5>Google promises to be good with Knative as it releases Cloud Run serverless containers</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/14/git_mobile_app/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/13/guthub_mobile_app.jpg"><h5>If you've wanted to lazily merge code on GitHub from the pub, couch or beach, there's now a mobile app for that</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/13/docker_enterprise_miranits/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/13/docker_shutterstock.jpg"><h5>Just Docker room talk: Container upstart's enterprise wing sold to Mirantis, CEO out, Swarm support faces ax</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/13/redis_kubernetes_redisinsight_gui_tool/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/13/shutterstock_underground.jpg"><h5>Redis releases automatic cluster recovery for Kubernetes and RedisInsight GUI tool</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/ex_unix_sysadmin_elected_president_sri_lanka/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/18/gotabaya_rajapaksa.jpg"><h5>From humble Unix sysadmin to brutal separatist suppressor to president of Sri Lanka</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/sage_flogs_payments_business_for_230m/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/20/cloud.jpg"><h5>If it's not cloud, GTFO: Sage flogs payments business to US firm Elavon for £230m</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/capita_accountant_10k_blackmail_appeal/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/01/26/blackmail.jpg"><h5>Ex-Capita accountant who claimed £10k bung to leave was blackmail has appeal thrown out</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/hp_xerox_valuation/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/11/16/no_shutterstock.jpg"><h5>HP to Xerox: Nope, your $33.5bn bid falls short of our valuation</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/18/ifixitmacbookprokeyboard.jpg"><h5>Apple's latest keyboard travels back in time to when they weren't crap</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/intel_ditching_dusty_drivers_and_bios/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/24/pc_9387698456757.jpg"><h5>Intel end-of-lifing BIOS and driver downloads for dusty hardware</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/bose_soundbars_new_firmware_fails/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/11/25/alanpartridge.jpg"><h5>'Literally a paperweight': Bose users fume at firmware update that 'doesn't fix issues'</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/huawei_mate_30_pro_teardown/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/15/huaweimate30pro.jpg"><h5>Huawei's first Google-free phone stripped and searched: Repair not too painful... once you're in</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/space_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/14/crazydrillman.jpg"><h5>Anomaly-free SpaceX fires up SuperDracos, ISS astros go iFixit in orbit, and Buran turns 31</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/nasa_oig_commercial_crew/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/12/21/starliner_interior.jpg"><h5>NASA told to get act together on commercial crew vendors as chance of American-free ISS rises</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/laser_laughing_gas/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/15/scientists_laughing.jpg"><h5>Physicists are rather giddy after creating a rare type of laser using laughing gas</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/korea_nuclear_bomb/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/07/16/shutterstock_77474908.jpg"><h5>Boffins show the 2017 Nork nuke can move, move, move any mountain (by a meter)</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/bloodhound_breaks_1000kph/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/05/16/bloodhound_ssc.jpg"><h5>The Bloodhound Gang hits 1,010kph, retreats to lab to work on smashing the land speed record</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/microsoft_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/07/flying_cat_teaser.jpg"><h5>Rapid-fire Windows 10 builds, Azure on Arm not for the eyes of mortals, and Teams at 10,000ft</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/18/ai_roundup_151119/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/16/freaked_out.jpg"><h5>Twitter wants help with deepfakes, and Microsoft Azure will rent out new AI chips for its cloud users, and more</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/16/cultured_meat_expo/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/16/cms2019.jpg"><h5>Welcome to cultured meat – not pigs reading Proust but a viable alternative to slaughter</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/15/bollard_run_over/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/15/ukkeepleftbollard.jpg"><h5>What a load of bollards! Object of bloke's street furniture romp run over</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/14/wild_boar_destroys_20k_euro_cocaine_stash/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/14/wildboar.jpg"><h5>What a boar! Wild pigs snort and snuffle €20k worth of marching powder stashed in Tuscan forest</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/13/woman_fined_for_rage_over_boiled_eggs_on_train/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/11/13/boiledegg.jpg"><h5>I've had it with these motherflipping eggs on this motherflipping train</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/11/08/dxc_exec_stands_for_brexit_party_in_upcoming_general_election/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/24/brexit_puzzle.jpg"><h5>All bets are Hoff: DXC exec is standing for Brexit Party in UK General Election</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_personal_tech/front&amp;sz=300x250&amp;tile=2&amp;c=2XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_personal_tech/front&amp;sz=300x250&amp;tile=2&amp;c=2XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col><div id="article-wrapper">
        
        
        <div id="crumb_trail">
            
            <a href="/personal_tech/" class="dcl sub_sec">
                <h4>Personal Tech</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Apple's latest keyboard travels back in time to when they weren't crap</h1>
                
                <h2>It's Magic!</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/John-Oates" title="Read more by this author" class="alt_colour dcl">John Oates</a>
                        
                        <span class="dateline">
                            18&nbsp;Nov&nbsp;2019&nbsp;at&nbsp;17:00
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/11/18/apples_latest_keyboard_more_like_2016_one/" class="reg_comments">                                    <span class="count">6</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&title=Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap&amp;url=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&amp;redirect_uri=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&amp;title=Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap&amp;summary=It%27s%20Magic%21" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2019/11/18/ifixitmacbookprokeyboard.jpg?x=442&amp;y=293&amp;crop=1" alt="MacBook Pro new keyboard" width=442 height=293 class="article_img">
                    <div class=img_caption>The key mechanism in the 2019 16" MacBook Pro is very similar to that in older models <i>Pic: iFixit</i></div>
            </div>
            <div id="body">
                
                <p>The MacBook keyboard nightmare is over – Apple's latest attempt reverts back to something remarkably similar to the key design it was using up until 2016. The one that worked.</p>
                <p>The geeks at <a target="_blank" href="https://www.ifixit.com/News/16-inch-macbook-pro-magic-keyboard-throwback">iFixit</a> have got their paws on a new MacBook Pro and are in the process of taking apart its keyboard. It's all but identical to the old Magic boards – so much so that old keys even fit the new one.</p>
                <p>"The new Magic Keyboard in the 16-inch MacBook Pro uses a scissor switch that looks almost identical to the switches in the desktop Magic Keyboard, and MacBooks sold before the butterfly blunder," they said. "The switch is two plastic pieces, crossed, with a pivot in the middle to control key movement. It's more robust than butterfly switches, and there's more space to tolerate debris within its movements."</p>
                <p>The keys are about 0.2mm thicker than the old ones and have about 0.5mm more travel. The iFixit crew also noticed stronger clips connecting keys to the scissor switches, which should give a better chance of reconnecting if a key is removed for cleaning or repair. But the changes result in a keyboard which doesn't appear much thicker or heavier.</p>
                <p>The geeks mused wistfully that maybe this is evidence of a new Apple more responsive to demands from customers for more easily repairable or upgradeable hardware...</p>
                <p>The problems began in 2015 and 2016 for the MacBook Pro. Apple chose to create a thinner keyboard with less key travel, relying on butterfly hinges. Initial response was not ecstatic with complaints about the sound and feel of the new keys compared to the company's previous keyboards.</p>
                <p>But things got worse when the boards began to fail early and often. Space bars were the main culprits but any key could be knocked out by even the tiniest specs of dust.</p>
                <p>In 2018 Apple added <a target="_blank" href="https://www.theregister.co.uk/2018/07/16/apple_gives_keyboard_rubber_pants/">a rubber prophylactic layer</a> to keep out the gremlins, although publicly it insisted the move was to reduce noise.</p>
                <p>Apple rejected all complaints until <a target="_blank" href="https://www.theregister.co.uk/2018/06/23/apple_macbook_keyboard_replacement_free/">finally offering replacements</a>, repairs and an extension to warranties.</p>
                <p>The saga has resulted in <a target="_blank" href="https://www.theregister.co.uk/2018/05/14/apple_macbook_keyboards_defective_claims_lawsuit/">a class-action suit</a> from disgruntled fan people.</p>
                <p>There's more from <a target="_blank" href="https://www.ifixit.com/News/16-inch-macbook-pro-magic-keyboard-throwback">iFixit here</a> but the full teardown will be published later today. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1858/-7801/your-guide-to-becoming-truly-data-driven-with-unrivalled-data-analytics-performance?td=wptl1858">Your Guide to Becoming Truly Data-Driven with Unrivalled Data Analytics Performance</a>
                </p>
                <script>
                    RegWpTl = [
                        '<a href="https://go.theregister.co.uk/tl/1858/-7798/how-to-process-wrangle-analyze-and-visualize-your-data-with-three-complementary-tools?td=wptl1858">How to Process, Wrangle, Analyze and Visualize your Data with Three Complementary Tools<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7800/what-next-after-netezza?td=wptl1858">What next after Netezza?<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7802/technical-overview-exasol-peek-under-the-hood?td=wptl1858">Technical Overview: Exasol Peek Under the Hood<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7801/your-guide-to-becoming-truly-data-driven-with-unrivalled-data-analytics-performance?td=wptl1858">Your Guide to Becoming Truly Data-Driven with Unrivalled Data Analytics Performance<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7799/beyond-the-data-frontier?td=wptl1858">Beyond the Data Frontier<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7813/how-to-get-more-from-microstrategy-by-optimising-your-data-stack?td=wptl1858">How to get more from MicroStrategy by optimising your data stack<\/a>'
                    ];
                </script>            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/11/18/apples_latest_keyboard_more_like_2016_one/">
                        <span>6</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/apple">Apple</a>
                </li>
                <li>
                    <a href="/Tag/ifixit">Ifixit</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&title=Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap&amp;url=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&amp;redirect_uri=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/&amp;title=Apple%27s%20latest%20keyboard%20travels%20back%20in%20time%20to%20when%20they%20weren%27t%20crap&amp;summary=It%27s%20Magic%21" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div></div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_personal_tech/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_personal_tech/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3 class="title_rhs_line">MOST READ</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/11/18/who_me/">
                            <img src="https://regmedia.co.uk/2018/08/31/shutterstock_1071449234.jpg?x=200&amp;y=200&amp;crop=1" alt="Man at desk overwhelmed by flood of messages" width=90 height=90>
                <h4>Email! HUH! Yeah. What is it good for? Absolutely nothing...
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/11/18/nasa_oig_commercial_crew/">
                            <img src="https://regmedia.co.uk/2015/12/21/starliner_interior.jpg?x=200&amp;y=200&amp;crop=1" alt="The interior of the Starliner. Pic: Boeing" width=90 height=90>
                <h4>NASA told to get act together on commercial crew vendors as chance of American-free ISS rises
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/11/18/hp_xerox_valuation/">
                            <img src="https://regmedia.co.uk/2018/11/16/no_shutterstock.jpg?x=200&amp;y=200&amp;crop=1" alt="no" width=90 height=90>
                <h4>HP to Xerox: Nope, your $33.5bn bid falls short of our valuation
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/11/18/intel_ponte_vecchio_gpu/">
                            <img src="https://regmedia.co.uk/2019/11/17/shutterstock_ponte_vecchio.jpg?x=200&amp;y=200&amp;crop=1" alt="Ponte Vecchio, Italy" width=90 height=90>
                <h4>A bridge over troubled water: Intel teases Ponte Vecchio, the GPU brains in US govt's 1-exaFLOPS Aurora supercomputer
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/11/18/security_roundup_15_november/">
                            <img src="https://regmedia.co.uk/2019/09/17/shutterstock_mailbox_stuffed.jpg?x=200&amp;y=200&amp;crop=1" alt="Image of an overstuffed mail box" width=90 height=90>
                <h4>Pemex hit by ransomware, US Postal Service gets a copycat and new WhatsApp bugs
                </h4>
            </a>
        </li>
    </ol>
</div>
<a id="story_rhs_ml_signup" href="https://account.theregister.co.uk/register/?product=thereg_weekly_newsletter&utm_medium=site&utm_source=article&utm_campaign=story_rhs_ml_signup">
    <h4>SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER</h4>
    <span aria-hidden="true" class="subscribe_newsletter_button">SUBSCRIBE</span>
    <img class="half_vulture16bits" alt="" width="83" height="65" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_16bits_half.svg">
</a>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_personal_tech/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_personal_tech/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_personal_tech/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_personal_tech/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/09/02/apple_free_repair_service_for_defective_watches/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/12/13/broken_window.jpg?x=198&amp;y=131&amp;crop=1" alt="Broken window" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Apple cracks, straps on free repair service for defective Watches</h4>
                            <div class=standfirst>
                                Got a Series 2 or 3 in aluminium with a borked screen? Things might be looking up for you
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/10/22/apple_tim_cook_chairman_of_advisory_board_tsinghua_university/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/04/16/cook_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="cook" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Apple chief Tim Cook ascends to top of tech pantheon on Chinese biz school's advisory board</h4>
                            <div class=standfirst>
                                Look what happens when you bend for Beijing
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/10/30/apple_security_patches_catalina_macos_ios/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/07/23/band_aid_648.jpg?x=198&amp;y=131&amp;crop=1" alt="band_aid_648" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>While Apple fanbois rage at Catalina, iGiant quietly drops iOS and macOS security patches</h4>
                            <div class=standfirst>
                                RCEs and all sorts of other vulns plugged, so get installing
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/11/11/irish_teachers_on_apple_funded_trips/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/06/14/angryteacher.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Teachers: Make your pupils' parents buy them an iPad to use at school. Oh and did you pack sunglasses for the Apple-funded jolly?</h4>
                            <div class=standfirst>
                                iGiant paid for Irish educators to attend events abroad &#8211; report
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/09/17/apple_eu_tax_appeal/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/06/10/ireland_map_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Ireland map, photo via Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Apple tells European Commission it's nutty for slapping €13bn tax bill on Irish subsidiary</h4>
                            <div class=standfirst>
                                Sweetheart deal crackdown 'defies reality and common sense' apparently
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/10/25/apple_lawyer_insider_trading_indictment/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/05/15/embarrassed.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Now the US DoJ has charged Apple's insider trading lawyer with, er... well, it's embarrassing</h4>
                            <div class=standfirst>
                                He's got the key, he's got the secret &#8211; allegedly
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/11/05/apple_app_store_electron/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/11/05/shutterstock_648801757.jpg?x=198&amp;y=131&amp;crop=1" alt="A person being directed to leave a group" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Bad news, developers: Apple Mac App Store tells cross-platform Electron apps to get lost</h4>
                            <div class=standfirst>
                                Programmers who reoffend risk permanent exile from the fondleslab empire
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/23/apple_intel_modems/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/03/31/tim_cook_photo_by_jstone_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Tim Cook, photo by JStone via Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Checkmate, Qualcomm: Apple in billion-dollar bid to gobble Intel’s 5G modem blueprints, staff – new claim</h4>
                            <div class=standfirst>
                                Logical step for the biz that wants to own its supply chain
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/8014/embracing-hpc-and-ai-change?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Embracing HPC and AI change</h4>
                <div class=standfirst>
                    HPC and AI represent highly disruptive changes to your IT infrastructure - so where to begin? Find out with Intel’s Jump-Start Your AI Journey With Your Existing HPC infrastructure.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7942/comprehensive-cloud-data-protection?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Comprehensive Cloud Data Protection</h4>
                <div class=standfirst>
                    Organizations are moving to a comprehensive strategy for on-premises and cloud data protection. As more IT teams use cloud for digital transformation, they are also updating data protection strategies.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7844/data-protection-for-the-enterprise-with-commvault-and-hpe?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Data Protection for the Enterprise with Commvault and HPE</h4>
                <div class=standfirst>
                    To succeed in the enterprise space, vendors need to deliver a strong set of features that will also integrate with the underlying infrastructure.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7955/qumulos-quest-for-file-storage-perfection?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="" width=55 height=55>
                <h4>Qumulo's quest for file storage perfection</h4>
                <div class=standfirst>
                    The Register is going to look at the developing file storage landscape, examine how file and object storage can interact and then discuss the public cloud. What role does it play in file storage?
                </div>
            </a>
        </div>

    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/11/18/apples_latest_keyboard_more_like_2016_one/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_personal_tech/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_personal_tech/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XdLqx8CoyKcAACjePl0AAABQ&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup alt_colour dcl">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">SUBSCRIBE<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            if ( typeof(RegSendGA) === 'function' )
                RegSendGA();
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(826) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

