<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Traffic lights worldwide set to change after a Swedish engineer saw red over getting a ticket • The Register</title>
    <meta name="robots" content="max-snippet:-1, max-image-preview:standard, max-video-preview:0">
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2019/10/18/shutterstock_197283374.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/" />
    <meta property="og:title" content="Traffic lights worldwide set to change after a Swedish engineer saw red over getting a ticket" />
    <meta property="og:description" content="Mats Järlström's fight shows you never cross an engineer" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Science">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/"},
"headline":"Traffic lights worldwide set to change after a Swedish engineer saw red over getting a ticket",
"datePublished":"2019-10-21T11:03:14Z",
"dateModified":"2019-10-19T00:03:10Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2019/10/18/shutterstock_197283374.jpg","width":"648","height":"448"},
"author":{"@type":"Person","name":"Thomas Claburn"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/10/21/traffic_lights_changed/"><script>
        var RegArticle={id:205371,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['science','Science'],['math','Math'],['engineering','Engineering']],short_url:'http://reg.cx/2WPY',cp:0,noads:[],author:'Thomas Claburn',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400,700&amp;display=swap">
<link rel=stylesheet type="text/css" href="/css_picker/default/67525b8ba8e87817a827d2219814db0424e31ec2/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/cd84f90efc5f72454d1c822e749ed2fd317c0206/javascript/_.js"></script>
    <script async onerror="gpt_js_errored()" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/science&amp;s=vk/math&amp;s=vk/engineering&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


    <script src='https://static-42andpark-com.s3-us-west-2.amazonaws.com/js/adtoniq-www-theregister-co-uk.js'></script>
<script>
(function () {var x = 'f19064a6-8dca-4711-bd5b-f4b4dbb800e2'})
</script>
<link rel='stylesheet' href='https://static-42andpark-com.s3-us-west-2.amazonaws.com/css/adtoniq-messenger-alert.css'>
<style>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</style>

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Webcasts</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/fa16d26efb42e6ba1052f1d387470f643c5aa18d/graphics/std/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/who_me/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/07/14/big_pipe_photo_via_shutterstock.jpg"><h5>Don't look too closely at what is seeping out of the big Dutch pipe</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/storage_survey/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/18/shutterstock_data_silo2.jpg"><h5>Silos of paper scans, photos, forms, and other unstructured data blight today's corps. How are you tearing them down?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/microsoft_azure_mfa/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/17/shutterstock_pub.jpg"><h5>Good guy, Microsoft: Multi-factor auth outage gives cloudy Office, Azure users a surprise three-day weekend</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/mark_hurd_obituary/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/18/shutterstock_mark_hurd.jpg"><h5>Mark Hurd is dead</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/18/shutterstock_197283374.jpg"><h5>Traffic lights worldwide set to change after a Swedish engineer saw red over getting a ticket</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/vs_code_mssql/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/08/shutterstock_present_gift.jpg"><h5>Like Visual Studio Code and your data lives in SQL Server? Microsoft has something for you</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/17/canonical_releases_ubuntu_1910_eoan_ermine/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/17/stoat.jpg"><h5>This fall, Ubuntu 19.10 stars as Eoan Ermine in... Dawn of the Stoats</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/17/microsoft_cloud_app/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/19/shutterstock_open_container.jpg"><h5>OAMigod! Microsoft has a cloud app spec for you – and hopes Rudr can't fail</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/trend_micro_cloud_conformity/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/15/cloud_shutterstock.jpg"><h5>Trend Micro would like you to fall in line and become a victim of Cloud Conformity</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/action_fraud_computer_misuse_crimes_decrease/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/23/shutterstock_call_centre_worker_unhappy.jpg"><h5>If there were almost a million computer misuse crimes last year, Action Fraud is only passing 2% of cases to cops</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/british_spies_finger_russia_for_faking_iranian_hack_profiles/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/15/russian_soldier_shutterstock.jpg"><h5>Iran? More like Ivan: Brit and US spies say they can see through Turla hacking group's facade</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/security_roundup_181019/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/11/shutterstock_jail_free.jpg"><h5>Malware hides as iOS jailbreak, Sucuri is insecuri, and China is about to get even worse</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/serverless_london_conference/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/17/shutterstock_programmers.jpg"><h5>Soup up your serverless smarts with our practical hands-on workshops: Sign up now and we'll see you next month</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/17/gitlab_reverse_ferret/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/17/shutterstock_gitlab_logo.jpg"><h5>GitLab reset --hard bad1dea: Biz U-turns, unbans office political chat, will vet customers</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/16/puppet_interviews/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/12/masterofpuppetscrop.jpg"><h5>Masters of Puppet say: There's no magical one-size-fits-all answer to doing DevOpsery</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/16/gitlab_employees_gagged/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/30/money_9485789457.jpg"><h5>Blood money is fine with us, says GitLab: Vetting non-evil customers is 'time consuming, potentially distracting'</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/brexit_ip_copyright_notices/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/24/brexit_puzzle.jpg"><h5>We read the Brexit copyright notices so you don't have to… No more IP freely, ta very much</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/us_bill_promises_prison_for_privacy_failures/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/09/shutterstock_zuckerberg_mark_facebook.jpg"><h5>Pack your pyjamas, Zuck: US bill threatens execs with prison for data failures</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/google_health_gets_new_boss/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/04/17/doctor_shutterstock.jpg"><h5>All we need is just a little patients: Google's Alphabet hires new chief health officer</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/google_lashes_out_trump_oracle_us_supremes_copyright_fight/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/09/google.jpg"><h5>Google lashes out at DoJ, Oracle as it asks US Supremes to sniff Java suit one last time</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/google_ads_can_stop_gamers_becoming_cyber_crims_cambridge_university_research/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/26/pcgamer.jpg"><h5>Google ads from the po-po can prevent vengeful gamer nerds going full script kiddie – research</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/surface_pro_x_hands_on/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/17/panaysurface.jpg"><h5>Microsoft Surface Pro X: Windows on Arm usable at long last – but, boy, are you gonna pay for it</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/on_call/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/24/angry_laptop_man.jpg"><h5>A History of (Computer) Violence: Wait. Before you whack it again, try caressing the mouse</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/17/samsung_galaxy_s10_note_10_fingerprint_bypass/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/17/fingerprint.jpg"><h5>Any finger will do? Samsung Galaxy S10 with a screen protector reportedly easy to fool</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/19/10_artemis_missions/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/18/sls_pathfinder.jpg"><h5>Guess what's on the receiving end of more NASA dollars for SLS?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/nasa_insight_mole_moving/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/18/insight_mole.jpg"><h5>What's the scoop with Mars InSight's mired mole? It's digging again, thanks to trowel trickery</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/17/hubble_interstellar_comet/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/16/borisovcomet.jpg"><h5>Hubble grabs first snap of interstellar comet... or at least that's what we hope this smudge is</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/16/snc_dream_chaser/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/16/dream_chaser.jpg"><h5>Some assembly required as Dream Chaser mini-shuttle's empty husk arrives in Colorado</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/internet_of_fridge_part_2/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/29/terror.jpg"><h5>Samsung on fridge cert error: Someone tried to view 'unsavoury content' in middle of John Lewis</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/21/ai_roundup_181019/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/18/rubiks_cube_bot.jpg"><h5>Don't fall for the hype around OpenAI's Rubik's Cube playing robot, Berkeley bans facial recognition, and more</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/us_govt_border_patrol/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/27/us_border_agent.jpg"><h5>Guess who's dreaming of facial-recog body cams now? US border cops: AI tech sought to scrutinize travelers</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/gov_splashed_22m_on_failed_age_verification_policy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/07/05/shutterstock_smut.jpg"><h5>Junior minister says gov.UK considering facial recognition to verify age of p0rn-watchers</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/18/last_video_rental_kiosk/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/11/10/betamax_teaser.jpg"><h5>I discovered the world's last video rental kiosk and it would make a great spaceship</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/17/reg_vulture_mail_rail_tunnels/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/10/15/mail_rail_index.jpg"><h5>We're going deeper Underground: Vulture clicks claws over London's hidden tracks</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/15/telstra_chairman_if_kids_can_earn_5m_playing_fortnite_why_cant_i/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/21/shutterstock_fortnightgamer.jpg"><h5>Telstra chairman: If those darn kids can earn $5m playing Fortnite, why can't execs?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/10/14/lego_mulls_bricks_as_a_service_biz_model/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/08/10/shutterstock_lego_fight.jpg"><h5>How do we stop filling the oceans with Lego? By being a BaaS-tard, toy maker suggests</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Traffic lights worldwide set to change after a Swedish engineer saw red over getting a ticket</h1>
                
                <h2>Mats Järlström's fight shows you never cross an engineer</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Thomas-Claburn" title="Read more by this author" class="alt_colour dcl">Thomas Claburn in San Francisco</a>
                        
                        <span class="dateline">
                            21&nbsp;Oct&nbsp;2019&nbsp;at&nbsp;11:03
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/10/21/traffic_lights_changed/" class="reg_comments">                                    <span class="count">57</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&title=Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket&amp;url=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&amp;redirect_uri=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&amp;title=Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket&amp;summary=Mats%20J%C3%A4rlstr%C3%B6m%27s%20fight%20shows%20you%20never%20cross%20an%20engineer" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2019/10/18/shutterstock_197283374.jpg?x=442&amp;y=293&amp;crop=1" alt="Yellow traffic light" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>A Swedish engineer's umbrage at a traffic ticket has led to a six-year legal fight and now a global change in the speed with which traffic light signals are timed.</p>
                <p>After Mats Järlström <a target="_blank" rel="nofollow" href="https://www.oregonlive.com/commuting/2014/12/beaverton_mans_federal_lawsuit.html">lost an initial legal challenge</a> in 2014, a federal judge in January this year ruled Oregon's rules prohibiting people from representing themselves as engineers without a professional license from the state <a target="_blank" rel="nofollow" href="https://www.theregister.co.uk/2019/01/02/oregon_engineer_license_laws/">are unconstitutional</a>.</p>
                <p>And now Järlström's calculations and advocacy have led the Institute of Transportation Engineers (ITE) to <a target="_blank" rel="nofollow" href="https://ij.org/wp-content/uploads/2019/10/Letter-Transmitting-Appeals-Panel-Recommendations.pdf">revisit its guidelines</a> [PDF] for the timing of traffic signals. As a result, yellow lights around the globe could burn for longer – ITE is an international advisory group with members in 90 countries.</p>
                <p>Järlström discovered a problem with the timing of traffic lights in Beaverton, Oregon, after his wife Laurie received a $260 ticket for a red light violation from an automated traffic light camera in 2013.</p>
                <p>Järlström, who studied electrical engineering in Sweden, challenged the ticket, arguing the timing interval for yellow lights fails to account for scenarios like a driver entering an intersection and slowing to make a turn. A slightly longer interval, he argued, would allow drivers making turns on a yellow light to exit intersections before the light turned red. Even a small timing increase would help – the automatically generated ticket in this case was issued 0.12 seconds after the light turned red.</p>
                <p>When Järlström brought the issue to the Oregon State Board of Examiners for Engineering and Land Surveying, the state board opened an investigation in 2015 and fined him $500 the following year for practicing engineering without a professional license.</p>
                <p>Thanks to the assistance of the Institute for Justice, a legal advocacy organization focused on limiting the scope of government, Järlström has won not only the right to refer to himself as an engineer, a refund of the surveying board fine (though not the ticket penalty), and the removal of the moving violation from his car insurance premium, but also the opportunity to fix a formula that has governed traffic light timing since 1960.</p>
                <p>Since the injunction prohibiting Oregon from enforcing its unconstitutional speech restriction, Järlström has been working with other engineers and advocates to change the way traffic lights work. Over the summer, an ITE panel met to hear arguments along those lines and last month it agreed light timing should be reconsidered.</p>
                <p>
  <img src="https://regmedia.co.uk/2019/10/18/equation_jpg.jpg" width="648" height="448" alt="Mats Järlström's equation" title="Mats Järlström's equation"/>
</p>
                <p>"The yellow traffic signal was first conceived in 1920 and in 1960, scientists [Denos] Gazis, [Robert] Herman, and [Alexei] Maradudin presented the <a target="_blank" rel="nofollow" href="http://jarlstrom.com/PDF/The_Problem_Of_The_Amber_Signal_Light_In_Traffic_Flow.pdf">foundational science</a> still in use today," Järlström said in an email to <i>The Register</i>. "It is a historic moment to now update the science by extending the 1960 solution to also be applicable to turning maneuvers."</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2017/04/28/mats_jarlstrom.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Mats Jarlstrom, pointing to a traffic light camera"/>
<h2 title="Licensing red-tape violate First Amendment, says court in battle over timing algorithm">Oregon can't stop people from calling themselves engineers, judge rules in Traffic-Light-Math-Gate</h2>
<a href="https://www.theregister.co.uk/2019/01/02/oregon_engineer_license_laws/"><span>READ MORE</span></a></div>
                <p>Järlström said if the ITE accepts his solution, the duration of a yellow light in the right-turn scenario he described in 2015 would be extended from 3.2 seconds to 4.5 seconds using current input values – driver-vehicle perception-reaction time and maximum safe, comfortable deceleration. Such timing may vary depending on other considerations, but in general the adoption of Järlström's formula should result in slightly longer yellow lights.</p>
                <p>The ITE staff will develop and formalize the proposed changes to produce a final document called the Recommended Practice that will be submitted to the ITE Board of Directors for final approval in early 2020.</p>
                <p>Jarlstrom said it has been a long process to reach this point. In addition to his own efforts, he credited the support of Alexei Maradudin, Jay Beeber, Brian Ceccarelli and the National Motorist Association’s Joe Bahen. He also said test equipment made by UK-based Racelogic provided a way to prove his theories.</p>
                <p>"Our common goal is to improve traffic safety and fairness through our signalized intersections worldwide," said Järlström.</p>
                <p>In a way, history is repeating itself. The initial 1960 light timing work came about because one of the scientists involved believed he'd been wrongly ticketed. In email correspondence with Järlström, Maradudin explained that he became a co-author of the 1960 paper because another co-author, Robert Herman, invited him to spend time at the General Motors Technical Center to work on traffic light math. Herman did so, Maradudin said, because he had received a red light ticket that he felt was unfair. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1858/-7802/technical-overview-exasol-peek-under-the-hood?td=wptl1858">Technical Overview: Exasol Peek Under the Hood</a>
                </p>
                <script>
                    RegWpTl = [
                        '<a href="https://go.theregister.co.uk/tl/1858/-7802/technical-overview-exasol-peek-under-the-hood?td=wptl1858">Technical Overview: Exasol Peek Under the Hood<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7813/how-to-get-more-from-microstrategy-by-optimising-your-data-stack?td=wptl1858">How to get more from MicroStrategy by optimising your data stack<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7798/how-to-process-wrangle-analyze-and-visualize-your-data-with-three-complementary-tools?td=wptl1858">How to Process, Wrangle, Analyze and Visualize your Data with Three Complementary Tools<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7799/beyond-the-data-frontier?td=wptl1858">Beyond the Data Frontier<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7801/your-guide-to-becoming-truly-data-driven-with-unrivalled-data-analytics-performance?td=wptl1858">Your Guide to Becoming Truly Data-Driven with Unrivalled Data Analytics Performance<\/a>',
                        '<a href="https://go.theregister.co.uk/tl/1858/-7800/what-next-after-netezza?td=wptl1858">What next after Netezza?<\/a>'
                    ];
                </script>
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/10/21/traffic_lights_changed/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/10/21/traffic_lights_changed/">
                        <span>57</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/science">Science</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&title=Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket&amp;url=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&amp;redirect_uri=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/&amp;title=Traffic%20lights%20worldwide%20set%20to%20change%20after%20a%20Swedish%20engineer%20saw%20red%20over%20getting%20a%20ticket&amp;summary=Mats%20J%C3%A4rlstr%C3%B6m%27s%20fight%20shows%20you%20never%20cross%20an%20engineer" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/10/19/10_artemis_missions/">
                            <img src="https://regmedia.co.uk/2019/10/18/sls_pathfinder.jpg?x=88&amp;y=58&amp;crop=1" alt="SLS Core Stage Pathfinder in VAB" width=88 height=58>
                <h4>Guess what's on the receiving end of more NASA dollars for SLS?
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/">
                            <img src="https://regmedia.co.uk/2019/10/18/shutterstock_197283374.jpg?x=88&amp;y=58&amp;crop=1" alt="Yellow traffic light" width=88 height=58>
                <h4>Traffic lights worldwide set to change after a Swedish engineer saw red over getting a ticket
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/10/21/who_me/">
                            <img src="https://regmedia.co.uk/2016/07/14/big_pipe_photo_via_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="Big pipe, photo via Shutterstock" width=88 height=58>
                <h4>Don't look too closely at what is seeping out of the big Dutch pipe
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/10/21/security_roundup_181019/">
                            <img src="https://regmedia.co.uk/2019/07/11/shutterstock_jail_free.jpg?x=88&amp;y=58&amp;crop=1" alt="jail free" width=88 height=58>
                <h4>Malware hides as iOS jailbreak, Sucuri is insecuri, and China is about to get even worse
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/10/21/internet_of_fridge_part_2/">
                            <img src="https://regmedia.co.uk/2017/09/29/terror.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Samsung on fridge cert error: Someone tried to view 'unsavoury content' in middle of John Lewis
                </h4>
            </a>
        </li>
    </ol>
</div>
<a id="story_rhs_ml_signup" href="https://account.theregister.co.uk/register/?product=thereg_weekly_newsletter&utm_medium=site&utm_source=article&utm_campaign=story_rhs_ml_signup">
    <h4>SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER</h4>
    <span aria-hidden="true" class="subscribe_newsletter_button">SUBSCRIBE</span>
    <img class="half_vulture16bits" alt="" width="83" height="65" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_16bits_half.svg">
</a>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/07/19/france_turns_to_scifi_to_feel_out_future_threats/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/07/19/shutterstock_cyber_gothw.jpg?x=198&amp;y=131&amp;crop=1" alt="cyber goth" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>France seeks science-fiction writers to help futureproof its military against science-fact</h4>
                            <div class=standfirst>
                                'Aliens'
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/01/23/reg_lecture_smash_this_big_sciences_growing_data_challenge/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/01/22/2001_space_odyssey.jpg?x=198&amp;y=131&amp;crop=1" alt="2001 Space Odyssey" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Register Lecture: Can big science keep up with discovery?</h4>
                            <div class=standfirst>
                                <span class=trailer>Reg Lectures</span>
                                Lessons from LHC &#8211; the world&#8217;s largest scientific machine
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/08/08/plans_to_cut_tuition_fees_could_harm_science_research_lords/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/11/25/scientists.jpg?x=198&amp;y=131&amp;crop=1" alt="WHite lab coated scientist looks sceptical in front of microscope. Photo by Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Y'know how everyone hated it when tuition fees went up? Cutting them now could harm science, say UK Lords</h4>
                            <div class=standfirst>
                                STEM subjects already lose universities &#163;1,400 per student
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/06/10/who-me/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/07/17/mrburnsevil.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Idle Computer Science skills are the Devil's playthings</h4>
                            <div class=standfirst>
                                <span class=trailer>Who, Me?</span>
                                It isn't only birds that like nesting
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/02/07/cal_poly_leak/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/09/15/dunce_cap_648.jpg?x=198&amp;y=131&amp;crop=1" alt="dunce_cap_648" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Who are the last people you'd expect to spill thousands of student records? A computer science dept? What a fantastic guess</h4>
                            <div class=standfirst>
                                O(1)? More like O(h) n(O)! Proto-boffins' info leaks out
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/26/spacex_crs18_starhopper/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/05/15/samsung_s8_spacehopper_50pc.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>SpaceX Dragon flies British science into orbit, while stubby 'watertower' hops around Texas</h4>
                            <div class=standfirst>
                                Here - have a new Docking Adaptor. Sorry about that whole exploding rocket thing
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/09/21/curiositys_computer_silent_on_science_baffling_boffins/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/08/20/curiosity_bucksin_selfie.jpg?x=198&amp;y=131&amp;crop=1" alt="his low-angle self-portrait of NASA&amp;#39;s Curiosity Mars rover shows the vehicle at the site from which it reached down to drill into a rock target called &amp;quot;Buckskin.&amp;quot; The MAHLI camera on Curiosity&amp;#39;s robotic arm took multiple images on Aug. 5, 2015, that were stitched together into this selfie. Credit: NASA/JPL-Caltech/MSSS" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Curiosity's computer silent on science, baffling boffins</h4>
                            <div class=standfirst>
                                Robot is 'responsive' but for some reason it can't transmit science data
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/05/01/bill_gates_declined_offer_to_serve_as_donald_trumps_science_advisor/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/09/26/billgatessept2017.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Bill Gates declined offer to serve as Donald Trump's science advisor</h4>
                            <div class=standfirst>
                                Spontaneous offer made during chat about vaccines (which - phew! - Trump seemed to like)
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/10/21/traffic_lights_changed/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7948/intel-and-sap-bringing-the-memory-revolution-to-your-intelligent-enterprise?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Intel &amp; SAP: Bringing the Memory Revolution to Your Intelligent Enterprise</h4>
                <div class=standfirst>
                    SAP and Intel have collaborated on memory &amp;amp; processor co-innovation to help you deliver the intelligent enterprise.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7845/key-data-protection?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Key Data Protection</h4>
                <div class=standfirst>
                    Specific capabilities and why they matter.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7938/defending-against-the-siege-of-ransomware?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Defending Against the Siege of Ransomware</h4>
                <div class=standfirst>
                    Ransomware is big business. But to win the war against this cyber threat, without paying a king’s ransom, you need a strong defense.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7931/how-data-architecture-drives-cloud-transformation?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>How data architecture drives cloud transformation</h4>
                <div class=standfirst>
                    You’re looking to move to the cloud because you know just how powerful the model can be. You’ve seen what you can make possible, if you harness the wealth of data now available to your applications. You’re looking to deliver on your digital transformation goals, respond to new business opportunities and disrupt your entire market.
                </div>
            </a>
        </div>
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55Xa22F8CoyKcAAAwQ5XIAAADW&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

            <script>var RegABTest = 'fxb7KtLLQWiecYcljPha3A.2-0';</script>    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup alt_colour dcl">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">SUBSCRIBE<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            if ( typeof(RegSendGA) === 'function' )
                RegSendGA();
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(837) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

