<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Stallman's final interview as FSF president: Last week we quizzed him over Microsoft visit. Now he quits top roles amid rape remarks outcry • The Register</title>
        <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2019/09/13/richard_stallman.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/" />
    <meta property="og:title" content="Stallman's final interview as FSF president: Last week we quizzed him over Microsoft visit. Now he quits top roles amid rape remarks outcry" />
    <meta property="og:description" content="GNU man resigns after Minsky email defense 'the final straw' for dev world" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Development">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/"},
"headline":"Stallman's final interview as FSF president: Last week we quizzed him over Microsoft visit. Now he quits top roles amid rape remarks outcry",
"datePublished":"2019-09-17T05:11:04Z",
"dateModified":"2019-09-17T21:28:25Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2019/09/13/richard_stallman.jpg","width":"648","height":"448"},
"author":{"@type":"Person","name":"Thomas Claburn"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/09/17/richard_stallman_final_interview/"><script>
        var RegArticle={id:204820,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['richard stallman','Richard Stallman'],['free software','Free Software'],['development','Development']],short_url:'http://reg.cx/2Wsx',cp:0,noads:[],author:'Thomas Claburn',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400,700&amp;display=swap">
<link rel=stylesheet type="text/css" href="/css_picker/default/5fbc0bab567dcb77c233b66f3a8bb0551e220faa/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/338889d1d13ff602d311fe1e0e391f7baf37afd6/javascript/_.js"></script>
    <script async src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/richard%20stallman&amp;s=vk/free%20software&amp;s=vk/development&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Webcasts</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/vmware_on_aws_why_and_why_not/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/vmware-aws.jpg"><h5>VMware on AWS: Low-risk option or security blanket for those who don't like change?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/brit_government_chief_digital_info_officer/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/18/shutterstock_mobile_surprise.jpg"><h5>Brit government WLTM one Chief Digi Info Officer</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/data_warehouse_analytics/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/shutterstock_google_cloud_event.jpg"><h5>Is it time to update your data warehouse and retool your analytics? Google Cloud's gurus are here to guide you</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/oracle_cloud_free_tier/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/16/openworld19.jpg"><h5>Larry Ellison tiers Amazon a new one: Oracle cloud gets 'always' free offer, plus something about Linux</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/gitlab_268m_investment/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/10/19/shutterstock_moneystack.jpg"><h5>DevOps darling GitLab pockets another $268m to be valued at $2.75bn</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/net_core_3_rc1/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/shutterstock_scooby_and_shaggy.jpg"><h5>.NET Core 3.0 thought it was all ready for release. And it would have been too, if it weren't for those pesky Visual Studio kids</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/microsoft_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/shutterstock_beers_bavaria.jpg"><h5>Disney signs on with Microsoft, SQLCMD arrives in Data Studio and Azure goes German</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/13/richard_stallman.jpg"><h5>Stallman's final interview as FSF president: Last week we quizzed him over Microsoft visit. Now he quits top roles amid rape remarks outcry</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/us_govt_sues_snowden/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/09/12/shutterstock_ed_snowden.jpg"><h5>US government sues ex-IT guy for breaking his NDA (Yes, we mean Edward Snowden)</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/24m_medical_records_unsecured_online/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/04/17/doctor_shutterstock.jpg"><h5>Seriously, this sh!t again? 24m medical records, 700m+ scan pics casually left online</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/small_office_home_office_network_kit_security/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/18/shutterstock_fence_break_security.jpg"><h5>Vulns out of the box: 12 in 13 small biz network devices terribly insecure by default – research</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/hp_inc_printer_privacy_policy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/06/printer.jpg"><h5>HP printer small print says kit phones home data on whatever you print – and then some</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/11/kubernetes_cloud_foundry_director/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/11/kearns.jpg"><h5>Why would anyone need Cloud Foundry when we have Kubernetes? Um, 'cos K8s is really hard!</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/08/serverless_computing_giveaway/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/23/serverless_london_index.jpg"><h5>Do you work at a non-profit? Would you like to be non-servers, too? We've got 20 conf tix up for grabs if you're quick</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/05/atlassian_free_jira/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/05/freestuff.jpg"><h5>Freebie tier coming to issue-tracking Jira, but you'll have to cough up to unlock the good stuff</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/03/serverless_event_promo/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/24/view_qe_ii.jpg"><h5>Think you’ve blown your chance to save with serverless? Not so FaaSt...</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/mcnealy_trump_fundraiser/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/04/24/trumpspeechflag.jpg"><h5>Scott McNealy gets touchy feely with Trump: Sun cofounder hosts hush-hush reelection fundraiser for President</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/apple_eu_tax_appeal/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/10/ireland_map_photo_via_shutterstock.jpg"><h5>Apple tells European Commission it's nutty for slapping €13bn tax bill on Irish subsidiary</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/google_age_discrimination_santa_clara_case/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/04/shutterstock_google_hq.jpg"><h5>Google age discrimination case: Supervisor called me 'grandpa', engineer claims</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/facebook_files_to_trademark_book/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/02/22/zuckerberg_photo_facebook.jpg"><h5>First they came for 'face' and I did not speak out because I... have no face? Then they came for 'book'</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/fitbit_syncing_horror_stories/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/shutterstock_fitbit.jpg"><h5>We asked for your Fitbit horror stories and, oh wow, did you deliver: Readers sync their teeth into 'junk' gizmos</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/16/fit_bit_update_disrupts_sync/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/21/fitbit.jpg"><h5>Fitbit fitness fans furious following flummoxing flawed firmware float, fleeting feedback, failed fixes</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/16/ccpa_intact/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/15/shutterstock_business_success.jpg"><h5>The results are in… and California’s GDPR-ish digital privacy law has survived onslaught by Google and friends</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/13/wall_street_analyst_slashes_hp_inc_share_rating_amid_mounting_worries_over_the_printer_declines/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/13/shutterstock_printer.jpg"><h5>Wall Street analyst slashes HP Inc's share rating amid mounting worries over printer supplies declines</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/space_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/17/enterprise_cockpit.jpg"><h5>NASA's lunar spy looks for hide-and-seek champ Vikram, Starliner test success, and more</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/like_computers_love_fungus/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/03/26/mushrooms_shutterstock.jpg"><h5>You look like a fungi. Got mushroom in your life to build stuff with mycelium computers?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/14/magnetic_cockroaches_dirty_money_wombat_poo_and_postmens_testicles_ig_nobels_2019/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/13/ignobel-prize-2019.jpg"><h5>Magnetic cockroaches, dirty money, wombat poo and posties' balls: It's the Ig Nobels 2019</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/14/darkest_black_mit_99_995/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/13/blackest_material.jpg"><h5>MIT boffins turn black up to 11 with carbon nanotubes that absorb 99.995% of light</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/mcubed_ai_machine_learning/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/18/m3_l0_logo.jpg"><h5>Neural networks. Sparse data. TensorFlow. PyTorch. Text mining. Ethics – and lots more. We've got every angle of AI covered at MCubed</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/four_year_delay_for_smart_meter_rollout/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/03/06/smart_meter.jpg"><h5>UK.gov's smart meter cost-benefit analysis for 2019 goes big on cost, easy on the benefits</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/17/twitter_bullying_classifier/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/16/hate_speech.jpg"><h5>Boffins build AI that can detect cyber-abuse – and if you don't believe us, YOU CAN *%**#* *&amp;**%* #** OFF</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/16/ai_roundup_130919/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/16/shutterstock_usa_police.jpg"><h5>Face-recognizing cop body cams hit another hurdle, genderless voice assistants, and more</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/16/worlds_oldest_human_122_yr_old_french_smoker/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/16/clouseau.jpg"><h5>World's oldest human <i>was</i> a 122-year-old French smoker after all</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/16/gold_toilet_stolen/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/03/07/man_holds_in_poo_toilet.jpg"><h5>Au my bog: Bloke, 66, on bail after 'solid-gold' crapper called 'America' stolen from stately home</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/15/kenyan_mp_aeroplane_flatulence/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/09/13/skydivers.jpg"><h5>Wake me up before you Gogo ... so I can jump out: Kenyan MP takes on aeroplane flatulence</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/09/14/teadrinkers_have_better_brains_say_boffins_with_even_better_brains/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/15/shutterstock_659139859.jpg"><h5>Time for another cuppa then? Tea-drinkers have better brains, say boffins with even better brains</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Stallman's final interview as FSF president: Last week we quizzed him over Microsoft visit. Now he quits top roles amid rape remarks outcry</h1>
                
                <h2>GNU man resigns after Minsky email defense 'the final straw' for dev world</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Thomas-Claburn" title="Read more by this author" class="alt_colour dcl">Thomas Claburn in San Francisco</a>
                        
                        <span class="dateline">
                            17&nbsp;Sep&nbsp;2019&nbsp;at&nbsp;05:11
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/09/17/richard_stallman_final_interview/" class="reg_comments">                                    <span class="count">116</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&title=Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry&amp;url=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&amp;redirect_uri=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&amp;title=Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry&amp;summary=GNU%20man%20resigns%20after%20Minsky%20email%20defense%20%27the%20final%20straw%27%20for%20dev%20world" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2019/09/13/richard_stallman.jpg?x=442&amp;y=293&amp;crop=1" alt="Richard Stallman" width=442 height=293 class="article_img">
                    <div class=img_caption>Stalled-man ... Richard Stallman at The Register's SF office</div>
            </div>
            <div id="body">
                
                <p><strong class="trailer">Interview</strong> Shortly after <i>The Register</i> learned that Richard Stallman, founder and then president of the <a target="_blank" rel="nofollow" href="https://www.fsf.org/">Free Software Foundation</a> and creator of the <a target="_blank" rel="nofollow" href="https://www.gnu.org">GNU Project</a>, had been <a target="_blank" href="https://www.theregister.co.uk/2019/09/05/richard_stallman_microsoft/">invited to speak</a> at Microsoft's corporate headquarters, we emailed him to ask about the apparent incongruity of advocating for software freedom at a company singled out by the FSF as a <a target="_blank" rel="nofollow" href="https://www.gnu.org/proprietary/malware-microsoft.en.html">maker of malware</a>.</p>
                <p>To our surprise, Stallman volunteered to be interviewed, in person no less, since he would be in San Francisco on Thursday, September 12.</p>
                <p>That was the day Selam Gano, a mechanical engineer at XYZ Robotics and an MIT graduate, published a <a target="_blank" rel="nofollow" href="https://medium.com/@selamie/remove-richard-stallman-fec6ec210794">post on Medium</a> assailing Stallman for disputing, in an MIT mailing list post, the applicability of the term "sexual assault" in a description of <a target="_blank" rel="nofollow" href="https://www.facebook.com/events/687098025098336/">an MIT student protest</a> planned for Friday, September 13.</p>
                <p>That protest was organized to seek the dismissal of senior university administrators who knew about donations made to the college by Jeffrey Epstein, the financier and convicted sex offender who killed himself last month while behind bars awaiting federal sex-trafficking charges. The description of the protest included a reference to the "deceased AI ‘pioneer’ Marvin Minsky (who is accused of assaulting one of Epstein’s victims)."</p>
                <p>Said victim, Virginia Giuffre, <a target="_blank" rel="nofollow" href="https://www.theverge.com/2019/8/9/20798900/marvin-minsky-jeffrey-epstein-sex-trafficking-island-court-records-unsealed">earlier said</a> she was told to have sex with Minsky at Epstein's US Virgin Islands retreat. She was 17 at the time, in a place where the age of consent is 18.</p>
                <p>Stallman's post to the MIT mailing list argued, in a spectacularly insensitive fashion, that Minsky may not have been aware Giuffre had been coerced to have sex.</p>
                <p>"The most plausible scenario is that she presented herself to him as entirely willing," Stallman wrote in his post last Wednesday. "Assuming she was being coerced by Epstein, he would have had every reason to tell her to conceal that from most of his associates. I’ve concluded from various examples of accusation inflation that it is absolutely wrong to use the term 'sexual assault' in an accusation."</p>
                <p>On the internet and in news publications, this attempt to downplay the rape of a 17-year-old trafficking-ring victim didn't go over well, and led to further scrutiny of past emails and online posts <a target="_blank" rel="nofollow" href="https://www.thedailybeast.com/famed-mit-computer-scientist-richard-stallman-defends-epstein-victims-were-entirely-willing">that made matters worse</a>. He had previously expressed <a target="_blank" rel="nofollow" href="https://geekfeminism.wikia.org/wiki/Richard_Stallman">skepticism</a> of age of consent laws and of the wrongness of "voluntary pedophilia," suggesting there is no harm done if a child and an adult have consensual sex together.</p>
                <p><i>The Register</i> asked Stallman if he wanted to respond to Gano's complaints about him. In an email on Friday, he said, "I care about all sorts of rights for everyone – male, female, or neither. I wish people would read what I really wrote. The accusations cause me hurt."</p>
                <p>That same day, he posted <a target="_blank" rel="nofollow" href="https://stallman.org/archives/2019-jul-oct.html#14_September_2019_(Statements_about_Epstein)">a note</a> to his personal blog saying the media had mischaracterized his statements.</p>
                <p>"Headlines say that I defended Epstein," Stallman wrote. "Nothing could be further from the truth. I've called him a 'serial rapist,' and said he deserved to be imprisoned. But many people now believe I defended him — and other inaccurate claims — and feel a real hurt because of what they believe I said. I'm sorry for that hurt. I wish I could have prevented the misunderstanding."</p>
                <p>And he renounced past statements about pedophilia.</p>
                <p>He <a target="_blank" rel="nofollow" href="https://stallman.org/archives/2019-jul-oct.html#14_September_2019_(Sex_between_an_adult_and_a_child_is_wrong)">wrote</a>, "Many years ago I posted that I could not see anything wrong about sex between an adult and a child, if the child accepted it. Through personal conversations in recent years, I've learned to understand how sex with a child can harm per psychologically. This changed my mind about the matter: I think adults should not do that. I am grateful for the conversations that enabled me to understand why."</p>
                <p>But the damage, self-inflicted or otherwise, was done.</p>
                <p>On Monday, the Software Freedom Conservancy called for his resignation. "When considered with other reprehensible comments he has published over the years, these incidents form a pattern of behavior that is incompatible with the goals of the free software movement," the group said in a <a target="_blank" rel="nofollow" href="https://sfconservancy.org/news/2019/sep/16/rms-does-not-speak-for-us/">blog post</a>. "We call for Stallman to step down from positions of leadership in our movement."</p>
                <p>So did the <a target="_blank" rel="nofollow" href="https://blog.halon.org.uk/2019/09/gnome-foundation-relationship-gnu-fsf/">GNOME Foundation</a>'s executive director Neil McGovern, who said Stallman's Minksy defense email was "the straw that broke the camel’s back."</p>
                <p>By Monday evening, Stallman had resigned as Visiting Scientist at MIT's well-respected Computer Science and Artificial Intelligence Laboratory (CSAIL), and, crucially, <a target="_blank" rel="nofollow" href="https://twitter.com/fsf/status/1173780935910797312">quit</a> as president of the Free Software Foundation, as well as its board of directors.</p>
                <p>"I am resigning effective immediately from my position in CSAIL at MIT. I am doing this due to pressure on MIT and me over a series of misunderstandings and mischaracterizations," he <a target="_blank" rel="nofollow" href="https://stallman.org/archives/2019-jul-oct.html#16_September_2019_(Resignation)">complained</a> on his website.</p>
                <p>Meanwhile, the FSF confirmed his departure in a statement: "On September 16, 2019, Richard M. Stallman, founder and president of the Free Software Foundation, resigned as president and from its board of directors. The board will be conducting a search for a new president, beginning immediately."</p>
                <h3 class="crosshead">
  <span>To publish or not</span>
</h3>
                <p>Which brings us to this interview, evidently his last as leader of the Free Software movement. We've debated what to do with this piece as Stallman's circumstances changed over the past few days. Within hours of his departure from our office on Thursday, Gano's Medium post went live, and the floodgates were washed away: amid attempts by his supporters to defend him, critics opened fire on Twitter with complaints of past behavior. The anger was real.</p>
                <p>By Monday, as we were revising this article, he was gone from the FSF and MIT.</p>
                <p>Had we fully known of his past and present views, had we paid attention to the red flags, had we seen his MIT email the day before, the interview would have gone rather differently, veering away from his appearance at Microsoft and his views on software freedom.</p>
                <p>Rather than bin the piece, or bury it to the back of the site, though, we've decided to let it stand in recognition of the social consequences of free speech.</p>
                <p>In hindsight, Stallman's exacting standards for the words used in conjunction with his work would have been better applied to his own statements.</p>
                <p>Stallman – whose <a target="_blank" rel="nofollow" href="https://groups.google.com/a/mysociety.org/forum/#!msg/mysociety-community/zkyZpOXjgoQ/_8xyXSxv9zYJ">speaking gig rider</a> is mind-boggling – had some specific preconditions for being interviewed.</p>
                <p>He asked if we end up referring to the operating system he helped create, that we refer to it as "GNU." "Linux" refers to the kernel, he said, and is but one of many components of the overall operating system. And along those lines, he asked that we should not place this article in a category labelled "Linux." A <a target="_blank" rel="nofollow" href="https://www.gnu.org/gnu/linux-and-gnu.html">rather lengthy explanation</a> of his views about this can be found on the FSF website.</p>
                <p>He also asked that we not connect his work as a Free Software advocate to "Open Source." He explained, "That is the slogan adopted in 1998 by people who reject the philosophy of the Free Software Movement. They have the right to promote their views, but we would like to be associated with our views, not theirs."</p>
                <p>Then there was the challenge of arranging entry into building where <i>The Register</i>'s US operation is based. Stallman asked not to be identified by name to the building staff to avoid the possibility that his name might end up in a database. "Resisting tracking of persons is everyone's duty," he explained.</p>
                <p>Meeting him in the lobby proved to be easier than working out how to ask front desk staff to admit an individual who could not be named. Eventually, we were able to get Mister Anonymous into the office, and the following conversation took place...</p>
                <p><b><i>The Register</i>:</b> Let's start by talking about your recent visit to Microsoft, a company that in the past has shown antipathy toward the GNU General Public License, a company that you've criticized.</p>
                <p><b>Richard Stallman:</b> First of all, I have always disapproved of Microsoft for making non-free software. It still makes non-free software. And I still say that's an injustice. But it's like so many other companies that are committing the same kind of injustice. So I never hated Microsoft, especially. I never believed that Microsoft was the great Satan. I never thought that the purpose of our efforts was to defeat Microsoft, in particular, because if that had left all the other proprietary software companies, it wouldn't be victory. They're all contributing to the subjugation of the users of computing. And our goal is to put an end to that subjugation no matter who, or what is doing it.</p>
                <p>So I had no special reason to refuse to speak to Microsoft. Now the next question was, was it worth the trouble? Because executives invited me, I figured it was worth the trouble. The worst that could happen is they would reject what I said, and I would achieve nothing. But given the importance of that company, I figured if they seem to be inclined to listen, I should converse with them. And I'm glad that I did.</p>
                <p>What they told me was that their main field is now enterprise support services. And these may or may not be done in an ethical way. But there's nothing inherently unethical about doing that business. And therefore, I figured I would make suggestions to them and present to them the philosophy of the Free Software movement, which I did. And I requested specific changes in their practices, changes that would help the Free Software movement.</p>
                <p><b><i>The Register</i>:</b> Did Microsoft seem receptive to your suggestions?</p>
                <p><b>Richard Stallman:</b> They seemed receptive in a general way. But you know, whether Microsoft will change anything in practice, remains to be seen. Maybe it will change some things and not others, right? That's often happens. But I believe in judging each thing that a company does separately. So if a company is doing this thing, which is wrong and unjust, and this thing, which is helpful, I'd rather not add them up. If these two activities are separable in practice, in other words, if it's possible to look at each one, individually, and distinguish it from the other, if they're not tied up with each other, so much that that's a nonsensical thing to do, then I do that. Because that way, I can disapprove of whatever is bad and approve of whatever is good. That's more useful, just adding it up to get one total for a given company.</p>
                <p><b><i>The Register</i>:</b> Are there companies so hostile to the Free Software movement that you'd refuse an invitation to speak?</p>
                <p><b>Richard Stallman:</b> [Companies] have to do something to show willingness to think about the issue. For instance, someone said, "Well, since you're speaking at Microsoft, would you like to speak at Amazon?" And I hesitated, you know, I said, "Would there be any point?" I could do it, but it wouldn't be of any use. I asked the FSF board, and nobody suggested that it would be of any use.</p>
                <p><b><i>The Register</i>:</b> I saw a video in which you said, "Social inertia is the biggest obstacle to switching to free software." Are there other barriers that deserve consideration?</p>
                <p><b>Richard Stallman:</b> They're all forms of social inertia. Because if not, for the social inertia, we would make free software perfectly easy to use, we'd make it do everything. The problem is today, that the companies that make the software in mobile devices – that means Google and Apple, for the most part – they set up a way of life, which is based on non-free software. And you can run free software in some Android devices. Apple has very carefully locked us out of the iMonsters. But even with Android devices, you can't really do that much. And it's going to be an enormous job, although I think the <a target="_blank" href="https://www.theregister.co.uk/2018/06/15/meet_the_man_building_a_googlefree_android/">Librem</a> phone is a step forward.</p>
                <p>But I simply refuse to use mobile devices, especially portable phones, because your movements are tracked. And because of the backdoor in the modem processor, the radio processor bit communicates with the phone radio network, they can convert almost every mobile phone into a listening device. So I call them Stalin's dream.</p>
                <p><b><i>The Register</i>:</b> So even if the Librem phone meets all your requirements, you wouldn't want to carry it?</p>
                <p><b>Richard Stallman:</b> No, it solves one of the problems, it can't be remotely converted into a listening device because the radio processor doesn't talk to the microphone. And also the radio processor can't install different software into the application processor. So if you have a free system in the application processor, it's not going to be easy for the radio processor to attack it.</p>
                <p>Basically, you've got to think of every mobile phone, including that one as containing an attack device, the radio processor. And in most phones, the radio processor talks directly to the microphone, meaning that they can just load listening software into the radio processor and have it start listening immediately. And the radio processor, I believe, is also responsible for shutting the thing off. So when they use the universal backdoor to convert it into a listening device, they also make it refuse to really shut off, it only pretends to shut off. Most of that's blocked by the Librem phone.</p>
                <p>But what it can't block is the fact that if you want to receive any kind communications, it has to be saying where you are. So you're being tracked. That's a matter of the design of the phone network. And I don't think there's any way a phone can fix that. So I would only carry such a thing if I almost always had it switched off, at least in regard to radio communication. But then is it useful? It's not clear to me it's useful enough to, to want to bother.</p>
                <p>But I have one idea that might turn out to be both acceptable and useful. And that is to carry a one way pager, and anyone who wants to talk with me on the phone pages me first explaining what it's about. And then I will decide when to reveal my location by turning yet on. Whether that will prove to be practical enough and useful enough to be worth doing? I don't know, but at least I find it acceptable.</p>
                <p><b><i>The Register</i>:</b> Are there assumptions you made when you started advocating for software freedom that you've had to revise over the years?</p>
                <p><b>Richard Stallman:</b> One thing that has changed is that nowadays, a non-free program is typically malware as well. That was not the case in 1983. In 1983, when a proprietary software product was discovered to be malware, it was scandalous. It was shocking. It made the news, sort of at least in the tech press, because this wasn't the usual case. It there was a certain level of scruples, even among proprietary software developers.</p>
                <p>But over the years, those scruples have evaporated, as companies raced each other to the bottom in terms of mistreating their own users. And now, almost any non free program you run is mistreating you somehow. And this is another powerful reason to reject all non free software. It's designed to mistreat you. Most of them most proprietary programs, spy on people, as far as we can tell. They have DRM, they have back doors, they do censorship. They're designed to be addictive. They sabotage people. They're designed from programmed obsolescence. So many nasty things. If you look in gnu.org/malware, you'll see a catalog of hundreds of examples.</p>
                <p>So this makes it far more obvious that you need to kick that stuff out of your life, that we all need to organize to kick that stuff out of our lives. Maybe someday, we can actually pass laws about this. I've never proposed to prohibit non-free software as such. But I think that implementing DRM ought to be a felony.</p>
                <p><b><i>The Register</i>:</b> There's Europe's General Data Protection Regulation, the GDPR.</p>
                <p><b>Richard Stallman:</b> There's movement. There's attention. But the GDPR is far too weak, because it attempts to regulate the use of databases, but that's too late. Once the data are collected in a database, they will be misused. Because there are so many ways that can happen. One of them is intentional misuse by the organization that collected the data. The GDPR make an effort to limit that. But it's not obvious that it has any real teeth.</p>
                <p>For instance, in many cities in Europe, the way you pay for parking, is you type the license plate number into the parking meter. Now, this is a massive surveillance system. While it may have the side effect of collecting payments, its principal effect is to track everyone who drives and that is vicious. So if the GDPR is interpreted in a way that makes those systems illegal, then I will, I will congratulate the GDPR for having some teeth. But I don't expect that. People in Europe don't seem to expect it to do that. And if it doesn't do that, it's obviously inadequate.</p>
                <p>But then there the other ways the data can be misused by rogue employees. It might be a crime, but crimes are committed you know, or there they could maintain lax security and leak the data. And someone else can misuse it. Or crackers might break into the site and steal the data.</p>
                <p>By the way, please don't call them hackers. That's offensive to us hackers. Hacking is playful cleverness. When it's a matter of breaking security of computers, please call that cracking. Anyway, then there's another way the state can take that data. Now, this is more and more common around the world that countries clear the path for the state, in the name of security, to take any and all databases of personal data. This is one of the horrible things that the USA did in the Pat-Riot Act.</p>
                <p>[Yes, Stallman purposefully pronounces "Patriot" in this context as two distinct words.]</p>
                <p>And I warned about this before it was passed. On September 11 2001, it took me a couple of hours to recognize what the next target would be – it would be Americans' freedom. And that's exactly what happened. Congress targeted Americans' freedom. And of course, W [President George W. Bush] was happy to attack that. So now we've got to get rid of it, more or less. We've especially the part about now national security letters. We have a system for supposed judicial review of surveillance plans. And the FISA court said that it was unable to review these plans ... in effect, that intelligence agencies were bamboozling it so much, and keeping it so much in the dark, that [the court] couldn't tell if they were doing something unconstitutional. So it was a recipe for violating our rights.</p>
                <p><b><i>The Register</i>:</b> That leads to my next question: how does the decline in civic and political freedom around the world affect free software? Does it make the Free Software Foundation's mission more challenging?</p>
                <p><b>Richard Stallman:</b> It may. If the only place you've got any freedom is inside your computer, you're not living a life and freedom. You know, I focus my efforts on the Free Software movement, because that's the problem I am focusing on, someone has to. A lot of people have to, but that doesn't reduce the importance of all the other theaters of this battle in which we are defending our freedom, and others, other people and other organizations take the lead. And I support Sanders for President or else Warren. And I hope, I hope others will, too, because they propose changes big enough to restore democracy. They want to restore democracy, and the centrist so-called democrats are content to let the plutocracy continue.</p>
                <p>We know that since the 1990s, public opinion is essentially disconnected from political decisions. This is probably why so many Americans feel that politics is futile, because it has been futile. But we may be able to change that if we elect enough people who insist on changing it. And we have the chance to try to do that. If we don't do that, if we don't pin back the massive surveillance systems, which are spreading everywhere – you know, Sanders is in favor of banning government use of face recognition. Well, that's the first step we have to take in regard to face recognition. But we've got a ban private use of face recognition, except in very narrow circumstances with that narrowly specified lists of people. Otherwise, it will just result in privatized total tracking of everybody.</p>
                <p><b><i>The Register</i>:</b> That's already happening to some extent with the <a target="_blank" rel="nofollow" href="https://www.eff.org/deeplinks/2019/08/five-concerns-about-amazon-rings-deals-police">Amazon Ring police partnership</a>.</p>
                <p><b>Richard Stallman:</b> I have friends who discovered a Ring doorbell across the street, and they resent the surveillance of people who come to visit them. Now, it seems to me that there could be a law saying if you want to set up one of those video doorbells, you've got to put up a screen so that it can't just see everybody passing on the street, it can only see people come up to your door bell.</p>
                <p><b><i>The Register</i>:</b> What's the state of the <a target="_blank" rel="nofollow" href="https://www.gnu.org/licenses/gpl-3.0.en.html">GNU GPL</a>? Does it still address your requirements for software freedom?</p>
                <p><b>Richard Stallman:</b> I don't see a need to revise GPL version three. It may happen someday. But so far, there's no problem that is worth the trouble of making a new version. But nothing is perfect. And situations change. The reasons for changes in the GPL are of two kinds. One is issues that I wasn't in a position to pay attention to, for versions one and two, and changes in the in the situation and the laws and the practices. To give one simple example: In 1991, when I published GPL version two, I didn't imagine anything like BitTorrent. But in BitTorrent, when you're receiving, you're also transmitting. So what happened is if you use BitTorrent to download a binary of a GPL-covered program. Well, with GPL version two, you're violating the GPL because you're redistributing that binary.</p>
                <p>But there are conditions for how to redistribute a binary. You've got to offer source code. And you're probably not doing that, you're only fetching the binaries. Because the binaries are all you want to get at that moment. So that violates GPL version two, but obviously, it should be permitted. So in GPO version three, there's a change to permit it. It says if you're using a system to get a binary, and the nature of that system is it redistributes the same stuff that you're downloading, and that's the only way you distribute the binaries, it's okay. Whoever's created the tar archive and has to make the source code available. But you don't have to do that yourself.</p>
                <p><b><i>The Register</i>:</b> Does machine learning and AI pose a different challenge to software freedom that traditional software?</p>
                <p><b>Richard Stallman:</b> Not different ones. If someone releases a binary program that does some sort of AI technique, right? Well, that's the same injustice as any other non-free program. It takes away users' freedom, it imposes, it puts them under the power of the program's owner. But if you're looking for new issues that are specifically due to AI, I don't think there is one.</p>
                <p>I think that AI raises a tremendously important political issue, because it will potentiate disparities of power. The companies that use data to exercise power over society, they can gain an awful lot from AI. They can use it on their databases about people to learn to figure out even more about these people, which is even more reason why we shouldn't allow those databases to be collected at all. That's how we should really solve the problem, to go beyond the GDPR. Instead of addressing the problem at the level of regulating use of the databases, to say we will not let these databases be collected. Systems must not be designed so that they systematically collect personal data of any kind.</p>
                <p><b><i>The Register</i>:</b> Do you still find time to write code?</p>
                <p><b>Richard Stallman:</b> Oh, no, I don't try. I enjoyed programming 30 years ago when I was good at it. But I'm 66 years old. There's no reason to think I could be as good at it now. My memory for all sorts of details of a large piece of code and why I did this and that, it wouldn't be the same. But in any case, there are lots of other people who are doing that. And so in the 1990s, I was involuntarily self-promoted into management. Basically, I recognized that that's what I had to be doing. That's what I was needed for more than for writing the code.</p>
                <p><b><i>The Register</i>:</b> What are some of the current software projects, either with the Free Software Foundation or elsewhere, that most interest you at the moment?</p>
                <p><b>Richard Stallman:</b> Well, one interesting thing is Guix, which is our GNU/Linux distribution, which is meant to be a technical advance in many ways. And there are other distros where you get the sources and you build them. This however, is more advanced, it uses Scheme as the basis for a lot of what it does. That's something I wanted GNU to do ever since before I started it, but now maybe we will.</p>
                <p>Another thing that I think is tremendously important is the <a target="_blank" rel="nofollow" href="https://taler.net">GNU Taler</a>, which is an anonymous payment system designed for buying things from stores. So it's not a cryptocurrency. The payments are denominated in whatever currency is convenient, I suppose in the US, it would be dollars mostly. And you buy your Taler tokens from something that's called the mint, it's not a government-owned mint, it's an organization that will sell you Taler tokens. It uses David Chaum's blind signature technique.</p>
                <p>So you end up with signed Taler tokens, but the bank doesn't know what tokens it signed, and you use them to pay and the merchant takes the tokens and the transaction information to the bank to get paid. You can't re-spend the Taler tokens, you get if your're merchant. All you can do is take them in to get money. And this way, Taler doesn't encourage tax evasion. That's important to the developers of Taler and to me. So we think it's better than cryptocurrencies in a lot of ways.</p>
                <p><b><i>The Register</i>:</b> What's the most significant challenge in advocating for software freedom today?</p>
                <p><b>Richard Stallman:</b> I focus on teaching people the values of freedom in computing, because if you understand that, you will resent every piece of non-free software somebody tries to make you run, and you will want to escape. You'll look for ways to do work to escape. But if you don't get those things, if you don't understand the point, well, you might cooperate and contribute somehow, but you won't reinforce our defense of freedom. There are lots of contributors to free software who don't agree with the Free Software philosophy in the slightest They probably talk about "Open Source" instead. That's the term that was coined by people who rejected our values, so as to disconnect our practical work from our values. And they are more likely to use a push-over licenses, rather than copyleft licenses. The weak, push-over licenses, they're free licenses, they make the software free, but they foolishly permit putting that code into non-free programs.</p>
                <p><b><i>The Register</i>:</b> Does the Free Software community need to do more litigation to protect against GPL abuse?</p>
                <p><b>Richard Stallman:</b> Yes, and no. We did sue a company once. And it agreed to stop –</p>
                <p><b><i>The Register</i>:</b> Cisco?</p>
                <p><b>Richard Stallman:</b> Yes. We've agreed not to say what we agreed to. But we did resolve the problem. And we could do that again if we have to.</p>
                <p><b><i>The Register</i>:</b> But it's not particularly fruitful way to advance your goals?</p>
                <p><b>Richard Stallman:</b> Well, it is sometimes. I do not agree with the people who think there's something wrong about suing violators of the GPL. When that's called for, go to it. It does require some resources. It would be nice to have a well-endowed fund for doing this. But our approach to enforcing the GPL... the main thing we want is for the violator to start respecting users' rights. That's after all, what copyleft is for. It's a legally-based requirement for re-distributors to respect the freedom of the users. The freedom of the users is what it's all about.</p>
                <p><b><i>The Register</i>:</b> Is there anything we haven't touched on that you'd particularly like to mention?</p>
                <p><b>Richard Stallman:</b> One thing is, if you want to get paid for developing free software, there is a gigantic area of software – which I think is actually the majority of paid software development – which is the development of custom software that is meant to be used and not released. And in that area, if you insist on delivering your code to the client under a free license, well, I don't think that would stop you from getting the job. I mean, anyone who would develop a program for clients and not let the clients have the four freedoms, is taking advantage of them. And the client who accepts that is being suckered.</p>
                <p>The Government of Canada is one example of a client that got suckered. It developed a program, I think it's called <a target="_blank" rel="nofollow" href="https://www.tpsgc-pwgsc.gc.ca/remuneration-compensation/services-paye-pay-services/centre-presse-media-centre/index-eng.html">Phoenix</a>, to calculate and write the checks to its employees, it's full of bugs, they can't fix the bugs there, they're not allowed to fix it. The government is not allowed to fix these bugs, it doesn't have the source code, it has no control at all. And the company that developed it apparently is not fixing these bugs. And somebody is developing a free replacement, which is a tremendous technological advance also, because it has a database of the rules by which the pay is calculated and figures out how to combine those rules.</p>
                <p>So this demonstrates how if you're a client for development of some custom software that you're going to use, you must insist that you get it as free software. It should be in the contract, that unless we see that all the code is free, and it runs on a free system also, you will not get paid. ®</p>
                
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/09/17/richard_stallman_final_interview/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments large">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/09/17/richard_stallman_final_interview/">
                        <span>116</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/development">Development</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&title=Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry&amp;url=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&amp;redirect_uri=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/&amp;title=Stallman%27s%20final%20interview%20as%20FSF%20president%3A%20Last%20week%20we%20quizzed%20him%20over%20Microsoft%20visit.%20Now%20he%20quits%20top%20roles%20amid%20rape%20remarks%20outcry&amp;summary=GNU%20man%20resigns%20after%20Minsky%20email%20defense%20%27the%20final%20straw%27%20for%20dev%20world" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/09/16/123reg_namesco_uk_domains/">
                            <img src="https://regmedia.co.uk/2019/09/13/shutterstock_unhappy_lady.jpg?x=88&amp;y=58&amp;crop=1" alt="unhappy" width=88 height=58>
                <h4>Two years ago, 123-Reg and NamesCo decided to register millions of .uk domains for customers without asking them. They just got the renewal reminders...
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/09/16/cobol_at_60/">
                            <img src="https://regmedia.co.uk/2017/11/14/grumpyoldman.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>COBOL: Five little letters that if put on a CV would ensure stable income for many a greybeard coder
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/">
                            <img src="https://regmedia.co.uk/2019/09/13/richard_stallman.jpg?x=88&amp;y=58&amp;crop=1" alt="Richard Stallman" width=88 height=58>
                <h4>Stallman's final interview as FSF president: Last week we quizzed him over Microsoft visit. Now he quits top roles amid rape remarks outcry
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/09/16/who_me/">
                            <img src="https://regmedia.co.uk/2015/03/24/mounties.jpg?x=88&amp;y=58&amp;crop=1" alt="Mounties" width=88 height=58>
                <h4>Justice served: There is no escape from the long server log of the law
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/09/16/fit_bit_update_disrupts_sync/">
                            <img src="https://regmedia.co.uk/2015/10/21/fitbit.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Fitbit fitness fans furious following flummoxing flawed firmware float, fleeting feedback, failed fixes
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/09/17/richard_stallman_final_interview/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7623/sans-2019-top-new-attacks-and-threat-report?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>SANS 2019 Top New Attacks and Threat Report</h4>
                <div class=standfirst>
                    Basic security hygiene has been proven to be the foundation for every successful cybersecurity program.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7722/rethinking-your-infrastructure-for-enterprise-ai?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Rethinking Your Infrastructure for Enterprise AI</h4>
                <div class=standfirst>
                    This white paper discusses these challenges and looks at how IBM proposes to help businesses overcome them.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7601/endpoint-buyers-guide?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Endpoint Buyers Guide</h4>
                <div class=standfirst>
                    As cyber threats become ever more complex, the pressure on IT and security managers to have the right endpoint solution in place has also grown.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7664/getting-smart-about-data-growth-with-intelligent-data-management?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Getting Smart about Data Growth with Intelligent Data Management</h4>
                <div class=standfirst>
                    Take a fresh look at how you manage data and find out whether cold data is eating up valuable resources.
                </div>
            </a>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/09/05/richard_stallman_microsoft/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/02/06/apocalypse.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Another sign of the End Times: Free software guru Richard Stallman speaks at Microsoft HQ</h4>
                            <div class=standfirst>
                                <span class=trailer>Photo</span>
                                Firebrand in town to give Redmond a GNU lease of life
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/05/09/gnu_glic_abort_stallman/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/06/03/bare_knuckle_fight_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Bare knuckle fight, photo via Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>You have GNU sense of humor! Glibc abortion 'joke' diff tiff leaves Richard Stallman miffed</h4>
                            <div class=standfirst>
                                FSF firebrand rails against purged abort() docs 'satire'
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2016/04/12/bundling_zfs_and_linux_is_impossible_says_richard_stallman/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/11/04/richard_stallman_by_webmink_flickr_under_cc_20.jpg?x=198&amp;y=131&amp;crop=1" alt="Richard Stallman" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Bundling ZFS and Linux is impossible says Richard Stallman</h4>
                            <div class=standfirst>
                                GNU man doesn't mention Oracle or Ubuntu, but that's who he's lashing
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2015/11/05/wiegley_new_emacs_maintainer/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/11/04/richard_stallman_by_webmink_flickr_under_cc_20.jpg?x=198&amp;y=131&amp;crop=1" alt="Richard Stallman" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Emacs gets new maintainer as Richard Stallman signs off</h4>
                            <div class=standfirst>
                                Long-time contributor John Wiegley steps into the chair
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2015/05/25/stallman_windows_and_mac_are_malware/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/02/17/malware_secuirty.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Windows and OS X are malware, claims Richard Stallman</h4>
                            <div class=standfirst>
                                'Resist gratification', says super-GNU-man freedom fighter
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/01/23/free_software_foundation_high_priority_projects_list_2017/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/07/11/gnu_logo.jpg?x=198&amp;y=131&amp;crop=1" alt="GNU logo" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Stallman's Free Software Foundation says we need a free phone OS</h4>
                            <div class=standfirst>
                                Because that worked so well for Firefox OS, and Ubuntu Touch, and Sailfish, and Tizen &#8230;
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2013/11/22/richard_stallman_decides_emacs_should_go_wysiwyg/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2012/06/12/richard_stallman.jpg?x=198&amp;y=131&amp;crop=1" alt="Richard Stallman, credit: Victor Powell" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Richard Stallman decides Emacs should go WYSIWYG</h4>
                            <div class=standfirst>
                                GNU Daddy revives 25 year-old ambition to get graphical
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2012/06/12/stallman_laptop_stolen/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2013/02/05/default_image-2.png?x=198&amp;y=131&amp;crop=1" alt="The Register breaking news" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Thief open-sources Richard Stallman's laptop, passport, visa</h4>
                            <div class=standfirst>
                                Free Software firebrand's hardware liberated in Argy-bargy
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XYFcosCoyKoAADQVyE4AAADX&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>ABOUT US<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>MORE CONTENT<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>SITUATION PUBLISHING<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <div class="foot_desc_wrapper">
                    <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
                </div>
            </div>

        </div>

        <div class="right_block">
            <div class="newsletter_and_social">
                <div class="newsletter_signup alt_colour dcl">
                    <h4>SIGN UP TO OUR NEWSLETTERS</h4>
                    <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                    <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">SUBSCRIBE<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
                </div>

                <div class="social alt_colour dcl">
                    <div id=follow_btns>
                        <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                            <div class="circ">
                                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                            </div>
                        </a>
                        <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                            <div class="circ">
                                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                            </div>
                        </a>
                        <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                            <div class="circ">
                                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                            </div>
                        </a>
                        <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                            <div class="circ">
                                <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                            </div>
                        </a>
                    </div>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            function login_state() {
                // Get what we can in terms of user info from the s/ml/sl cookies
                var raw_cookies = [
                    [ 's' , 'full log in'    ],
                    [ 'ml', 'newsletter link'],
                    [ 'sl', 'whitepaper link']
                ];
                var log_state = 'none';
                for (var i = 0; i < raw_cookies.length; i++) {
                    var s = $.cookie(raw_cookies[i][0]).split(':');
                    // jump to next if cookie does NOT contain the proper information
                    if ( s[0] != 1 || ( typeof(s[3]) === 'undefined' || s[3] === '0' ) ) continue;
                    // if good information, set the log_state and terminate the FOR
                    log_state = raw_cookies[i][1];
                    break;
                }
                return log_state;
            }

            // returns true if the current page is an Article and the previous
            // page is a different Article.
            function is_article2article () {
                if (typeof(RegPageType) !== 'undefined' && RegPageType === 'Story' &&
                typeof(document.referrer) !== 'undefined' &&
                document.referrer.match(/^https?:\/\/www\.theregister\.co\.uk\/[1-3][0-9]{3}\/[0-1][0-9]\/[0-3][0-9]\/[^\/]+/) &&
                document.referrer !== window.location.pathname &&
                !window.location.href.match(/\?.+/))
                    return true;
                else return false;
            }


            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof(RegTruePageType) !== 'undefined') ? RegTruePageType : '');
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('set', 'dimension8', login_state());
            if ( typeof(RegABTest) !== 'undefined' ) ga('set','exp', RegABTest);
            if ( is_article2article() ) {
                var page_has_url_params = typeof(window.location.href.split(/\/\?.*/)[1]) !== 'undefined';
                ga('send', 'pageview', window.location.href.split(/^https?:\/\/www\.theregister\.co\.uk/)[1] + ( page_has_url_params ? '&' : '?' ) + 'from_article=1' );
            }
            else ga('send', 'pageview');
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(373) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

