<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Microsoft's Windows Terminal preview gets jiggy with Azure – but emphasis on 'preview' • The Register</title>
        <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2019/08/05/preview.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/08/05/windows_terminal/" />
    <meta property="og:title" content="Microsoft's Windows Terminal preview gets jiggy with Azure – but emphasis on 'preview'" />
    <meta property="og:description" content="Open-source command line fun and ga- oh. It crashed again." />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Microsoft, Windows">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/08/05/windows_terminal/"},
"headline":"Microsoft's Windows Terminal preview gets jiggy with Azure \u2013 but emphasis on 'preview'",
"datePublished":"2019-08-05T13:00:12Z",
"dateModified":"2019-08-05T10:51:42Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2019/08/05/preview.jpg","width":"648","height":"432"},
"author":{"@type":"Person","name":"Richard Speed"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';
      var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/08/05/windows_terminal/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/08/05/windows_terminal/"><script>
        var RegArticle={id:204211,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['microsoft','Microsoft'],['windows terminal','Windows Terminal'],['windows','Windows']],short_url:'http://reg.cx/2UXU',cp:0,noads:[],author:'Richard Speed',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400,700&amp;display=swap">
<link rel=stylesheet type="text/css" href="/css_picker/default/be852d330cfd7f58020ec6ed134f16a6f1ce31be/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/38e837a29e46bc261eada60ac5c724f50fe77ce1/javascript/_.js"></script>
    <script async src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/microsoft&amp;s=vk/windows%20terminal&amp;s=vk/windows&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/06/wyden_amazon_letter/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/06/07/wyden-section702.jpg"><h5>Jeff Bezos feels a tap on the shoulder. Ahem, Mr Amazon, care to explain how Capital One's AWS S3 buckets got hacked?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/amazon_sues_aws_sales_exec_non_compete/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/04/09/google_cloud_next19.jpg"><h5>Choc blocked: AWS sues sales exec for legging it to Google Cloud. Yup, another bitter battle over non-compete clauses</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/seagate_spins_off_a_bit_of_cash_from_slowing_disk_drive_business/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/12/19/seagate_multi-actuators.jpg"><h5>Seagate spins off a bit of cash from slowing disk drive business</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/bt_flogs_its_fleet_biz/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/05/11/bt_openreach_van_648x429.jpg"><h5>BT flogs off its fleet vehicle maintenance arm to German private equity types Aurelius</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/microsoft_licensing_windows_clouds/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/05/shutterstock_wallet.jpg"><h5>Microsoft hikes cost of licensing its software on rival public clouds, introduces Azure 'Dedicated' Hosts</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/windows_terminal/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/05/preview.jpg"><h5>Microsoft's Windows Terminal preview gets jiggy with Azure – but emphasis on 'preview'</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/vbscript_disabled_by_default/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/06/15/death_shutterstock.jpg"><h5>Disabled by default: Microsoft ups the ante in its war against VBScript on Internet Explorer</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/microsoft_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/10/17/old_shutterstock.jpg"><h5>Everything old is new again in this week's Microsoft roundup</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/fbi_camera_upskirt/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/05/shuttrstock_fbi_agent.jpg"><h5>F-B-Yikes! FBI bod allegedly hid spy camera under desk to snap coworker's upskirt pics</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/chrome_incognito_mode_fix_falls_flat/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/05/shutterstock_hiding_from_computer.jpg"><h5>Googlers hate it! This one weird trick lets websites dodge Chrome 76's defenses, detect you're in Incognito mode</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/black_hat_survival/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/05/shutterstock_white_hat_hacker.jpg"><h5>How to avoid getting burned at Black Hat, destroyed at DEF CON or blindsided by Bsides</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/uk_gov_offers_cash_for_coastguard_drones/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/11/20/drone_flier_shutterstock.jpg"><h5>The sea is dangerous and no one likes robots, so why not send a drone on rescue missions?</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/serverless_computing_london/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/23/serverless_london_index.jpg"><h5>Join us at Serverless Computing London: We'll get you up and running FaaS-er for less</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/17/continuous_lifecycle_2020_call_for_papers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/16/continuous_lifecycle_2020.jpg"><h5>Share your story: Continuous Lifecycle 2020 call for papers is open NOW – what are you waiting for?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/16/ibm_promising_easier_kubernetes_with_kabanero_package/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/01/20/ibm.jpg"><h5>IBM drags Websphere devs towards Kubernetes with Kabanero package</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/12/aws_visual_studio_code/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/14/newneighbours.jpg"><h5>Amazon brings serverless pie to Visual Studio Code party</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/mike_lynch_leaves_witness_box_autonomy_trial/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/09/meg_whitman.jpg"><h5>I miss him already, says judge as Mike Lynch's court marathon ends</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/trump_continues_on_the_war_path_now_tariffs_cover_nearly_everything_arriving_from_china/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/16/war.jpg"><h5>Trump continues on the warpath: Now US tariffs cover nearly everything arriving from China</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/japan_south_korea_trade_list/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/16/shutterstock_samsung_south_korea.jpg"><h5>Who's for another trade war? Japan hits South Korea, Seoul survivor promises to retaliate</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/godaddy_ceo_resigns/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/01/13/unhappy-godaddy.jpg"><h5>GoDaddy's daddy goes: Chief exec Scott Wagner steps down as hosting biz swings into the red</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/01/lyft_pulls_ebike_fleet/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/01/shutterstock_lyft_bike_sf.jpg"><h5>Lyft pulls its e-bike fleet from San Francisco Bay Area after exploding batteries make them the hottest seat in town</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/01/google_is_going_big_on_video_game_servers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/06/shutterstock_gamer_woman.jpg"><h5>You'll soon be fragging noobs on Kubernetes with Google's cloudy take on game servers</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/01/smartphone_decline/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/12/dull.jpg"><h5>And we're back live with the state of the smartphone market in 2019. Any hope? Yeah, nah</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/31/chinese_ipad_smuggler_jail/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/03/29/ipadlongdivision.jpg"><h5>US gives Chinese smuggler 37 months in the slammer for selling knock-off Apple kit</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/space_roundup/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/09/01/spacex_fire_1.jpg"><h5>Waiting for Amos: SpaceX delays satellite launch as it tries hard not to blow this one up</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/development_and_conservation_not_mutually_exclusive/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/16/migrating_birds_and_clouds_shutterstock.jpg"><h5>Researchers find development and conservation aren't mutually exclusive</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/01/esa_encrypted_commsi/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/31/esa_crpytography_cube.jpg"><h5>Pi in the sky as ESA starts testing encrypted comms on International Space Station</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/31/orbitbeyond_drops_nasa_moon_contract/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/10/moon.jpg"><h5>Will someone plz dump our shizz on the Moon, NASA begs as one of the space biz vendors drops out</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/apple_siri_no_conversations/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/02/shutterstock_headphones.jpg"><h5>Apple: Ok, ok, we'll stop listening in on your Siri conversations. For now, but maybe in the future</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/ai_pub_system/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/01/bar.jpg"><h5>Take two cornerstones of British life, booze and queues, then squirt them with face scans: AI Bar</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/31/mcubed_early_bird_ending/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/05/m3_logo.jpg"><h5>No hype, no BS. Just pure practical AI and ML knowledge from our fantastic expert line-up: Join us at MCubed</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/29/ai_roundup_260719/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/27/listening_in.jpg"><h5>Apple techies analyzing Siri recordings may have heard you unzipping and bonking – plus more</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/05/silver_spitfire_takes_off_on_round_the_world_jaunt/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/08/05/silverspitfire.jpg"><h5>Storied veteran Spitfire slapped with chrome paint job takes off on round-the-world jaunt</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/edward_snowden_autobiography_permanent_record/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/24/snowden.jpg"><h5>The NSA's own bastard operator from Hell, aka Edward Snowden, puts out memoir next month</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/08/02/cheers_to_beer_day/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/05/15/beer_shutterstock.jpg"><h5>It's Friday lunchtime on International Beer Day. Bitter hop to it, boss'll be none the weiser</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/29/rockstar/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/08/26/gta_v_in_game_4k_1.jpg"><h5>UK taxpayers funded Grand Theft Auto V maker to tune of £42m – while biz paid no corp tax and made billions</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Microsoft's Windows Terminal preview gets jiggy with Azure – but emphasis on 'preview'</h1>
                
                <h2>Open-source command line fun and ga- oh. It crashed again.</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Richard-Speed" title="Read more by this author" class="alt_colour dcl">Richard Speed</a>
                        
                        <span class="dateline">
                            5&nbsp;Aug&nbsp;2019&nbsp;at&nbsp;13:00
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/08/05/windows_terminal/" class="reg_comments">                                    <span class="count">1</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/08/05/windows_terminal/&title=Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27&amp;url=https://www.theregister.co.uk/2019/08/05/windows_terminal/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/08/05/windows_terminal/&amp;redirect_uri=https://www.theregister.co.uk/2019/08/05/windows_terminal/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/08/05/windows_terminal/&amp;title=Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27&amp;summary=Open-source%20command%20line%20fun%20and%20ga-%20oh.%20It%20crashed%20again." class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2019/08/05/preview.jpg?x=442&amp;y=293&amp;crop=1" alt="Curious actor or illusionist is looking behind red curtain" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>Microsoft continued its breakneck pace of Windows Terminal development with a major update to its open source command line baby over the weekend.</p>
                <p>The very-preview code has <a target="_blank" rel="nofollow" href="https://devblogs.microsoft.com/commandline/windows-terminal-preview-v0-3-release/">hit 0.3</a>, and we took a look at version 0.3.2142.0, which can currently be found in the otherwise moribund Microsoft Store. The release can also be picked up on GitHub if downloading from the Store just isn't your thing.</p>
                <p>Two changes will grab the attention of new and old users alike.</p>
                <p>The first is cosmetic and represents a tidying up of the interface. It's a small thing, but significant: the icon to add a new command shell tab along with the profile drop-down has been moved to the right of the last tab. It had been previously shunted to the far right of the title bar of the window.</p>
                <p>It's more consistent with how browsers such as Chrome or Chromium Edge work so feels a good deal more natural.</p>
                <p>While we're not sure that the Settings screen (such as it is – more on that later) really belongs in the drop-down menu beside the Add button, that menu does include an additional feature to please the faithful – the <a target="_blank" rel="nofollow" href="https://devblogs.microsoft.com/commandline/the-azure-cloud-shell-connector-in-windows-terminal/">Azure Cloud Shell</a>. The Windows Terminal already supported the likes of PowerShell, WSL and good old-fashioned cmd, so adding the Azure Shell is a logical step.</p>
                <p>Setting it up is a simple matter of giving a code to Microsoft's cloud services to authenticate the session and selecting a tenant to be dropped into the world of the Azure Command Line Interface.</p>
                <p>It is at once impressively slick and a little clunky. There's a certain joy to be had in manipulating one's Azure resources from a tab in the Windows Terminal, but an occasional keyboard entry lag and a proclivity to lock solid if ignored for a few minutes belies the very early preview nature of things.</p>
                <p>"Slick but clunky" is a handy phrase to use to describe the rest of the update. Accessibility improvements abound along with tweaks to key bindings. Console jockeys have yet more customisation options, including the ability to define the tab title of each profile, but it doesn't take a lot of prodding to discover the team isn't joking about "preview".</p>
                <p>While it is now possible to move the window around by dragging from anywhere on the title bar, resize that window and marvel at how tabs are hidden with no indication that more may be lurking on the right. If you're very lucky, Windows Terminal may simply fall over in shock at such shenanigans.</p>
                <p>And, quite frankly, one shouldn't have to carefully edit a .json file in order to take advantage of those lauded customisation features.</p>
                <p>However, and we cannot emphasise this enough, this is a self-confessed preview indicating where Microsoft is going with its terminal tech, and so it can be cut plenty of slack for the time being. While it is clearly not production-ready, that tabbed shell remains hard to resist, customisation fiends can spend happy hours tinkering with the interface and Azure CLI fans will enjoy the cloud connector.</p>
                <p>Once, of course, it works. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1842/-7432/balancing-consumerization-and-corporate-control?td=wptl1842">Balancing consumerization and corporate control</a>
                </p>
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/08/05/windows_terminal/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/08/05/windows_terminal/">
                        <span>1</span>
                        Comment
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/microsoft">Microsoft</a>
                </li>
                <li>
                    <a href="/Tag/windows">Windows</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/08/05/windows_terminal/&title=Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27&amp;url=https://www.theregister.co.uk/2019/08/05/windows_terminal/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <a class=faceb_dialog href="https://www.facebook.com/dialog/feed?app_id=727516617265205&display=popup&amp;link=https://www.theregister.co.uk/2019/08/05/windows_terminal/&amp;redirect_uri=https://www.theregister.co.uk/2019/08/05/windows_terminal/">
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </a>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/08/05/windows_terminal/&amp;title=Microsoft%27s%20Windows%20Terminal%20preview%20gets%20jiggy%20with%20Azure%20%E2%80%93%20but%20emphasis%20on%20%27preview%27&amp;summary=Open-source%20command%20line%20fun%20and%20ga-%20oh.%20It%20crashed%20again." class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/08/05/who_me/">
                            <img src="https://regmedia.co.uk/2019/08/01/shutterstock_tv.jpg?x=88&amp;y=58&amp;crop=1" alt="90s era tv set" width=88 height=58>
                <h4>Y2K, Windows NT4 Server and Notes. It's a 1990s Who, Me? special
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/08/05/black_hat_defcon_hotels/">
                            <img src="https://regmedia.co.uk/2019/08/02/shutterstock_vegas_outdoors.jpg?x=88&amp;y=58&amp;crop=1" alt="Las Vegas in the sunshine" width=88 height=58>
                <h4>It's Black Hat and DEF CON in Vegas this week. And yup, you know what that means. Hotel room searches for guns
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/08/05/mike_lynch_leaves_witness_box_autonomy_trial/">
                            <img src="https://regmedia.co.uk/2015/10/09/meg_whitman.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>I miss him already, says judge as Mike Lynch's court marathon ends
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/08/05/cloudflare_stops_services_to_8chan/">
                            <img src="https://regmedia.co.uk/2016/07/19/do_the_right_thing_sign_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="Do the right thing on the internet of things" width=88 height=58>
                <h4>Cloudflare punts far-right hate-hole 8chan off the internet after 30 slayed in US mass shootings
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/08/05/security_roundup_0209819/">
                            <img src="https://regmedia.co.uk/2018/09/12/shutterstock_whackmole.jpg?x=88&amp;y=58&amp;crop=1" alt="People playing whack-a-mole game" width=88 height=58>
                <h4>LAPD loses job applicant details, Project Zero pokes holes in iOS, AWS S3 whack-a-mole continues, and more
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/08/05/windows_terminal/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7599/a-flash-storage-technical-and-economic-primer?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>A Flash Storage Technical and Economic Primer</h4>
                <div class=standfirst>
                    Although today’s NAND flash storage has its roots in 30-year-old technology, innovation has negated almost all of the challenges that are inherent in the media.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7186/automation-devops-and-the-demands-of-a-multicloud-world?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Automation, DevOps, and the Demands of a Multicloud World</h4>
                <div class=standfirst>
                    IDC's global study assessing how IT and automation strategies are evolving due to cloud computing, DevOps and digital transformation initiatives.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7567/defending-against-the-siege-of-ransomware?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Defending Against the Siege of Ransomware</h4>
                <div class=standfirst>
                    Ransomware is big business. But to win the war against this cyber threat, without paying a king’s ransom, you need a strong defense.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7581/time-to-transform-your-oracle-journey?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Time to transform your Oracle journey</h4>
                <div class=standfirst>
                    See how Nutanix can transform the way you approach your Oracle workloads.
                </div>
            </a>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/07/11/microsofts_reasons_for_ending_free_licenses_for_partners/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/12/19/microsoftvancouver_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Microsoft building in Vancouver" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft giveth and Microsoft taketh away: Partner boss explains yanking of free licences</h4>
                            <div class=standfirst>
                                <span class=trailer>Updated</span>
                                Cloud giant's blunt instrument clobbers loyal resellers too
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/22/microsoft_hungary_bribe/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/09/13/bribe_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="bribe" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft breaks out checkbook, turns Hungarian 'bribe' charge into a mere 'settlement'</h4>
                            <div class=standfirst>
                                Brad's big bucks banish bothersome Budapest bung
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/30/dutch_office_online_mobile/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/10/13/holland.jpg?x=198&amp;y=131&amp;crop=1" alt="holland" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Dutch cheesed off at Microsoft, call for Rexit from Office Online, Mobile apps over Redmond data slurping</h4>
                            <div class=standfirst>
                                Cloggies less than chilled out over Windows telemetry
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/26/half_of_all_public_cloud_money_goes_to_amazon_and_microsoft/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/02/04/shutterstock_cloud.jpg?x=198&amp;y=131&amp;crop=1" alt="cloud eat" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>The democratisation of IT: Amazon and Microsoft own half the cloud infrastructure market</h4>
                            <div class=standfirst>
                                Choice? Yes, we've heard of it too
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/05/17/microsoft_sends_partners_hundreds_of_invoices_intended_for_other_customers/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/06/20/shutterstock_email_attack.jpg?x=198&amp;y=131&amp;crop=1" alt="A man hiding from a lot of emails coming from a laptop" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft sends partners hundreds of unwanted OPI: Other People's Invoices</h4>
                            <div class=standfirst>
                                Risky business: Azure cloud rains bills
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/24/dont_press_the_red_b_windows_insiders_hit_by_a_surprise_microsoft_emission/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/02/13/shutterstock_fist_red_button.jpg?x=198&amp;y=131&amp;crop=1" alt="Picture of a person&amp;#39;s fist hitting an emergency red button" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Don't press the red b-... Windows Insiders' rings hit by surprise Microsoft emission</h4>
                            <div class=standfirst>
                                That's 20H1 for you, 20H1 for you and 20H1 for you
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/08/05/vbscript_disabled_by_default/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/06/15/death_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Death" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Disabled by default: Microsoft ups the ante in its war against VBScript on Internet Explorer</h4>
                            <div class=standfirst>
                                Will the last IE 11 user please turn out the lights?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/07/02/microsoft_fslogix_office_365/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/10/06/shutterstock_tortoise_fast_slow_mo.jpg?x=198&amp;y=131&amp;crop=1" alt="A tortoise catches an orange frisbee. Photo by Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft puts freshly borged FSLogix to work speeding up Office 365</h4>
                            <div class=standfirst>
                                It's a virtualized world and everyone's welcome. Even Citrix and VMware
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XUj9OsCoyKgAAD7g8ysAAADX&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            function login_state() {
                // Get what we can in terms of user info from the s/ml/sl cookies
                var raw_cookies = [
                    [ 's' , 'full log in'    ],
                    [ 'ml', 'newsletter link'],
                    [ 'sl', 'whitepaper link']
                ];
                var log_state = 'none';
                for (var i = 0; i < raw_cookies.length; i++) {
                    var s = $.cookie(raw_cookies[i][0]).split(':');
                    // jump to next if cookie does NOT contain the proper information
                    if ( s[0] != 1 || ( typeof(s[3]) === 'undefined' || s[3] === '0' ) ) continue;
                    // if good information, set the log_state and terminate the FOR
                    log_state = raw_cookies[i][1];
                    break;
                }
                return log_state;
            }

            // returns true if the current page is an Article and the previous
            // page is a different Article.
            function is_article2article () {
                if (typeof(RegPageType) !== 'undefined' && RegPageType === 'Story' &&
                typeof(document.referrer) !== 'undefined' &&
                document.referrer.match(/^https?:\/\/www\.theregister\.co\.uk\/[1-3][0-9]{3}\/[0-1][0-9]\/[0-3][0-9]\/[^\/]+/) &&
                document.referrer !== window.location.pathname &&
                !window.location.href.match(/\?.+/))
                    return true;
                else return false;
            }


            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof(RegTruePageType) !== 'undefined') ? RegTruePageType : '');
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('set', 'dimension8', login_state());
            if ( typeof(RegABTest) !== 'undefined' ) ga('set','exp', RegABTest);
            if ( is_article2article() ) {
                var page_has_url_params = typeof(window.location.href.split(/\/\?.*/)[1]) !== 'undefined';
                ga('send', 'pageview', window.location.href.split(/^https?:\/\/www\.theregister\.co\.uk/)[1] + ( page_has_url_params ? '&' : '?' ) + 'from_article=1' );
            }
            else ga('send', 'pageview');
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(377) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

