<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Low Barr: Don't give me that crap about security, just put the backdoors in the encryption, roars US Attorney General • The Register</title>
        <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2019/07/23/barr1.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/" />
    <meta property="og:title" content="Low Barr: Don't give me that crap about security, just put the backdoors in the encryption, roars US Attorney General" />
    <meta property="og:description" content="I don't want to hear about hackers and keys, nerds – make it happen, or we'll pass a law making it happen" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Encryption">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/"},
"headline":"Low Barr: Don't give me that crap about security, just put the backdoors in the encryption, roars US Attorney General",
"datePublished":"2019-07-23T21:38:12Z",
"dateModified":"2019-07-24T11:13:12Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2019/07/23/barr1.jpg","width":"649","height":"595"},
"author":{"@type":"Person","name":"Iain Thomson"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/07/23/us_encryption_backdoor/"><script>
        var RegArticle={id:204037,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['backdoor','Backdoor'],['encryption','Encryption'],['william barr','William Barr'],['ron wyden','Ron Wyden']],short_url:'http://reg.cx/2UNG',cp:0,noads:[],author:'Iain Thomson',vid:1}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400,700&amp;display=swap">
<link rel=stylesheet type="text/css" href="/css_picker/default/3e42a64dca166499786c1c6c4c02c8798b108339/design.css">

    <style>
        #sec-security, #m-sec-security,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/security/headlines.atom" title="The Register: Security section">

    
    <script src="/design_picker/e345e328380bcb2898b618d2a71ae3f30ce8f3d5/javascript/_.js"></script>
    <script async src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/sec.front&amp;s=vk/backdoor&amp;s=vk/encryption&amp;s=vk/william%20barr&amp;s=vk/ron%20wyden&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_security/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


</head>
<body  data-pagetype='Story' data-video='LQQhJyN071s' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/vodafone_and_o2_cosy_up_to_share_5g_gear/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/07/shutterstock_5g_antenna.jpg"><h5>A bunch of also-RAN: Vodafone and O2 cosy up to share '5G-active' gear</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/linkedin_azure/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/27/cloud-face.jpg"><h5>LinkedIn to chow down on Microsoft's cloudy dogfood</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/plusnet_vodafone_ofcom/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/17/sprinters.jpg"><h5>Plusnet holds off spirited charge from Vodafone in broadband complaint charts</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/google_wispy_payout/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/23/streetview_car.jpg"><h5>Google pays out $13m to make Wi-Spy scandal go away: Bung goes to peeps and privacy orgs</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/visual_studio_aspnet_core_and_linux_some_friction/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/23/efcore.jpg"><h5>El Reg sits down to code with .NET for Linux and MySQL, hitting some bumps along the way</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/bt_adopts_openstack_5g/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/24/5g_shutterstock.jpg"><h5>BT adopts Ubuntu OpenStack as core brains for its 5G, fibre-to-the-premises rollout</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/ibm_wins_955_million_epr_delivery_contract_with_the_australian_dod/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/01/salisbury_plain_training_area_soldiers.jpg"><h5>I don't know but I've been told: IBM slurps AU$95.5m ERP delivery contract from Aussie DoD</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/22/suse_poaches_sap_executive_melissa_di_donato_to_lead_the_company/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/02/chameleon.jpg"><h5>SUSE taps SAP exec Melissa Di Donato to become open-source biz's first female CEO</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/lancaster_university_hack_breach_man_arrested/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/11/07/arrest_2387963984753894.jpg"><h5>Man arrested over UK's Lancaster University data breach hack allegations</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/bluekeep_code_release/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/24/shutterstock_windows_punch.jpg"><h5>With more hints dropped online on how to exploit BlueKeep, you've patched that Windows RDP flaw, right?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/23/barr1.jpg"><h5>Low Barr: Don't give me that crap about security, just put the backdoors in the encryption, roars US Attorney General</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/remote_code_flaw_vlc/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/04/hacker_shutterstock.jpg"><h5>Dodgy vids can hijack PCs via VLC security flaw, US, Germany warn. Software's makers not app-y with that claim</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/17/continuous_lifecycle_2020_call_for_papers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/16/continuous_lifecycle_2020.jpg"><h5>Share your story: Continuous Lifecycle 2020 call for papers is open NOW – what are you waiting for?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/16/ibm_promising_easier_kubernetes_with_kabanero_package/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/01/20/ibm.jpg"><h5>IBM drags Websphere devs towards Kubernetes with Kabanero package</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/12/aws_visual_studio_code/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/14/newneighbours.jpg"><h5>Amazon brings serverless pie to Visual Studio Code party</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/09/serverless_conference/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/23/serverless_london_index.jpg"><h5>Want to get deep into AWS Lambda or Azure Functions? Spend the day with us...</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/autonomy_trial_judge_questions_value_of_cross_examination/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/08/10/shutterstock_lego_fight.jpg"><h5>'We've done it, we've wasted further time!' Judge raps HP over Mike Lynch court scrutiny</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/doj_probes_tech/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/18/shutterstock_president_trump.jpg"><h5>Here we go: Uncle Sam launches antitrust probe into *cough* Facebook, Google *cough* Amazon *splutter* Twitter...</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/boris_johnson_new_prime_minister/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/17/shutterstock_boris_johnson.jpg"><h5>It's Prime Minister Boris Johnson: Tech industry speaks its brains on Brexit-monger's victory</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/how_does_uk_gov_mess_up_it_projects/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/04/12/stumble.jpg"><h5>How does UK.gov fsck up IT projects? Let us count the ways</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/22/raspberry_pi_4_too_hot_to_handle/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/22/pi4.jpg"><h5>Too hot to handle? Raspberry Pi 4 fans left wondering if kit should come with a heatsink</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/22/who_me/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/10/game_of_thrones.jpg"><h5>When you play the game of Big Spendy Thrones, nobody wins – your crap chair just goes missing</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/20/creative_content_piracy/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/02/22/french-pirate.jpg"><h5>British ISPs throw in the towel, give up sending out toothless copyright infringement warnings</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/18/proprivacy_browser_act/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/10/16/confused.jpg"><h5>The pro-privacy Browser Act has re-appeared in US Congress. But why does everyone except right-wing trolls hate it?</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/lightsail_2_unfurls_sails/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/23/lightsail_2_pic.jpg"><h5>LightSail 2 successfully unfurls its silvery solar sails, prepares to become a truly solar-powered satellite</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/chris_kraft_mission_control_obit/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/23/chriskraft.jpg"><h5>Houston, we've had a legend: Boffin behind NASA Mission Control signs off for final time</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/milky_way_collision/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/03/11/milky_way.jpg"><h5>Revealed: Milky Way's shocking cannibalistic dark past – it gobbled a whole dwarf eons ago</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/19/apollo_11_50/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/18/apollo_11_flag.jpg"><h5>Apollo 11 @ 50: The long shadow of the flag</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/jp_morgan_ai_malware/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/02/02/bank_shutterstock.jpg"><h5>Phuck off, phishers! JPMorgan Chase crafts AI to sniff out malware menacing staff networks</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/rights_groups_attack_uk_cops_crime_victims_phones/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/23/shutterstock_iphone_unlokc.jpg"><h5>UK cops blasted over 'disproportionate' slurp of years of data from crime victims' phones</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/move_fast_and_break_everything/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/22/shutterstock_7_11.jpg"><h5>Silly money: Before you chuck your chequebook away, triple-check that super-handy digital coin</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/mcubed_conference/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/09/mcubed_logo.jpg"><h5>There are dozens of fantastic reasons why you should join us at our AI conference – and here's yet another one</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/24/its_hot/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/10/24/blacksmith.jpg"><h5>It's so hot, UK needs to start naming heatwaves like we do when it's a bit windy – climate boffins</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/23/van_with_112m_worth_of_crystal_meth_in_back_hits_cop_car_at_sydney_police_station/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/02/23/vidalfacepalm.jpg"><h5>Braking bad? Van with £112m worth of crystal meth in back hits cop car at police station</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/22/uncle_bulgaria_issues_edict_against_using_cockwomble/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/22/womblebulgaria.jpg"><h5>'Cockwomble' is off the menu: Uncle Bulgaria issues edict against using name in vain</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/07/19/france_turns_to_scifi_to_feel_out_future_threats/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/07/19/shutterstock_cyber_gothw.jpg"><h5>France seeks science-fiction writers to help futureproof its military against science-fact</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250&amp;tile=2&amp;c=2XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250&amp;tile=2&amp;c=2XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/security/" class="dcl sub_sec">
                <h4>Security</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>Low Barr: Don't give me that crap about security, just put the backdoors in the encryption, roars US Attorney General</h1>
                
                <h2>I don't want to hear about hackers and keys, nerds – make it happen, or we'll pass a law making it happen</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Iain-Thomson" title="Read more by this author" class="alt_colour dcl">Iain Thomson in San Francisco</a>
                        
                        <span class="dateline">
                            23&nbsp;Jul&nbsp;2019&nbsp;at&nbsp;21:38
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/07/23/us_encryption_backdoor/" class="reg_comments">                                    <span class="count">196</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/&title=Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General&amp;url=https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/&amp;title=Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General&amp;summary=I%20don%27t%20want%20to%20hear%20about%20hackers%20and%20keys%2C%20nerds%20%E2%80%93%20make%20it%20happen%2C%20or%20we%27ll%20pass%20a%20law%20making%20it%20happen" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2019/07/23/barr1.jpg?x=442&amp;y=293&amp;crop=1" alt="barr" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p><strong class="trailer">Analysis</strong> If the cops and Feds can't read people's encrypted messages, you will install backdoors for us, regardless of the security hit, US Attorney General William Barr has told the technology world.</p>
                <p>While speaking today in New York, Barr demanded eavesdropping mechanisms be added to consumer-level software and devices, mechanisms that can be used by investigators to forcibly decrypt and pry into strongly end-to-end encrypted chats, emails, files, and calls. No ifs, no buts.</p>
                <p>And while this will likely weaken secure data storage and communications – by introducing backdoors that hackers and spies, as well as the cops and FBI, can potentially leverage to snoop on folks – it will be a price worth paying. And, after all, what do you really need that encryption for? Your email and selfies?</p>
                <p>“We are not talking about protecting the nation’s nuclear launch codes,” Barr <a target="_blank" rel="nofollow" href="https://www.justice.gov/opa/speech/attorney-general-william-p-barr-delivers-keynote-address-international-conference-cyber">told</a> the International Conference on Cyber Security at Fordham University.</p>
                <p>“Nor are we necessarily talking about the customized encryption used by large business enterprises to protect their operations. We are talking about consumer products and services such as messaging, smart phones, email, and voice and data applications.”</p>
                <p>If you're not the military nor in big business, you'll just have to suck it up, and use that backdoored encryption system for your personal communication and commercial dealings, Barr argued. Otherwise, he claimed, criminals, who are able to chat privately outside the grasp of the law, would have a free hand at the expense of society. And again, over what? Encrypted sexts and selfies? Get real, nerds.</p>
                <p>Cryptography expert Matt Blaze <a target="_blank" rel="nofollow" href="https://twitter.com/mattblaze/status/1153708198718840832">likened</a> Barr’s line – that citizens' personal and business information isn't worth protecting with top-notch encryption – to "flat Earth bizarre" thinking. "I don’t even know where to begin," the professor added.</p>
                <p>The Attorney General also insisted that investigators accessing people's private data via backdoors – with a suitable warrant, of course – will not be in violation of the US Fourth Amendment, which protects “persons, houses, papers, and effects, against unreasonable searches and seizures.” It's one thing to respect people's privacy, but the people also expect crimes to be investigated, he said, and that's not always possible when unbreakable encryption shields evidence and suspects.</p>
                <p>“The key point is that the individual’s right to privacy and the [police's] right of access are two sides of the same coin,” Barr said.</p>
                <p>“The reason we are able, as part of our basic social compact, to guarantee individuals a certain zone of privacy is precisely because the public has reserved the right to access that zone when public safety requires. If the public’s right of access is blocked, then these zones of personal privacy are converted into 'law-free zones' insulated from legitimate scrutiny.”</p>
                <p>Barr said legislation mandating backdoors in software may be avoided, though he refused to rule it out because a terror attack or some such may conveniently swing the population toward outlawing strong cryptography. “A major incident may well occur at any time that will galvanize public opinion on these issues,” he said.</p>
                <p>It’s hardly a novel approach, piggybacking on a tragedy to push for backdoor access to private conversations, as we saw with the Obama administration’s <a target="_blank" href="https://www.theregister.co.uk/2018/03/27/fbi_encryption_showdown/">handling</a> of the San Bernardino shooting <a target="_blank" href="https://www.theregister.co.uk/2016/02/17/apple_help_fbi_san_bernardino/">aftermath</a>.</p>
                <h3 class="crosshead">
  <span>Clueless</span>
</h3>
                <p>Barr echoed the familiar refrain that criminals were using encryption to “go dark,” and frustrate officers and agents' efforts to catch them. If this were true, we’d be seeing an explosion - or at least some rise in crime - here in America. However, that’s simply not the case – quite the opposite in fact:</p>
                <blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Crime rates are dropping as law enforcement goes dark. Barr's claim that they are raising is even less true that his claim the Meuller report totally exonerates his boss. <a href="https://t.co/DFr4nFHrRy">pic.twitter.com/DFr4nFHrRy</a></p>
— Robᵇᵉᵗᵒ Graham (@ErrataRob) <a href="https://twitter.com/ErrataRob/status/1153736516449046528?ref_src=twsrc%5Etfw">July 23, 2019</a></blockquote>
                <p>Barr cited three possible methods for providing the cops and Feds with the ability to beat “warrant-proof encryption,” all of which have been mooted before, and none of which work.</p>
                <p>His first example was previously suggested by British spies at GCHQ, and it involves putting "virtual crocodile clips" on encrypted apps. Specifically, the intelligence services would be allowed to silently enter encrypted chat groups or calls as an extra participant without anyone else in the session being aware of this intrusion and subsequent eavesdropping.</p>
                <p>The <a target="_blank" href="https://www.theregister.co.uk/2018/11/29/gchq_encrypted_apps/">proposal</a> would force software developers to quietly implement such sneaky access, and Australia has <a target="_blank" href="https://www.theregister.co.uk/2018/12/07/australias_crypto_legislation/">already passed</a> a law making such backdoors mandatory. The plans have been dismissed as unworkable by experts.</p>
                <p>Jon Callas, cofounder of the PGP encryption software and the Silent Circle secure messaging and phone systems, has done an <a target="_blank" rel="nofollow" href="https://www.aclu.org/blog/ghost-user-ploy-break-encryption-wont-work">excellent in-depth analysis</a> of why such a system is impossible to set up at scale in such a way that only law enforcement could use it. It’s a basic problem with backdoors of this kind – they are easy to set up, and impossible to control so that only officers and g-men can use them.</p>
                <p>This kind of special secret access has already ended in disaster, as we saw in the case of Juniper’s firewalls. Persons unknown, presumably the NSA though the whole shambles remains highly classified, <a target="_blank" href="https://www.theregister.co.uk/2016/01/26/juniper_us_government/">silently introduced backdoors</a> into the vendor's ScreenOS firmware. Then everyone found out about the hardcoded password and weakened VPN technology in ScreenOS, and could abuse them to slip into corporate networks, or snoop on VPN traffic, via Juniper's vulnerable gateways. It’s not known how long the backdoors were in there, though what we do know is that someone found them and used them against targets to steal sensitive data.</p>
                <h3 class="crosshead">
  <span>More pie-in-the-sky</span>
</h3>
                <p>Barr's second proposal was one touted, and patented, by ex-Microsoftie Ray Ozzie – who, while a smart dude, has very little in the way of security expertise. Ozzie’s <a target="_blank" href="https://www.theregister.co.uk/2018/04/27/ray_ozzie_encryption_backdoor/">idea</a>, which is for smartphones only, would involve a return of the infamous Clipper chip that was dropped more than 15 years ago ago.</p>
                <p>Ozzie’s proposal is for a key escrow system that involves a dedicated piece of hardware holding encryption keys that would be accessible to investigators and no one else. The only problem is no one has any idea how to create such a thing at scale that will remain secret.</p>
                <p>The third suggestion was an old idea from ex-GCHQ analyst Matt Tait involving layers of encryption that would allow law enforcement access to the underlying private information. It’s a cute idea, and no one has a clue how to do it:</p>
                <blockquote class="twitter-tweet" data-conversation="none">
<p lang="en" dir="ltr">8. Barr goes on to claim that there are many proposals for encryption backdoors on the table. He gives three. They’re the same three we always get.
<br/>
<br/>
1. A (hardware, phones only) proposal by Ray Ozzie.
<br/>
2. A proposal to tap chat groups by GCHQ.
<br/>
3. An ancient article by Matt Tait.</p>
— Matthew Green (@matthew_d_green) <a href="https://twitter.com/matthew_d_green/status/1153689198928547841?ref_src=twsrc%5Etfw">July 23, 2019</a></blockquote>
                <p>Barr also said software companies use keys and certificates to sign automatic software updates, which are then pushed to users. If these keys can be kept safe, surely keys to cryptography backdoors can be stopped from falling into the wrong hands, right?</p>
                <p>"Providers design their products to allow access for software updates using centrally managed security keys,” he said. “We know of no instance where encryption has been defeated by compromise of those provider-maintained keys. Providers have been able to protect them.”</p>
                <p>Obviously Barr hasn’t been paying attention. This is exactly how the <a target="_blank" href="https://www.theregister.co.uk/2017/06/28/petya_notpetya_ransomware/">NotPetya</a> ransomware that crippled businesses worldwide spread: via poisoned software updates using fake keys. Also Stuxnet used stolen digital keys to cryptographically sign itself so that it looked like legit software. Microsoft <a target="_blank" href="https://www.theregister.co.uk/2016/08/10/microsoft_secure_boot_ms16_100/">lost control</a> of some of its secure boot system's golden keys. The list goes on.</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="https://go.theregister.co.uk/tl/1842/-7432/balancing-consumerization-and-corporate-control?td=wptl1842">Balancing consumerization and corporate control</a>
                </p>
            </div>

            <div id="page_select">
                <div id=nextpage>
                    Next page:
                    <a href="?page=2">
  The terrorists are coming!
</a>
                </div>
                <div id="page-nav">
                    Page:
                    <ul>
                        <li class="current">1</li>
                        <li>
                            <a href="?page=2">2</a>
                        </li>
                        <li>
                            <a href="?page=2">Next →</a>
                        </li>
                    </ul>
                </div>
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/07/23/us_encryption_backdoor/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments large">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/07/23/us_encryption_backdoor/">
                        <span>196</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/encryption">Encryption</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/&title=Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General&amp;url=https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/&amp;title=Low%20Barr%3A%20Don%27t%20give%20me%20that%20crap%20about%20security%2C%20just%20put%20the%20backdoors%20in%20the%20encryption%2C%20roars%20US%20Attorney%20General&amp;summary=I%20don%27t%20want%20to%20hear%20about%20hackers%20and%20keys%2C%20nerds%20%E2%80%93%20make%20it%20happen%2C%20or%20we%27ll%20pass%20a%20law%20making%20it%20happen" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/">
                            <img src="https://regmedia.co.uk/2019/07/23/barr1.jpg?x=88&amp;y=58&amp;crop=1" alt="barr" width=88 height=58>
                <h4>Low Barr: Don't give me that crap about security, just put the backdoors in the encryption, roars US Attorney General
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/07/22/bt/">
                            <img src="https://regmedia.co.uk/2015/05/21/confused.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>BT boss warns 16-min walk from current HQ to new London base 'just the tip of the iceberg'
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/07/22/raspberry_pi_4_too_hot_to_handle/">
                            <img src="https://regmedia.co.uk/2019/07/22/pi4.jpg?x=88&amp;y=58&amp;crop=1" alt="Raspberry Pi 4: power of a PC for pennies, but watch out for overheating" width=88 height=58>
                <h4>Too hot to handle? Raspberry Pi 4 fans left wondering if kit should come with a heatsink
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/07/23/apple_intel_modems/">
                            <img src="https://regmedia.co.uk/2016/03/31/tim_cook_photo_by_jstone_via_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="Tim Cook, photo by JStone via Shutterstock" width=88 height=58>
                <h4>Checkmate, Qualcomm: Apple in billion-dollar bid to gobble Intel’s 5G modem blueprints, staff – new claim
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/07/22/dram_averages_price_set_to_slide_more_than_40_per_cent_2019/">
                            <img src="https://regmedia.co.uk/2018/05/30/shuttertsock_biz_fear.jpg?x=88&amp;y=58&amp;crop=1" alt="Business man gets the fear " width=88 height=58>
                <h4>God DRAM you! Prices to slide more than 40% in 2019 because chip makers can't forecast
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/07/23/us_encryption_backdoor/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7593/storage-designs-for-big-data-and-real-time-analytics?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Storage Designs for Big Data and Real-Time Analytics</h4>
                <div class=standfirst>
                    Infrastructure designs for big data and real time analytics.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7567/defending-against-the-siege-of-ransomware?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Defending Against the Siege of Ransomware</h4>
                <div class=standfirst>
                    Ransomware is big business. But to win the war against this cyber threat, without paying a king’s ransom, you need a strong defense.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7592/oracle-database-deployment-on-nutanix-enterprise-cloud?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Oracle Database Deployment on Nutanix Enterprise Cloud</h4>
                <div class=standfirst>
                    Hesitant to move your Oracle Workloads to Nutanix? From simple architecture to data locality and database automation, you may want to reconsider!
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7480/enterprise-automation-checklist-in-a-devops-world?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="Book Icon" width=55 height=55>
                <h4>Enterprise Automation Checklist in a DevOps World</h4>
                <div class=standfirst>
                    An enterprise-wide automation strategy helps organizations improve existing processes and execute upon digital transformation.
                </div>
            </a>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/06/11/huawei_uk_parliament_backdoors/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/06/10/john_suffolk.jpg?x=198&amp;y=131&amp;crop=1" alt="John Suffolk, Huawei" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>No backdoor, no backdoor... you're a backdoor! Huawei won't spy for China or anyone else, exec tells MPs</h4>
                            <div class=standfirst>
                                'If we were put under any pressure by any country that we felt was wrong, we would prefer to close the business'
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/04/30/huawei_enterprise_router_backdoor_is_telnet/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/07/27/slapped_98673453.jpg?x=198&amp;y=131&amp;crop=1" alt="Batman. Credit: DC Comics." width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Oh dear. Secret Huawei enterprise router snoop 'backdoor' was Telnet service, sighs Vodafone</h4>
                            <div class=standfirst>
                                We all want to see hard proof of deliberate espionage. This is absolutely not it
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/08/14/oz_encryption_backdoor/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/05/15/spy_eye_648.jpg?x=198&amp;y=131&amp;crop=1" alt="spy_eye_648" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>When's a backdoor not a backdoor? When the Oz government says it isn't</h4>
                            <div class=standfirst>
                                Draconian new proposals on data privacy from Australia
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/05/02/cisco_vulnerabilities/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/05/09/shutterstock_network_panel_cables.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Sinister secret backdoor found in networking gear perfect for government espionage: The Chinese are – oh no, wait, it's Cisco again</h4>
                            <div class=standfirst>
                                Better ban this gear from non-US core networks, right?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/12/20/backdoor_wordpress_captcha/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/07/24/backdoor_648.jpg?x=198&amp;y=131&amp;crop=1" alt="backdoor_648. Pic via Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>WordPress captcha plugin on 300,000 sites had a sneaky backdoor</h4>
                            <div class=standfirst>
                                WordFence says a fix has landed
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/08/10/via_c3_x86_processor_backdoor/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/08/10/shutterstock_open_backdoor.jpg?x=198&amp;y=131&amp;crop=1" alt="A backdoor in plain sight" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>The off-brand 'military-grade' x86 processors, in the library, with the root-granting 'backdoor'</h4>
                            <div class=standfirst>
                                <span class=trailer>Black Hat</span>
                                Dive into a weird and wonderful 'feature' of Via's embedded hardware chips
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/06/12/australia_considers_copying_uk_investigatory_powers_act/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/01/27/spy_pic_aust.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Oz government says UK's backdoor will be its not-a-backdoor model</h4>
                            <div class=standfirst>
                                Investigatory Powers Act suggested as good model for local crypto workaround
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/01/08/wd_mycloud_nas_backdoor/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/10/02/epic_fail_sign_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Epic Fail" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>WD My Cloud NAS devices have <i>hard-wired</i> backdoor</h4>
                            <div class=standfirst>
                                <span class=trailer>UPDATE</span>
                                This is serious: some of the messed-up machines can host VMs and databases
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XThbr8CoyKoAACHCAg4AAACS&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>


<script>facebook_sdk();</script>    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            function login_state() {
                // Get what we can in terms of user info from the s/ml/sl cookies
                var raw_cookies = [
                    [ 's' , 'full log in'    ],
                    [ 'ml', 'newsletter link'],
                    [ 'sl', 'whitepaper link']
                ];
                var log_state = 'none';
                for (var i = 0; i < raw_cookies.length; i++) {
                    var s = $.cookie(raw_cookies[i][0]).split(':');
                    // jump to next if cookie does NOT contain the proper information
                    if ( s[0] != 1 || ( typeof(s[3]) === 'undefined' || s[3] === '0' ) ) continue;
                    // if good information, set the log_state and terminate the FOR
                    log_state = raw_cookies[i][1];
                    break;
                }
                return log_state;
            }

            // returns true if the current page is an Article and the previous
            // page is a different Article.
            function is_article2article () {
                if (typeof(RegPageType) !== 'undefined' && RegPageType === 'Story' &&
                typeof(document.referrer) !== 'undefined' &&
                document.referrer.match(/^https?:\/\/www\.theregister\.co\.uk\/[1-3][0-9]{3}\/[0-1][0-9]\/[0-3][0-9]\/[^\/]+/) &&
                document.referrer !== window.location.pathname &&
                !window.location.href.match(/\?.+/))
                    return true;
                else return false;
            }


            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof(RegTruePageType) !== 'undefined') ? RegTruePageType : '');
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('set', 'dimension8', login_state());
            if ( typeof(RegABTest) !== 'undefined' ) ga('set','exp', RegABTest);
            if ( is_article2article() ) {
                var page_has_url_params = typeof(window.location.href.split(/\/\?.*/)[1]) !== 'undefined';
                ga('send', 'pageview', window.location.href.split(/^https?:\/\/www\.theregister\.co\.uk/)[1] + ( page_has_url_params ? '&' : '?' ) + 'from_article=1' );
            }
            else ga('send', 'pageview');
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(244) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

