<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>The best and worst of GitHub: Repos wiped without notice, quickly restored – but why? • The Register</title>
    
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    
    <meta property="og:image" content="https://regmedia.co.uk/2016/09/14/github.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/" />
    <meta property="og:title" content="The best and worst of GitHub: Repos wiped without notice, quickly restored – but why?" />
    <meta property="og:description" content="That feel when the 'beating heart' of your project returns a 404" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Github">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/"},
"headline":"The best and worst of GitHub: Repos wiped without notice, quickly restored \u2013 but why?",
"datePublished":"2019-06-07T08:10:11Z",
"dateModified":"2019-06-07T16:03:53Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2016/09/14/github.jpg","width":"800","height":"642"},
"author":{"@type":"Person","name":"Tim Anderson"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegCC = [  ];
      var RegVFC = {nfa:"88a1eda567089a3420eba23d5582dcb2",nfb:"f7471c90ac809c20836ef39b2e92d5b9",vfc:"43ca677792d6d1ffa10bc1d0979d4f1b",bet:"43ca677792d6d1ffa10bc1d0979d4f1b"};
      var RegPageType = 'Story';var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/"><script>
        var RegArticle={id:203287,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['github','Github']],short_url:'http://reg.cx/2U45',cp:0,noads:[],author:'Tim Anderson',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/b815eb7f08bfcaba1b832336d34e708f06b63e50/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/966544d3ac3513711622c9bd181be978f5380a9b/javascript/_.js"></script>
    <script async src="//www.googletagservices.com/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;g=vvfc&amp;s=c/soft.front&amp;s=vk/github&amp;s=vvfc/f7471c90ac809c20836ef39b2e92d5b9&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b&amp;s=vvfc/43ca677792d6d1ffa10bc1d0979d4f1b"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


</head>
<body class="DYNX" data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-kite');
            });
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg">
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/samsung_joyent_closure/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/13/shutterstock_garbage.jpg"><h5>Samsung goes Marie Kondo on its public cloud outfit: Does this bring me Joyent? Nope. Then in the bin it goes</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/ibm_walks_away_from_870m_tsystems_mainframe_deal_amid_competition_concerns/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/11/01/shutterstock_run_to_fire_exit.jpg"><h5>IBM walks away from £870m T-Systems mainframe deal amid competition concerns</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/arista_rolls_out_first_edgy_switches_wifi_6_gear/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/07/arista_720xp.jpg"><h5>Arista whips out first crop of edgy switches, Wi-Fi 6 gear</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/cinia_and_megafon_plan_a_submarine_cable_across_the_arctic_sea/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/06/arctic_ice.jpg"><h5>Finnish and Russian comms giants shake hands on submarine cable across Arctic Sea</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/microsoft_office_offline_files_borked/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/10/24/shutterstock_man_down.jpg"><h5>Like using the latest version of Microsoft Office? Love Offline Files? Not for long!</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/09/14/github.jpg"><h5>The best and worst of GitHub: Repos wiped without notice, quickly restored – but why?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/zorin_os_15/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/06/zorin_os_15.png"><h5>Zorin OS 15 nods at Ubuntu and welcomes Windows escapees</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/github_desktop_is_20_stash_and_rebase_from_the_gui/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/06/gitstashing.jpg"><h5>Powers of stash and rebase fall into the hands of noobs with GitHub Desktop 2.0</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/microsoft_police_phishing/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/07/shutterstock_fish_chips3.jpg"><h5>Praise the lard! Police hook up with Microsoft to school us on National Phish and Chip Day</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/theres_a_reason_why_my_cat_doesnt_need_twofactor_authentication/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/11/19/cat_laptop_teaser.jpg"><h5>There's a reason why my cat doesn't need two-factor authentication</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/komodo_npm_wallets/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/09/shutterstock_vault_bank_door.jpg"><h5>Someone slipped a vuln into crypto-wallets via an NPM package. Then someone else siphoned off $13m in coins to protect it from thieves</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/congress_amca_leak_quest_labcorp/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/09/congress.jpg"><h5>You. Quest and LabCorp. Explain these medical database super-hacks, say US senators as 425,000 more people hit</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/aws_goes_live_with_windows_containers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/10/12/shutterstock_trapped_box.jpg"><h5>AWS goes live with Windows containers... but contain yourselves: It's going to be niche</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/03/cloudflare_goes_big_on_serverless_with_new_command_line_free_accounts/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/06/19/cloud_magic_castle_shutterstock.jpg"><h5>Cloudflare goes big on serverless with new command line, lures devs with free account tier</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/05/23/github_acquires_dependabot_to_automate_open_source_bug_zapping_chucks_money_at_developers/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/23/shutterstock_github.jpg"><h5>GitHub slurps open-source bug zapping automator Dependabot, chucks cash at devs</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/05/23/serverless_conference_london/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/23/serverless_london_index.jpg"><h5>Serverless Computing London: Agenda on its way, blind birds heading off</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/tech_data_archive/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/03/21/shutterstock_fortune_wheel.jpg"><h5>Who left a database of emails, credit cards, plain-text passwords, and more open to the web this week? Tech Data, come on down!</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/us_china_trade_war_making_dram_oversupply_issues_worse/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/06/dram_stick.jpg"><h5>But of course the US and China's trade war is making those godDRAM oversupply issues worse</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/nominet_uk_domain_names/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/05/reply_shutterstock.jpg"><h5>It's official! <i>The Register</i> is fake news… according to .uk overlord Nominet. Just a few problems with that claim, though</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/google_european_commission_fine/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/05/google_search.jpg"><h5>The e-mpire strikes back: Google appeals that $1.7bn EU fine for choking web ad rivals</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/ammon_municipal_broadband/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/05/15/shutterstock_interested.jpg"><h5>If your broadband bill is too high consider moving to Idaho, they get the internet for free</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/fcc_robocall_block/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/06/23/shutterstockrobocall.jpg"><h5>The FCC has finally, finally approved a half-decent plan to destroy the robocall scourge... but there's a catch</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/05/apple_stand_copyright_lockdown/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/05/stand.jpg"><h5>Apple strips clips of WWDC devs booing that $999 monitor stand from the web using copyright claims. Fear not, you can listen again here...</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/05/amazon_alexa_prewakeword_patent_application_show_plans_to_process_more_of_your_speech/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/05/alexa.jpg"><h5>Amazon Alexa: 'Pre-wakeword' patent application suggests plans to process more of your speech</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/nasa_goes_commercial/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/07/nasa_iss_image.jpg"><h5>NASA goes commercial, publishes price for trips to the ISS – and it'll be multi-millionaires only for this noAirBNB</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/bezos_project_kuiper_moon/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/20/earthrise.jpg"><h5>Box shifting on the Moon? Lunar payloads on Amazon Prime</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/water_institute_secrets_theft/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/06/shutterstock_1092309179.jpg"><h5>New twist in underworld of alleged code, data theft: Two, er, boffins accused of trying to steal, uh, a river model</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/humans_ingest_microplastics/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/05/drinking_beer.jpg"><h5>Barbie Girl was wrong? Life is plastic, it's not fantastic: We each ingest '121,000 pieces' of microplastics a year</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/facebook_ai_3d_models_princeton_lawsuit/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/10/31/shutterstock_facebook_panic.jpg"><h5>Boffins stole our 3D files – and gave them all to Facebook's AI eggheads, claims Lithuanian biz</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/databricks_mlflow_release/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/07/machine_learning.jpg"><h5>Databricks wants one tool to rule all AI systems – coincidentally, its own MLflow tool</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/rise_of_intelligent_iot/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/18/shutterstock_factory.jpg"><h5>Security and networking were industrial IoT's top challenges. Now there's a third: Practical AI</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/mcubed_blind_bird_tickets/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/18/m3_l0_logo.jpg"><h5>MCubed AI conference: Save £100s with our blind bird offer that expires on Monday</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/07/pavel_durov_gives_up_food_for_telegram/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/23/shutterstock_318151469_jesus.jpg"><h5>Russian Jesus gives up food to meditate on how he can improve crypto messenger Telegram</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/06/heathrow_promises_ct_scanners_will_smooth_security_struggles/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/01/08/heathrow_airport.jpg"><h5>Heathrow Airport drops £50m on CT scanners to help smooth passage through security checks</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/05/russian_scrap_thieves_steal_entire_bridge/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/06/05/scrapmetal.jpg"><h5>Church roofs? Nyet, say Russian scrap thieves, we're taking this bridge</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/06/03/trump_greeted_with_textbook_todger/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/16/trump_shutterstock.jpg"><h5>One man went to mow a meadow, hoping Trump would spot giant grass snake under flightpath</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            googletag.cmd.push( function() {
                googletag.display('ad-condor');
            });
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article" >

            <div class="article_head">
                <h1>The best and worst of GitHub: Repos wiped without notice, quickly restored – but why?</h1>
                
                <h2>That feel when the 'beating heart' of your project returns a 404</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Tim-Anderson" title="Read more by this author" class="alt_colour dcl">Tim Anderson</a>
                        
                        <span class="dateline">
                            7&nbsp;Jun&nbsp;2019&nbsp;at&nbsp;08:10
                        </span>
                        
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/" class="reg_comments">                                    <span class="count">63</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/&title=The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F&amp;url=https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/&amp;title=The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F&amp;summary=That%20feel%20when%20the%20%27beating%20heart%27%20of%20your%20project%20returns%20a%20404" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

            </div>
            <div id="body">
                
                <p><strong class="trailer">Updated</strong> Game designer Jason Rohrer has had a bad week, discovering that his 23 code repositories representing 15 years of development and community contributions were wiped from GitHub.</p>
                <p>"I can't believe how easy it apparently is to have someone's life work taken down from Github," he <a target="_blank" href="https://onehouronelife.com/forums/viewtopic.php?id=6834">said</a> on his forum, fortunately hosted elsewhere. "And GitHub never emailed me about this. Not a whisper. Just poof, account gone. When I logged in, I could see my account, and see that it had been 'flagged', with no other explanation given."</p>
                <p>Rohrer turned to the last and sometimes sole refuge of tech giant victims – social media. "If you're thinking about using @github for your life's work, FYI, they may remove it without any warning or notice," he protested. 373 retweets and a few hours later, and everything was restored.</p>
                <p>GitHub CEO Nat Friedman noted that support restored the account even before he noticed the incident on Twitter, and <a target="_blank" href="https://twitter.com/jasonrohrer/status/1136316601433649153">apologised personally</a> to Rohrer.</p>
                <blockquote class="twitter-tweet" data-lang="en">
<p lang="en" dir="ltr">Thank you!</p>
— Jason Rohrer (@jasonrohrer) <a href="https://twitter.com/jasonrohrer/status/1136320054486683648?ref_src=twsrc%5Etfw">June 5, 2019</a></blockquote>
                <p>The incident raises questions for developers about the safety of their GitHub code. It is not quite as bad as it sounds, since the way it works means that developers have a copy of the repository on their own machine. But it is still pretty bad. "GitHub is the beating heart of my operation. I'm running 30 linodes as game servers, download servers and other types of servers, and they all update automatically using git pull," said Rohrer.</p>
                <p>Another problem is that discussions and bug tracking on GitHub are not locally downloaded so real work can be lost in this type of incident.</p>
                <p>Why did it happen? Friedman notes that GitHub is "investigating", and the company refused to give <i>The Reg</i> any comment on the matter. Rohrer thought at first that an ill-wisher had reported his account for something like inappropriate content. Then he speculated that by posting a series of issues with links to his forum, an algorithm had identified his repo as a source of spam.</p>
                <p>Any free service on the internet (GitHub has both free and paid accounts) attracts plenty of malicious or undesirable registrations, and coping with these is a major headache. Such accounts are often created by bots and putting in place human approval systems does not scale, which means that companies rely on algorithms and AI to automate account flagging and clean-up.</p>
                <p>But you'd think that such algorithms would be able to distinguish between accounts that operate actively and without incident for many years, and those created on the fly with obvious bad intent.</p>
                <p>Account hijacking is another issue, but where this is suspected, deleting years of work without notice does not seem the right approach.</p>
                <p>Just as well we have Twitter, eh?®</p>
                <h3 class="crosshead">
  <span>Updated to add 17:03, 7 June</span>
</h3>
                <p>A GitHub spokesperson told <i>The Register</i>: "This account was mistakenly flagged by our spam algorithm, and we restored it promptly after learning of the mistake. We work hard to make GitHub a safe and inclusive place to host developer content and are constantly working on improvements to our spam filtering."</p>
                
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/">
                        <span>63</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/github">Github</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/&title=The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F&amp;url=https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/&amp;title=The%20best%20and%20worst%20of%20GitHub%3A%20Repos%20wiped%20without%20notice%2C%20quickly%20restored%20%E2%80%93%20but%20why%3F&amp;summary=That%20feel%20when%20the%20%27beating%20heart%27%20of%20your%20project%20returns%20a%20404" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            googletag.cmd.push( function() {
                                googletag.display('ad-eagle');
                            });
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/06/05/apple_stand_copyright_lockdown/">
                            <img src="https://regmedia.co.uk/2019/06/05/stand.jpg?x=88&amp;y=58&amp;crop=1" alt="stand" width=88 height=58>
                <h4>Apple strips clips of WWDC devs booing that $999 monitor stand from the web using copyright claims. Fear not, you can listen again here...
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/06/04/binary_asteroid_nasa_dart/">
                            <img src="https://regmedia.co.uk/2019/06/03/1999_kw4.jpg?x=88&amp;y=58&amp;crop=1" alt="1999_KW4" width=88 height=58>
                <h4>Bad news. Asteroid 1999 KW4 flew by, did not hit Earth killing us all. Good news: Another one, Didymos, is on the way
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/06/03/apple_wwdc_macpro_itunes/">
                            <img src="https://regmedia.co.uk/2019/06/03/apple_new_mac_pro.jpg?x=88&amp;y=58&amp;crop=1" alt="Apple's latest Mac Pro, coming fall 2019" width=88 height=58>
                <h4>Apple kills iTunes, preps pricey Mac Pro, gives iPad its own OS – plus: <i>That</i> $999 monitor stand
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/06/06/nominet_uk_domain_names/">
                            <img src="https://regmedia.co.uk/2019/06/05/reply_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="reply" width=88 height=58>
                <h4>It's official! <i>The Register</i> is fake news… according to .uk overlord Nominet. Just a few problems with that claim, though
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/06/05/apple_enterprise/">
                            <img src="https://regmedia.co.uk/2016/06/14/shutterstock_business_beach.jpg?x=88&amp;y=58&amp;crop=1" alt="Guy in shirt and tie visits the beach. wearing &quot;beach business-casual&quot;. Photo by Shutterstock" width=88 height=58>
                <h4>Still sniggering at that $999 monitor stand? Apple just got serious about the enterprise
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-falcon');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-hawk');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>
<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/06/07/github_repos_wiped_without_notice_quickly_restored_but_why/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7083/business-impact-of-rapid-application-response-time?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Business Impact of Rapid Application Response Time</h4>
                <div class=standfirst>
                    Everyone in IT storage gets excited about the prospect of flash storage.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7294/getting-smart-about-data-growth-with-intelligent-data-management?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Getting Smart about Data Growth with Intelligent Data Management</h4>
                <div class=standfirst>
                    Take a fresh look at how you manage data and find out whether cold data is eating up valuable resources.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7438/getting-your-house-in-order?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Getting Your House in Order</h4>
                <div class=standfirst>
                    1E have sponsored a large research project to determine whether the situation has improved since devastating cyber attacks swept through the world.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7260/2018-annual-threat-report?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>2018 Annual Threat Report</h4>
                <div class=standfirst>
                    eSentire Managed Detection and Response (MDR) is an all-encompassing cybersecurity service that detects and responds to cyberattacks.
                </div>
            </a>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/05/23/github_acquires_dependabot_to_automate_open_source_bug_zapping_chucks_money_at_developers/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/05/23/shutterstock_github.jpg?x=198&amp;y=131&amp;crop=1" alt="github mobile app" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>GitHub slurps open-source bug zapping automator Dependabot, chucks cash at devs</h4>
                            <div class=standfirst>
                                Matched funds for open source developers, plus new features for enterprise accounts
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/03/07/open_source_windows_calculator/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/03/07/shutterstock_calculator.jpg?x=198&amp;y=131&amp;crop=1" alt="man happy with his calculator" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft flings the Windows Calculator source at GitHub</h4>
                            <div class=standfirst>
                                Something about calc.exe bugging you? Get in there and fix it
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/05/14/too_much_open_source_at_microsoft_eclipse_director_sounds_note_of_alarm/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/05/14/github-package-registry.png?x=198&amp;y=131&amp;crop=1" alt="The GitHub Package Registry" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>How much open source is too much when it's in Microsoft's clutches? Eclipse Foundation boss sounds note of alarm</h4>
                            <div class=standfirst>
                                'Wouldn't it be ironic if all paths used by open-source developers lead to Microsoft?'
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/05/10/github_package_registry_javascript/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/05/26/github_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Github photo via Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>NPM today stands for Now Paging Microsoft: GitHub just launched its own software registry</h4>
                            <div class=standfirst>
                                GitHub Package Registry provides libraries and other bits and bytes for Java, JavaScript, Ruby, .NET and more
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/05/24/github_is_independent_despite_microsoft_acquisition_insists_ceo/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/05/23/natfriedman.jpg?x=198&amp;y=131&amp;crop=1" alt="GitHub CEO Nat Friedman" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft? Oh it's just another partnership, insists GitHub CEO</h4>
                            <div class=standfirst>
                                We're a strong, independent company
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/05/30/github_security_fixes/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/05/29/shutterstock_441757531.jpg?x=198&amp;y=131&amp;crop=1" alt="A patched piece of denim from Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Git your patches here! GitHub offers to brew automatic pull requests loaded with vuln fixes</h4>
                            <div class=standfirst>
                                Your repo's dependencies need updating to close a hole? We're way ahead of you, pal
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/02/07/microsoft_openchain/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/11/02/halo.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Born-again open-source enthusiast Microsoft rucks up at OpenChain</h4>
                            <div class=standfirst>
                                How do you solve a problem like compliance?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/04/17/red_hat_survey/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/04/26/girlredcap.jpg?x=198&amp;y=131&amp;crop=1" alt="Studio portrait of funny baby girl in red baseball cap over gray wall background" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Open-source enterprise software slinger Red Hat bravely reveals that IT bosses love open-source enterprise software</h4>
                            <div class=standfirst>
                                Hold the front page
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                googletag.cmd.push( function() {
                    googletag.display('ad-owl');
                });
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XP1HycCoyKgAAIrZYFsAAACO&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

<script>facebook_sdk();</script>    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            function login_state() {
                // Get what we can in terms of user info from the s/ml/sl cookies
                var raw_cookies = [
                    [ 's' , 'full log in'    ],
                    [ 'ml', 'newsletter link'],
                    [ 'sl', 'whitepaper link']
                ];
                var log_state = 'none';
                for (var i = 0; i < raw_cookies.length; i++) {
                    var s = $.cookie(raw_cookies[i][0]).split(':');
                    // jump to next if cookie does NOT contain the proper information
                    if ( s[0] != 1 || ( typeof(s[3]) === 'undefined' || s[3] === '0' ) ) continue;
                    // if good information, set the log_state and terminate the FOR
                    log_state = raw_cookies[i][1];
                    break;
                }
                return log_state;
            }

            // returns true if the current page is an Article and the previous
            // page is a different Article.
            function is_article2article () {
                if (typeof(RegPageType) !== 'undefined' && RegPageType === 'Story' &&
                typeof(document.referrer) !== 'undefined' &&
                document.referrer.match(/^https?:\/\/www\.theregister\.co\.uk\/[1-3][0-9]{3}\/[0-1][0-9]\/[0-3][0-9]\/[^\/]+/) &&
                document.referrer !== window.location.pathname &&
                !window.location.href.match(/\?.+/))
                    return true;
                else return false;
            }


            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof(RegTruePageType) !== 'undefined') ? RegTruePageType : '');
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('set', 'dimension8', login_state());
            if ( typeof(RegABTest) !== 'undefined' ) ga('set','exp', RegABTest);
            if ( is_article2article() ) {
                var page_has_url_params = typeof(window.location.href.split(/\/\?.*/)[1]) !== 'undefined';
                ga('send', 'pageview', window.location.href.split(/^https?:\/\/www\.theregister\.co\.uk/)[1] + ( page_has_url_params ? '&' : '?' ) + 'from_article=1' );
            }
            else ga('send', 'pageview');
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { RegUtils.set_bucket_group(940) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

