<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>WWW = Woeful, er, winternet wendering? CERN browser rebuilt after 30 years barely recognizes modern web • The Register</title>
    
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    <meta property="og:image" content="https://regmedia.co.uk/2019/02/19/shutterstock_1273499458.jpg"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/" />
    <meta property="og:title" content="WWW = Woeful, er, winternet wendering? CERN browser rebuilt after 30 years barely recognizes modern web" />
    <meta property="og:description" content="Berners-Lee's WorldWideWeb code can't handle much, but hey, it now runs in a browser" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Software, Web, Development">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/"},
"headline":"WWW = Woeful, er, winternet wendering? CERN browser rebuilt after 30 years barely recognizes modern web",
"datePublished":"2019-02-19T22:04:07Z",
"dateModified":"2019-02-19T22:16:03Z",
"image":{"@type":"ImageObject","url":"https://regmedia.co.uk/2019/02/19/shutterstock_1273499458.jpg","width":"648","height":"448"},
"author":{"@type":"Person","name":"Thomas Claburn"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegZoot = {  };
      var RegPageType = 'Story';var RegTruePageType = 'www story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2019/02/19/cern_browser_reawakened/"><script>
        var RegArticle={id:201573,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['software','Software'],['web','Web'],['development','Development']],short_url:'http://reg.cx/2RHP',cp:0,noads:[],author:'Thomas Claburn',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/798a1a001dc24772fa169e4df72a2c298967933b/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/798a1a001dc24772fa169e4df72a2c298967933b/javascript/_.js"></script>
    <script async src="//www.googletagservices.com/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;s=c/soft.front&amp;s=vk/software&amp;s=vk/web&amp;s=vk/development"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel="apple-touch-icon" sizes="180x180" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="16x16" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-16x16.png">
<link rel="icon" type="image/png" sizes="32x32" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon-32x32.png">
<link rel="manifest" href="/design_picker/6e3385376d6492f20e9eb3afd7c84900985f2128/graphics/favicons/site.webmanifest">
<link rel="mask-icon" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/safari-pinned-tab.svg" color="#ff0000">
<link rel="SHORTCUT ICON" href="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#ff0000">
<meta name="msapplication-config" content="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/favicons/browserconfig.xml">
<meta name="theme-color" content="#ff0000">


</head>
<body class="DYNX" data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            show_gpt('ad-kite');
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
            </a>
            <a href="https://google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                <img width="18" height="18" alt="G+" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/google_plus.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg" class=black_vulture>
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_white.svg" class=white_vulture>
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">Software</a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">Security</a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">Business</a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">Science</a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers><a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">Servers</a></li>
                    <li id=sub-sec-hpc><a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">HPC</a></li>
                    <li id=sub-sec-cloud><a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">Cloud</a></li>
                    <li id=sub-sec-storage><a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">Storage</a></li>
                    <li id=sub-sec-networks><a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">Networks</a></li>
                    <li id=sub-sec-virtualization><a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">Virtualization</a></li>
                    <li id=sub-sec-bofh><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/google_buys_alooma/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/11/14/shutterstock_data_vacuum.jpg"><h5>All your ETL pipeline are belong to us: Google snaps up Alooma</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/uk_ministry_of_defence_payroll_contract_dxc/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/11/17/army_shutterstock.jpg"><h5>Ministry of Defence's new payroll contract is, surprise, surprise, MIA: Missing In Action</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/jedi_contract_on_hold/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/29/blakes_seven_logo.jpg"><h5>Cut open a tauntaun, this JEDI is frozen! US court halts lawsuit over biggest military cloud deal since the Death Star</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/oracle_sales_rep_allegations/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/20/shutterstock_1020439987.jpg"><h5>New claim dogs Oracle: After $11m of sales, I was unfairly axed before next big deal – because I am a 64yo woman</h5></a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/germany_us_to_be_hit_hardest_in_sap_restructuring_reports_that_machine_learning_analytics_excluded/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/23/box_pack_redundant.jpg"><h5>Germany, US staffers to be hit hardest as SAP starts shedding 4,400 bodies</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/shutterstock_1273499458.jpg"><h5>WWW = Woeful, er, winternet wendering? CERN browser rebuilt after 30 years barely recognizes modern web</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/cast_software_heritage/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/evolution.jpg"><h5>CAST links arms with Software Heritage to tease out your open-source ancestry</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/splunk_quits_russia/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/12/07/moscow_8973456986345.jpg"><h5>Splunk does a bunk from Russia: No software and services for you, Putin!</h5></a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/password_managers_security_bugs/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/12/18/shutterstock_key.jpg"><h5>Password managers may leave your online crown jewels 'exposed in RAM' to malware – but hey, they're still better than the alternative</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/iab_rtb_complain_fresh_evidence/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/20/gdpr.jpg"><h5>Unearthed emails could be smoking gun in epic GDPR battle against Google, adtech giants</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/lauri_love_computer_appeal_rejected/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/lauri_love_westminster_magistrates_court.jpg"><h5>Accused hacker Lauri Love loses legal bid to reclaim seized IT gear</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/extent_of_security_fears_about_security_biz_kaspersky_lab_revealed/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/11/kaspersky_shutterstock.jpg"><h5>Revealed: Numbers show extent of security fears about security biz Kaspersky Lab</h5></a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/github_code_hack_cash_tip_jacked_up/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/04/12/money_explosion_photo_via_shutterstock.jpg"><h5>Git money, git paid: GitHub waves larger wads of dollar bills to tempt bug hunters</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/nuweba/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/12/patching_983343554654645456.jpg"><h5>Uptown func: Serverless types Nuweba trouser $4.8m as investors eye faster FaaS</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/14/want_to_learn_how_to_accelerate_your_software_ops_and_save_big/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/07/18/cll19_logo_circles-large.jpg"><h5>Want to learn how to accelerate your software ops AND save big?</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/06/software_delivery_ops_new_speaker_continuous_lifecycle/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/14/continuous_lifecycle_london_logo.png"><h5>Squarespace's Tanya Reilly to deliver keynote at Continuous Lifecycle London</h5></a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy><a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">Policy</a></li>
                    <li id=sub-sec-channel><a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">The Channel</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/apples_reseller_pulls_down_the_shutters_calls_in_the_administrators/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/01/closed_shutterstock.jpg"><h5>Apple reseller Solutions Inc pulls down shutters, calls in administrators</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/nhsx_digital_data_tech_health_service/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/11/28/shutterstock_hancock.jpg"><h5>What has an 'open-door policy' with industry and puts the X into NHS? Brits, let app-happy Matt Hancock tell you</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/autonomy_trial_christopher_egan_testimony_headscratcher/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/09/shutterstock_nope.jpg"><h5>Autonomy trial: Key HPE witness might not testify, UK High Court told</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/dwp_health_data_tool/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/01/05/hospital.jpg"><h5>Guess who's working on a health data-slurping digital tool? Bzzt! Nope, it's the UK Department for Work and Pensions</h5></a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/sms_lives_omg/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/20/shutterstock_730360414.jpg"><h5>U wot, m8? OMG SMS is back from dead</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/agm_x3_the_new_rugged_champ/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/agm_x3_teaser_shot.jpg"><h5>AGM X3: Swoon at this rugged interloper mobe then throw it on the floor to impress your mates</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/apple_mac_audio/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/07/shutterstock_music_computer.jpg"><h5>Turn on, tune in, drop out: Apple's whizz-bang T2 security chips hit a bum note for Mac audio</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/lg_snubs_foldable_fone/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/bentphone.jpg"><h5>LG folds at prospect of launching bendy phone while Samsung flaunts its upcoming kit on telly</h5></a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek><a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">Geek's Guide</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/uk_navigation_overlay_service/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/20/brexit_space_sat.jpg"><h5>How do you solve a problem like Galileo? With a strap-on L-band payload, of course!</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/oldest_white_dwarf/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/20/oldest_white_dwarf_star.jpg"><h5>Oldest white dwarf star catches amateur's eye – and its dusty ring leaves boffins baffled</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/20/grand_canyon_uranium/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/grand_canyon.jpg"><h5>Visited the Grand Canyon since 2000? You'll have great photos – and maybe a teensy bit of unwanted radiation</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/18/harpooning_satellites/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/18/shutterstock_uk_from_space.jpg"><h5>Surrey Uni mans the space harpoons, and NASA buys more seats on Russian rockets</h5></a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence><a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">Artificial Intelligence</a></li>
                    <li id=sub-sec-internet-of-things><a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">Internet of Things</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/18/ai_roundup_150219/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/16/robot_pal.jpg"><h5>Want to create fake web profile pics? This creepy AI tool makes them on demand. Plus predictive policing, and more</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/15/texas_3d_gun/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/20/laptop-gun.jpg"><h5>Bloke thrown in the cooler for eight years after 3D-printing gun to dodge weapon ban</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/15/blockchain_week_2019/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/03/21/wrong_sign_shutterstock.jpg"><h5>Blockchain is bullsh!t, prove me wrong meets 'chain gang fans at tech confab</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/14/microsoft_meets_pope/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/25/pope_francis.jpg"><h5>Boss of venerable sect with millions of devoted followers meets boss of venerable sect with... yeah, you get the idea</h5></a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob><a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">Verity Stob</a></li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/19/occult_text_from_buffy_the_vampire_slayer_ep_actually_just_story_about_new_bus_lane_in_dublin/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/19/shutterstock_buffy.jpg"><h5>'Occult' text from <i>Buffy The Vampire Slayer</i> ep actually just story about new bus lane in Dublin</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/18/sap_naming_munich_stadium/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/18/shutterstock_munich_olympic_stadium.jpg"><h5>You know the drill: SAP has asked Joe Public to name Munich arena so go forth and be very silly</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/18/sundials_dying_out_and_millennials_are_to_blame/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/18/sundial.jpg"><h5>Twilight of the sundials: Archaic timepiece dying out and millennials are to blame, reckons boffin</h5></a>
                    <a class="story_link" href="https://www.theregister.co.uk/2019/02/15/newhaven_campaign_for_easy_e_statue/"><img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2019/02/15/eazy_e.jpg"><h5>Sussex rap fan wants statue of Easy-E from NWA in his hometown because he's a 'legend'</h5></a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
<a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">Data Centre</a>
<a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">Software</a>
<a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">Security</a>
<a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">DevOps</a>
<a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">Business</a>
<a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">Personal Tech</a>
<a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">Science</a>
<a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">Emergent Tech</a>
<a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">Bootnotes</a>
<div id="m-sub-sec-bofh"><a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a></div>
<a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">Lectures</a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            show_gpt('ad-condor');
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article"  data-cat='news'>

            <div class="article_head">
                <h1>WWW = Woeful, er, winternet wendering? CERN browser rebuilt after 30 years barely recognizes modern web</h1>
                
                <h2>Berners-Lee's WorldWideWeb code can't handle much, but hey, it now runs in a browser</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Thomas-Claburn" title="Read more by this author" class="alt_colour dcl">Thomas Claburn in San Francisco</a>
                        
                        <span class="dateline">
                            19&nbsp;Feb&nbsp;2019&nbsp;at&nbsp;22:04
                        </span>
                        
                        
                        <script>tweet_btn()</script>
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/all/2019/02/19/cern_browser_reawakened/" class="reg_comments">                                    <span class="count">41</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns top_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/&title=WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web&amp;url=https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/&amp;title=WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web&amp;summary=Berners-Lee%27s%20WorldWideWeb%20code%20can%27t%20handle%20much%2C%20but%20hey%2C%20it%20now%20runs%20in%20a%20browser" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

            </div>
            <div id="body">
                
                <p>In preparation for next month's 30th anniversary of the <a target="_blank" rel="nofollow" href="https://www.w3.org/History/1989/proposal.html">proposal</a> that gave us the world wide web, boffins at the behest of CERN have recreated the world's first web browser, and made it accessible as a modern web page.</p>
                <p>Created by Sir Tim Berners-Lee, the ur-browser, first called WorldWideWeb, and later Nexus, was built from Objective-C in 1990 on a NeXT workstation to display its maker's HyperText Markup Language.</p>
                <p>The browser's resurrection – <a target="_blank" rel="nofollow" href="https://worldwideweb.cern.ch/browser/">click here to try it out</a> – follows five days of hacking by an <a target="_blank" rel="nofollow" href="https://worldwideweb.cern.ch/colophon/">international team of nine developers</a>, reunited after a previous effort to revive the original <a target="_blank" rel="nofollow" href="http://line-mode.cern.ch/">Line Mode Browser</a> in 2013.</p>
                <div class="CaptionedImage width_85"><a href="https://regmedia.co.uk/2019/02/19/screenshot_www_browser.png" target="_blank"><img src="https://regmedia.co.uk/2019/02/19/screenshot_www_browser.png?x=648&amp;y=555&amp;infer_y=1" alt="Screenshot of TBL's WWW browser accessing The Reg in 2019" title="Screenshot of TBL's WWW browser accessing The Reg in 2019" height="555" width="648"/></a>
<p class="text_center">Web noir ... Screenshot of the browser trying to render <i>El Reg</i>
<br/>
(Click to enlarge)</p>
</div>
                <p>The server side part of the simulation comes from the Line Mode Browser source; binaries of various versions of <a target="_blank" rel="nofollow" href="https://www.w3.org/History/1991-WWW-NeXT/Implementation/">WorldWideWeb/Nexus</a> were also consulted. The project, unveiled this month, was built with JavaScript and the React framework.</p>
                <p>The browser's monochrome window into the past includes a basic menu interface that features both functional and non-functional elements. It does allow you to open web pages, via the <i>Document -&gt; Open from full document reference</i> menu, though they're all text. It serves as a reminder of how much the web has changed, for good or ill.</p>
                <p>There are no images, videos, ads or ad tracking code. JavaScript, which wouldn't be invented until 1995, and Cascading Style Sheets (CSS), which wouldn't debut until 1996, have been employed to recreate the retro look and feel. Much attention went to the <a target="_blank" rel="nofollow" href="https://worldwideweb.cern.ch/typography/">blocky aliased fonts</a>. The color palette includes a four-option spectrum: black, white, and two shades of gray.</p>
                <p>WorldWideWeb recognizes just <a target="_blank" rel="nofollow" href="https://worldwideweb.cern.ch/code/">26 HTML tags</a> – the term "element" was not a part of web development jargon.</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2010/12/16/tim_berners_lee.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Tim Berners-Lee, photo by Paul Clarke"/>
<h2 title="Downhill from there">25 years ago: Sir Tim Berners-Lee builds world's first website</h2>
<a href="https://www.theregister.co.uk/2015/12/22/25_years_ago_worlds_first_website/"><span>READ MORE</span></a></div>
                <p>One aspect of the original browser that got lost over time was that it was intended to be both a document viewer and editor.</p>
                <p>"Today it's hard to imagine that web browsers might also be used to create web pages," the project's documentation explains. "It turned out that people were quite happy to write HTML by hand – something that Tim Berners-Lee and colleagues never expected. They thought that some kind of user interface would be needed for making web pages and links."</p>
                <p>Modern browsers like Chrome retain the ability to edit loaded pages via the Inspect menu, but generally their tools for content display and editing have been separated.</p>
                <p>Nowadays, web code tends to be difficult to read. It's often minified – compressed into a compact form to save space – or obfuscated – deliberately made obscure. Facebook web pages, for example, rely on <a target="_blank" rel="nofollow" href="https://twitter.com/themikepan/status/1093035372186034176">impenetrable class names</a> and words fragmented into multiple div elements to foil ad blockers.</p>
                <p>Thirty years on, the first web browser recalls a time before commerce came online. ®</p>
                
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2019/02/19/cern_browser_reawakened/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/all/2019/02/19/cern_browser_reawakened/">
                        <span>41</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/software">Software</a>
                </li>
                <li>
                    <a href="/Tag/web">Web</a>
                </li>
                <li>
                    <a href="/Tag/development">Development</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/&title=WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web&amp;url=https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/&amp;title=WWW%20%3D%20Woeful%2C%20er%2C%20winternet%20wendering%3F%20CERN%20browser%20rebuilt%20after%2030%20years%20barely%20recognizes%20modern%20web&amp;summary=Berners-Lee%27s%20WorldWideWeb%20code%20can%27t%20handle%20much%2C%20but%20hey%2C%20it%20now%20runs%20in%20a%20browser" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            show_gpt('ad-eagle');
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2019/02/18/teams_down/">
                            <img src="https://regmedia.co.uk/2019/02/18/shutterstock_fall_backwards_stairs.jpg?x=88&amp;y=58&amp;crop=1" alt="man falls backwards down stairs " width=88 height=58>
                <h4>Down productivity tools: Microsoft Teams takes a Monday tumble
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/02/18/microsoft_roundup/">
                            <img src="https://regmedia.co.uk/2019/02/18/shutterstock_penguin_hug.jpg?x=88&amp;y=58&amp;crop=1" alt="two penguins walk along surf, &quot;chatting&quot;. One embraces the other by slinging a wing over its pal's shoulder" width=88 height=58>
                <h4>Windows Subsystem for Linux adds pop to release, SAC-T sacked, crypto-jacking apps: It's Microsoft's week
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/02/19/lauri_love_computer_appeal_rejected/">
                            <img src="https://regmedia.co.uk/2019/02/19/lauri_love_westminster_magistrates_court.jpg?x=88&amp;y=58&amp;crop=1" alt="Lauri Love outside Westminster Magistrates' Court today. Leaving is building is barrister Andrew Bird for the NCA" width=88 height=58>
                <h4>Accused hacker Lauri Love loses legal bid to reclaim seized IT gear
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/02/19/occult_text_from_buffy_the_vampire_slayer_ep_actually_just_story_about_new_bus_lane_in_dublin/">
                            <img src="https://regmedia.co.uk/2019/02/19/shutterstock_buffy.jpg?x=88&amp;y=58&amp;crop=1" alt="sarah michelle gellar who plays buffy in the series" width=88 height=58>
                <h4>'Occult' text from <i>Buffy The Vampire Slayer</i> ep actually just story about new bus lane in Dublin
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2019/02/18/oracle_ironic_anti_arbitration/">
                            <img src="https://regmedia.co.uk/2015/08/18/shutterstock_irony_w648.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Court sees Morissette Meter flip out as Oracle assumes anti-arbitration stance in pay dispute
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                show_gpt('ad-falcon');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>show_gpt('ad-hawk');</script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>
<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2019/02/19/cern_browser_reawakened/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6429/remedying-the-email-security-gaps-in-microsoft-office-365?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Remedying the Email Security Gaps in Microsoft Office 365</h4>
                <div class=standfirst>
                    If you have made the move to Microsoft Office 365™ or imminently plan to, you are in good company.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7085/flash-storage-growth-acceptance-and-the-rise-of-nvme?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Flash Storage: Growth, Acceptance, and the Rise of NVMe</h4>
                <div class=standfirst>
                    At a high level, solid-state storage continues to experience high levels of adoption while delivering a myriad of technical, operational, and financial benefits.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7142/becoming-a-pragmatic-security-leader?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Becoming a Pragmatic Security Leader</h4>
                <div class=standfirst>
                    With companies of all sizes looking to get on top of their cybersecurity challenges, what does it take to get into a security leadership position?
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/7067/data-pipeline-for-enterprise-ai?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Data Pipeline for Enterprise AI</h4>
                <div class=standfirst>
                    Throughput bottlenecks, architecture and integration issues, from resiliency, security and governance are just a few of the pesky challenges that get in the way of ensuring that AI’s data needs are met.
                </div>
            </a>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2019/02/19/cast_software_heritage/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/02/19/evolution.jpg?x=198&amp;y=131&amp;crop=1" alt="Theory of evolution of man into programmer" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>CAST links arms with Software Heritage to tease out your open-source ancestry</h4>
                            <div class=standfirst>
                                Who do you think you are?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/12/17/the_truth_about_software_reliability/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/10/03/frustrated_woman_worker.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>We asked, you answered: The truth about software reliability</h4>
                            <div class=standfirst>
                                <span class=trailer>Research results</span>
                                It's not just about quality
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/11/22/cisco_buys_ensoft/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/08/31/acquire_buy_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Cisco snaps up Brit networking software bods Ensoft</h4>
                            <div class=standfirst>
                                From main customer to owner
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/11/05/veracode_software_thoma_bravo/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/08/31/acquire_buy_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Veracode Software gobbled by private equity house Thoma Bravo for $950m</h4>
                            <div class=standfirst>
                                Home of McAfee and SonicWall slurps app security testing biz from Broadcom
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/01/04/acronis_sddc/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2019/01/04/shutterstock_overslept_work2.jpg?x=198&amp;y=131&amp;crop=1" alt="Business person tired at work " width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>VMware bods – you back at work yet? Guess who's just poked their head into the software-defined data centre...</h4>
                            <div class=standfirst>
                                Data protector Acronis luring customers with virty storage Swiss roll
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2019/02/14/want_to_learn_how_to_accelerate_your_software_ops_and_save_big/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/07/18/cll19_logo_circles-large.jpg?x=198&amp;y=131&amp;crop=1" alt="CLL19 Logo" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Want to learn how to accelerate your software ops AND save big?</h4>
                            <div class=standfirst>
                                CLL 19 early bird tickets disappear in two weeks
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/04/26/red_hat_supermicro_storage_one/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/04/26/girlredcap.jpg?x=198&amp;y=131&amp;crop=1" alt="Studio portrait of funny baby girl in red baseball cap over gray wall background" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Red Hat sticks its storage software cap on Supermicro hardware</h4>
                            <div class=standfirst>
                                Software-defined storage meets single SKU-ery
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/12/07/hcl_18bn_ibm_software/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/12/07/shutterstock_supermarket_shop.jpg?x=198&amp;y=131&amp;crop=1" alt="man loads oversized basket with groceries" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>HCL picks up Notes, spanks total of $1.8bn at Honest John's IBM software sale</h4>
                            <div class=standfirst>
                                Don't worry, Red Hat. We're sure Big Blue will love you more than it did Lotus
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                show_gpt('ad-owl');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55XG1SCsCoyKgAAB7MzEkAAACD&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

<script>facebook_sdk();</script>    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" height="11" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img width="1" height="1" src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2019</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            function login_state() {
                // Get what we can in terms of user info from the s/ml/sl cookies
                var raw_cookies = [
                    [ 's' , 'full log in'    ],
                    [ 'ml', 'newsletter link'],
                    [ 'sl', 'whitepaper link']
                ];
                var log_state = 'none';
                for (var i = 0; i < raw_cookies.length; i++) {
                    var s = $.cookie(raw_cookies[i][0]).split(':');
                    // jump to next if cookie does NOT contain the proper information
                    if ( s[0] != 1 || ( typeof(s[3]) === 'undefined' || s[3] === '0' ) ) continue;
                    // if good information, set the log_state and terminate the FOR
                    log_state = raw_cookies[i][1];
                    break;
                }
                return log_state;
            }

            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof(RegTruePageType) !== 'undefined') ? RegTruePageType : '');
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('set', 'dimension8', login_state());
            ga('send', 'pageview');
        </script>

<script>!function(a,e,d,m,t){a.adm={};a.adm.pixid=137060;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="https://ps.l.admedo.com/e7b7041f-8d65-4024-9168-fd38b9a62669.json",a.adm.pixurl="https://pool.admedo.com",c.src="https://pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" alt="" src="https://pool.admedo.com/pixel?id=137060&t=img"></noscript>


        <script>
            $(function() { set_bucket_group(254) });
        </script>
        <div id="fb-root"></div>
    </div></div>
</body>
</html>

