<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Gitpod git-bolts git-IDE onto GitHub for in-browser code git-editing • The Register</title>
    
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    <meta property="og:image" content="https://regmedia.co.uk/2018/09/04/shutterstock_390754486.jpg?x=1200&y=794"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/" />
    <meta property="og:title" content="Gitpod git-bolts git-IDE onto GitHub for in-browser code git-editing" />
    <meta property="og:description" content="Devs can deal with pull requests from Chrome" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Software, Development, Github">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/"},
"headline":"Gitpod git-bolts git-IDE onto GitHub for in-browser code git-editing",
"datePublished":"2018-09-04T20:37:20Z",
"dateModified":"2018-09-05T07:40:29Z",
"image":{"@type":  "ImageObject","url":"https://regmedia.co.uk/2018/09/04/shutterstock_390754486.jpg?x=1200&amp;y=794","width":1200,"height":794},
"author":{"@type":"Person","name":"Thomas Claburn"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegPageType = 'Story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2018/09/04/gitpod_github_ide/">
    <script>
        var RegArticle={id:198769,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['software','Software'],['development','Development'],['github','Github'],['gitpod','Gitpod']],short_url:'http://reg.cx/2Mzd',cp:0,noads:[],author:'Thomas Claburn',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/71c541df3d8850aedfd5485dd2df35f7e39aa370/design.css">

    <style>
        #sec-software, #m-sec-software,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/71c541df3d8850aedfd5485dd2df35f7e39aa370/javascript/_.js"></script>
    <script async src="//www.googletagservices.com/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=vk&amp;g=c&amp;g=sa&amp;s=c/soft.front&amp;s=vk/software&amp;s=vk/development&amp;s=vk/github&amp;s=vk/gitpod"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_software/front');
        });
    </script>

    <link rel="SHORTCUT ICON" type="image/x-icon" href="/favicon.ico">
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel=apple-touch-icon href="/Design/graphics/icons/vulture_black_60_trans.png">

</head>
<body class="DYNX" data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            show_gpt('ad-kite');
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
            </a>
            <a href="https://google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                <img width="18" height="18" alt="G+" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/google_plus.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture.svg" class=black_vulture>
                <img width="21" height="17" alt="Home" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/vulture_white.svg" class=white_vulture>
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">
                Data Centre
            </a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">
                Lectures
            </a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers>
                        <a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">
                            Servers
                        </a>
                    </li>
                    <li id=sub-sec-hpc>
                        <a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">
                            HPC
                        </a>
                    </li>
                    <li id=sub-sec-cloud>
                        <a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">
                            Cloud
                        </a>
                    </li>
                    <li id=sub-sec-storage>
                        <a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">
                            Storage
                        </a>
                    </li>
                    <li id=sub-sec-networks>
                        <a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">
                            Networks
                        </a>
                    </li>
                    <li id=sub-sec-virtualization>
                        <a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">
                            Virtualization
                        </a>
                    </li>
                    <li id=sub-sec-bofh>
                        <a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">
                            BOFH
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/pentagon_pushes_back_jedi_deadline/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Pentagon - building - houses the US dept of defense in Arlington Virginia" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/04/17/shutterstock_pentagons.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cloud-slingers get 3-week extension to pitch for Pentagon's JEDI contract</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/juniper_ericsson_sign_5g_product_pact/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="handshake" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/07/handshake.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Juniper, Ericsson sign 5G product pact</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/oz_carrier_vocus_rushes_cable_into_service_following_smw3_break/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Cable ship Ile de Re" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/08/iledereinsydneyharbour.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Oz carrier Vocus rushes cable into service following SMW-3 break</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/webinar_build_apps_microsoft_azure/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Microsoft Azure" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/29/microsoft_azure_2_shutterstock_editorial_use_only.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Webinar series: Learn to build better apps with Microsoft's Azure cloud</h5>
                    </a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/outlook_updates_microsoft_ribbon/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="scissors" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/05/18/shutterstock_scissors.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microsoft sharpens its claws to cut Outlook UI excess, snip Ribbon</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Illustration of developer writing code at desk with three monitors" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/04/shutterstock_390754486.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Gitpod git-bolts git-IDE onto GitHub for in-browser code git-editing</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/microsoft_takes_a_pruning_axe_to_skypes_forest_of_features/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Skype's redesignd mobile UI" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/04/skype_mobile_ui.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microsoft takes a pruning axe to Skype's forest of features</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/03/microsoft_round_up_sept_3/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Usborne intro to programming" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/02/09/introtoprogrammingtitle.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microsoft gives Windows 10 a name, throws folks a bone</h5>
                    </a>
                </div>
            </div>
            <div class=sec_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-insider-threat>
                        <a href="/security/insider_threat/" data-name="Insider Threat" title="Insider Threat">
                            Insider Threat
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/silence_cybercrooks/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Pinky and the Brain" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/08/19/pinky_brain.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Silence! Cybercrime's Pinky and the Brain have nicked $800k off banks</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/george_duke_cohan_guilty_pleas_hoax_bomb_threats/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="George Duke-Cohan. Pic: National Crime Agency" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/04/george_duke_cohan_national_crime_agency.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Brit teen pleads guilty to Minecraft-linked bomb and airline hoaxes</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/email_scams_sitrep/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="phishing" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/11/11/phishing.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cybercrooks home in on infosec's weakest link – you poor gullible people</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/sec_social_media/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="A businessman in handcuffs" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/07/22/whitecollarcrime.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Uncle Sam wants tech toolkit to snoop social media stock scammers</h5>
                    </a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/atlassian_buys_opsgenie/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/31/acquire_buy_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>DevOps darling Atlassian gets into the monitoring business with OpsGenie gobble</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/think_you_can_save_money_by_going_serverless/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Money cloud" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/cloud_money_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Conference alert: Think you can save money by going Serverless?</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/03/webinar_build_better_apps_and_release_them_faster_with_microsoft_app_center/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/04/15/enterprise-mobility-webinar.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Webinar: build better apps and release them faster with Microsoft App Center</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/31/we_can_show_you_where_serverless_worksand_where_it_doesnt/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Serverless Computing London Logo" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/20/serverless_london_logo.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>We can show you where serverless works ... and where it doesn’t</h5>
                    </a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy>
                        <a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">
                            Policy
                        </a>
                    </li>
                    <li id=sub-sec-channel>
                        <a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">
                            The Channel
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/google_ad_sting/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/08/04/shutterstock_oracle.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Google skewered in ad sting after Oracle-backed bods turn troll</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/hundred_meellion_kiwi_oracle_project_on_hold_after_deloitte_review/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Down the drain - Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/04/16/drain_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Hundred million Kiwi Oracle project on hold after Deloitte review</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/wayback_machine_legit/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="evidence" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/04/evidence_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Archive.org's Wayback Machine is legit legal evidence, US appeals court judges rule</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/google_at_20/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Woman looks bored wearing birthday hat. Photo by Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/30/shutterstock_boredom_birthday.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Google is 20, Chrome is 10, and Microsoft would rather ignore the Nokia deal's 5th birthday</h5>
                    </a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/enterprise_smartphone_buyers_still_pretty_dopey_about_updates/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="A bulldozer in a dump" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/12/01/bulldozerdump.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Enterprise smartphone buyers still pretty dopey about updates</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/apple_admits_to_iphone_8_mobo_problem/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="J. Lekavicius http://www.shutterstock.com/gallery-511162p1.html" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/12/patching_983343554654645456.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Apple cops to iPhone 8 production oops, offers to fix borked phones</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/tardy_qualcomm_leaves_the_great_wearables_reveal_to_jokers_and_clowns/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Sony FES Watch" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/03/fes2_w1296px.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Qualcomm's tardy chip upgrade leaves the Great Wearables Reveal to jokers and clowns</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/huawei_mate_20_lite/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Huawei Mate 20 Lite" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/03/huawei_mate20lite_group_shot1.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Huawei Mate 20 Lite: A business mobe aimed at millennials? Er, OK then</h5>
                    </a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek>
                        <a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">
                            Geek's Guide
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/drill_caused_soyuz_hole/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Installing a deadbolt drillbit in the door frame" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/11/13/shutterstock_deadbolt_door_install.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Roskosmos admits that Soyuz 'meteorite' hole had more earthly origins</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/31/black_holes_white_dwarf_stars/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="When white dwarf stars collide" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/09/stars_collide.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Black holes can briefly bring dead white dwarf stars back to life</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/31/fruit_flies_sun/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Fruit fly in nature - drosophila melanogaster" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/05/shutterstock_drosophila_melanogaster.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Fruit flies use the power of the sun to help them fly in straight lines</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/30/iss_springs_a_leak/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="NASA" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/30/nasa_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Space station springs a leak while astronauts are asleep (but don't panic)</h5>
                    </a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence>
                        <a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">
                            Artificial Intelligence
                        </a>
                    </li>
                    <li id=sub-sec-internet-of-things>
                        <a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">
                            Internet of Things
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/consumer_ai_ifa_2018_roundup/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/02/23/clippy.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>I've seen the future of consumer AI, and it doesn't have one</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/ai_heart_attack/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/19/heartattackman.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Heart-stopping predictions from AI doctors could save lives</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/04/autonomous_drones_filming/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="hollywood" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/04/hollywood.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Lights, camera, AI-ction! Robo-drones turned into spies, er, filmmakers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/01/ai_roundup_310818/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="sashimi" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/01/sashimi.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Google goes bilingual, Facebook fleshes out translation and TensorFlow is dope</h5>
                    </a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob>
                        <a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">
                            Verity Stob
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/09/05/midlands_councillor_and_software_dev_sets_up_rubbish_chatbot/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="fly tipping a**holes leave washing machine in a forest.  " width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/09/05/shutterstock_fly_tipping.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Software dev-turned-councillor launches rubbish* chatbot</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/30/cisco_ceo_chuck_sells_mansion/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Cisco Live keynote 2018 Chuck Robbins screengrab" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/12/chuck_robbins_live_2018.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>You can buy Cisco CEO Chuck Robbins' mansion for a cool $13m</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/28/nameless_man_google_high_court_lumen_database/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="London's Royal Courts of Justice" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/17/royal_courts_justice_overcast.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Don't let Google dox me on Lumen Database, nameless man begs</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/27/who-me/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Swearing and ranting" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/31/swearing_megaphone_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Experimental 'insult bot' gets out of hand during unsupervised weekend</h5>
                    </a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <div id=mobile_menu_toggle>
            <span></span>
            <span></span>
            <span></span>
        </div>
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>

            <a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">
                Data Centre
            </a>
            <a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>
            <div id="m-sub-sec-bofh">
                <a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a>
            </div>
            <a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">
                Lectures
            </a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            show_gpt('ad-condor');
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=2&amp;c=2W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>
        <div id="article"  data-cat='news'>

            <div class="article_head">
                <h1>Gitpod git-bolts git-IDE onto GitHub for in-browser code git-editing</h1>
                
                <h2>Devs can deal with pull requests from Chrome</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Thomas-Claburn" title="Read more by this author" class="alt_colour dcl">Thomas Claburn in San Francisco</a>
                        
                        <span class="dateline">
                            4&nbsp;Sep&nbsp;2018&nbsp;at&nbsp;20:37
                        </span>
                        
                        
                        <script>tweet_btn()</script>
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/1/2018/09/04/gitpod_github_ide/" class="reg_comments">                                    <span class="count">2</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/&title=Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing&amp;url=https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/&amp;title=Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing&amp;summary=Devs%20can%20deal%20with%20pull%20requests%20from%20Chrome" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2018/09/04/shutterstock_390754486.jpg?x=442&amp;y=293&amp;crop=1" alt="Illustration of developer writing code at desk with three monitors" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>Developers who use GitHub – 28 million at last count – now have the option to edit code with the click of a button using Gitpod, an integrated development environment (IDE) that can be launched directly from the social code hosting site.</p>
                <p>Based on <a target="_blank" rel="nofollow" href="https://www.theia-ide.org/">Theia</a>, an open source cloud-and-desktop IDE developed by Ericsson, IBM, TypeFox and RedHat, Gitpod can be invoked by prefixing a GitHub URL with "https://gitpod.io#" or using a Chrome browser extension.</p>
                <p>Gitpod runs in a cloud-based Kubernetes container using a Docker image that can be customized with user-specified tools. It will check out the appropriate version of file being examined in the IDE and, when working on a GitHub issue, it will create a git branch and set the commit message. If launched from a pull request, it activates code review mode.</p>
                <p>The editing app can handle approving and merging pull requests too.</p>
                <p>"Gitpod gives developers full featured terminals to run any processes such as compiling, linting or simply running tests or your application," said Sven Efftinge, CEO of TypeFox, in a <a target="_blank" rel="nofollow" href="https://medium.com/gitpod/gitpod-gitpod-online-ide-for-github-6296b907a886">blog post</a>. "Any Docker image works and you can even configure Gitpod to automatically launch certain tasks on start."</p>
                <p>Gitpod's container-based workspaces are disposable. While this avoids the maintenance burden of workspaces on local devices, it also demands a few seconds of waiting while the container gets spun up and provisioned.</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2018/08/16/sam_lambert_github.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Sam Lambert, GitHub"/>
<h2 title="Ruby shop turns to Go, Java, and Kubernetes for platform makeover">GitHub goes off the Rails as Microsoft closes in</h2>
<a href="https://www.theregister.co.uk/2018/08/16/github_rails_microsoft/"><span>READ MORE</span></a></div>
                <p>Theia, being a cloud-based version of Microsoft's popular Visual Studio Code, supports the <a target="_blank" rel="nofollow" href="https://microsoft.github.io/language-server-protocol/">Language Server Protocol</a>, which simplifies adding support for different programming languages. Currently, Gitpod has been tailored to run JavaScript/Typescript, Java, Python, Go, PHP, Ruby, and C++, along with JSON, CSS and HTML.</p>
                <p>That means in addition to syntax coloring, users can expect code completion, diagnostic messages, documentation when hovering over a term, navigation to method, function or variable definitions, and refactorings.</p>
                <p>C#, Swift, Clojure, Groovy, Objective-C, Markdown, Less, XML and other languages benefit from syntax highlighting but not much else.</p>
                <p>According to Efftinge, support for for Bitbucket, GitLab, and Jira is under development, along with debugging and collaboration capabilities.</p>
                <p>Gitpod is available under a tiered pricing scheme. The free tier provides 10 hours of usage per month with unlimited workspaces and private repos. The basic and pro tiers, $19 per month tier (100 hours) and $39 per month (300 hours) respectively, are not yet available. There's also an on-premises version for enterprises. ®</p>
                
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2018/09/04/gitpod_github_ide/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/1/2018/09/04/gitpod_github_ide/">
                        <span>2</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/software">Software</a>
                </li>
                <li>
                    <a href="/Tag/development">Development</a>
                </li>
                <li>
                    <a href="/Tag/github">Github</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/&title=Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing&amp;url=https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/&amp;title=Gitpod%20git-bolts%20git-IDE%20onto%20GitHub%20for%20in-browser%20code%20git-editing&amp;summary=Devs%20can%20deal%20with%20pull%20requests%20from%20Chrome" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            show_gpt('ad-eagle');
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2018/09/04/azure_its_getting_hot_in_here/">
                            <img src="https://regmedia.co.uk/2017/08/29/sweatyguy.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Microsoft Azure: It's getting hot in here, so shut down all your cores
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/09/03/surface_plus_axed/">
                            <img src="https://regmedia.co.uk/2018/06/22/peasant.jpg?x=88&amp;y=58&amp;crop=1" alt="young man in medieval peasant costume" width=88 height=58>
                <h4>If you weren't rich enough to buy a Surface before, you may as well let that dream die
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/09/04/web_site_source_code_disclosure/">
                            <img src="https://regmedia.co.uk/2016/06/24/shutterstock_shock.jpg?x=88&amp;y=58&amp;crop=1" alt="Child in shock in front of computer. Photo by Shutterstock" width=88 height=58>
                <h4>Excuse me, but your website's source code appears to be showing
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/09/03/tech_support_ads/">
                            <img src="https://regmedia.co.uk/2017/06/14/scam_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="scam" width=88 height=58>
                <h4>Google cracks down on dodgy tech support ads
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/09/04/microsoft_takes_a_pruning_axe_to_skypes_forest_of_features/">
                            <img src="https://regmedia.co.uk/2018/09/04/skype_mobile_ui.jpg?x=88&amp;y=58&amp;crop=1" alt="Skype's redesignd mobile UI" width=88 height=58>
                <h4>Microsoft takes a pruning axe to Skype's forest of features
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                show_gpt('ad-falcon');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>show_gpt('ad-hawk');</script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>
<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2018/09/04/gitpod_github_ide/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6732/flash-storage-growth-acceptance-and-the-rise-of-nvme?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Flash Storage: Growth, Acceptance, and the Rise of NVMe</h4>
                <div class=standfirst>
                    At a high level, solid-state storage continues to experience high levels of adoption while delivering a myriad of technical, operational, and financial benefits.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6429/remedying-the-email-security-gaps-in-microsoft-office-365?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Remedying the Email Security Gaps in Microsoft Office 365</h4>
                <div class=standfirst>
                    If you have made the move to Microsoft Office 365™ or imminently plan to, you are in good company.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6751/innovation-without-limits-your-guide-to-high-performance-computing-in-the-cloud?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Innovation Without Limits - Your Guide to High Performance Computing in the Cloud</h4>
                <div class=standfirst>
                    Discover how enterprises and research institutions are maximizing productivity and saving on costs by moving their HPC workloads to AWS.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6585/ibm-delivers-innovative-cloud-infrastructure-solutions-spanning-on-premises-and-hybrid-cloud?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>IBM Delivers Innovative Cloud Infrastructure Solutions Spanning On-Premises and Hybrid Cloud</h4>
                <div class=standfirst>
                    To support existing Power Systems customers, and to address the needs of new customers seeking to expand their cloudhosting capabilities, IBM has announced two new families of cloud-ready POWER8-based servers.
                </div>
            </a>
        </div>

        <div id="read_more_on" class="deploy_aux">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2018/04/26/red_hat_supermicro_storage_one/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/04/26/girlredcap.jpg?x=198&amp;y=131&amp;crop=1" alt="Studio portrait of funny baby girl in red baseball cap over gray wall background" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Red Hat sticks its storage software cap on Supermicro hardware</h4>
                            <div class=standfirst>
                                Software-defined storage meets single SKU-ery
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/05/28/fiat_chrysler_software_recall/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/08/28/jeep_cherokee_1.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Buggy software could lock a Jeep's cruise control</h4>
                            <div class=standfirst>
                                How's that 'self-driving' vision coming along, again?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/08/30/killer_but_unverifiable_performance_from_storone_software_and_flash_drives/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/05/30/shutterstock_superman_flying.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Killer performance numbers on software and flash drives, StorONE ...</h4>
                            <div class=standfirst>
                                Would be good to see some independent tests, though
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/06/22/blackberry_q1_fy2019_results/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/02/23/blackberry-squashed-jam-shutterstock_86397745.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>BlackBerry continues its gentle slide even as software sales embiggen</h4>
                            <div class=standfirst>
                                Strong showing for that and services in Q1 '19 results
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/06/05/yarrrr_the_bsa_reckons_piracy_be_down_me_hearties/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/08/10/shutterstock_pirate.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Yarrrr, the Business Software Alliance reckons piracy be down, me hearties</h4>
                            <div class=standfirst>
                                Report: dodgy software still accounts for beeeellions of lost cash and malware aplenty
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/05/02/cisco_offloads_video_software_business_back_to_permira/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/08/24/businessman-booted.jpg?x=198&amp;y=131&amp;crop=1" alt="Man being kicked by oversized leg with city in background" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Cisco kicks shrivelling video software unit back to Dr Martens owner</h4>
                            <div class=standfirst>
                                Word on the street: it's getting <i>far</i> less than $5 beeellion it paid
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/03/01/dell_stops_swonly_sales_of_scaleio_virtual_san/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/05/16/switch.jpg?x=198&amp;y=131&amp;crop=1" alt="Switch" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Want ScaleIO virtual SAN software? You'll need to buy Dell servers</h4>
                            <div class=standfirst>
                                Integral part of VxRack FLEX hyperconverged kit henceforth
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/08/23/hiveio_hive_fabric_7/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/08/18/honey.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>HiveIO claims latest HCI software 'eliminates' complexity... Isn't that the whole point of HCI?</h4>
                            <div class=standfirst>
                                Drowned Atlantis tech reinvented as AI-ready product
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                show_gpt('ad-owl');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55W4-LXcCoyKcAAEdfKFUAAAAl&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

<script>facebook_sdk();</script>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" alt="" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/d2e337b97204af4aa34dda04c4e5d56d954b216f/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2018
</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>




        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof RegArticle != 'undefined' ? (RegArticle.pf ? 'p' : (RegArticle.cp ? 'c' : 'a')) : 'i'));
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('send', 'pageview');
        </script>

        <script>
            (function() {
            var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script');
            s.type='text/javascript';
            s.async=true;
            s.src='https://s.dpmsrv.com/dpm_812ed4562d3211363a7b813aa9cd2cf042b63bb2.min.js';
            h.appendChild(s);
            })();
        </script>


    <script>
        $(function() { set_bucket_group(285) });
    </script>
        <div id="fb-root"></div>
    </div>
</div>
</body>
</html>

