<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Cracking the passwords of some WPA2 Wi-Fi networks just got easier • The Register</title>
    
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    <meta property="og:image" content="https://regmedia.co.uk/2017/03/10/password1.jpg?x=1200&y=794"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/" />
    <meta property="og:title" content="Cracking the passwords of some WPA2 Wi-Fi networks just got easier" />
    <meta property="og:description" content="Technique exploits weakness in design of roaming-enabled IEEE 802.11i/p/q/r wireless" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Security , Hacking, Networks">
<script type="application/ld+json">
{
"@context":"http://schema.org",
"@type":"NewsArticle",
"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/"},
"headline":"Cracking the passwords of some WPA2 Wi-Fi networks just got easier",
"datePublished":"2018-08-06T18:26:07Z",
"dateModified":"2018-08-06T19:05:44Z",
"image":{"@type":  "ImageObject","url":"https://regmedia.co.uk/2017/03/10/password1.jpg?x=1200&amp;y=794","width":1200,"height":794},
"author":{"@type":"Person","name":"Shaun Nichols"},
"publisher":{"@type":"Organization","name":"The Register","url":"https://www.theregister.co.uk/","logo":{"@type":"ImageObject","url":"https://www.theregister.co.uk/Design/graphics/icons/reg_logo.png","width":330,"height":60}}
}
</script>
    <script>
      var RegPageType = 'Story';
    </script>
    <link rel="canonical" href="https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2018/08/06/wpa2_wifi_pmkid_hashcat/">
    <script>
        var RegArticle={id:198217,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['wifi','Wifi'],['security','Security '],['hacking','Hacking'],['networks','Networks']],short_url:'http://reg.cx/2M7L',cp:0,noads:[],author:'Shaun Nichols',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/2a337c33f315018c502a84f26b17cc87fd1b4207/design.css">

    <style>
        #sec-security, #m-sec-security,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/security/headlines.atom" title="The Register: Security section">

    
    <script src="/design_picker/bca69db4a2dfbd030e71ffd5dd4f4279a19a8e2a/javascript/_.js"></script>
    <script async src="//www.googletagservices.com/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=c&amp;g=sa&amp;s=c/sec.front"></script>
    <script>
        Reg__adct = 's-async';
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.cmd.push(function() {
            init_gpt('reg_security/front');
        });
    </script>

    <link rel="SHORTCUT ICON" type="image/x-icon" href="/favicon.ico">
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel=apple-touch-icon href="/Design/graphics/icons/vulture_black_60_trans.png">

</head>
<body class="DYNX" data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="https://serverlesscomputing.london/" target=_blank title="The Serverless Computing Conference London">Serverless</a></li>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            show_gpt('ad-kite');
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
            </a>
            <a href="https://google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                <img width="18" height="18" alt="G+" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.svg" class=black_vulture>
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.svg" class=white_vulture>
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">
                Data Centre
            </a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>
            <a href="/lectures/" id=sec-lectures data-nav=".lectures_nav" data-name="Lectures">
                Lectures
            </a>
            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers>
                        <a href="/data_centre/servers/" data-name="Servers" title="Enterprise server news, analysis and opinion">
                            Servers
                        </a>
                    </li>
                    <li id=sub-sec-hpc>
                        <a href="/data_centre/hpc/" data-name="HPC" title="High Performance Computing news, analysis and opinion">
                            HPC
                        </a>
                    </li>
                    <li id=sub-sec-cloud>
                        <a href="/data_centre/cloud/" data-name="Cloud" title="Cloud news, analysis and opinion">
                            Cloud
                        </a>
                    </li>
                    <li id=sub-sec-storage>
                        <a href="/data_centre/storage/" data-name="Storage" title="Enterprise Storage news, analysis and opinion">
                            Storage
                        </a>
                    </li>
                    <li id=sub-sec-networks>
                        <a href="/data_centre/networks/" data-name="Networks" title="Networks news, analysis and opinion">
                            Networks
                        </a>
                    </li>
                    <li id=sub-sec-virtualization>
                        <a href="/data_centre/virtualization/" data-name="Virtualisation" title="Virtualization news, analysis and opinion">
                            Virtualization
                        </a>
                    </li>
                    <li id=sub-sec-bofh>
                        <a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">
                            BOFH
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/07/cisco_vpn_certificate_expiry/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Woman says oops after data breach... or spome other mistake, possibly. Illustration by Shutterstock/sergey sobin" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/21/shutterstock_oops.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cisco let an SSL cert expire in its VPN kit – and broke network provisioning brokers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/07/fcc_net_neutrality_ddos/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/10/ajit-pai.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Denial of denial-of-service served: There was NO DDoS on FCC net neutrality comments</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/arista_cisco_agreement/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Cat attacking" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/28/shutterstock_attack_cat.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Arista cats cough up $400m furball to satisfy Cisco in legal war truce</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/salesforce_breach/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Salesforce web page" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/01/salesforce_web_page_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Salesforce cloud glitch blurted customer data at unauthorised users</h5>
                    </a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/microsoft_roundup/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Shutterstock tools" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/30/toolkit_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Edge, Azure and Windows Phone receives a Telegram. Yup, it's the week at Microsoft</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/kotlin_code_quality/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Women smelling coffee" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/02/shutterstock_1014863197.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Well, this makes scents: Kotlin code quality smells better than Java</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/oracle_amazon_shift_from_database_2020/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Oracle acrobatics in the cloud" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/27/oracle_airplane_shutterstock_editorial_use_only.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Amazon, ditch us? But they can't do without us – Oracle</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/apple_axes_affilitiates/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="workboots in apple barn, with axe and apples  - still life, by Michael J Zittel/shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/02/shutterstock_apples_axeman.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Apple takes an axe to its App Affiliate Program</h5>
                    </a>
                </div>
            </div>
            <div class=sec_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-insider-threat>
                        <a href="/security/insider_threat/" data-name="Insider Threat" title="Insider Threat">
                            Insider Threat
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/us_spying_programs/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/01/19/mad_men_456456456457787.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Battle lines drawn over US mass surveillance as senators probe NSA's bonfire of phone records</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/ibm_atm_security_research/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="ATM money shot" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/03/atm_money.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>IBM, ATMs – WTF? Big Blue to probe cash machines, IoT, vehicles, etc in new security labs</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/blackberry_ransomware/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="ransomware" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/06/ransomware_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>BlackBerry claims it can do to ransomware what Apple did to its phones</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="password" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/10/password1.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cracking the passwords of some WPA2 Wi-Fi networks just got easier</h5>
                    </a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/messagebird_twilio_push_code_diet/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Someone typing away on the ol' internet" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/03/shutterstock_messaging_services.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>MessageBird, Twilio tout low-code tools for DIY comms app plumbing</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/serverless_computing_conference_tickets/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Serverless Computing London Logo" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/20/serverless_london_logo.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Serverless Computing: Here's an easy way to save £££s from the start</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/07/31/istio_sets_sail_as_red_hat_renovates_openshift_container_ship/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Woman in ret hat photo via Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/28/woman_in_ret_hat_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Istio sets sail as Red Hat renovates OpenShift container ship</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/07/26/google_cloud_github/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Some programmers looking at a screen" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/07/26/shutterstock_developer_meeting.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Only a day late and a dollar short, Google: Now its cloud cozies up to Microsoft's GitHub</h5>
                    </a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy>
                        <a href="/business/policy/" data-name="Policy" title="Policy News, analysis and opinion">
                            Policy
                        </a>
                    </li>
                    <li id=sub-sec-channel>
                        <a href="/business/channel/" data-name="The Channel" title="The Channel news, analysis and opinion">
                            The Channel
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/accenture_facebook_age_discrimination/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Being millennialsplained" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/06/shutterstock_age_discrimination.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>New age discrim row: Accenture, Facebook sued by sales boss for favoring 'new blood'</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/botched_sap_implementation_national_grid_wipro_settlement_75m/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/04/17/money_sm.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Wipro hands $75m to National Grid US after botched SAP upgrade</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/tech_telco_and_media_deals_rise_107_amid_highprofile_battles/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/15/money_76358642.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>World+dog did 107% more tech, telco and media deals this year so far</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/symantec_job_cuts/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="A hand holding an axe in shadow" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/28/shutterstockaxe.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Symantec culling 8% of workforce to soak up slow enterprise sales</h5>
                    </a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/google_android_9_pie/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/26/cobbler_356435.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Sur-Pies! Google shocks world with sudden Android 9 Pixel push</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/motorola_5g_mod/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Moto 5G Mod" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/06/moto_5g_mod_teaser.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Motorola strap-on packs a 2,000mAh battery to appease the 5G gods</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/retro_computers_ltd_roundup/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="A ZX Spectrum Vega+ V2, as delivered by Retro Computers Ltd at the end of July 2018. Pic: Craig Wootton" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/06/zx_spectrum_vega_plus.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>ZX Spectrum reboot latest: Some Vega+s arrive, Sky pulls plug, Clive drops ball</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/microsoft_surface/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="sloW" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/05/21/shutterstock_slow_down.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microsoft's cheapo Surface: Like a netbook you can't upgrade</h5>
                    </a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek>
                        <a href="/science/geeks_guide/" data-name="Geeks Guide" title="Geek's Guide to Britain">
                            Geek's Guide
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/fast_radio_burst/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="radio_telescopes" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/03/radio_telescopes.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>First low-frequency fast radio burst to grace our skies detected at last</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/blast_from_the_past_boffins_find_the_fastest_exploding_nonsupernova_star_in_the_milky_way/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="eta_carinae" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/02/eta_carinae.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Blast from the past: Boffins find the fastest exploding non-supernova star</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/uk_booze_study/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="alcohol" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/02/alcohol.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Get drinking! Abstinence just as bad for you as getting bladdered</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/nasa_open_source_rover/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="NASA's Open Source Rover -- JPL/Caltech image" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/02/nasa_open_source_rover.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Build your own NASA space rover: Here are the DIY JPL blueprints</h5>
                    </a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence>
                        <a href="/emergent_tech/artificial_intelligence/" data-name="Artificial Intelligence" title="Artificial Intelligence">
                            Artificial Intelligence
                        </a>
                    </li>
                    <li id=sub-sec-internet-of-things>
                        <a href="/emergent_tech/internet_of_things/" data-name="Internet of Things" title="Internet of Things">
                            Internet of Things
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/06/openai_bots_dota_2_semipros/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Screenshot from the DOTA OpenAI Twitch stream" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/06/screenshot_dota2_openai.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>OpenAI bots thrash team of Dota 2 semi-pros, set eyes on mega-tourney</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/04/ai_roundup/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="The Raspberry Pi 2 Model B" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/02/pi_board_page.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>AI on Raspberry Pi, Waymo touts robo-rides to Arizonians, and more</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/robot_feelings/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="nao_robot" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/03/nao_robot.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Uptight robots that suddenly beg to stay alive are less likely to be switched off by humans</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/fbi_cyber_security_tip_sheet/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="The FBI seal on a building" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/11/fbiseal.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>The wheel turns slowly, but it turns: Feds emit IoT security tip sheet</h5>
                    </a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob>
                        <a href="/bootnotes/stob/" data-name="Verity Stob" title="Verity Stob">
                            Verity Stob
                        </a>
                    </li>
                </ul>
                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/04/china_winnie_the_pooh/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="pooh" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/03/pooh-ping.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Click this link and you can get The Register banned in China</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/03/summer_nights_cool_down_and_help_action_for_children/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Jenny Agutter at Byte Night launch" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/06/21/jenny_agutter_launches_byte_night.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Summer nights? Cool down and help Action for Children</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/02/beer_winners/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="beer" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/05/15/beer_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>I'll have two pints of Blockchain Brew and a half of Cloudy Bollocks</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/08/01/oz_retro_computer_collection_in_dire_straits_bulldozers_on_horizon/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Australian computer history museum's PDP-8" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/08/01/pdp8.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Oz retro computer collection in dire straits, bulldozers on horizon</h5>
                    </a>
                </div>
            </div>
        </div>
    </div>


        <div id=site_nav_mobile class=static>
        <img id=mobile_menu_toggle width="22" height="20" alt="Menu" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/burger_menu.svg">
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>

            <a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data Centre">
                Data Centre
            </a>
            <a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>
            <div id="m-sub-sec-bofh">
                <a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a>
            </div>
            <a href="/lectures/" id=m-sec-lectures data-nav=".lectures_nav" data-name="Lectures">
                Lectures
            </a>
        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            show_gpt('ad-condor');
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250&amp;tile=2&amp;c=2W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250&amp;tile=2&amp;c=2W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D2%26raptor%3Dcondor%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>






    <div id=main-col>
        
        
        <div id="crumb_trail">
            
            <a href="/security/" class="dcl sub_sec">
                <h4>Security</h4>
            </a>
                    </div>
        <div id="article"  data-cat='news'>

            <div class="article_head">
                <h1>Cracking the passwords of some WPA2 Wi-Fi networks just got easier</h1>
                
                <h2>Technique exploits weakness in design of roaming-enabled IEEE 802.11i/p/q/r wireless</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Shaun-Nichols" title="Read more by this author" class="alt_colour dcl">Shaun Nichols in San Francisco</a>
                        
                        <span class="dateline">
                            6&nbsp;Aug&nbsp;2018&nbsp;at&nbsp;18:26
                        </span>
                        
                        
                        <script>tweet_btn()</script>
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/1/2018/08/06/wpa2_wifi_pmkid_hashcat/" class="reg_comments">                                    <span class="count">5</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/&title=Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier&amp;url=https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/&amp;title=Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier&amp;summary=Technique%20exploits%20weakness%20in%20design%20of%20roaming-enabled%20IEEE%20802.11i%2Fp%2Fq%2Fr%20wireless" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

                            <img src="https://regmedia.co.uk/2017/03/10/password1.jpg?x=442&amp;y=293&amp;crop=1" alt="password" width=442 height=293 class="article_img">
            </div>
            <div id="body">
                
                <p>The folks behind the password-cracking tool Hashcat claim they've found a new way to crack some wireless network passwords in far less time than previously needed.</p>
                <p>Jens Steube, creator of the open-source software, <a target="_blank" rel="nofollow" href="https://hashcat.net/forum/thread-7717.html">said the new technique</a>, discovered by accident, would potentially allow someone to get all the information they need to brute force decrypt a Wi-Fi password, by snooping on a single data packet going over the air.</p>
                <p>Previously, an attacker would need to wait for someone to log into a network, capture the four-way handshake process used to authenticate users with a wireless access point, and use that to brute-force search for the password.</p>
                <p>This particular technique specifically works against WPA and WPA2-secured Wi-Fi networks with PMKID-based roaming features enabled, and it can be used to recover the PSK (Pre-Shared Key) login passwords.</p>
                <div class="promo_article"><img src="https://regmedia.co.uk/2016/10/31/shutterstock_wifi_cloud.jpg?x=174&amp;y=115&amp;crop=1" width="174" height="115" alt="Wi-fi symbol made out of clouds. Photo by Shutterstock"/>
<h2 title="If at first you don't succeed, try (WEP) try (WPA) try (WPA2)...">With WPA3, Wi-Fi will be secure this time, really, wireless bods promise</h2>
<a href="https://www.theregister.co.uk/2018/01/09/wi_fi_wpa3/"><span>READ MORE</span></a></div>
                <p>"This attack was discovered accidentally while looking for new ways to attack the new WPA3 security standard," Syeube explained late last week, adding that it won't work against <a target="_blank" href="https://www.theregister.co.uk/2018/06/26/wpa3_wireless_security_revamp/">next-gen wireless security protocol WPA3</a>.</p>
                <p>"WPA3 will be much harder to attack because of its modern key establishment protocol called Simultaneous Authentication of Equals (SAE).</p>
                <p>"The main difference from existing attacks is that in this attack, capture of a full EAPOL 4-way handshake is not required. The new attack is performed on the RSN IE (Robust Security Network Information Element) of a single EAPOL frame."</p>
                <p>The team found that, when an attacker has the RSN IE information, the PMKID (the key needed to establish a connection between a user and an access point) can be pulled out via a packet capture tool and then brute-force decrypted with Hashcat. Steube noted that this can often be done in around 10 minutes or so, depending on noise over the Wi-Fi channel.</p>
                <p>"Since the PMK is the same as in a regular EAPOL 4-way handshake this is an ideal attacking vector," Steube explained. "We receive all the data we need in the first EAPOL frame from the AP."</p>
                <p>As a result, the attacker would be able to break into a vulnerable wireless network in far less time without needing to get any other information from other users or devices, only information the router itself provides to all users, authenticated or otherwise.</p>
                <p>Steube said that while he does not yet know which brands and models of routers are specifically at risk to the technique, he believes "most modern routers" using IEEE 802.11i/p/q/r protocols with roaming functions enabled would be exploitable. ®</p>
                
            </div>

            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/1/2018/08/06/wpa2_wifi_pmkid_hashcat/">
                        <span>5</span>
                        Comments
                    </a>
                </div>
            
            </div>
                    </div>

        <div id=tags>
            <ul>
                <li>
                    <strong>MORE</strong>
                </li>
                <li>
                    <a href="/Tag/security">Security </a>
                </li>
                <li>
                    <a href="/Tag/hacking">Hacking</a>
                </li>
                <li>
                    <a href="/Tag/networks">Networks</a>
                </li>
            </ul>
        </div>


        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/&title=Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier&amp;url=https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/&amp;title=Cracking%20the%20passwords%20of%20some%20WPA2%20Wi-Fi%20networks%20just%20got%20easier&amp;summary=Technique%20exploits%20weakness%20in%20design%20of%20roaming-enabled%20IEEE%20802.11i%2Fp%2Fq%2Fr%20wireless" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="text/javascript">show_article_signup_ml();</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            show_gpt('ad-eagle');
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x252%7C300x600&amp;tile=3&amp;c=33W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D3%26raptor%3Deagle%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2018/08/06/who-me/">
                            <img src="https://regmedia.co.uk/2018/08/03/shutterstock_road_block_no_access.jpg?x=88&amp;y=58&amp;crop=1" alt="Road closed sign" width=88 height=58>
                <h4>'Can you just pop in to the office and hit the power button?' 'Not really... the G8 is on'
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/08/06/amd_epyc_intel_xeon_x86_server_revenue_share/">
                            <img src="https://regmedia.co.uk/2017/07/19/big_fish_eats_little_fish_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="The big fish eats the little fish" width=88 height=58>
                <h4>Hmm, there's something fishy about this graph charting AMD's push into Intel's server turf
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/08/06/microsoft_surface/">
                            <img src="https://regmedia.co.uk/2018/05/21/shutterstock_slow_down.jpg?x=88&amp;y=58&amp;crop=1" alt="sloW" width=88 height=58>
                <h4>Microsoft's cheapo Surface: Like a netbook you can't upgrade
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/08/06/openai_bots_dota_2_semipros/">
                            <img src="https://regmedia.co.uk/2018/08/06/screenshot_dota2_openai.jpg?x=88&amp;y=58&amp;crop=1" alt="Screenshot from the DOTA OpenAI Twitch stream" width=88 height=58>
                <h4>OpenAI bots thrash team of Dota 2 semi-pros, set eyes on mega-tourney
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/08/06/retro_computers_ltd_roundup/">
                            <img src="https://regmedia.co.uk/2018/08/06/zx_spectrum_vega_plus.jpg?x=88&amp;y=58&amp;crop=1" alt="A ZX Spectrum Vega+ V2, as delivered by Retro Computers Ltd at the end of July 2018. Pic: Craig Wootton" width=88 height=58>
                <h4>ZX Spectrum reboot latest: Some Vega+s arrive, Sky pulls plug, Clive drops ball
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                show_gpt('ad-falcon');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D4%26raptor%3Dfalcon%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x100%7C300x250%7C300x251&amp;tile=4&amp;c=44W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D426raptor%3Dfalcon%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>show_gpt('ad-hawk');</script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=6&amp;c=66W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D6%26raptor%3Dhawk%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>
<div id=story-bot-col>
    
        <hr>
        <div class="OUTBRAIN" data-src="https://www.theregister.co.uk/2018/08/06/wpa2_wifi_pmkid_hashcat/" data-widget-id="GS_1" data-ob-template="Theregister_201806030243"></div>
        <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
        <hr>
    

    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6433/office-365-risk-mitigation?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Office 365 Risk Mitigation</h4>
                <div class=standfirst>
                    What are the three key areas of concern around Office 365 email you should be aware of?
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6579/software-defined-storage-sds?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Software defined storage (SDS)</h4>
                <div class=standfirst>
                    Enterprises generally have a positive awareness and acceptance of SDS: 61% of enterprises that deployed SDS realized tangible beneﬁts.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6546/a-framework-for-deep-learning-performance?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>A Framework for Deep Learning Performance</h4>
                <div class=standfirst>
                    This paper explores PLASTER - the seven major AI challenges - in the context of NVIDIA’s DL solutions.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6609/frost-and-sullivan-security-information-and-event-management-siem-mid-market-analysis?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Frost and Sullivan: Security Information and Event Management (SIEM) Mid-Market Analysis</h4>
                <div class=standfirst>
                    This abbreviated brief focuses on the SIEM requirements of mid-market organizations and an analysis of the vendors who serve this market, including in-depth coverage of AlienVault.
                </div>
            </a>
        </div>

        <div id="read_more_on" class="deploy_aux">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2018/06/27/microsofts_next_cloud_trick_kicking_things_out_of_the_cloud_to_azure_iot_edge/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/06/25/cloudedge.jpg?x=198&amp;y=131&amp;crop=1" alt="Man with hiking equipment standing on rock&amp;#39;s edge" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft's next trick? Kicking things out of the cloud to Azure IoT Edge</h4>
                            <div class=standfirst>
                                Open-source service sticks containers in internet of stuffs
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/06/11/lpwan_techs_research_abi/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/09/30/moonspike_teaser.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Bad news, mobile operators: Unlicensed IoT tech rocketing ahead of NB-IoT and LTE-M – report</h4>
                            <div class=standfirst>
                                Plus global mobe mobs name Sigfox top IoT tech lag
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/05/21/azure_sphere_goes_retro_in_its_43_year_old_altair_basic_boots/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/05/18/altair_8800.jpg?x=198&amp;y=131&amp;crop=1" alt="Altair 8800 -" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Now that's old-school cool: Microsoft techies slap Azure Sphere IoT chip in an Altair 8800</h4>
                            <div class=standfirst>
                                Cloudy tech seen in oversized suit holding temperature probe
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/04/06/microsoft_internet_of_things_research_budget/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/09/30/trading_places.jpg?x=198&amp;y=131&amp;crop=1" alt="Trading Places" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft's five-billion-buck IoT R&amp;D plan is just business as usual</h4>
                            <div class=standfirst>
                                It&#8217;s not new money and not a huge slab of Redmond's research budget
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/07/18/windows_10_iot/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/07/01/grab_the_controls.jpg?x=198&amp;y=131&amp;crop=1" alt="Grab The Controls" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Windows 10 IoT Core Services unleashed to public preview</h4>
                            <div class=standfirst>
                                Gizmos gain control over Windows 10 updates - at a price
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/12/07/microsoft_emergency_update_malware_protection_engine_needs_erm_malware_protection/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/05/12/microsoftpatchscaled.jpg?x=198&amp;y=131&amp;crop=1" alt="Microsoft patch" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Microsoft emergency update: Malware Engine needs, erm, malware protection</h4>
                            <div class=standfirst>
                                Stop appreciating the irony and go install the patch now
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/05/21/telstra_mobile_national_outage/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/10/19/australia_with_ethernet_cable.jpg?x=198&amp;y=131&amp;crop=1" alt="Australia with ethernet cable" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Telstra's mobile networks go TOESUP* in national outage</h4>
                            <div class=standfirst>
                                <span class=trailer>Updated</span>
                                That's 'Total Outage Ends Support for Usual Performance', natch
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2018/07/16/zoomeye_iot_dahua/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2018/07/16/hacker_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="hacker" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>IoT search engine ZoomEye 'dumbs down' Dahua DVR hijackings by spewing passwords</h4>
                            <div class=standfirst>
                                And noone wants to fix it
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        
<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                show_gpt('ad-owl');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x50&amp;tile=5&amp;c=55W2kTZcCoyKkAAHiiAH0AAAAn&amp;t=ct%3Dns%26unitnum%3D5%26raptor%3Dowl%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

<script>facebook_sdk();</script>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2018
</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>




        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof RegArticle != 'undefined' ? (RegArticle.pf ? 'p' : (RegArticle.cp ? 'c' : 'a')) : 'i'));
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('send', 'pageview');
        </script>

        <script>
            (function() {
            var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script');
            s.type='text/javascript';
            s.async=true;
            s.src='https://s.dpmsrv.com/dpm_812ed4562d3211363a7b813aa9cd2cf042b63bb2.min.js';
            h.appendChild(s);
            })();
        </script>


    <script>
        $(function() { set_bucket_group(360) });
    </script>
        <div id="fb-root"></div>
    </div>
</div>
</body>
</html>

