<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>LEDE and OpenWRT kiss and make up • The Register    </title>
    
    <meta name="viewport" content="initial-scale=1.0, width=device-width"/>
    <meta property="og:title" content="LEDE and OpenWRT kiss and make up" />
    <meta property="og:image" content="https://regmedia.co.uk/2018/01/08/getting_back_together_shutterstock.jpg?x=1200&y=794"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/" />
    <meta property="og:description" content="Newly re-merged open router project goes live" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">


    <link rel="canonical" href="https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2018/01/08/lede_and_openwrt_merge/">
    <script>
        var RegArticle={id:193594,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['merge','Merge'],['openwrt','Openwrt'],['lede','Lede']],short_url:'http://reg.cx/2wkw',cp:0,noads:[],author:'Richard Chirgwin',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/da0bb77a6553d2156cffc7f502ca4c1a72bae873/design.css">

    <style>
        #sec-data-centre, #m-sec-data-centre
,
        #sub-sec-networks a {
          font-weight: bold;
        }
    </style>
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/data_centre/networks/headlines.atom" title="The Register: Networks section">

    
    <script src="/design_picker/6b366d9e6cbf8b97ee3f6112977289187a2aefcf/javascript/_.js"></script>
    <script src="//www.googletagservices.com/tag/js/gpt.js"></script>
    <script src="https://nir.regmedia.co.uk/?g=c&amp;g=sa&amp;s=c/dc.networks"></script>
    <script>
        Reg__adct = 's-async';
        googletag.cmd.push(function() {
            init_gpt('reg_datacentre/networks');
        });
    </script>

    <link rel="SHORTCUT ICON" type="image/x-icon" href="/favicon.ico">
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel=apple-touch-icon href="/Design/graphics/icons/vulture_black_60_trans.png">

</head>
<body class="DYNX" data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="https://continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2018">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="https://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-kite class=adu>
        <script>
            show_gpt('ad-kite');
        </script>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
            </a>
            <a href="https://google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                <img width="18" height="18" alt="G+" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.svg" class=black_vulture>
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.svg" class=white_vulture>
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data_centre">
                Data Center
            </a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>

            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers data-name="Servers">
                        <a href="/data_centre/servers/" title="Enterprise server news, analysis and opinion">
                            Servers
                        </a>
                    </li>
                    <li id=sub-sec-hpc data-name="HPC">
                        <a href="/data_centre/hpc/" title="High Performance Computing news, analysis and opinion">
                            HPC
                        </a>
                    </li>
                    <li id=sub-sec-cloud data-name="Cloud">
                        <a href="/data_centre/cloud/" title="Cloud news, analysis and opinion">
                            Cloud
                        </a>
                    </li>
                    <li id=sub-sec-storage data-name="Storage">
                        <a href="/data_centre/storage/" title="Enterprise Storage news, analysis and opinion">
                            Storage
                        </a>
                    </li>
                    <li id=sub-sec-networks data-name="Networks">
                        <a href="/data_centre/networks/" title="Networks news, analysis and opinion">
                            Networks
                        </a>
                    </li>
                    <li id=sub-sec-virtualization data-name="Virtualisation">
                        <a href="/data_centre/virtualization/" title="Virtualization news, analysis and opinion">
                            Virtualization
                        </a>
                    </li>
                    <li id=sub-sec-bofh data-name="Bofh">
                        <a href="/data_centre/bofh/" title="The Home of the Mighty BOFH">
                            BOFH
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/08/caida_euro_boffins_want_to_end_bgp_hijacks/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Charlie Chaplin Modern Times" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/17/charlie_chaplin_modern_times.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Net boffins brew poison for BGP hijacks</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/08/azure_fpga_nics/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/11/18/cloud_89736487353434564.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microsoft offloads networking to FPGA-powered NICs</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/08/wd_mycloud_nas_backdoor/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Epic Fail" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/10/02/epic_fail_sign_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>WD My Cloud NAS devices have <i>hard wired</i> backdoor</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Making up" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/08/getting_back_together_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>LEDE and OpenWRT kiss and make up</h5>
                    </a>
                </div>

            </div>
            <div class=software_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/yahoooooh_no_our_emails_down/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Yahoo" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/10/05/yahoo.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Yahooooo<i>!</i> says<i>!</i> its<i>!</i> email<i>!</i> is<i>!</i> scrahoooo-ed<i>!</i></h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/munich_linux_costs_ownership/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/19/fistbite.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>And we return to Munich's migration back to Windows - it's going to cost what now?! €100m!</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/linux_mint_18_3_review/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Toothpaste image via Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/01/toothpaste_image_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Linux Mint 18.3: A breath of fresh air? Well, it's a step into the unGNOME</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/02/open_source_trademark_battle/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Hippie peace, image via Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/06/15/hippie_peace_image_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Open-source civil war: Olive branch offered in trademark spat... with live grenade attached</h5>
                    </a>
                </div>

            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/06/amd_cpu_psp_flaw/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="AMD bloodbath" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/16/amd_bloodbath.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Security hole in AMD CPUs' hidden secure processor code revealed ahead of patches</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/06/qualcomm_processor_security_vulnerabilities/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Cat peeks outside cardboard box. Photo by shuttertsock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/08/shutterstock_cat_peek.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Qualcomm joins Intel, Apple, Arm, AMD in confirming its CPUs suffer hack bugs, too</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/wi_fi_crypto_mining/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="screenshot of coffee miner code" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/05/coffeeminer_png.png?x=198&amp;y=131&amp;crop=1">
                        <h5>How to hack Wi-Fi for fun and imprisonment with crypto-mining inject</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/dell_data_protection_suite_patched/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/12/shutterstock_holes_in_bucket.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Dell EMC patches 3 zero-days in Data Protection Suite</h5>
                    </a>
                </div>

            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/12/20/microservices_101/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Tiny robot photo via Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/04/tiny_robot_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microservices 101</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/12/19/year_in_containers_and_year_ahead/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Containers in the fridge " width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/12/19/shuttertsock_container_freezer.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>2017 – the year of containers! It wasn't? Oops. Maybe next year</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/12/13/continuous_lifecycle_2018_keynotes_speakers_and_earlybirds/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Continuous Lifecycle London 2016 logo" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/14/continuous_lifecycle_london_logo.png?x=198&amp;y=131&amp;crop=1">
                        <h5>Continuous Lifecycle 2018: Keynotes, speakers and earlybirds</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/12/11/you_say_you_are_doing_devops/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Stressed looking business person. " width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/09/11/shutterstock_stressed_business.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>So you're 'agile', huh? I do not think it means what you think it means</h5>
                    </a>
                </div>

            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy data-name="Policy">
                        <a href="/business/policy/" title="Policy News, analysis and opinion">
                            Policy
                        </a>
                    </li>
                    <li id=sub-sec-channel data-name="The Channel">
                        <a href="/business/channel/" title="The Channel news, analysis and opinion">
                            The Channel
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/07/south_australia_cancels_contract_for_aler_sa_app/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/25/houseonfire.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>South Australia bins emergency alert app, contract</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/age_verification_could_harm_small_isps_and_encourage_risky_online_behaviour/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/04/adultsonly.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>UK.gov admits porn age checks could harm small ISPs and encourage risky online behaviour</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/google_pay_gap_suit_gets_another_go/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="A frustrated woman" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/12/12/frustratedperson.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Women reboot gender discrimination lawsuit against Google</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/citrix_launches_patent_action_against_avi/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Gavel" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/04/21/gavel.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Citrix hurls patent suit at network tiddler Avi, claims rival smeared NetScaler</h5>
                    </a>
                </div>

            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/us_customs_copying_files/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="TSA gloves" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/14/tsa_gloves.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>US border cops told to stop copying people's files just for the hell of it</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/hp_announces_global_recall_laptop_battery/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="David Caruso as famously sunglasses-lowering cheeseball crime scene investigator Horatio Crane in CSI: Miami. Photo copyright CBS" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/02/10/horatio_csi_sunglasses.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Wait! Before you <i>fire up</i> that HP lappy, check the battery</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/qinetic_drone_collision_study_airliner_windows/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="An Airbus A320-series airliner cockpit. Pic: Shutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/04/a320_cockpit_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>UK drone collision study didn't show airliner window penetration</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/02/lenovo_ftc_superfish_settlement/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Lenovo web page editorial use only" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/05/26/lenovo_web_page_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>SuperFish cram scandal: Lenovo must now ask nicely before stuffing new PCs with crapware</h5>
                    </a>
                </div>

            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-geek data-name="Geeks_guide">
                        <a href="/science/geeks_guide/">
                            Geek's Guide
                        </a>
                    </li>
                </ul>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/50th_mersenne_prime_discovered/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Pretty pretty, all in a box" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/05/shutterstock_numbsss.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>GIMPS crack whip on plucky processor to find largest prime number</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/new_battery_design_mobile_phones_electric_vehicles/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/14/baevb.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Whizzes' lithium-iron-oxide battery 'octuples' capacity on the cheap</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/tarantula_nebula_massive_stars/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/05/tarantula_nebula_nasa.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Nebula spotted with more super-sized bodies than a gym on Jan 2nd</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/03/tabbys_star_is_no_alien_megastructure_just_a_star_obscured_by_dust/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/03/tabbys_star.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Soz, guys. No 'alien megastructure' around Tabby's Star, only cosmic dustbunnies</h5>
                    </a>
                </div>

            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence data-name="Artificial Intelligence">
                        <a href="/emergent_tech/artificial_intelligence/" title="Artificial Intelligence">
                            Artificial Intelligence
                        </a>
                    </li>
                    <li id=sub-sec-internet-of-things data-name="Internet of Things">
                        <a href="/emergent_tech/internet_of_things/" title="Internet of Things">
                            Internet of Things
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/nissan_brain_controlled_car_wheeze/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/07/27/cloud-face.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>If you won't use your brain our machine will use it for you, Nissan tells drivers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/our_ai_overlords_will_not_magically_arise_from_deep_learning_says_expert/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="AI boss and human slaves" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/04/shutterstock_ai_overlord.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Skynet it ain't: Deep learning will not evolve into true AI, says boffin</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/03/honda_alibaba_car_navigation/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Period Map, showing River Irwell and modern ship canal" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/07/05/period_map_river_irwell_modern_ship_canal.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Honda pores over in-car navigation software with Alibaba – report</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/03/nvidia_server_gpus/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Nvidia GeForce" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/04/15/nvidia_geforce.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Nvidia: Using cheap GeForce, Titan GPUs in servers? Haha, nope!</h5>
                    </a>
                </div>

            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob data-name="Verity_stob">
                        <a href="/bootnotes/stob/" title="Verity Stob">
                            Verity Stob
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/05/grrm_nightflyers_tv_series/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/05/spookyspace.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5><i>Game of Thrones</i> author's space horror <i>Nightflyers</i> hitting telly</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/nato_official_hymn/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2018/01/04/kidschoir.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Military alliance NATO adopts official hymn</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/angry_scots_protest_against_irn_bru_recipe_change/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Scots as Braveheart photo Cintia Erdens Paiva via Shutterstock " width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/02/17/scots_as_braveheart_photo_cintia_erdens_paiva_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Jocks in shock as Irn-Bru set to slash sugar and girder content</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2018/01/04/bristol_man_fakes_crash_to_get_details_of_owner_of_private_reg_plate/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="Confused lost-looking driver with map. Photo by SHutterstock" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/07/08/shutterstock_confused_lost_driver.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Wannabe W1 DOW-er faked car crash to track down reg plate's owner</h5>
                    </a>
                </div>

            </div>
        </div>
    </div>

        <div id=site_nav_mobile class=static>
        <img id=mobile_menu_toggle width="22" height="20" alt="Menu" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/burger_menu.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/burger_menu.svg">
        <nav id=top_nav_mobile class=dcl>
        <form id=search_form_mobile action="https://search.theregister.co.uk/" method=GET>
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            <input type=text name=q id=mobile_q placeholder="Search site">
        </form>
            <a href="/data_centre/" id=m-sec-data-centre data-nav=".data_cent_nav" data-name="Data_centre">
                Data Center
            </a>
            <a href="/software/" id=m-sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=m-sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/devops/" id=m-sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=m-sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=m-sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=m-sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=m-sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=m-sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>
            <div id="m-sub-sec-bofh">
                <a href="/data_centre/bofh/" data-name="Bofh" title="The Home of the Mighty BOFH">BOFH</a>
            </div>

        </nav>
    </div>
    <div id=page_overlay_side></div>

    
    <div id=ad-condor class=adu>
        <script>
            show_gpt('ad-condor');
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_datacentre/networks&amp;sz=728x90%7C970x90%7C970x250&amp;tile=2&amp;c=22WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D2%26unitname%3Dwww_top_leader%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_datacentre/networks&amp;sz=728x90%7C970x90%7C970x250&amp;tile=2&amp;c=22WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D2%26unitname%3Dwww_top_leader%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>







    <div id=main-col>
        
        <div id="crumb_trail">
            <a href="/data_centre/" class=dcl>
                <h4>Data Center</h4>
            </a>
            <img class="crumbtrail_arrow" width="6" height="7" src="/design_picker/8ad74c8c7be441b49006a522ed8d25dfe0b94636/graphics/icon/crumbtrail_arrow_small.png" alt="Arrow">
            <a href="/data_centre/networks/" class="dcl sub_sec">
                <h4>Networks</h4>
            </a>
        </div>
        <div id="article"  data-cat='news'>

            <div class="article_head">
                <h1>LEDE and OpenWRT kiss and make up</h1>
                
                <h2>Newly re-merged open router project goes live</h2>
                

                
                <div class="byline_and_share">
                    <div class="byline">
                        
                            By <a href="/Author/Richard-Chirgwin" title="Read more by this author" class="alt_colour dcl">Richard Chirgwin</a>
                        <span class="dateline">
                            8&nbsp;Jan&nbsp;2018&nbsp;at&nbsp;00:05
                        </span>
                        
                        <script>tweet_btn()</script>
                    </div>
                    <div class="comments_share">
                        
                            <a href="https://forums.theregister.co.uk/forum/1/2018/01/08/lede_and_openwrt_merge/" class="reg_comments">                                    <span class="count">1</span>
                                    <img width="17" height="15" src="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.png" srcset="/design_picker/029b461aa66d73b1e8cb351f99212507d4da660c/graphics/icon/rect_comment_bubble_white.svg" alt="Reg comments">                            </a>                        <a href="#" class="share_toggle">SHARE <span>&#9660;</span></a>
                    </div>
                </div>
                
    <div class="social_btns alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/&title=LEDE%20and%20OpenWRT%20kiss%20and%20make%20up" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/reddit.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=LEDE%20and%20OpenWRT%20kiss%20and%20make%20up&amp;url=https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/&amp;title=LEDE%20and%20OpenWRT%20kiss%20and%20make%20up&amp;summary=Newly%20re-merged%20open%20router%20project%20goes%20live" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_alt.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>

                

            </div>
            <div id="body">
                
                <p>The OpenWRT and LEDE open router projects have merged and promised a major release in the coming months.</p>
                <p>OpenWRT was, for years, the only serious open source codebase for router firmware, allowing users to overwrite vendor firmware, either for security reasons or to conduct their own low-level development.</p>
                <p>LEDE was created in March 2016 when a group of developers, unhappy with where OpenWRT was going, created the alternative Linux Embedded Development Environment. At the time, the LEDE group worried that OpenWRT lacked a process to bring new core developers into the project at a time developer numbers were dwindling.</p>
                <p>When the split first emerged, we <a target="_blank" rel="nofollow" href="http://www.theregister.co.uk/2016/05/05/router_hackers_reach_for_the_fork_lede_splits_from_openwrt/">reported</a> that LEDE was led by Jo-Philipp Wich, John Crispin, Daniel Golle, Felix Fietkau, Hauke Mehrtens, Matthias Schiffer and Steven Barth.</p>
                <p>At the end of 2016, the two groups started discussing merging again, and in May 2017, they <a target="_blank" rel="nofollow" href="https://www.theregister.co.uk/2017/05/10/openwrt_and_lede_peace_plan/">reached agreement</a> on the terms of a merger.</p>
                <p>Such things take time, but the OpenWRT/LEDE merged project has now <a target="_blank" rel="nofollow" href="https://forum.lede-project.org/t/announcing-the-openwrt-lede-merge/10217">gone live</a> at last.</p>
                <p>The announcement says the project will be governed under the rules of the LEDE project, and that the focus will be on small, frequent minor releases, as well as stability and release maintenance.</p>
                <p>Support has ended for OpenWRT releases prior to 15.05 (meaning no security or bugfixes), and the project has warned that OpenWRT CC 15.05 patches will run behind time for a while since it's “not yet fully integrated into our release automation”.</p>
                <p>“The LEDE 17.01 release will continue to get full security and bug fix support for both source code and binary releases,” the project team announced. ®</p>
                
                <p class="wptl btm">
                    <span>Sponsored: </span>
                    <a href="http://go.theregister.com/tl/1757/shttp://www.mcubed.london/">Minds Mastering Machines - Call for papers now open</a>
                </p>            </div>


            
            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20LEDE%20and%20OpenWRT%20kiss%20and%20make%20up&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/1/2018/01/08/lede_and_openwrt_merge/">
                        <span>1</span>
                        Comment
                    </a>
                </div>
            
            </div>
                    </div>



        
    <div class="social_btns bot_article alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/&title=LEDE%20and%20OpenWRT%20kiss%20and%20make%20up" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/reddit.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/reddit.svg" alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=LEDE%20and%20OpenWRT%20kiss%20and%20make%20up&amp;url=https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg" alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg" alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2018/01/08/lede_and_openwrt_merge/&amp;title=LEDE%20and%20OpenWRT%20kiss%20and%20make%20up&amp;summary=Newly%20re-merged%20open%20router%20project%20goes%20live" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_alt.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_alt.svg" alt="linkedin">
            </div>
        </a>
    </div>


        
            <script type="application/javascript">show_article_signup_ml()</script>
        

    </div>

    <div id=right-col>
                            <div id=ad-eagle class=adu>
                        <script>
                            show_gpt('ad-eagle');
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_datacentre/networks&amp;sz=300x250%7C300x600%7C300x1050&amp;tile=3&amp;c=33WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D3%26unitname%3Dwww_top_mpu%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_datacentre/networks&amp;sz=300x250%7C300x600%7C300x1050&amp;tile=3&amp;c=33WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D3%26unitname%3Dwww_top_mpu%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2018/01/02/intel_cpu_design_flaw/">
                            <img src="https://regmedia.co.uk/2016/02/03/malware_45656768.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Kernel-memory-leaking Intel processor design flaw forces Linux, Windows redesign
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/01/04/intel_amd_arm_cpu_vulnerability/">
                            <img src="https://regmedia.co.uk/2017/05/21/shocked_couple_screaming_shutterstock.jpg?x=88&amp;y=58&amp;crop=1" alt="Shocked couple scream and clutch their hair" width=88 height=58>
                <h4>Meltdown, Spectre: The password theft bugs at the heart of Intel CPUs
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/01/04/intel_meltdown_spectre_bugs_the_registers_annotations/">
                            <img src="https://regmedia.co.uk/2016/09/02/intel_core_navin_shenoy.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>We translated Intel's crap attempt to spin its way out of CPU security bug PR nightmare
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/01/04/microsoft_windows_patch_meltdown/">
                            <img src="https://regmedia.co.uk/2018/01/04/shutterstock_chernobyl.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Microsoft patches Windows to cool off Intel's Meltdown – wait, antivirus? Slow your roll
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2018/01/05/spectre_flaws_explained/">
                            <img src="https://regmedia.co.uk/2017/11/29/dumpster-fire.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Woo-yay, Meltdown CPU fixes are here. Now, Spectre flaws will haunt tech industry for years
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-falcon class=adu>
            <script>
                show_gpt('ad-falcon');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_datacentre/networks&amp;sz=300x100%7C300x250&amp;tile=4&amp;c=44WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D4%26unitname%3Dwww_mid_mpu%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_datacentre/networks&amp;sz=300x100%7C300x250&amp;tile=4&amp;c=44WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D426unitname%3Dwww_mid_mpu%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


    </div><hr id=story_section_break>
    <div id=boot>
        
        <div id=ad-hawk class=adu>
            <script>show_gpt('ad-hawk');</script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_datacentre/networks&amp;sz=728x90%7C970x90&amp;tile=6&amp;c=66WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D6%26unitname%3Dwww_btm_leader%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_datacentre/networks&amp;sz=728x90%7C970x90&amp;tile=6&amp;c=66WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D6%26unitname%3Dwww_btm_leader%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>
<div id=story-bot-col>
        <div id="read_more_on" class="deploy_aux">
            <h3>More from The Register</h3>
            <div class=stories><div class="story">
                    <a href="/2017/09/18/linux_4_14_rc1_released/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/09/18/golden_linux_penguin_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Golden Linux penguin" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Linux 4.14 'getting very core new functionality' says Linus Torvalds</h4>
                            <div class=standfirst>
                                Memory management wonks, this release is for you. And also you Hyper-V admins
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/01/31/cryptkeeper_cooked/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/01/23/tripping_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Tripping over" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>You're taking the p... Linux encryption app Cryptkeeper has universal password: 'p'</h4>
                            <div class=standfirst>
                                Give 'p's a chance... no?
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/10/03/amber_rudd_still_does_not_understand_encryption/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/07/14/amber_rudd_photograph_by_department_of_energy_and_climate_change.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Home Sec Amber Rudd: Yeah, I don't understand encryption. So what?</h4>
                            <div class=standfirst>
                                Techies! Will you please stop patronising and sneering! ;_;
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/09/26/linux_4_14_rc2/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/09/26/foot_stuck_on_chewing_gum_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Foot stuck in chewing gum" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Latest Linux kernel release candidate was a sticky mess</h4>
                            <div class=standfirst>
                                4.14 rc2 tarball trapped the unwary with missed patch
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/09/01/max_hill_qc_deny_encryption_anonymous_users/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/07/13/crypto_325345456456.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>'Independent' gov law reviewer wants users preemptively identified before they're 'allowed' to use encryption</h4>
                            <div class=standfirst>
                                UK watchdog echoes Home Sec in anti-crypto comments
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/08/31/deputy_ag_rosenstein_calls_to_force_backdoors/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/11/25/digital_keys.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Deputy AG Rosenstein calls for law to require encryption backdoors</h4>
                            <div class=standfirst>
                                If you won't open up conversations, we'll make it a law, says Sessions' #2
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/11/22/linux_4_14_bcache_bug_destroys_data/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/12/01/shutterstock_hard_disk_ice_cold2.jpg?x=198&amp;y=131&amp;crop=1" alt="Frost-covered hard disk. Photo by Shutterstock" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>'Urgent data corruption issue' destroys filesystems in Linux 4.14</h4>
                            <div class=standfirst>
                                Using <code>bcache</code> to speed Linux 4.14? Stop if you want your data to live
                            </div>
                        </div>
                    </a>
                </div><div class="story">
                    <a href="/2017/09/25/home_hub_insecurity/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/03/06/smartthings_devices.jpg?x=198&amp;y=131&amp;crop=1" alt="SmartThings hub and devices" width=198 height=131>
                        </div>
                        <div class=title_standfirst>
                            <h4>Insteon and Wink home hubs appear to have a problem with encryption</h4>
                            <div class=standfirst>
                                Which is to say neither do it
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        


    
        <div id=whitepapers>
            <h3>
                <a href="https://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6104/modern-storage-strategies-for-sql-server?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Modern Storage Strategies for SQL Server</h4>
                <div class=standfirst>
                    The volume of data retained and accessed by today’s organizations is exploding at an unprecedented rate.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6188/using-cloud-deployment-to-jump-start-application-security?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Using cloud deployment to jump start application security</h4>
                <div class=standfirst>
                    The cloud has significantly changed corporate application development.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6158/preparing-for-the-new-owasp?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Preparing For The New OWASP</h4>
                <div class=standfirst>
                    Having the right tools and third-party controls in place can go a long way toward mitigating risk—and speeding development of your application at the same time.
                </div>
            </a>

            <a class=story href="https://whitepapers.theregister.co.uk/paper/view/6101/tegile-intelliflash-bests-nimble-storage-through-architecture-flexibility?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Tegile Intelliflash Bests Nimble Storage Through Architecture Flexibility</h4>
                <div class=standfirst>
                    Tegile IntelliFlash Arrays bring the benefits of all-flash or hybrid storage to nearly any workload.
                </div>
            </a>
        </div><div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a target=_blank href="http://pubads.g.doubleclick.net/gampad/clk?id=4394211586&amp;iu=/6978">Protect your business from Ransomware with Mimecast</a></li>
        <li><a target=_blank href="http://pubads.g.doubleclick.net/gampad/clk?id=4394592908&amp;iu=/6978">Talk to a Mimecast Email Archiving Specialist today</a></li>
        <li><a target=_blank href="http://pubads.g.doubleclick.net/gampad/clk?id=4394211997&amp;iu=/6978">The GDPR deadline is coming. Get your Mimecast GDPR Preparedness Kit</a></li>
        <li><a target=_blank href="http://pubads.g.doubleclick.net/gampad/clk?id=4394592905&amp;iu=/6978">Download Mimecast's report of ESRA tests</a></li>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
</ul>
</div>

            <div id=ad-owl class=adu>
            <script>
                show_gpt('ad-owl');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_datacentre/networks&amp;sz=300x250&amp;tile=5&amp;c=55WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D5%26unitname%3Dwww_btm_mpu%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_datacentre/networks&amp;sz=300x250&amp;tile=5&amp;c=55WlLv5MCoyKkAAJGN5ZEAAABB&amp;t=ct%3Dns%26unitnum%3D5%26unitname%3Dwww_btm_mpu%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>


</div>

<script>facebook_sdk();</script>
    <div id=footer><div class=foot_wrapper>

        <div class="left_block">
            <div class="foot_list alt_colour dcl">
                <h4>About us<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Profile/about_the_register/">Who we are</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/website/">Under the hood</a></li>
                    <li><a href="https://www.theregister.co.uk/about/company/contact/">Contact us</a></li>
                    <li><a target=_blank href="https://situationpublishing.com/home/contact-us/">Advertise with us</a></li>
                </ul>
            </div>

            <div class="foot_list more_us alt_colour dcl">
                <h4>More content<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                    <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                    <li><a href="https://account.theregister.co.uk/alert/?create=1">Alerts</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/">Whitepapers</a></li>
                </ul>
            </div>

            <div class="foot_list what_else alt_colour dcl">
                <h4>Situation Publishing<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_black.svg" class="expand_arrow"></h4>
                <ul>
                    <li><a href="https://www.nextplatform.com/">The Next Platform</a></li>
                    <li><a href="https://continuouslifecycle.london/">Continuous Lifecycle London</a></li>
                    <li><a href="http://www.mcubed.london/">M-cubed</a></li>
                    <li><a href="https://whitepapers.theregister.co.uk/events/list">Webinars</a></li>
                </ul>
            </div>

            <span class="foot_delim"></span>

            <div class="reg_foot">
                <a href="https://situationpublishing.com/" id="sitpub_logo">
                    <img width="132" height="51" alt="Situation Publishing" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/sitpub_footer.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/sitpub_footer.svg">
                </a>
                <p class="foot_desc"><strong>The Register</strong> - Independent news and views for the tech community. Part of Situation Publishing</p>
            </div>
        </div>

        <div class="right_block">
            <div class="newsletter_signup alt_colour dcl">
                <h4>Sign up to our Newsletters</h4>
                <p>Join our daily or weekly newsletters, subscribe to a specific section or set <a href="https://account.theregister.co.uk/alert/?create=1">News alerts</a></p>
                <a class="subscribe_newsletter_button" href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe<img width="7" alt="" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/footer_mob_nav_arrow_white.svg"></a>
            </div>

            <div class="social alt_colour dcl">
                <div id=follow_btns>
                    <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                        <div class="circ">
                            <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
                        </div>
                    </a>
                    <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                        <div class="circ">
                            <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
                        </div>
                    </a>
                    <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target="_blank" class="linkin">
                        <div class="circ">
                            <img width="18" height="18" alt="LinkedIn" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin_white.svg">
                        </div>
                    </a>
                    <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                        <div class="circ">
                            <img width="18" height="18" alt="feeds" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.svg">
                        </div>
                    </a>
                </div>
            </div>
        </div>
        <noscript><img src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>

    </div></div>

    <div id=foot_btm>
        <p>Biting the hand that feeds IT © 1998–2018
</p>
        <div class=foot_btm_links>
            <a href="https://www.theregister.co.uk/Profile/cookies/">Cookies</a>
            <a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a>
            <a href="https://www.theregister.co.uk/Profile/terms_and_conditions_of_use/">Ts&amp;Cs</a>
        </div>
    </div>

    <div id=end_scripts>




        <script>
            googletag.cmd.push(function() { 
                var abt1 = '<img style="position:absolute" src="https://go.theregister.co.uk/k/abt_';
                var abt2 = '" width=1 height=1 alt="">';
                var ch = 0;
                $('.adu').each(function(i) {
                    ch += $(this).height();
                });
                if (ch == 0 && !ad_free()) {
                    $("#footer").append($(abt1 + 'b' + abt2));
                } else {
                    $("#footer").append($(abt1 + 'a' + abt2));
                }
            });
        </script>

        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof RegArticle != 'undefined' ? (RegArticle.pf ? 'p' : (RegArticle.cp ? 'c' : 'a')) : 'i'));
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('send', 'pageview');
        </script>

        <script>
            (function() {
            var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script');
            s.type='text/javascript';
            s.async=true;
            s.src='https://s.dpmsrv.com/dpm_812ed4562d3211363a7b813aa9cd2cf042b63bb2.min.js';
            h.appendChild(s);
            })();
        </script>



    <script>
        $(function() { set_bucket_group(793) });
    </script>
        <div id="fb-root"></div>
    </div>
</div>
</body>
</html>

