<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>Most of 2016's holes had fixes the day we knew about 'em. Did we patch? Did we @£$% • The Register    </title>
    
    <meta property="og:title" content="Most of 2016's holes had fixes the day we knew about 'em. Did we patch? Did we @£$%" />
    <meta property="og:image" content="https://regmedia.co.uk/2016/01/28/adobe_98375778978789.jpg?x=1200&y=794"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/" />
    <meta property="og:description" content="Code red on code-fix rates" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Vulnerability, Secunia, Patching">


    <link rel="canonical" href="https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/"><link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.theregister.co.uk/2017/03/13/patching_sitrep_secunia/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2017/03/13/patching_sitrep_secunia/">
    <script>
        var RegArticle={id:186551,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['vulnerability','Vulnerability'],['secunia','Secunia'],['patching','Patching']],short_url:'http://reg.cx/2shL',cp:0,noads:[],author:'John Leyden',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/7ce262f7737cb811725729d49697045b8da7407a/design.css">

    <style>
        #sec-security a,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/security/headlines.atom" title="The Register: Security section">

    
    <script src="/design_picker/d5ebce2c873ee1e0ed75a97c2aa2b7e3a6d10981/javascript/_.js"></script>
    <script>
      if (Math.floor(Math.random()*100)<90) var Reg__adct = 's-sync';
      else var Reg__adct = 's-async'; 
      if ($.cookie('test_ct') == 's-sync') var Reg__adct = 's-sync';
      if ($.cookie('test_ct') == 's-async') var Reg__adct = 's-async'; 
      if (window.Reg__adct == 's-async') {
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function() {
          var gads = document.createElement("script");
          gads.async = true;
          gads.type = "text/javascript";
          gads.src = "//www.googletagservices.com/tag/js/gpt.js";
          var node = document.getElementsByTagName("script")[0];
          node.parentNode.insertBefore(gads, node);
        })();
      } else {
        document.write('<scr' + 'ipt src="//www.googletagservices.com/tag/js/gpt.js"></scr' + 'ipt>');
      }
    </script>
    
    <script src="https://nir.regmedia.co.uk/?g=c&amp;g=sa&amp;s=c/sec.front"></script>
    
    <script>
      if (window.Reg__adct == 's-async') {
        googletag.cmd.push(function() {
          init_gpt('reg_security/front');
        });
      } else {
        init_gpt('reg_security/front');
      }
    </script>


    <link rel="SHORTCUT ICON" type="image/x-icon" href="/favicon.ico">
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel=apple-touch-icon href="/Design/graphics/icons/vulture_black_60_trans.png">

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="http://www.continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2017">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="http://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-oop-spot class=adu>
        <script>
            show_gpt('ad-oop-spot');
        </script>
    </div>
    
    <div id=ad-ldr-spot class=adu>
        <script>
            show_gpt('ad-ldr-spot');
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=728x90%7C970x90%7C970x250&amp;tile=2&amp;c=22WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D2%26unitname%3Dwww_top_leader%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=728x90%7C970x90%7C970x250&amp;tile=2&amp;c=22WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D2%26unitname%3Dwww_top_leader%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
            </a>
            <a href="https://google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                <img width="18" height="18" alt="G+" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-nav=".front_nav" data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.svg" class=black_vulture>
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.svg" class=white_vulture>
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data_centre">
                Data Center
            </a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/transformation/" id=sec-transformation data-nav=".trans_nav" data-name="Transformation">
                Transformation
            </a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>

            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=front_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li data-name="Alerts">
                        <a href="https://account.theregister.co.uk/alert/?create=1">
                            Alerts
                        </a>
                    </li>
                    <li data-name="Newsletters">
                        <a href="https://account.theregister.co.uk/register/?product=theregister_newsletter">
                            Newsletters
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/japan_toshiba_memory_biz_bidders/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/26/pistol_granny_teaser.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Japan fires shot warning off risky bidders for Toshiba's memory biz – report</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/01/28/adobe_98375778978789.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Most of 2016's holes had fixes the day we knew about 'em. Did we patch? Did we @£$%</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/pure_drops_to_fifth_overtaken_by_ibm/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/17/speed.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Sweet AFA: Pure sees flash of Big Blue as it drops to fifth behind IBM</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/vodafone_to_bring_2100_customer_service_jobs_inhouse/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/12/09/angryphonelady.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Vodafone to bring 2,100 customer service jobs in-house</h5>
                    </a>
                </div>
            </div>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers data-name="Servers">
                        <a href="/data_centre/servers/" title="Enterprise server news, analysis and opinion">
                            Servers
                        </a>
                    </li>
                    <li id=sub-sec-hpc data-name="HPC">
                        <a href="/data_centre/hpc/" title="High Performance Computing news, analysis and opinion">
                            HPC
                        </a>
                    </li>
                    <li id=sub-sec-cloud data-name="Cloud">
                        <a href="/data_centre/cloud/" title="Cloud news, analysis and opinion">
                            Cloud
                        </a>
                    </li>
                    <li id=sub-sec-storage data-name="Storage">
                        <a href="/data_centre/storage/" title="Enterprise Storage news, analysis and opinion">
                            Storage
                        </a>
                    </li>
                    <li id=sub-sec-networks data-name="Networks">
                        <a href="/data_centre/networks/" title="Networks news, analysis and opinion">
                            Networks
                        </a>
                    </li>
                    <li id=sub-sec-virtualization data-name="Virtualisation">
                        <a href="/data_centre/virtualization/" title="Virtualization news, analysis and opinion">
                            Virtualization
                        </a>
                    </li>
                    <li id=sub-sec-bofh data-name="Bofh">
                        <a href="/data_centre/bofh/" title="BOFH">
                            BOFH
                        </a>
                    </li>
                </ul>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/japan_toshiba_memory_biz_bidders/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/26/pistol_granny_teaser.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Japan fires shot warning off risky bidders for Toshiba's memory biz – report</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/pure_drops_to_fifth_overtaken_by_ibm/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/17/speed.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Sweet AFA: Pure sees flash of Big Blue as it drops to fifth behind IBM</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/layoffs_at_dssd_california/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/14/pink_slips.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>May is the cruellest month - especially for these California storage techies</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/storage_news_roundup/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/28/streetcaller_66990952.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Monday muster point for storage news. Get in here now if juggling terabytes is your trade</h5>
                    </a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/hold_em_dont_fold_em_how_to_bite_bitcoin_pools/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/05/25/bitcoin_punch_card.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Hold 'em, don't fold 'em: how to bite Bitcoin pools</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/repo_roundup/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/17/spanner_hammer_screw_648.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>'Jarvis' brings AI to the Linux command line, without Iron Man</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/linux_4_11_rc2/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/13/linus_torvalds_with_toy_penguins.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Linus Torvalds explains how to Pull without jerking his chain</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/swift_pops_top_10/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/12/taylor_swift_haters.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Favored Swift hits the charts: Now in top 10 programming languages</h5>
                    </a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/01/28/adobe_98375778978789.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Most of 2016's holes had fixes the day we knew about 'em. Did we patch? Did we @£$%</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/thousands_of_nhs_staff_details_lost_in_breach_of_it_contractors_server/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/09/26/nhs_hosptial_photo_by_marbury_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Thousands of NHS staff details lost in breach of IT contractor's server</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/new_aircraft_carrier_jetty_portsmouth/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/13/hms_dragon_fog_portsmouth.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>This is where the Navy will park its 75,000-ton aircraft carriers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/canada_revenue_agency_outage_to_patch_something/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/08/13/dudley_do_right_canadian_mounted_police2.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Canadians can file online tax returns again after emergency outage</h5>
                    </a>
                </div>
            </div>
            <div class=trans_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/09/police_scotland_braced_over_taxpayers_millions_lost_in_bungled_it_project/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/09/police_scotland_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Police Scotland and Accenture were at odds over ill-fated IT project i6</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/07/hpe_on_buying_spree_picks_up_nimble_storage/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/31/acquire_buy_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>HPE gobbles Nimble Storage for $1.2bn</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/21/big_data_part_of_our_core_national_infrastructure_civil_service_chief_exec/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/21/john_manzoni.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Big data should be 'part of UK's core national infrastructure' – Civil Service chief exec</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/17/hyperconverged_market_gets_hypercompetitive/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/25/race_horse.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Hyperconverged market gets hyper-competitive as new riders enter field</h5>
                    </a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/continuous_lifecycle_early_bird_offer_extended_to_friday/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/20/continuous_lifecycle_juggling.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Continuous Lifecycle early bird offer extended to Friday</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/want_a_deal_on_continuous_lifecycle_tickets_act_now/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/14/continuous_lifecycle_london_logo.png?x=198&amp;y=131&amp;crop=1">
                        <h5>Want a deal on Continuous Lifecycle tickets? Act now</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/09/poor_code_makes_banks_insecure_report/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/10/fiancial_results_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Devs bashing out crappy code is making banks insecure – report</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/08/continuous_lifecycle_just_days_till_early_bird_tickets_fly_off_the_menu/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/01/24/view_qe_ii.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Continuous Lifecycle: Just days till early bird tickets fly off the menu</h5>
                    </a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy data-name="Policy">
                        <a href="/business/policy/" title="Policy News, analysis and opinion">
                            Policy
                        </a>
                    </li>
                    <li id=sub-sec-channel data-name="The Channel">
                        <a href="/business/channel/" title="The Channel news, analysis and opinion">
                            The Channel
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/vodafone_to_bring_2100_customer_service_jobs_inhouse/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/12/09/angryphonelady.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Vodafone to bring 2,100 customer service jobs in-house</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/lloyds_to_outsource_2000_staff_in_ibm_deal/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/23/shutterstock_flick.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Lloyds to outsource 2,000 staff in IBM deal</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/home_office_warns_staff_not_to_tweet_negative_trump_posts/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/12/12/trump.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Home Office warns tech staff not to tweet negative Donald Trump posts</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/cloudera_set_for_41bn_ipo_this_year_say_reports/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/15/sparks_image_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cloudera set for $4.1bn IPO this year – reports</h5>
                    </a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/bbc_partners_itv_and_launches_long_awaited_us_svod/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/28/doctor_who_zygon_invasion_4.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>BBC hooks up with ITV, launches long awaited US subscription VoD</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/08/huaweis_just_changed_the_way_youll_use_android/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/02/android_toys_648.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Huawei's just changed the way you'll use Android</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/07/2017_business_pc_guide/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/11/16/hp_mini_z3_workstation.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Shopping for PCs? Ding, dong, the Dock is dead in 2017's new models</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/06/smart_meters_prove_dim/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/06/shutterstock_meter.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Watt the f... Dim smart meters caught simply making up readings</h5>
                    </a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-spb data-name="SPB">
                        <a href="/science/special_projects_bureau/">
                            SPB
                        </a>
                    </li>
                    <li id=sub-sec-geek data-name="Geeks_guide">
                        <a href="/science/geeks_guide/">
                            Geek's Guide
                        </a>
                    </li>
                </ul>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/frbs_interstellar_craft/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/10/harvard_smithsonian_photon_craft.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>If fast radio bursts really are revving up interstellar sailcraft, here's the maths</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/09/spacex_falcon_9_satellite_launch/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/11/gwynne_shotwell.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>What went up, Musk come down again: SpaceX to blast sat into orbit with used rocket</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/09/nasas_atomchiller_ready_to_fly_to_the_iss/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/09/cal_concept_648.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>NASA's atom-chiller ready to fly to the ISS</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/08/blue_origin_eutelsat/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/08/new_glenn.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Your Amazon order is confirmed: Eutelsat via Blue Origin. Estimated delivery date: 2022</h5>
                    </a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence data-name="Artificial Intelligence">
                        <a href="/emergent_tech/artificial_intelligence/" title="Artificial Intelligence">
                            Artificial Intelligence
                        </a>
                    </li>
                    <li id=sub-sec-internet-of-things data-name="Internet of Things">
                        <a href="/emergent_tech/internet_of_things/" title="Internet of Things">
                            Internet of Things
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/machine_learning_system_to_detect_guns_in_videos/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/12/21/james_bond_gun_gadget.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Is that a phone in your hand – or a gun? This neural network reckons it has it all figured out</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/11/autobot_makers_sued_over_technicians_death/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/27/shutterstock_car_manufacturer.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Family of technician slain by factory robot sues everyone involved</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/touchy_side_of_robotes/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/09/robot_hand_human_handshake_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Get a GRIP! Robolution ain't happening until TOUCH is cracked</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/deepmind_system_to_protect_medical_data/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/09/hospital.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>DeepMind. Blockchain. Medical records. Google. AI – wow, we just won machine learning bingo!</h5>
                    </a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob data-name="Verity_stob">
                        <a href="/bootnotes/stob/" title="Verity Stob">
                            Verity Stob
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/13/internet_of_dildos_firm_3_75m_privacy_lawsuit/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/03/13/shutterstock_cellphone_in_bed.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Smart sex toys firm coughs up $3.75m in privacy lawsuit</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/cold_callers_illegally_sold_aussie_farmers_1700_years_worth_of_printer_ink/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/29/old-farmer.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cold callers illegally sold Aussie farmers 1,700 years worth of printer ink</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/lawyer_defending_arsonist_flees_court_with_own_pants_on_fire/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/05/01/gushing_fire_hyrdant_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Lawyer defending arson suspect flees court with pants on fire</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/03/10/spanish_priest_apologises_for_dressing_up_as_hugh_hefner/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/23/priest_image_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Repentant priest from Cuntis sorry he dressed as Hugh Hefner</h5>
                    </a>
                </div>
            </div>
        </div>
    </div>





    <div id=story_rhs_more>
        <div id=tags>
            <h4>More like this</h4>
            <ul>
                <li>
                    <a href="/Tag/vulnerability">Vulnerability</a>
                </li>
                <li>
                    <a href="/Tag/secunia">Secunia</a>
                </li>
                <li>
                    <a href="/Tag/patching">Patching</a>
                </li>
            </ul>
        </div>

    </div>


        <div id="crumb_trail">
            
            <a href="/security/" class="dcl sub_sec">
                <h4>Security</h4>
            </a>
                    </div>

    <div id=main-col>
        <div id="article"  data-cat='news'>

            <div class="article_head ">
                
                <h1>Most of 2016's holes had fixes the day we knew about 'em. Did we patch? Did we @£$%</h1>
                
                <h2>Code red on code-fix rates</h2>
                

                            <img src="https://regmedia.co.uk/2016/01/28/adobe_98375778978789.jpg?x=648&amp;y=348&amp;crop=1" alt="" width=648 height=348 class="article_img">

    <div id=social_btns class="alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/&title=Most%20of%202016%27s%20holes%20had%20fixes%20the%20day%20we%20knew%20about%20%27em.%20Did%20we%20patch%3F%20Did%20we%20%40%C2%A3%24%25" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/reddit.png srcset=/Design/graphics/icon/reddit.svg alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=Most%20of%202016%27s%20holes%20had%20fixes%20the%20day%20we%20knew%20about%20%27em.%20Did%20we%20patch%3F%20Did%20we%20%40%C2%A3%24%25&amp;url=https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/twitter.png srcset=/Design/graphics/icon/twitter.svg alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/facebook.png srcset=/Design/graphics/icon/facebook.svg alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2017/03/13/patching_sitrep_secunia/&amp;title=Most%20of%202016%27s%20holes%20had%20fixes%20the%20day%20we%20knew%20about%20%27em.%20Did%20we%20patch%3F%20Did%20we%20%40%C2%A3%24%25&amp;summary=Code%20red%20on%20code-fix%20rates" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/linkedin_alt.png srcset=/Design/graphics/icon/linkedin_alt.svg alt="linkedin">
            </div>
        </a>
    </div>


                <div class="byline">
                    
                    <span class="dateline">
                        13 Mar 2017 at 15:28,
                    </span>
                    
                    
                        <a href="/Author/2578" title="Read more by this author" class="alt_colour dcl">John Leyden</a>
                    
                    <script>tweet_btn()</script>
                </div>
            </div>
            <div id="body">
                
                <p>Patching rates went down in 2016 despite an increase in availability of security patches, according to a new study out today.</p>
                <p>Last year Secunia Research at Flexera Software recorded a total of 17,147 vulnerabilities in 2,136 products from 246 vendors.</p>
                <div class="article_side_content not_moved">
                    <div id="article-mpu-container">

                    </div>
                </div>
                
                <p>Even though a big majority (81 per cent) of all vulnerabilities had patches on the day of disclosure there was a decrease in patching rates. This is a clear indicator that the software supply chain is broken, according to security researchers.</p>
                <p>The rate of unpatched PDF Readers is very high, according to Secunia. Three in four (75 per cent) of its private users ran unpatched versions of Adobe Reader in 2016, despite a plethora of available patches.</p>
                <p>Other findings in the Vulnerability Review 2017 confirm trends from previous years: The number of zero-day vulnerabilities (22) was a bit lower than the 26 recorded in 2015.</p>
                <p>The split between vulnerabilities in Microsoft and non-Microsoft products in the 50 most popular applications on private PCs is at 22.5 per cent and 77.5 per cent.</p>
                <p>Last year 713 vulnerabilities were discovered in the five most popular browsers (Google Chrome, Mozilla Firefox, Internet Explorer, Opera and Safari). That is a 27.5 per cent decrease from 2015. ®</p>
                
            </div>


            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20Most%20of%202016%27s%20holes%20had%20fixes%20the%20day%20we%20knew%20about%20%27em.%20Did%20we%20patch%3F%20Did%20we%20%40%C2%A3%24%25&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2017/03/13/patching_sitrep_secunia/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/1/2017/03/13/patching_sitrep_secunia/">
                        <span>2</span>
                        Comments
                    </a>
                </div>
            
            </div>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>

            <div class=row>
                <div class="story">
                    <a href="/2017/02/16/xen_project_wants_permission_to_reveal_fewer_vulnerabilities/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/01/28/xen_project_logo.jpg?x=198&amp;y=131&amp;crop=1" alt="Xen project logo" width=198 height=131>
                        </div>
                        <h4>Xen Project wants permission to reveal fewer vulnerabilities</h4>
                        <div class=standfirst>
                            <span class=trailer>Poll</span>
                            Should bugs that don't expose user data be left alone, saving time and effort?
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                27 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2017/01/20/ge_scada_vulns/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/05/05/scada_98579864764587645.jpg?x=198&amp;y=131&amp;crop=1" alt="image byemo http://www.shutterstock.com/gallery-2659924p1.html" width=198 height=131>
                        </div>
                        <h4>General Electric plays down industrial control plant vulnerabilities</h4>
                        <div class=standfirst>
                            Only a local hacker in a facility would be able to run an attack
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                21 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2017/03/08/cia_hacking_tool_dump_vuln_disclosure_debate/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/03/07/shutterstock_cyber_spy_hacker.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>CIA hacking dossier leak reignites debate over vulnerability disclosure</h4>
                        <div class=standfirst>
                            Spy agencies more interested in stockpiling bugs than closing the gaps
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                21 Comments
                            </div>
                        </div>
                    </a>
                </div>
            </div>
            <div class=row>
                <div class="story">
                    <a href="/2016/10/25/joomla_readies_patch_for_core_vulnerability_so_critical_it_isnt_talking/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/02/04/dr_strangelove.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>Joomla! readies patch for core vulnerability so critical it isn't talking</h4>
                        <div class=standfirst>
                            Patch to drop 1400 UTC, Tuesday. And the haste of its release suggests this is scary
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                11 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2016/03/21/secunia_vuln_report/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/03/21/shutterstock_zeros.jpg?x=198&amp;y=131&amp;crop=1" alt="Bread/pretzels in the shape of zeros tumble out of a paper packet. photo via sHutterstock" width=198 height=131>
                        </div>
                        <h4>Zero-day vulnerability count up by, er, zero in 2015</h4>
                        <div class=standfirst>
                            Mind the app, says Secunia as bug count remains stable
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                2 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2016/11/29/cisco_pushes_vulnerability_disclosures_to_90_days/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/02/13/time.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>Cisco stre...tches vulnerability disclosure timeline out to 90 days</h4>
                        <div class=standfirst>
                            Big vendors patch bugs <i>nearly</i> as quick as open source coders
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        

        
        <div id=whitepapers>
            <h3>
                <a href="http://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5072/how-it-can-unlock-the-power-of-modern-collaboration?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>How IT can unlock the power of modern collaboration</h4>
                <div class=standfirst>
                    A Modern Content Platform will integrate and work seamlessly with business-critical apps and systems.
                </div>
            </a>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5474/digital-transformation-in-the-us?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Digital Transformation in the US</h4>
                <div class=standfirst>
                    This IDC InfoBrief examines the drivers, value, challenges, and potential solutions of digital transformation, including Red Hat’s role in simplifying IT operations to achieve DX.
                </div>
            </a>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5577/supermicro-microblade-powers-one-of-the-worlds-most-energy-efficient-data-centers?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Supermicro MicroBlade Powers One of the World’s Most Energy Efficient Data Centers</h4>
                <div class=standfirst>
                    A Fortune 100 Company has deployed over 30,000 Supermicro MicroBlade disaggregated Intel Xeon
                </div>
            </a>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5551/capacity-management-in-the-modern-data-center?td=s-uu">
                <img src="/design_picker/4ee431b84ac2d23c13376f753522acd7ecbb9b47/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Capacity Management in the Modern Data Center</h4>
                <div class=standfirst>
                    Capacity management tools were originally developed to support IBM mainframes.
                </div>
            </a>
        </div>
    </div>

    <div id=right-col>
                            <div id=ad-mu1-spot class=adu>
                        <script>
                            show_gpt('ad-mu1-spot');
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250%7C300x600%7C300x1050&amp;tile=3&amp;c=33WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D3%26unitname%3Dwww_top_mpu%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250%7C300x600%7C300x1050&amp;tile=3&amp;c=33WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D3%26unitname%3Dwww_top_mpu%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2017/03/13/new_aircraft_carrier_jetty_portsmouth/">
                            <img src="https://regmedia.co.uk/2017/03/13/hms_dragon_fog_portsmouth.jpg?x=88&amp;y=58&amp;crop=1" alt="HMS Dragon emerging from the fog at HM Naval Base Portsmouth" width=88 height=58>
                <h4>This is where the Navy will park its 75,000-ton aircraft carriers
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/03/12/malware_infecting_androids_somewhere_in_the_supply_chain/">
                            <img src="https://regmedia.co.uk/2016/08/15/mobile_malware_worm_phishing.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Malware infecting Androids somewhere in the supply chain
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/03/13/linux_4_11_rc2/">
                            <img src="https://regmedia.co.uk/2017/03/13/linus_torvalds_with_toy_penguins.jpg?x=88&amp;y=58&amp;crop=1" alt="Linus Torvalds with toy penguins" width=88 height=58>
                <h4>Linus Torvalds explains how to Pull without jerking his chain
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/03/13/home_office_warns_staff_not_to_tweet_negative_trump_posts/">
                            <img src="https://regmedia.co.uk/2016/12/12/trump.jpg?x=88&amp;y=58&amp;crop=1" alt="Trump" width=88 height=58>
                <h4>Home Office warns tech staff not to tweet negative Donald Trump posts
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/03/13/repo_roundup/">
                            <img src="https://regmedia.co.uk/2015/06/17/spanner_hammer_screw_648.jpg?x=88&amp;y=58&amp;crop=1" alt="Hammer, spanner and screw" width=88 height=58>
                <h4>'Jarvis' brings AI to the Linux command line, without Iron Man
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-btn-spot class=adu>
            <script>
                show_gpt('ad-btn-spot');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x100%7C300x250&amp;tile=4&amp;c=44WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D4%26unitname%3Dwww_mid_mpu%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x100%7C300x250&amp;tile=4&amp;c=44WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D426unitname%3Dwww_mid_mpu%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

        <div id=ad-mu2-spot class=adu>
            <script>
                show_gpt('ad-mu2-spot');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=300x250&amp;tile=5&amp;c=55WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D5%26unitname%3Dwww_btm_mpu%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=300x250&amp;tile=5&amp;c=55WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D5%26unitname%3Dwww_btm_mpu%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>



        <div id=spotlight>
            <h3>Spotlight</h3>
            <a href="https://www.theregister.co.uk/2017/03/10/mac_address_randomization/" class="story">
                            <img src="https://regmedia.co.uk/2017/03/09/shutterstock_phones.jpg?x=88&amp;y=47&amp;crop=1" alt="" width=298 height=160 title="Analysis: Security flaws smash worthless privacy protection" data-stand_url="https://regmedia.co.uk/2017/03/09/shutterstock_phones.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>MAC randomization: A massive failure that leaves iPhones, Android mobes open to tracking</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/03/08/next_generation_security_is_mostly_hype/" class="story">
                            <img src="https://regmedia.co.uk/2016/07/18/ruby_slippers_from_wizard_of_oz.jpg?x=88&amp;y=47&amp;crop=1" alt="Ruby slippers from wizard of Oz" width=298 height=160 title="Sysadmin blog: Backup software – your best friend" data-stand_url="https://regmedia.co.uk/2016/07/18/ruby_slippers_from_wizard_of_oz.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Next Generation Security: No, Dorothy, there is no magic wand</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/03/01/speaking_in_tech_episode_250/" class="story">
                            <img src="https://regmedia.co.uk/2017/03/01/shutterstock_myspace.jpg?x=88&amp;y=47&amp;crop=1" alt="Myspace screengrab.  Editorial credit: thelefty / Shutterstock.com " width=298 height=160 title="Podcast: Gang discuss PoisonTap, SHA-1 and get a how-to on hacking" data-stand_url="https://regmedia.co.uk/2017/03/01/shutterstock_myspace.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Speaking in Tech: A chat with Web 2.0 MySpace worm dude Samy Kamkar</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/02/14/reg_guide_to_data_security_when_entering_us/" class="story">
                            <img src="https://regmedia.co.uk/2017/02/10/passport.jpg?x=88&amp;y=47&amp;crop=1" alt="Passport" width=298 height=160 title="Summary: You're (mostly) screwed without preparation" data-stand_url="https://regmedia.co.uk/2017/02/10/passport.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>The Register's guide to protecting your data when visiting the US</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/02/13/ai_agav_marketing_confusion_opinion/" class="story">
                            <img src="https://regmedia.co.uk/2016/10/06/ai.jpg?x=88&amp;y=47&amp;crop=1" alt="AI" width=298 height=160 title="Opinion: Vendors stuff jargon into antivirus marketing mix" data-stand_url="https://regmedia.co.uk/2016/10/06/ai.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Despite the spiel, we're still some decades from true anti-malware AI</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/02/08/honeypots_feature_and_how_to_guide/" class="story">
                            <img src="https://regmedia.co.uk/2017/02/07/honeypot_897634976454.jpg?x=88&amp;y=47&amp;crop=1" alt="Image by Bel Ka https://www.shutterstock.com/it/g/bel_ka" width=298 height=160 title="Feature: You catch more crooks with honey than vinegar" data-stand_url="https://regmedia.co.uk/2017/02/07/honeypot_897634976454.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Honeypots: Free psy-ops weapons that can protect your network before defences fail</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/02/01/nation_state_election_hacking/" class="story">
                            <img src="https://regmedia.co.uk/2017/01/31/shutterstock_558240034.jpg?x=88&amp;y=47&amp;crop=1" alt="MOSCOW, RUSSIA, JANUARY 2017: Russian traditional toy - Matryoshka with a portrait of Putin and Trump. showcase souvenir kiosk Editorial credit: dimbar76 / Shutterstock, Inc." width=298 height=160 title="Feature: Ah, kids today! Nope, nope, this is governments we're talking about" data-stand_url="https://regmedia.co.uk/2017/01/31/shutterstock_558240034.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Cyber-spying, leaking to meddle in foreign politics is the New Normal</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/01/12/kaymera_hardened_pixel_smartphone/" class="story">
                            <img src="https://regmedia.co.uk/2017/01/12/karmera_secured_pixel_phone2_photo_by_kaymera.jpg?x=88&amp;y=47&amp;crop=1" alt="Karmera secured Pixel phone photo2 by Kaymera" width=298 height=160 title="Kaymera: building on shoulders of a giant, claim" data-stand_url="https://regmedia.co.uk/2017/01/12/karmera_secured_pixel_phone2_photo_by_kaymera.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Security hardened, pah! Expert doubts Kaymera's mighty Google's Pixel</h4>
            </a>
        </div>

<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter"><strong>Get The Register's Headlines in your inbox daily - quick signup!</strong></a></li>
        <li><a target=_blank href="http://pubads.g.doubleclick.net/gampad/clk?id=117852219&amp;iu=/6978">New from Avere - Cloud-Enabled Data Center for Dummies. Download now</a></li>
        <li><a target=_blank href="http://forms.theregister.co.uk/studies/s201701/v2?td=tl"><strong>Just how important is flash storage in business? Make you voice heard.</strong></a></li>
</ul>
</div>

    </div>
    <div id=boot>
        
        <div id=ad-tlr-spot class=adu>
            <script>show_gpt('ad-tlr-spot');</script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_security/front&amp;sz=728x90%7C970x90&amp;tile=6&amp;c=66WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D6%26unitname%3Dwww_btm_leader%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_security/front&amp;sz=728x90%7C970x90&amp;tile=6&amp;c=66WMbF7MCoyKgAAATqcosAAAAH&amp;t=ct%3Dns%26unitnum%3D6%26unitname%3Dwww_btm_leader%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<script>facebook_sdk();</script>
    <div id=footer>

        <div class="social alt_colour dcl">
            <h4>Follow us</h4>
            <div id=follow_btns>
                <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                    <div class="circ">
                        <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
                    </div>
                </a>
                <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                    <div class="circ">
                        <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
                    </div>
                </a>
                <a href="https://plus.google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                    <div class="circ">
                        <img width="18" height="18" alt="G+" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.svg">
                    </div>
                </a>
                <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                    <div class="circ">
                        <img width="18" height="18" alt="feeds" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.svg">
                    </div>
                </a>
            </div>
        </div>

        <div class="foot_list more_us alt_colour dcl">
            <h4>More content</h4>
            <ul>
                <li><a href="https://account.theregister.co.uk/register/?product=thereg_daily_newsletter">Subscribe to newsletter</a></li>
                <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                <li><a href="https://www.theregister.co.uk/Archive/">Archive</a></li>
                <li><a href="https://whitepapers.theregister.co.uk/events/list">Webcasts</a></li>
            </ul>
        </div>

        <div class="foot_list alt_colour dcl">
            <h4>About us</h4>
            <ul>
                <li><a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a></li>
                <li class=last><a href="https://www.theregister.co.uk/about/company/">Company info</a></li>
                <li><a target=_blank href="http://media.theregister.co.uk/">Advertise with us</a></li>
                <li><a href="https://www.theregister.co.uk/about/company/republishing/">Syndication</a></li>
                <li><a href="https://www.theregister.co.uk/about/company/contact/">Send us news tips</a></li>

            </ul>
        </div>

        <div class=reg_foot>
            <h4><a href="https://www.theregister.co.uk/" class=dcl>The Register</a></h4>
            <div class=copyr>
                Biting the hand that feeds IT © 1998–2017

            </div>
            <div class=foot_desc>
                Independent news, views, opinions and reviews on the latest in the IT industry. Offices in London, San Francisco and Sydney.
            </div>
        </div>
        <noscript><img src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>
    </div>

    <div id=end_scripts>






    <script>
        $(function() {
            if ($('#top_tease').length) {
                var ab_set = {
                    view_tracking:  'true',
                    click_tracking: 'true',
                    click_target:   '#top_tease a.large_story',
                    group:          'B (650 image)',
                    name:           'AB: Toptease 2015'
                };
                track_bucket_user(ab_set);

                var ab_set = {
                    click_tracking: 'true',
                    click_target:   '#top_tease .story_list a',
                    group:          'B (650 image)',
                    name:           'AB: Toptease 2015 (side stories)'
                };
                track_bucket_user(ab_set);

                var ab_set = {
                    click_tracking: 'true',
                    click_target:   '#main-col #index_page .headline_row a',
                    group:          'B (650 image)',
                    name:           'AB: Toptease 2015 (main stories)'
                };
                track_bucket_user(ab_set);
            }
        });
    </script>        <script>
            googletag.cmd.push(function() { 
                var abt1 = '<img src="https://go.theregister.co.uk/k/abt_';
                var abt2 = '" width=1 height=1 alt="">';
                var ch = 0;
                $('.adu').each(function(i) {
                    ch += $(this).height();
                });
                if (ch == 0 && !ad_free()) {
                    $('body #end_scripts').append(abt1 + 'b' + abt2);
                    $('#ad-mu1-spot,#ad-mu2-spot').after('<iframe src="https://dda.regmedia.co.uk/research/mpu.html?20160317" width=300 height=255 frameborder=0 style="border:1px solid #CCC"></iframe>');
                }
                else {
                    $('body #end_scripts').append(abt1 + 'a' + abt2);
                }
            });
        </script>

        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof RegArticle != 'undefined' ? (RegArticle.pf ? 'p' : (RegArticle.cp ? 'c' : 'a')) : 'i'));
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('send', 'pageview');
        </script>

        <script>
            (function() {
            var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script');
            s.type='text/javascript';
            s.async=true;
            s.src='https://s.dpmsrv.com/dpm_812ed4562d3211363a7b813aa9cd2cf042b63bb2.min.js';
            h.appendChild(s);
            })();
        </script>



    <script>
        $(function() { set_bucket_group(291) });
    </script>
        <div id="fb-root"></div>
    </div>
</div>
</body>
</html>

