<!doctype html>
<html lang="en">
<head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
    
    <title>SQL Server on Linux? HELL YES! Linux on Windows 10? Meh • The Register    </title>
    
    <meta property="og:title" content="SQL Server on Linux? HELL YES! Linux on Windows 10? Meh" />
    <meta property="og:image" content="https://regmedia.co.uk/2017/02/08/punching_desk_photo_via_shutterstock.jpg?x=1200&y=794"/>
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/" />
    <meta property="og:description" content="Like GNU running in Windows – outrageous. And pointless" />
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@TheRegister">
    <meta name="news_keywords" content="Microsoft, Linux, Open Source, Cloud">


    <link rel="canonical" href="https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/"><link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/"><link rel="amphtml" href="https://www.theregister.co.uk/AMP/2017/02/09/microsoft_eye_from_the_linux_guy/">
    <script>
        var RegArticle={id:185700,pf:0,af:0,bms:0,cat:'news',ec:[],kw:[['microsoft','Microsoft'],['linux','Linux'],['open source','Open Source'],['cloud','Cloud']],short_url:'http://reg.cx/2s1B',cp:0,noads:[],author:'Scott Gilbertson',vid:0}
    </script>
    <link rel=stylesheet href="https://fonts.googleapis.com/css?family=Arimo:400%7CArimo:700">
<link rel=stylesheet type="text/css" href="/css_picker/default/4c29f6b817c397eb59654b80798150e9dd131e53/design.css">

    <style>
        #sec-software a,
        #sub-sec-none a {
          font-weight: bold;
        }
    </style>
    <link rel=alternate type="application/atom+xml" href="/headlines.atom" title="The Register: whole site">
    <link rel=alternate type="application/atom+xml" href="/software/headlines.atom" title="The Register: Software section">

    
    <script src="/design_picker/092ba9817dc87dca198c4864146157dc6e26efde/javascript/_.js"></script>
    <script>
      if (Math.floor(Math.random()*100)<90) var Reg__adct = 's-sync';
      else var Reg__adct = 's-async'; 
      if ($.cookie('test_ct') == 's-sync') var Reg__adct = 's-sync';
      if ($.cookie('test_ct') == 's-async') var Reg__adct = 's-async'; 
      if (window.Reg__adct == 's-async') {
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function() {
          var gads = document.createElement("script");
          gads.async = true;
          gads.type = "text/javascript";
          gads.src = "//www.googletagservices.com/tag/js/gpt.js";
          var node = document.getElementsByTagName("script")[0];
          node.parentNode.insertBefore(gads, node);
        })();
      } else {
        document.write('<scr' + 'ipt src="//www.googletagservices.com/tag/js/gpt.js"></scr' + 'ipt>');
      }
    </script>
    
    <script src="https://nir.regmedia.co.uk/?g=c&amp;g=sa&amp;s=c/soft.front"></script>
    
    <script>
      if (window.Reg__adct == 's-async') {
        googletag.cmd.push(function() {
          init_gpt('reg_software/front');
        });
      } else {
        init_gpt('reg_software/front');
      }
    </script>


    <link rel="SHORTCUT ICON" type="image/x-icon" href="/favicon.ico">
    <link rel=search href="https://search.theregister.co.uk/">
    <link rel=search type="application/opensearchdescription+xml" title="El Reg Search" href="/Design/page/search.osd">
    <link rel=apple-touch-icon href="/Design/graphics/icons/vulture_black_60_trans.png">

</head>
<body  data-pagetype='Story' data-pagenum=0>
<div id=page>
    <div id=topbar class="alt_colour dcl">
        <div class=login></div>
        <ul>
            <li><a href="http://www.mcubed.london/" target=_blank title="Minds Mastering Machines - The ML and AI Conference">M³</a></li>
            <li><a href="http://www.continuouslifecycle.london" target=_blank title="Continuous Lifecycle London 2017">CLL</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/events/list" title="Webcasts and Events from The Register">Events</a></li>
            <li><a href="https://whitepapers.theregister.co.uk/" title="Whitepapers and tech resources from The Register">Whitepapers</a></li>
            <li><a href="http://www.nextplatform.com/" title="High-end computing in-depth">The Next Platform</a></li>
        </ul>
    </div>
        <div id=ad-oop-spot class=adu>
        <script>
            show_gpt('ad-oop-spot');
        </script>
    </div>
    
    <div id=ad-ldr-spot class=adu>
        <script>
            show_gpt('ad-ldr-spot');
        </script>
        <noscript>
            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=728x90%7C970x90%7C970x250&amp;tile=2&amp;c=22WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D2%26unitname%3Dwww_top_leader%26pos%3Dtop%26test%3D0" target="_blank">
                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=728x90%7C970x90%7C970x250&amp;tile=2&amp;c=22WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D2%26unitname%3Dwww_top_leader%26pos%3Dtop%26test%3D0" alt="">
            </a>
        </noscript>
    </div>

    <div id=masthead>
        <a href="https://www.theregister.co.uk/" id=logo>
            <img src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/reg_logo.svg" width=330 height=63 alt="The Register® — Biting the hand that feeds IT">
        </a>
        <div id=follow_btns_top>
            <a class=tweet_link href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank>
                <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
            </a>
            <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
            </a>
            <a href="https://google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                <img width="18" height="18" alt="G+" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.svg">
            </a>
            <a href="https://www.linkedin.com/company/the-register" title="Follow us on LinkedIn" target=_blank class=linkin>
                <img width="18" height="18" alt="LinkedIn" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/linkedin.svg">
            </a>
        </div>
    </div>
        <div id=site_nav class=static>
        <nav id=top_nav class=dcl>
            <a href="https://www.theregister.co.uk/" class=nav_vulture data-nav=".front_nav" data-name="Home">
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture.svg" class=black_vulture>
                <img width="21" height="17" alt="Home" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/vulture_white.svg" class=white_vulture>
            </a>
            <a href="/data_centre/" id=sec-data-centre data-nav=".data_cent_nav" data-name="Data_centre">
                Data Center
            </a>
            <a href="/software/" id=sec-software data-nav=".software_nav" data-name="Software">
                Software
            </a>
            <a href="/security/" id=sec-security data-nav=".sec_nav" data-name="Security">
                Security
            </a>
            <a href="/transformation/" id=sec-transformation data-nav=".trans_nav" data-name="Transformation">
                Transformation
            </a>
            <a href="/devops/" id=sec-devops data-nav=".devops_nav" data-name="DevOps">
                DevOps
            </a>
            <a href="/business/" id=sec-business data-nav=".bus_nav" data-name="Business">
                Business
            </a>
            <a href="/personal_tech/" id=sec-personal_tech data-nav=".pers_nav" data-name="Personal Tech">
                Personal Tech
            </a>
            <a href="/science/" id=sec-science data-nav=".sci_nav" data-name="Science">
                Science
            </a>
            <a href="/emergent_tech/" id=sec-emergent-tech data-nav=".emer_nav" data-name="Emergent Tech">
                Emergent Tech
            </a>
            <a href="/bootnotes/" id=sec-bootnotes data-nav=".bootnotes_nav" data-name="Bootnotes">
                Bootnotes
            </a>

            <a href="https://search.theregister.co.uk/" class=nav_search data-name="Search">
                <img class="black_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search.svg">
            </a>
        </nav>
        <form id=search_form action="https://search.theregister.co.uk/" method=GET>
            <input type=text name=q id=q placeholder="Search site">
            <img class="white_search_icon" width="18" height="18" alt="search" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icons/search_white.svg">
        </form>
        <div id=nav_pop>
            <div class=front_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li data-name="Alerts">
                        <a href="https://account.theregister.co.uk/alert/?create=1">
                            Alerts
                        </a>
                    </li>
                    <li data-name="Newsletters">
                        <a href="https://account.theregister.co.uk/register/?product=theregister_newsletter">
                            Newsletters
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/punching_desk_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>SQL Server on Linux? HELL YES! Linux on Windows 10? Meh</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/hurding_pets_to_cattle_in_the_cloud/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/surprised_cat_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cattle that fail, not pets that purr – the future of servers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/memory1_makes_its_mark_on_spark/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/15/sparks_image_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Memory1: All right, Sparky, here's the deal: We've sorted your DRAM runtimes</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/euro_bloc_blocks_geoblocks/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/27/europe.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Euro bloc blocks streaming vid geoblocks</h5>
                    </a>
                </div>
            </div>
            <div class=data_cent_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-servers data-name="Servers">
                        <a href="/data_centre/servers/" title="Enterprise server news, analysis and opinion">
                            Servers
                        </a>
                    </li>
                    <li id=sub-sec-hpc data-name="HPC">
                        <a href="/data_centre/hpc/" title="High Performance Computing news, analysis and opinion">
                            HPC
                        </a>
                    </li>
                    <li id=sub-sec-cloud data-name="Cloud">
                        <a href="/data_centre/cloud/" title="Cloud news, analysis and opinion">
                            Cloud
                        </a>
                    </li>
                    <li id=sub-sec-storage data-name="Storage">
                        <a href="/data_centre/storage/" title="Enterprise Storage news, analysis and opinion">
                            Storage
                        </a>
                    </li>
                    <li id=sub-sec-networks data-name="Networks">
                        <a href="/data_centre/networks/" title="Networks">
                            Networks
                        </a>
                    </li>
                    <li id=sub-sec-virtualization data-name="Virtualisation">
                        <a href="/data_centre/virtualization/" title="Virtualization
 news, analysis and opinion">
                            Virtualization

                        </a>
                    </li>
                    <li id=sub-sec-bofh data-name="Bofh">
                        <a href="/data_centre/bofh/" title="BOFH">
                            BOFH
                        </a>
                    </li>
                </ul>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/hurding_pets_to_cattle_in_the_cloud/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/surprised_cat_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Cattle that fail, not pets that purr – the future of servers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/memory1_makes_its_mark_on_spark/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/15/sparks_image_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Memory1: All right, Sparky, here's the deal: We've sorted your DRAM runtimes</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/microsoft_patent_troll_protection_scheme/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/09/trolls.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Microsoft touts cheap-ish anti-patent troll protection shield for Azure-hosted devs</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/toshiba_mn_drive/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/horse_jumping_gap.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Tosh's new workhorse drive: Not too desktop, not too enterprise</h5>
                    </a>
                </div>
            </div>
            <div class=software_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/punching_desk_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>SQL Server on Linux? HELL YES! Linux on Windows 10? Meh</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/itut_pushes_start_on_new_codec_standard/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/08/25/squeezed.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>ITU-T wants video sizes to halve again by 2020</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/vivaldi_browser_one_point_seven/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/01/26/vivaldi_pageactions_sepia_3dfx_w650px.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Vivaldi and me: Just browsing? Nah, I'm sold</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/android_february_2017_patches/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/03/sad_android.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Android's February fix-fest flings 58 patches</h5>
                    </a>
                </div>
            </div>
            <div class=sec_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/filesilo_lost_plaintext_passwords/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/06/03/dumb_and_dumber_648.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Mag publisher Future stored your FileSilo passwords in plaintext. Then hackers hit</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/f5s_bigip_leaks_lots_of_little_chunks_of_memory/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/10/18/infosec_87464545.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>F5's Big-IP leaks little chunks of memory, even SSL session IDs</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/dhs_wants_enhanced_digital_vetting/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/joe_kelly.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Want to come to the US? Be prepared to hand over your passwords if you're on Trump's hit list</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/us_grand_jury_indicts_harold_martin_nsa/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/10/05/shutterstock_top_secretz.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Ex-NSA contractor Harold Martin indicted: He spent 'up to 20 years stealing top-secret files'</h5>
                    </a>
                </div>
            </div>
            <div class=trans_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/06/2017_data_center_year_in_review/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/03/ms_bing_data_center.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Wow, what an incredible 12 months: 2017's data center year in review</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/02/mnos_will_lose_5g_rewards_to_new_entrants_if_they_will_not_share_networks/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/09/23/radio_signal.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>MNOs will lose 5G rewards to new entrants if they will not share networks</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/01/31/what_might_hpe_do_with_simplivity/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/02/18/cloud-storage-arrays.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>What might HPE do with SimpliVity?</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/01/30/byok_encryption_public_cloud/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/01/18/infosec_985645646.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Study shows 'BYOK' can unlock public cloud market for businesses</h5>
                    </a>
                </div>
            </div>
            <div class=devops_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/devops_ufo/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/dynatrace_ufo_devops_lamp.gif?x=198&amp;y=131&amp;crop=1">
                        <h5>To do DevOps right, beam down a UFO says Dynatrace</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/what_was_that_microsoft_previews_custom_speech_service_for_better_jargon_detection/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/customspeech.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Eee by gum! Aye up, Microsoft, what's tha y' got? Cloud for accents?</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/mapr_seeking_devops_love_with_stateful_storage_access_for_docker_containers/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/28/hug.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>MapR seeks DevOps love: Stateful storage WLTM Docker containers</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/dynatrace_talking_systems_administration/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/small_robots_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>GitHubbers invited to hack Davis, the microservices chat bot</h5>
                    </a>
                </div>
            </div>
            <div class=bus_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-policy data-name="Policy">
                        <a href="/business/policy/" title="Policy News, analysis and opinion">
                            Policy
                        </a>
                    </li>
                    <li id=sub-sec-channel data-name="The Channel">
                        <a href="/business/channel/" title="The Channel news, analysis and opinion">
                            The Channel
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/euro_bloc_blocks_geoblocks/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/10/27/europe.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Euro bloc blocks streaming vid geoblocks</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/unusually_sincere_ceo_letter/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/11/26/prison_jailbreak_freedom_shutterstock.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Departing Autodesk CEO says he became dumber and less funny the moment he quit</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/nbn_tops_au400_million_halfyear_revenue/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/03/21/nbn_mount_cotton.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>nbn™ tops AU$400 million half-year revenue</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/ibm_workfromhome_cull_companywide/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/shutterstock_ibm_ceo.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Big blues: IBM's remote-worker crackdown is company-wide, including its engineers</h5>
                    </a>
                </div>
            </div>
            <div class=pers_nav>
                <div class=sub_nav></div>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/fitbit_jawbone_fights/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/08/16/shutterstock_cash_briefcase.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Jawbone leans over, whispers: Psst, guess who's in a criminal probe? Yes, it's Fitbit</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/samsung_battery_factory_catches_fire/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/samsung_fire.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Samsung battery factory bursts into flame in touching Note 7 tribute</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/android_wear_is_in_the_last_chance_saloon/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/smartwatch_graphic_sstock_w648px.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Android Wear: The bloatware that turned into gloatware</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/new_android_release_battery_drainer/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/07/17/android_tv_os_updating.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Google gets smooth early Android releases. OEMs are struggling</h5>
                    </a>
                </div>
            </div>
            <div class=sci_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-spb data-name="SPB">
                        <a href="/science/special_projects_bureau/">
                            SPB
                        </a>
                    </li>
                    <li id=sub-sec-geek data-name="Geeks_guide">
                        <a href="/science/geeks_guide/">
                            Geek's Guide
                        </a>
                    </li>
                </ul>

                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/09/new_orleans_tornado_trashes_nasa_history/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/nasa_wrecked_tank.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Vintage Space Shuttle fuel tank destroyed by New Orleans tornado</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/first_white_dwarf_pulsar_spotted/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/pulsar.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Pulsating white dwarf described as a 'dynamo' found, no, not in the back pages, 380 LY away</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/vaping_lowers_cancer_risk_study/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/19/shutterstock_vaping.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Vapists rejoice! E-cigs lower cancer risk (if you stop smoking, duh)</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/curiosity_mars_climate_change/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/mars.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>NASA's Curiosity puts cat among the climate pigeons: Lack of CO2 sinks water theory</h5>
                    </a>
                </div>
            </div>
            <div class=emer_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-artificial-intelligence data-name="Artificial Intelligence">
                        <a href="/emergent_tech/artificial_intelligence/" title="Artificial Intelligence">
                            Artificial Intelligence
                        </a>
                    </li>
                    <li id=sub-sec-internet-of-things data-name="Internet of Things">
                        <a href="/emergent_tech/internet_of_things/" title="Internet of Things">
                            Internet of Things
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/students_need_more_ethics_education_to_deal_with_ai_say_experts/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/shutterstock_robot_woman.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Teach undergrads ethics to ensure future AI is safe – compsci boffins</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/06/police_drones_rob_surgeons_and_chatbot_civil_servants_what_could_go_wrong/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/05/27/shutterstock_nightmare.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Police drones, robo surgeons and chatbot civil servants. What could go wrong?</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/03/hpe_micro_data_centre_edge_computing_iot/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2015/11/25/hpe_wood_street.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Don't let cloud slurp all your data. Chew it on the edge, says HPE</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/03/ai_challenge_to_help_fight_fake_news/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2016/04/28/editor_369751682.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Humanity needs you... to build an AI bot that can finger rotten headlines</h5>
                    </a>
                </div>
            </div>
            <div class=bootnotes_nav>
                <ul class="sub_nav alt_colour dcl">
                    <li id=sub-sec-stob data-name="Verity_stob">
                        <a href="/bootnotes/stob/" title="Verity Stob">
                            Verity Stob
                        </a>
                    </li>
                </ul>


                <div class=story_row>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/reg_readers_david_hockney_mockney_masthead/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/reg_masthead_hockney_648px.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>The best of <i>Reg</i> readers' David Hockney-style logo redesigns</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/08/final_concorde_journey/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/08/concorde_at_aerospace_bristol_museum.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Last Concorde completes last journey, at maybe Mach 0.02</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/raf_voyager_zz333_flt_lt_andrew_townshend_court_martial/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/raf_airbus_voyager_a330_crown_copyright.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>RAF pilot sent jet into 4,000ft plummet by playing with camera, court martial hears</h5>
                    </a>
                    <a class="story_link" href="https://www.theregister.co.uk/2017/02/07/telcos_spam_filter_erases_uber_from_canadian_vocabulary/">
                            <img src="https://regmedia.co.uk/2016/04/14/dl.gif" alt="" width=198 height=131 data-delay_url="https://regmedia.co.uk/2017/02/07/mountie.jpg?x=198&amp;y=131&amp;crop=1">
                        <h5>Canadian telco bans a little four-letter dirty word from texts: U B E R</h5>
                    </a>
                </div>
            </div>
        </div>
    </div>





    <div id=story_rhs_more>
        <div id=tags>
            <h4>More like this</h4>
            <ul>
                <li>
                    <a href="/Tag/microsoft">Microsoft</a>
                </li>
                <li>
                    <a href="/Tag/linux">Linux</a>
                </li>
                <li>
                    <a href="/Tag/open%20source">Open Source</a>
                </li>
                <li>
                    <a href="/Tag/cloud">Cloud</a>
                </li>
            </ul>
        </div>

    </div>


        <div id="crumb_trail">
            
            <a href="/software/" class="dcl sub_sec">
                <h4>Software</h4>
            </a>
                    </div>

    <div id=main-col>
        <div id="article"  data-cat='news'>

            <div class="article_head ">
                
                <h1>SQL Server on Linux? HELL YES! Linux on Windows 10? Meh</h1>
                
                <h2>Like GNU running in Windows – outrageous. And pointless</h2>
                

                            <img src="https://regmedia.co.uk/2017/02/08/punching_desk_photo_via_shutterstock.jpg?x=648&amp;y=348&amp;crop=1" alt="Punching desk photo via Shutterstock" width=648 height=348 class="article_img">

    <div id=social_btns class="alt_colour dcl">
        <a href="https://www.reddit.com/submit?url=https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/&title=SQL%20Server%20on%20Linux%3F%20HELL%20YES%21%20Linux%20on%20Windows%2010%3F%20Meh" target=_blank class=reddit_btn>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/reddit.png srcset=/Design/graphics/icon/reddit.svg alt="reddit">
            </div>
        </a>
        <a href="https://twitter.com/share?text=SQL%20Server%20on%20Linux%3F%20HELL%20YES%21%20Linux%20on%20Windows%2010%3F%20Meh&amp;url=https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/&amp;via=theregister" class=twit>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/twitter.png srcset=/Design/graphics/icon/twitter.svg alt="Twitter">
            </div>
        </a>
        <div class=faceb>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/facebook.png srcset=/Design/graphics/icon/facebook.svg alt="Facebook">
            </div>
        </div>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/&amp;title=SQL%20Server%20on%20Linux%3F%20HELL%20YES%21%20Linux%20on%20Windows%2010%3F%20Meh&amp;summary=Like%20GNU%20running%20in%20Windows%20%E2%80%93%20outrageous.%20And%20pointless" class=linkedin_social>
            <div class=circ>
                <img width=18 height=18 src=/Design/graphics/icon/linkedin_alt.png srcset=/Design/graphics/icon/linkedin_alt.svg alt="linkedin">
            </div>
        </a>
    </div>


                <div class="byline">
                    
                    <span class="dateline">
                        9 Feb 2017 at 10:02,
                    </span>
                    
                    
                        <a href="/Author/1785" title="Read more by this author" class="alt_colour dcl">Scott Gilbertson</a>
                    
                    <script>tweet_btn()</script>
                </div>
            </div>
            <div id="body">
                
                <p>Once the second biggest enemy of Linux (SCO Group takes top honours), Microsoft is positively giddy about not just supporting Linux but actually building tools that run Linux in Windows and about putting previously Windows-only software on Linux.</p>
                <p>You can run <a href="http://www.theregister.co.uk/2016/04/07/windows_10_with_ubuntu_now_in_public_preview/">Ubuntu inside Windows 10</a>, install CoreOS and Docker containers inside Azure, even fire up SQL Server on <a href="https://www.theregister.co.uk/2017/01/23/microsofts_linux_lovein_continues_with_suse_support_in_sql_server/">SUSE Enterprise Linux</a>.</p>
                <div class="article_side_content not_moved">
                    <div id="article-mpu-container">

                    </div>
                </div>
                
                <p>One thing I haven't heard a lot about is what it's like to actually use these new tools and – more importantly – whether anyone is using them.</p>
                <p>One thing is certain, though. Linux distros are betting that people will.</p>
                <p>First Ubuntu. Red Hat and SUSE Linux followed in rapid succession to support Microsoft's popular SQL Server. That quick pace says at least some aspects of the enterprise are itching to get their hands on SQL Server without giving up their Linux infrastructure.</p>
                <p>All Microsoft's database competitors are available on Linux, but until the recent announcement, SQL Server was not. That meant that if you wanted SQL Server you had to forego Linux, which might mean losing all sorts of other tools. At the very least it meant that SQL Server had a cost above and beyond the financial.</p>
                <p>Now SQL Server is on the major enterprise distros, that non-financial cost is gone. And while open-source supporters might be loath to admit it, SQL Server actually does have some advantages over competing open-source projects. Perhaps the best things about SQL Server is the plethora of tools around it, particularly tools that allow those with little to no SQL knowledge to build powerful databases and run queries without learning how to do table joins. The level of abstraction that SQL Server offers makes it more accessible than many similar tools.</p>
                <p>SQL Server on Linux eliminates the tight coupling with Windows and will most likely end up making Microsoft more money since it provides an inroad for SQL Server in all-Linux enterprise deployments, a place it would have previously been off the table. It also makes it easier to get SQL Server into the largely Linux-based world of container computing.</p>
                <p>There's a lot of hype around container-based computing, but believe it or not, some of that hype is deserved. Containers make it possible to run just about anything anywhere. The underlying operating system becomes largely irrelevant. Red Hat's <a target="_blank" rel="nofollow" href="http://www.projectatomic.io/">Project Atomic</a> provides the best linguistic clue about what this means: right now, containers are the atomic unit of computing.</p>
                <p>Once you have everything you need in individual containers you can deploy them on any platform you want. The only thing that matters is which set of tools you want to use to manage your containers. Microsoft's Azure platform happens to support all the popular choices right now: DC/OS, Docker Swarm and Kubernetes, which makes Azure a compelling option for a very un-Microsoft reason: choice.</p>
                <p>And believe it or not, Azure is actually pretty nice. My experience is limited to a single client, but Azure has been stable, has a wealth of management tools that don't require years of sysadmin experience to use and it supports just about every container management system you want to use. It's every bit as good as AWS and, frankly, it's the only real alternative out there.</p>
                <p>While AWS is a fantastic system, it has a virtual monopoly on cloud-based development, and if you don't think that's bad (because AWS is good) you haven't been working in this field long enough. Azure may well turn out to be the best thing that's happened to the DevOps/sysadmin world if for no other reason than providing meaningful competition for AWS.</p>
                <p>It should be no surprise that Azure has been the object of Microsoft's obsession lately – Microsoft chief executive Satya Nadella had run the server group that now houses Microsoft's cloud infrastructure service.</p>
                <p>Former CEO Steve Ballmer may be gone, but it's clear that his "developers, developers, developers" chant still echoes through the halls of Redmond. Microsoft recognises that it needs top developer tools to give to its top developers. And that's why you can now run Bash inside your Windows 10 install. That gets you a "native" experience in the shell with tools like awk, grep and all the other developer favourites.</p>
                <p>Technically speaking, this is not Linux running in Windows. Linux is a kernel and there's no kernel here. Intrepid hackers have, however, managed to get <a target="_blank" rel="nofollow" href="https://www.reddit.com/r/Windows10/comments/4rsmzp/bash_on_windows_getting_dbus_and_x_server_working/">the bulk of Ubuntu running in Windows</a>. That's not officially supported yet, but clearly the underlying tools make it possible to really run Ubuntu in Windows. The official Bash plus Ubuntu under the hood make it more like GNU running in Windows, which is actually slightly more outrageous from a historical point of view.</p>
                <p>Whatever the case, while I'm not about to suffer Windows 10 on a regular basis, at least now I can use the basic set of Bash tools I'm used to without running a virtual machine, which means everything is faster and there's less frustration.</p>
                <p>Still, every time I use it I can't help wondering, why not just run Ubuntu and put Windows in the virtual machine? Part of me thinks this move was – in addition to a PR play – mostly aimed at Microsoft's own developers.</p>
                <p>The company probably isn't quite ready to hand out laptops running Linux to employees, but it does need those tools available for developers and it also seems to grasp that improving the dev tools in Windows is not good enough. Bring Linux into Windows and your problems are solved.</p>
                <p>There's also the developer mind share to consider. Let's face facts: it's been a long time since anyone really cared about Windows. When was the last time you heard about a hot new technology for Windows that was developed by someone other than Microsoft? When was the last time you heard about a hot new startup building its infrastructure on Windows?</p>
                <p>Even if Windows soldiers on in the established enterprise market, it lost developer mind share and enthusiasm years, if not decades, ago. Azure, though, that does have some of that new hotness around it. That's part of why it already has a significant share of the so-called Infrastructure as a Service market.</p>
                <p>With SQL Server available on Linux and all the basic shell utilities running in Windows 10, many a sysadmin's life just got a whole lot more bearable.</p>
                <p>It does have one big feather to put in its cap, though: Azure is well ahead of Google Cloud Platform and Microsoft is clearly hoping that the Linux-backed announcements over the past year will propel it even closer to Amazon's heels. ®</p>
                
            </div>


            <div id=article_body_btm>
                <div id="tips_or_corrections">
                    <a href="mailto:corrections@theregister.co.uk?subject=%5Bcorrection%5D%20SQL%20Server%20on%20Linux%3F%20HELL%20YES%21%20Linux%20on%20Windows%2010%3F%20Meh&amp;body=re:%20http%3A%2F%2Fwww.theregister.co.uk/2017/02/09/microsoft_eye_from_the_linux_guy/"
                        title="Spotted an error or have a tip? Let us know.">
                        Tips and corrections
                    </a>
                </div>
                
                <div class="comments ">
                    <a class="reg_btn count" title="View comments on this article" href="https://forums.theregister.co.uk/forum/1/2017/02/09/microsoft_eye_from_the_linux_guy/">
                        <span>7</span>
                        Comments
                    </a>
                </div>
            
            </div>
        </div>

        <div id="read_more_on">
            <h3>More from The Register</h3>

            <div class=row>
                <div class="story">
                    <a href="/2017/02/06/desktop_skype_forced_upgrade/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/06/03/dom-joly-ipad.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>Update or shut up: Microsoft's choice for desktop Skypers</h4>
                        <div class=standfirst>
                            Mac and Windows Skype users given until March 1st to modernise themselves
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                52 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2017/01/29/microsofts_cooking_virtual_storage_in_azure/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/01/29/microsoft_azure_2_shutterstock_editorial_use_only.jpg?x=198&amp;y=131&amp;crop=1" alt="Microsoft Azure" width=198 height=131>
                        </div>
                        <h4>Microsoft is cooking virtual storage in Azure</h4>
                        <div class=standfirst>
                            SoftNAS spans on-prem and Azure with virtual NAS, and there's news to come in April
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                6 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2017/01/19/windows_7_sysadmin_certifications_ending/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/04/21/twitter-headmaster.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>Microsoft posts death notices for Windows 7 sysadmin certifications</h4>
                        <div class=standfirst>
                            They'll go in mid-2018. Does that support the 'too insecure for business' message?
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                21 Comments
                            </div>
                        </div>
                    </a>
                </div>
            </div>
            <div class=row>
                <div class="story">
                    <a href="/2016/12/13/microsoft_hub_sales_claim/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2016/12/13/ice_skating_photo_via_shutterstock.jpg?x=198&amp;y=131&amp;crop=1" alt="Ice skating photo via Shutterstock" width=198 height=131>
                        </div>
                        <h4>Microsoft skates over Surface Hub sales data</h4>
                        <div class=standfirst>
                            Multi-touch screen claims
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                5 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2017/02/02/microsofts_device_masterplan_shows_its_still_fighting_apple/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2017/02/02/macvpc.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>Microsoft's device masterplan shows it's still fighting Apple</h4>
                        <div class=standfirst>
                            2-in-1s are all about 'generating customer love'
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                27 Comments
                            </div>
                        </div>
                    </a>
                </div>
                <div class="story">
                    <a href="/2016/10/03/microsoft_azure_sets_up_shop_in_france/">
                        <div class="story_grid_img">
                            <img src="https://regmedia.co.uk/2015/10/15/france.jpg?x=198&amp;y=131&amp;crop=1" alt="" width=198 height=131>
                        </div>
                        <h4>Microsoft Azure sets up shop in France</h4>
                        <div class=standfirst>
                            Bonjour, mes fluffy white amis
                        </div>
                        <div class="time_comments">
                            <div class=comments>
                                22 Comments
                            </div>
                        </div>
                    </a>
                </div>
            </div>
        </div>
        

        <div id=whitepapers>
            <h3>
                <a href="http://whitepapers.theregister.co.uk/" class=dcl>Whitepapers</a>
            </h3>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5391/machine-learning-delivers-better-it-insights?td=s-uu">
                <img src="/Design/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Machine Learning Delivers Better IT Insights</h4>
                <div class=standfirst>
                    Learn how predictive analytics and machine learning can improve application performance.
                </div>
            </a>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5460/gdpr-centralise-unstructured-data-governance-across-on-premises-and-cloud?td=s-uu">
                <img src="/Design/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>GDPR: Centralise Unstructured Data Governance across On-Premises and Cloud</h4>
                <div class=standfirst>
                    CIOs are also struggling to balance their desire for consolidation and centralised management with the need to meet the GDPR deadline and solve the immediate operational challenges.
                </div>
            </a>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5420/cox-automotive-gains-big-data-horsepower-with-red-hat-storage?td=s-uu">
                <img src="/Design/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Cox Automotive gains big data horsepower with Red Hat storage</h4>
                <div class=standfirst>
                    Built an Apache Hadoop cluster to support big data analysis and mining
                </div>
            </a>

            <a class=story href="http://whitepapers.theregister.co.uk/paper/view/5405/development-of-advanced-applications-with-ibm-websphere-application-server-liberty-profile?td=s-uu">
                <img src="/Design/graphics/icon/whitepaper_book.png" alt="PDF Icon" width=55 height=55>
                <h4>Development of advanced applications with IBM websphere application server liberty profile</h4>
                <div class=standfirst>
                    The application serving run time, provided by the full profile, is composed of a wide spectrum of components that are always available in the application server.
                </div>
            </a>
        </div>
    </div>

    <div id=right-col>
                            <div id=ad-mu1-spot class=adu>
                        <script>
                            show_gpt('ad-mu1-spot');
                        </script>
                        <noscript>
                            <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250%7C300x600%7C300x1050&amp;tile=3&amp;c=33WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D3%26unitname%3Dwww_top_mpu%26pos%3Dtop%26test%3D0" target="_blank">
                                <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250%7C300x600%7C300x1050&amp;tile=3&amp;c=33WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D3%26unitname%3Dwww_top_mpu%26pos%3Dtop%26test%3D0" alt="">
                            </a>
                        </noscript>
                    </div>

<div id=hot>
    <h3>Most read</h3>
    <ol>
        <li>
            <a href="https://www.theregister.co.uk/2017/02/08/ibm_no_more_telecommuting/">
                            <img src="https://regmedia.co.uk/2017/02/08/ibm_office.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>IBM's Marissa Mayer moment: Staff ordered to work in one of 6 main offices – or face the axe
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/02/08/kodi_crackdown/">
                            <img src="https://regmedia.co.uk/2017/02/07/woman_holding_usb_stick.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Who's behind the Kodi TV streaming stick crackdown?
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/02/07/raf_voyager_zz333_flt_lt_andrew_townshend_court_martial/">
                            <img src="https://regmedia.co.uk/2017/02/07/raf_airbus_voyager_a330_crown_copyright.jpg?x=88&amp;y=58&amp;crop=1" alt="An RAF Airbus Voyager tanker-cum-troop transport aircraft. Pic: MoD/Crown copyright" width=88 height=58>
                <h4>RAF pilot sent jet into 4,000ft plummet by playing with camera, court martial hears
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/02/07/intel_atom_failures_go_back_18_months/">
                            <img src="https://regmedia.co.uk/2017/02/07/intel_atom_image.jpg?x=88&amp;y=58&amp;crop=1" alt="Intel Atom C2000 family" width=88 height=58>
                <h4>Intel Atom chips have been dying for at least 18 months – only now is truth coming to light
                </h4>
            </a>
        </li>
        <li>
            <a href="https://www.theregister.co.uk/2017/02/07/streetmap_loses_google_maps_appeal/">
                            <img src="https://regmedia.co.uk/2016/02/15/streetmap.jpg?x=88&amp;y=58&amp;crop=1" alt="" width=88 height=58>
                <h4>Streetmap loses appeal against Google Maps dominance judgement
                </h4>
            </a>
        </li>
    </ol>
</div>
        <div id=ad-btn-spot class=adu>
            <script>
                show_gpt('ad-btn-spot');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250&amp;tile=4&amp;c=44WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D4%26unitname%3Dwww_mid_mpu%26pos%3Dmid%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x100%7C300x250&amp;tile=4&amp;c=44WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D426unitname%3Dwww_mid_mpu%26pos%3Dmid%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

        <div id=ad-mu2-spot class=adu>
            <script>
                show_gpt('ad-mu2-spot');
            </script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=5&amp;c=55WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D5%26unitname%3Dwww_btm_mpu%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=300x250&amp;tile=5&amp;c=55WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D5%26unitname%3Dwww_btm_mpu%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>



        <div id=spotlight>
            <h3>Spotlight</h3>
            <a href="https://www.theregister.co.uk/2017/02/06/shuttleworth_unity_8_carrots/" class="story">
                            <img src="https://regmedia.co.uk/2017/02/03/mark_shuttleworth_photo_by_canonical.jpg?x=88&amp;y=47&amp;crop=1" alt="Mark Shuttleworth photo by Canonical" width=298 height=160 title="Of risk, re-invention and doing what's good for you" data-stand_url="https://regmedia.co.uk/2017/02/03/mark_shuttleworth_photo_by_canonical.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Ubuntu Linux daddy Mark Shuttleworth: Carrots for Unity 8?</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/02/01/dear_microsoft/" class="story">
                            <img src="https://regmedia.co.uk/2015/02/23/shutterstock_flick.jpg?x=88&amp;y=47&amp;crop=1" alt="A large hand flicks an icon of a little red man. Image via shutterstock (Lasse Kristensen)" width=298 height=160 title="Sysadmin Blog: I promise I've been a good boy this year" data-stand_url="https://regmedia.co.uk/2015/02/23/shutterstock_flick.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Dear Microsoft – a sysadmin's wishlist</h4>
            </a>
            <a href="https://www.theregister.co.uk/2017/01/24/boring_vim_beats_exciting_browsers/" class="story">
                            <img src="https://regmedia.co.uk/2017/01/23/cat_in_the_hat.jpg?x=88&amp;y=47&amp;crop=1" alt="Cat in the hat" width=298 height=160 title="Open Source Insider: 25 years, eight updates, all gravy" data-stand_url="https://regmedia.co.uk/2017/01/23/cat_in_the_hat.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Oh, the things Vim could teach Silicon Valley's code slingers</h4>
            </a>
            <a href="https://www.theregister.co.uk/2016/12/26/databases_in_mmxvi_remind_us_that_humans_are_humanitys_problem/" class="story">
                            <img src="https://regmedia.co.uk/2016/12/23/trump_with_flag_photo_via_shutterstock.jpg?x=88&amp;y=47&amp;crop=1" alt="Trump with flag photo via Shutterstock" width=298 height=160 title="Year in Review: What the Brexit PM and Orange POTUS elect meant" data-stand_url="https://regmedia.co.uk/2016/12/23/trump_with_flag_photo_via_shutterstock.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>A vintage year for snoopers and big state-ists</h4>
            </a>
            <a href="https://www.theregister.co.uk/2016/12/22/brillo_android_things_google_nest/" class="story">
                            <img src="https://regmedia.co.uk/2016/05/16/shutterstock_google_bike_editorial_use.jpg?x=88&amp;y=47&amp;crop=1" alt="Google bikes outside Google HQ. Photo by Randy Miramontez/Shutterstock - for editorial use only." width=298 height=160 title="Comment: The Internet of Google Things" data-stand_url="https://regmedia.co.uk/2016/05/16/shutterstock_google_bike_editorial_use.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>'Twas Brillo but then Android Things, which watched as Google Weaved its Nest</h4>
            </a>
            <a href="https://www.theregister.co.uk/2016/12/21/minio_microserever_aims_for_object_world_domination/" class="story">
                            <img src="https://regmedia.co.uk/2016/12/21/minio_x_648.jpg?x=88&amp;y=47&amp;crop=1" alt="" width=298 height=160 title="Backgrounder: Github star count has it beating Ceph and Swift" data-stand_url="https://regmedia.co.uk/2016/12/21/minio_x_648.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Gluster techie shows off 'MySQL of object storage' Minio projects</h4>
            </a>
            <a href="https://www.theregister.co.uk/2016/12/14/speaking_in_tech_episode/" class="story">
                            <img src="https://regmedia.co.uk/2015/12/16/wifi-trump.jpg?x=88&amp;y=47&amp;crop=1" alt="" width=298 height=160 title="Podcast: Plus: Visual Basic in 21 days?" data-stand_url="https://regmedia.co.uk/2015/12/16/wifi-trump.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>Speaking in Tech: Right, he's smacked the journos. Now Trump's called the techies in...</h4>
            </a>
            <a href="https://www.theregister.co.uk/2016/12/14/open_source_insider_openstreetview_takes_on_google/" class="story">
                            <img src="https://regmedia.co.uk/2016/11/25/toronto_google_map_image_via_shutterstock.jpg?x=88&amp;y=47&amp;crop=1" alt="Toronto Google Map image via Shutterstock" width=298 height=160 title="Open Source Insider: Deja vu for mapping nerds" data-stand_url="https://regmedia.co.uk/2016/11/25/toronto_google_map_image_via_shutterstock.jpg?x=298&amp;y=160&amp;crop=1">
                <h4 class=text>OpenStreetView? You are no longer hostage to Google's car-driven vision</h4>
            </a>
        </div>

<div id=sponlinks>
<h3>Sponsored links</h3>
<ul>
        <li><a target=_blank href="http://forms.theregister.co.uk/studies/s201701/?td=tl">All-Flash Arrays - A flash of brilliance or just a flash in the pan? Have your say in our reader survey</a></li>
        <li><a target=_blank href="https://account.theregister.co.uk/register/?product=theregister_newsletter">
Sign up to The Register to receive newsletters and alerts</a>
</li>
</ul>
</div>

    </div>
    <div id=boot>
        
        <div id=ad-tlr-spot class=adu>
            <script>show_gpt('ad-tlr-spot');</script>
            <noscript>
                <a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/6978/reg_software/front&amp;sz=728x90%7C970x90&amp;tile=6&amp;c=66WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D6%26unitname%3Dwww_btm_leader%26pos%3Dbtm%26test%3D0" target="_blank">
                    <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/6978/reg_software/front&amp;sz=728x90%7C970x90&amp;tile=6&amp;c=66WJxK88CoyKoAABdsLFsAAAMq&amp;t=ct%3Dns%26unitnum%3D6%26unitname%3Dwww_btm_leader%26pos%3Dbtm%26test%3D0" alt="">
                </a>
            </noscript>
        </div>

    </div>

<script>facebook_sdk();</script>
    <div id=footer>

        <div class="social alt_colour dcl">
            <h4>Follow us</h4>
            <div id=follow_btns>
                <a id="follow_us_twitter" href="https://twitter.com/intent/user?screen_name=theregister" title="Follow us on twitter" target=_blank class=twit>
                    <div class="circ">
                        <img width="18" height="18" alt="Twitter" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/twitter.svg">
                    </div>
                </a>
                <a href="https://www.facebook.com/VultureCentral" title="Like us on Facebook" target=_blank class=fbook>
                    <div class="circ">
                        <img width="18" height="18" alt="Facebook" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/facebook.svg">
                    </div>
                </a>
                <a href="https://plus.google.com/+theregister" title="Follow us on Google+" target=_blank class=gplus>
                    <div class="circ">
                        <img width="18" height="18" alt="G+" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/google_plus.svg">
                    </div>
                </a>
                <a href="https://www.theregister.co.uk/Design/page/feeds.html" title="Follow our RSS" target=_blank class=rss_feed>
                    <div class="circ">
                        <img width="18" height="18" alt="feeds" src="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.png" srcset="/design_picker/c00f80f04b0eaf0123d821f6c9488fc1cb55fd0a/graphics/icon/rss.svg">
                    </div>
                </a>
            </div>
        </div>

        <div class="foot_list more_us alt_colour dcl">
            <h4>More content</h4>
            <ul>
                <li><a href="https://account.theregister.co.uk/register/?product=theregister_newsletter">Subscribe to newsletter</a></li>
                <li><a href="https://www.theregister.co.uk/Popular/">Top 20 stories</a></li>
                <li><a href="https://www.theregister.co.uk/Week/">Week’s headlines</a></li>
                <li><a href="https://www.theregister.co.uk/Archive/">Archive</a></li>
                <li><a href="https://whitepapers.theregister.co.uk/events/list">Webcasts</a></li>
            </ul>
        </div>

        <div class="foot_list alt_colour dcl">
            <h4>About us</h4>
            <ul>
                <li><a href="https://www.theregister.co.uk/about/company/privacy/">Privacy</a></li>
                <li class=last><a href="https://www.theregister.co.uk/about/company/">Company info</a></li>
                <li><a target=_blank href="http://media.theregister.co.uk/">Advertise with us</a></li>
                <li><a href="https://www.theregister.co.uk/about/company/republishing/">Syndication</a></li>
                <li><a href="https://www.theregister.co.uk/about/company/contact/">Send us news tips</a></li>

            </ul>
        </div>

        <div class=reg_foot>
            <h4><a href="https://www.theregister.co.uk/" class=dcl>The Register</a></h4>
            <div class=copyr>
                Biting the hand that feeds IT © 1998–2017

            </div>
            <div class=foot_desc>
                Independent news, views, opinions and reviews on the latest in the IT industry. Offices in London, San Francisco and Sydney.
            </div>
        </div>
        <noscript><img src="/Design/graphics/std/transparent_pixel.png" alt="no-js"></noscript>
    </div>

    <div id=end_scripts>





        <script>
            googletag.cmd.push(function() { 
                var abt1 = '<img src="https://go.theregister.co.uk/k/abt_';
                var abt2 = '" width=1 height=1 alt="">';
                var ch = 0;
                $('.adu').each(function(i) {
                    ch += $(this).height();
                });
                if (ch == 0 && !ad_free()) {
                    $('body #end_scripts').append(abt1 + 'b' + abt2);
                    $('#ad-mu1-spot,#ad-mu2-spot').after('<iframe src="https://dda.regmedia.co.uk/research/mpu.html?20160317" width=300 height=255 frameborder=0 style="border:1px solid #CCC"></iframe>');
                }
                else {
                    $('body #end_scripts').append(abt1 + 'a' + abt2);
                }
            });
        </script>

        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-33330076-1', 'theregister.co.uk', { 'allowLinker': true });
            ga('require', 'linker');
            ga('linker:autoLink', ['channelregister.co.uk']);
            ga('require', 'displayfeatures');
            ga('set', 'dimension2', (typeof RegArticle != 'undefined') ? RegArticle.author : '');
            ga('set', 'dimension3', (typeof RegSection != 'undefined') ? RegSection : '');
            ga('set', 'dimension4', (typeof RegArticle != 'undefined' ? (RegArticle.pf ? 'p' : (RegArticle.cp ? 'c' : 'a')) : 'i'));
            ga('set', 'dimension5', (typeof RegArticle != 'undefined') ? RegArticle.cat : '');
            ga('set', 'dimension6', (typeof RegArticle != 'undefined') ? RegArticle.ads : '');
            ga('send', 'pageview');
        </script>

        <script>
            (function() {
            var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script');
            s.type='text/javascript';
            s.async=true;
            s.src='https://s.dpmsrv.com/dpm_812ed4562d3211363a7b813aa9cd2cf042b63bb2.min.js';
            h.appendChild(s);
            })();
        </script>



    <script>
        $(function() { set_bucket_group(808) });
    </script>
        <div id="fb-root"></div>
    </div>
</div>
</body>
</html>

