Feeds

Articles about Sagepay

For Sale sign detail

Sage Pay suffers 2nd day of downtime

Sage's online payment service SagePay is mainly not working for its 32,000 customers today, and it wasn't really working yesterday either. There seems to be a slight discrepancy between Sage's Twitter feed and its system monitor page on its website. The company's Twitter feed warns that live processing is not working but its …
John Oates, 03 Mar 2011
The Register breaking news

Doh! Sage Pay forgets to renew SSL certificate

Customers logging into "secure and efficient payment service" Sage Pay this morning were served up an error message saying that the site could not be trusted, and didn't have a valid security certificate. SSL certificate error message, credit: screengrab Looks like someone forgot to renew the site's SSL certificate – which …
Anna Leach, 26 Apr 2012
The Register breaking news

Sage Pay card stroker goes titsup for NINE hours

Sage Pay's card payment system choked up yesterday for nine hours in an intermittent outage that affected its 30,000 customers in the UK and Europe. Sage first alerted customers to an error at 1.39pm yesterday afternoon, then finally posted the all-clear after 10pm last night. A Reg reader also flagged up another snafu by the …
Anna Leach, 25 Apr 2012
cloud

Sage payment processor goes titsup - again

SagePay has been hit by what appears to be yet another spectacular outage, only three months on since the payment processor, which serves 25,000 firms in the UK and Ireland, collapsed for 24 hours on 8 September. Customers have contacted The Register to complain about SagePay's latest unscheduled lie-down. The service, which …
Kelly Fiveash, 11 Dec 2009
The Register breaking news

Sage payment processor suffers 24-hour outage

SagePay - the payments processor serving 25,000 companies in the UK and Ireland - experienced a major outage on Monday evening, and as problems dragged on late into Tuesday, one of its biggest competitors claimed a significant uptick in business. Caused by a "database-related" issue, the outage began at 7:48pm London time on …
Cade Metz, 09 Sep 2009