Original URL: http://www.theregister.co.uk/2013/08/21/cisco_goes_public_with_major_vulns/

Cisco goes public with major vulns

Unified comms, hosted collaboration need fixes

By Richard Chirgwin

Posted in Security, 21st August 2013 22:56 GMT

Users of Cisco's Unified Communications Manager, UCM instant messaging and presence, and Prime Central hosted collaboration system need to get busy with patches, after the Borg announced denial-of-service vulnerabilities across all three platforms.

UCM 7.1, Cisco advises, has an improper error handling vulnerability that can be used in denial-of-service. An attacker can hose the system by sending malformed registration messages.

There are also vulns in versions 8.5, 8.6 and 9.0 of UCM: some UDP ports don't rate-limit properly, and could therefore be hit with high-rate traffic for denial-of-service. The same versions also fail to rate-limit on UDP 5060, the SIP port.

There's also a buffer overrun vulnerability on UCM 7.1, 8.5, 8.6, 9.0 and 9.1. If exploited, an attacker would be able to run arbitrary commands, corrupt data, and disrupt services on the systems.

UCM's IM and Presence Service suffers from a memory leak, meaning large numbers of TCP connections to port 5060 or 5061 could DoS the system, requiring a restart.

And finally, Cisco Prime Central for HCS Assurance – a hosted application solution – has three vulnerabilities, all of them exposing the system to denial-of-service attacks. They are, in order:

With no workarounds available, Cisco is advising patches be applied to all affected systems. ®