Original URL: http://www.theregister.co.uk/2013/04/23/java_reflection_api_an_insecure_mess/

Java still vulnerable despite recent patches

Sun rises in the East

By Richard Chirgwin

Posted in Security, 23rd April 2013 01:35 GMT

Just days after the latest fix, another Java vulnerability has emerged.

Described in this Full Disclosure post, the Reflection API flaw affects all versions of Java SE 7 and, according to researcher Adam Gowdiak, “can be used to achieve a complete Java security sandbox bypass on a target system”.

As always, the victim would need to fail the Java user IQ test – not only still having it installed, but clicking “yes” to allow a malicious app to execute.

Gowdiak writes that his company, Security Explorations, has sent the vulnerability report along with proof-of-concept code to Oracle.

The vulnerability, he writes, is present in JRE Plugin software, the JDK, and the Server JRE.

The company says that since it has been reporting Reflection API issues to Oracle since April 2012, “it looks like Oracle was primarily focussed on hunting down potentially dangerous Reflection API calls in the “allowed” classes space.”

Last week, Oracle issued a patch covering 42 security flaws of which 19 held a top severity rating. The patches included an attempt to alert users when they were about to do something silly, such as allowing an in-browser Java app to actually do anything.

The Register has requested comment from Oracle on the latest vulnerability. ®