Original URL: http://www.theregister.co.uk/2013/01/10/ruby_on_rails_security_vuln/

Ruby off the Rails: Enormo security hole puts 240k sites at risk

Update NOW or give everyone shell access to your app server

By John Leyden

Posted in Security, 10th January 2013 15:31 GMT

Popular programming framework Ruby on Rails has two critical security vulnerabilities - one allowing anyone to execute commands on the servers running affected web apps.

The newly uncovered bugs both involve the parsing and handling of data supplied by visitors to a Rails application. The CVE-2013-0156 hole is the more severe of the two because it allows remote-code execution against any Ruby on Rails application that has the XML parser enabled - a feature switched on by default. According to security tools firm Sourcefire the flaw allows hackers to run system commands on the server with the same level of privileges as the app.

Both vulnerabilities can be resolved by updating to the latest version of the Ruby on Rails platform.

But what makes the holes particularly nasty is that, until the patches are applied, every application running on the insecure open-source framework will be vulnerable - like castles built on sand and the tide is rising: at least 240,000 websites powered by RoR are thought to be at risk.

An update on the Ruby on the Rails developer blog this week highlights the severity of flaw:

I'd like to announce that 3.2.11, 3.1.10, 3.0.19, and 2.3.15 have been released. These releases contain two extremely critical security fixes so please update IMMEDIATELY.

HD Moore, the developer of Metasploit and chief security officer at security biz Rapid7, reiterated the advice to patch sooner rather than later.

"Ruby on Rails remote code execution confirmed: expect a Metasploit module in the next 4 to 12 hours. Patch your Rails apps," Moore said in a Twitter update. The latest security flap is not related to a SQL injection vulnerability, also affecting Ruby on Rails, that emerged last week. ®