Original URL: http://www.theregister.co.uk/2011/10/05/moz_mcafee_security_plugin_crash_warning/

Mozilla to Firefox users: Ditch crashtastic McAfee plugin

Security FAIL... but is it Mozilla's or McAfee's?

By John Leyden

Posted in Security, 5th October 2011 16:29 GMT

Mozilla is advising Firefox users to disable a McAfee plugin that the open-source browser supplier blames for a high volume of crashes.

McAfee's ScriptScan software causes "stability or security problems", according to Firefox. Users of the software are confronted with a message stating the plugin has been "blocked for your protection".

"Users are strongly encouraged to disable the problematic add-on or plugin, but may choose to continue using it if they accept the risks described," the notice states.

"When Mozilla becomes aware of add-ons, plugins, or other third-party software that seriously compromises Firefox security, stability, or performance and meets certain criteria, the software may be blocked from general use. For more information, please read this support article," it explains.

ScriptScan is a component that comes bundled with McAfee's VirusScan security software. The technology is designed to scan websites for hostile code. Unfortunately ScriptScan does not play well with Firefox. Versions 14.4.0 and below reportedly cause all versions of Firefox, even the latest 7.x release, to crash.

The issue has generated a splattering of comments on McAfee's support forums. The Intel security division is reportedly working with Mozilla in developing a fix. In the meantime, surfers have the choice to either re-enable ScriptScan; rely on McAfee SiteAdvisor or other tools to warn about bad sites; or choose a different browser. The problem appears to be restricted to Firefox.

Recent versions of Firefox, prior to the 7.0 release, were memory hogs that had a tendency to crash all on their own, so it may be that McAfee is only partially to blame for this problem. ®