Original URL: http://www.theregister.co.uk/2011/03/29/firefox_four_for_android_does_not_support_arm_version_six_or_flash/

Firefox 4 for Android shuns ARMv6 phones

And Adobe Flash too

By Cade Metz

Posted in Mobile, 29th March 2011 20:48 GMT

Mozilla's Android incarnation of Firefox 4 does not run on devices using the older ARMv6 processor, and it does not support Adobe Flash.

Firefox 4 for Android – officially released on Tuesday – runs only on devices that use ARMv7 processors, including phones such as the Google Nexus One, the HTC Evo, and the Motorola Droid X, as well as tablets such as the Samsung Galaxy and the Motorola Xoom. It also requires 512MB of memory.

What's more, the browser is unable to run plug-ins such as Adobe Flash. But this is listed as a bug, and Mozilla intends to provide plug-in support. "Mozilla does not currently support Adobe Flash in Firefox for mobile. We are investigating the possibility of supporting Flash in the future, when we can deliver a great user experience," a Mozilla spokeswoman told us.

Previously, Mozilla offered experimental versions of the browser for use with ARMv6 devices, but these have been pulled. "Sorry, the experimental ARMv6 builds are no longer available," reads Mozilla's system-requirements page. "They contained bugs that caused them to crash immediately, so they were no longer useful for testing."

The open source outfit may or may not support the processor in the future. "While we'd like Firefox to run on as many phones as possible, we are focusing first on devices that can run current versions of Firefox with acceptable performance. As we improve Firefox's speed and memory use, it might become possible for us to support ARMv6 phones in the future, but we are not actively working on it now."

This means that the browser will not run on dozens of Android devices. You can see the full list on the Mozilla wiki. ®