Original URL: http://www.theregister.co.uk/2009/05/08/new_iphone_app_rules/

Apple bars 2.0 code from App Store

iPhone 3.0 or nothing

By Rik Myslewski

Posted in Mobile, 8th May 2009 20:02 GMT

Apple will no longer approve any iPhone application that isn't compatible with its upcoming iPhone 3.0 operating system.

This tidbit comes to us thanks to a post on The Loop Blog, which quotes the following meat of an email sent to all members of Apple's iPhone Developer Program:

All apps must be compatible with iPhone OS 3.0
Millions of iPhone and iPod touch customers will move to iPhone OS 3.0 this summer. Beginning today, all submissions to the App Store will be reviewed on the latest beta of iPhone OS 3.0. If your app submission is not compatible with iPhone OS 3.0, it will not be approved.
Existing apps in the App Store should already run on iPhone OS 3.0 without modification, but you should test your existing apps with iPhone OS 3.0 to ensure there are no compatibility issues. After iPhone OS 3.0 becomes available to customers, any app that is incompatible with iPhone OS 3.0 may be removed from the App Store.

According to Apple, iPhone 3.0 OS offers a "a rich set of over 1,000 new APIs" in support of new features such as in-application sales of services and content, background push notifications and alerts, communication with accessories over either the familiar 30-pin dock connector or Bluetooth, multi-player gaming connectivity, and in-app access to the Google Mobile Maps Service and a user's on-phone iTunes library.

While these new features are good news for developers of new apps, they're bad news for folks who have created apps that will now be made redundant by Apple-supplied apps that will arrive pre-baked into the new OS, such as Voice Memo, MMS messaging, and a system-wide landscape-mode keyboard.

More troubling is Apple's decision to remove any applications from the App Store that aren't compatible with iPhone 3.0 - especially if, as happened in the move from the iPhone's original OS to iPhone 2.0, iPod touch owners will have to shell out ten bucks for the privilege of moving to iPhone 3.0.

When Apple moved its Mac line from Motorola's 68xxx processors to the PowerPC, from the PowerPC to Intel, and from OS 9 to OS X, it bent over backwards to ensure that older apps still ran on the newer machines.

With the iPhone, however, Apple has changed tactics. If your app doesn't run on the new OS, well, "No soup for you!" ®