Original URL: http://www.theregister.co.uk/2007/10/19/alt_browser_vulns/

Bad hair day for alternative browser users

Critical Opera and Firefox bugs menace IE-refuseniks

By John Leyden

Posted in Security, 19th October 2007 13:18 GMT

There's bad news for users of alternative browsers this Friday, with both Opera and Firefox subject to security vulnerabilities.

A trio of faults in Opera create a means to construct cross-site scripting attacks and other mischief. The worst flaw of the bunch involves the possibility that external news readers or email clients might be used to inject hostile code onto vulnerable systems.

Providing a user has configured Opera to use an external newsgroup client or email application, maliciously crafted web pages taking advantage of the vulnerability might be created that can cause Opera to run that application incorrectly, potentially leading to the execution of arbitrary code.

Secondly, a bug in processing frames from different websites lends itself to cross-site scripting attacks.

There's bad news for users of Opera on Mac systems too. An unspecified error exists in Opera in combination with Adobe Flash Player 9.0.47.0 or earlier on Mac OS X machines.

All three bugs are addressed by upgrading to Opera version 9.24, as explained in a summary of the bugs by security notification firm Secunia.

Firefox users also need to upgrade. Version 2.0.0.8 of the popular open source browser fixes a number of vulnerabilities that might lend themselves to data exposure or system compromise risks. That's because both the browser and JavaScript engine of Firefox are subject to memory corruption bugs.

A separate error in displaying web pages written in the XUL markup language might be used to hide the window's title bar, a potentially useful trick for phishers.

Linux users also need to take note of the update. An error in the handling of "smb:" and "sftp:" URI schemes on certain Linux systems with gnome-vfs support creates a means to snoop on a user's files. Exploitation of this bug is far from trivial, but it's still worth knowing about.

Secunia has a useful summary of the various flaws here.

Users of Thunderbird, Firefox's email client, and Mozilla's SeaMonkey suite also need to upgrade as a result of the same bugs to versions 2.0.0.8 and 1.1.5, respectively. ®