Original URL: http://www.theregister.co.uk/2006/05/03/x11/

X marks the bug

Linux component flaw deemed 'critical'

By John Leyden

Posted in Security, 3rd May 2006 15:46 GMT

Security researchers have discovered a critical vulnerability in the X Window system used in Unix and Linux systems. The buffer overflow vulnerability creates a means for hackers to seize root access to vulnerable systems or launch denial of service attacks. So it's just as well that patches are available.

The flaw stems from programming errors within the XRender extension triangle handling code connected with a missing parentheses. "This can be exploited by a client that is authorised to connect to the X server to cause a buffer overflow," security notification firm Secunia explains.

The error was unearthed using an automated code-scanning tool during an open-source security audit conducted by security firm Coverity and paid for by the US Department of Homeland Security. The vulnerability reportedly affects X11R6.8.x, X11R6.9.0, and X11R7.0 (xorg-server 1.0.x). More info and details of available patches can be found in Secunia's advisory here. ®