Original URL: http://www.theregister.co.uk/2002/02/28/php_flaws_pose_hacker_risk/

PHP flaws pose hacker risk

Scripting language could be a tool for script kiddies

By John Leyden

Posted in Security, 28th February 2002 16:01 GMT

Updated Flaws in the popular open source scripting language PHP could allow crackers to execute arbitrary code on a victim's system or crash a Web server, security clearing house CERT has warned.

The vulnerabilities arise from the way PHP handles multipart/form-data POST requests (aka POST fileuploads) which give rise to a variety of possible attacks, with varying degrees of difficulty.

Tests by Stefan Esser, a PHP developer at German security consultancy e-matters, who discovered the bugs, suggest that not only PHP4 but also older versions of PHP3 tree are vulnerable.

Most of these vulnerabilities are exploitable only on Linux or Solaris, but one relatively trivial attack is only exploitable on x86 boxes and an arbitrary heap overflow in PHP3 is relatively easily exploitable on most platforms, including BSD.

According to our contacts a PHP exploit, targeted at Linux servers, is in circulation, though it’s not been widely used, as yet. This makes the PHP vulnerabilities a serious security issue.

As a workaround, users running PHP 4.0.3 or above might mitigate their exposure to the security risk by disabling fileupload support.

However a better solution is to upgrade to version 4.1.2 of PHP or apply patches to earlier versions, which have been made available. Because fileupload code was completely rewritten for the 4.2.0 branch, developers using this version of the scripting language are immune from the vulnerability.

PHP is a scripting language widely used in web development. PHP can be installed on a variety of web servers, including Apache, IIS, Netscape and iPlanet, among others. Servers not running PHP are immune to the problem. ®

External links

CERT: Multiple vulnerabilities in PHP fileupload
e-matters advisory