Outlook.com is still not functioning properly for some Microsoft punters

It ain't no thang... only 'a small percentage' of 'hundreds of millions' affected...

Microsoft is still working to resolve "difficulties" faced by its Outlook customers, despite months of complaints about the disappearance of sent emails and 550 Errors.

A growing number of complaints threads have been posted to Microsoft's questions page regarding Outlook after recent upgrades to the service. They both precede and follow last week's outage, which Redmond's PRs failed to explain to us.

One such complaint raised by Mike300ZXna on 4 November, noted that the last upgrade borked his sent emails from being stored in his Sent Items folder.

The earliest complaint regarding the storage of emails sent from connected accounts in Sent Items folders claimed the issue had arisen back on 20 May, prompting Mike300ZXna to tell The Register that: "Microsoft appears to have been doing a head/sand job or fob-off-the-customer-until-they-go-away job on these issues for some months."

A Microsoft spokesperson confirmed to The Register that "a very small percentage" of its "hundreds of millions of customers" are still experiencing "difficulties" brought on by recent updates, which have caused issues for "customers with certain account configurations".

In Redmond's own words:

Hundreds of millions of customers are using the new Outlook.com every day to stay connected and be more productive. We're working to resolve difficulties a very small percentage of customers with certain account configurations may be experiencing.

While leaving the maths of how many users might be affected to readers, El Reg notes complaints about these issues are persisting on social media too.

Further issues seem to be troubling users who are receiving 550 errors, seemingly due to Outlook's failure to comply with RFC 2822, specifically section 3.3's specifications on Data Headers.

Although potentially only affecting the new version of Connected Accounts, Microsoft customers' emails are throwing up 550 errors stating that: "Messages should have one or no Date headers, not 2."

Users are asking Microsoft why they are receiving the invalid date error message, which "suggests the sender is using a badly-written mailout program rather than a regular email client" error messages. Redmond's support monkeys have yet to respond to either them or The Register.

We will update this article if we hear when these issues may be resolved, or what is causing them. As always, if you're having issues, please get in touch. ®


Biting the hand that feeds IT © 1998–2017