And now for a lazy Fri…d'oh! Two VMware patches just landed!?

Arbitrary code execution and XSS messes may need to be done before the weekend

VMware's just announced two significant bugs that need attention, sooner rather than later.

The problems are “a DLL hijacking issue in Windows-based VMware Tools and an HTTP Header injection issue in vCenter Server and ESXi” and are rated Important, a step down from Critical. Whether they ruin your weekend is up to you.

The VMware Tools bug “... is present in the VMware Tools "Shared Folders" (HGFS) feature running on Microsoft Windows,” says VMware's advisory.

“Exploitation of this issue may lead to arbitrary code execution with the privileges of the victim. In order to exploit this issue, the attacker would need write access to a network share and they would need to entice the local user into opening their document.”

All of which is doable with a little phishing.

The problem – officially CVE-2016-5330 - impacts vCenter Server, vSphere Hypervisor (ESXi), Workstation Pro, Workstation Player, Fusion and VMware Tools.

Patches are available on each product's page and/or in the VMware Knowledge Base.

The second bug – CVE-2016-5331 - is described as an “HTTP Header injection issue in vCenter Server and ESXi.”

This one means “An attacker can exploit this issue to set arbitrary HTTP response headers and cookies, which may allow for cross-site scripting and malicious redirect attacks.

Only version 6.0 of vCenter Server and ESXi are impacted and there are patches ready to roll. You may even be immune: the current version of vCenter Server is 6.0U2 and that's what fixes this mess.

Securify B.V. spotted the first bug and folks from Positive Technologies, Netcraft Ltd, A2secure​ and a chap called Ammarit Thongthua all spotted the second problem. ®

Sponsored: Minds Mastering Machines - Call for papers now open




Biting the hand that feeds IT © 1998–2018