More like this




Fail0verflow GitHubs PS4 Linux loader

Jailbreaker goes public, helping put penguins on PlayStations

Fail0verflow has gone public with its Linux-on-PS4 loader, a little over two months after presenting an early and “ugly” version of it to the Chaos Computer Club conference in Germany.

Consistent with the 32c3 conference presentation, the loader only works on firmware versions up to 1.76.

The requirements are imposing for all but serious hackers: there's a special PS4 Linux kernel fork (here), a PS4 kernel exploit discovered last year called BadIRET, which has just leaked in the last day or so, and of course fail0verflow's PS4-kexec.

A user who gets through all of this would end up either with a PS4 running Gentoo on the 4.4 kernel, or (more likely for most users) a bricked machine.

The original fail0verflow presentation said the 32c3 demonstration depended on a WebKit flaw patched in post-version-1.76 systems.

However, Twitter user @CTurtE has laid claim to jailbreaking the PS4 via a kernel heap overflow.

@CTurt has a write-up of the PS4 kernel heap overflow with qwertyoruiop here. ®

Sponsored: IBM FlashSystem V9000 product guide