More like this

Data Center

Arrow

Virtualization

Xen forgets recent patches in new maintenance release

Is this any way to run a supposedly cloud-grade hypervisor?

The Xen Project has announced a new maintenance release for version 4.6.1 of its hypervisor, but along the way has admitted it forgot to add some recent patches.

“Note that …. due to two oversights the fixes for both XSA-155 and XSA-162 have only been partially applied to this release,” says the announcement of the maintenance release. The mess also applies to the recent version 4.4.4 release, the last update to the Xen 4.4.

Forgetting to add the patches is kind of a big deal, because XSA-155 has a chance of allowing “arbitrary code execution in backend” and XSA-162 allows a guest to enjoy the privileges of the Qemu process.

The accidental omission is also notable because it's the second security SNAFU in two months: last December the Xen Project ignored its own bug publishing policy and announced a bug to the world without the usual two-week embargo. That policy is designed to ensure that cloud operators using the hypervisor – notably Amazon Web Services – have time to patch bugs before they're universally known. It's thought that publicly announcing Xen bugs would have the effect of turning the millions of VMs in clouds into instant hacker honeypots.

Plenty of Xen users will diligently apply patches as they land, so the missing fixes won't be an issue. But the omission will be a trap for the unwary who make less frequent upgrades, or those installing the software for the first time. If they dare, given the project's stumbles. ®

Sponsored: Cluster speeds molecular dynamics research with NVIDIA GPUs