Related topics

Firefox fix lances memory corruption bug

Unload update stars in weekend patch release

cloud

Firefox users need to update their browser software following the discovery of multiple vulnerabilities.

The flaws might be exploited to bypass security restrictions, conduct cross-site scripting or spoofing attacks, pinch sensitive information, or even gain control of vulnerable systems.

The flaws affect both the 1.5 and newer 2.0 releases of the popular open source browser. Users are advised to update to versions 2.0.0.2 or 1.5.0.10 to guard against attack. Users of the SeaMonkey also need to update to version 1.0.8 because of the same set of problems.

The most serious of the flaws fixed by the updates involves a failure to properly handle JavaScript onUnload events. This creates a risk of memory corruption in cases where a user is duped into visiting a maliciously-constructed website or viewing HTML in a hostile spam email, for example. The ruse, which might be used to trick a user into executing arbitrary code.

The Mozilla Foundation advises users to disable JavaScript as a workaround in cases where a new version of the browser can't be immediately installed.

An error in the Network Security Services (NSS) code involved in processing SSLv2 server messages might also be used to inject hostile code onto vulnerable systems running 1.5 versions of Firefox.

Mozilla isn't alone in having problems with onUnload coding, a feature security watchers have tagged as a security calamity waiting to happen for some time, the SANS Institute's Internet Storm Centre reports.

Internet Explorer 7's handling of "onunload" events might be exploited by a malicious website to spoof the address bar, security notification firm Secunia warns, in a vulnerability it describes as "less critical". ®

Sponsored: Network DDoS protection