Firefox update guards against critical flaws

Patch issued, calamity averted

arrow pointing up

Firefox users need to upgrade their browsers following the discovery of multiple security vulnerabilities.

The flaws affect both Firefox 1.x and the latest Firefox 2.0.x releases. Surfers need to upgrade to version 1.5.0.9 or 2.0.0.1 of the browser, respectively. Users also need to upgrade to a new version of the Mozilla email client, Thunderbird 1.5.0.9, for similar reasons.

The nine security bugs (reported by various security researchers) create a means for hackers to swipe sensitive information, run cross-site scripting attacks, or gain control of vulnerable systems, security notification firm Secunia reports.

The bugs involve flaws in Firefox's JavaScript engine, the feed preview feature of Firefox 2.0, Scalable Vector Graphics (SVG) processing code, and various buffer overflow flaws in other components of the browser software, as explained in greater detail here. ®

Sponsored: Designing and building an open ITOA architecture