Firefox fans too frumpy for Beautifulpeople.net

Oh behave

Elitist online dating website Beautifulpeople.net is excluding Firefox users. Alternative browser users report being given the cold shoulder by the site, which prides itself on only allowing pretty people (as voted by its existing members) to join.

Attempting to view beautifulpeople.net using Firefox (7 million users and counting) results in the following terse message:

BeautifulPeople.net is only supported by Internet Explorer. You are currently using version: Netscape 5.0. To be able to use. BeautifulPeople you need to update to a newer version of Internet Explorer.

Charming. As reader Hamish put it "If you browse with Firefox - you're Ug-lair, baybee!" Don't these people know smart is sexy. Using a browser that is less susceptible to spyware infection is surely no bad thing. ®

Related stories

Cupid, love hearts, revenge and monkeys
Why the Friendster bubble 'has peaked will pop'
Alternative browser villains named and shamed

Sponsored: Driving business with continuous operational intelligence